12.1.1-2
This commit is contained in:
parent
200ab99d30
commit
b2315f360e
3
gcc.spec
3
gcc.spec
@ -275,6 +275,7 @@ Patch8: gcc12-no-add-needed.patch
|
||||
Patch9: gcc12-Wno-format-security.patch
|
||||
Patch10: gcc12-rh1574936.patch
|
||||
Patch11: gcc12-d-shared-libphobos.patch
|
||||
Patch12: gcc12-pr105551.patch
|
||||
|
||||
Patch100: gcc12-fortran-fdec-duplicates.patch
|
||||
Patch101: gcc12-fortran-flogical-as-integer.patch
|
||||
@ -802,6 +803,7 @@ so that there cannot be any synchronization problems.
|
||||
%patch10 -p0 -b .rh1574936~
|
||||
%endif
|
||||
%patch11 -p0 -b .d-shared-libphobos~
|
||||
%patch12 -p0 -b .pr105551~
|
||||
|
||||
%if 0%{?rhel} >= 9
|
||||
%patch100 -p1 -b .fortran-fdec-duplicates~
|
||||
@ -3238,6 +3240,7 @@ end
|
||||
tree-optimization/105940
|
||||
- enable tsan and lsan on s390x (#2101610)
|
||||
- trim RHEL fortran patches
|
||||
- fix nvptx build (PRs bootstrap/105551, target/105938)
|
||||
|
||||
* Sat May 7 2022 Jakub Jelinek <jakub@redhat.com> 12.1.1-1
|
||||
- update from releases/gcc-12 branch
|
||||
|
28
gcc12-pr105551.patch
Normal file
28
gcc12-pr105551.patch
Normal file
@ -0,0 +1,28 @@
|
||||
2022-05-11 Richard Biener <rguenther@suse.de>
|
||||
|
||||
PR bootstrap/105551
|
||||
* opts.cc (finish_options): Also disable var-tracking if
|
||||
!DWARF2_DEBUGGING_INFO.
|
||||
|
||||
--- gcc/opts.cc
|
||||
+++ gcc/opts.cc
|
||||
@@ -1334,11 +1334,15 @@ finish_options (struct gcc_options *opts, struct gcc_options *opts_set,
|
||||
|| opts->x_flag_selective_scheduling2));
|
||||
|
||||
/* We know which debug output will be used so we can set flag_var_tracking
|
||||
- and flag_var_tracking_uninit if the user has not specified them. Note
|
||||
- we have not yet initialized debug_hooks so we might uselessly run
|
||||
- var-tracking on targets without var_location debug hook support. */
|
||||
+ and flag_var_tracking_uninit if the user has not specified them. */
|
||||
if (opts->x_debug_info_level < DINFO_LEVEL_NORMAL
|
||||
- || !dwarf_debuginfo_p (opts))
|
||||
+ || !dwarf_debuginfo_p (opts)
|
||||
+ /* We have not yet initialized debug hooks so match that to check
|
||||
+ whether we're only doing DWARF2_LINENO_DEBUGGING_INFO. */
|
||||
+#ifndef DWARF2_DEBUGGING_INFO
|
||||
+ || true
|
||||
+#endif
|
||||
+ )
|
||||
{
|
||||
if ((opts_set->x_flag_var_tracking && opts->x_flag_var_tracking == 1)
|
||||
|| (opts_set->x_flag_var_tracking_uninit
|
Loading…
Reference in New Issue
Block a user