5.0.0-0.15
This commit is contained in:
parent
19b59d9a23
commit
a2ef59f731
1
.gitignore
vendored
1
.gitignore
vendored
@ -7,3 +7,4 @@
|
||||
/gcc-5.0.0-20150212.tar.bz2
|
||||
/gcc-5.0.0-20150214.tar.bz2
|
||||
/gcc-5.0.0-20150216.tar.bz2
|
||||
/gcc-5.0.0-20150217.tar.bz2
|
||||
|
14
gcc.spec
14
gcc.spec
@ -1,9 +1,9 @@
|
||||
%global DATE 20150216
|
||||
%global SVNREV 220728
|
||||
%global DATE 20150217
|
||||
%global SVNREV 220752
|
||||
%global gcc_version 5.0.0
|
||||
# Note, gcc_release must be integer, if you want to add suffixes to
|
||||
# %{release}, append them after %{gcc_release} on Release: line.
|
||||
%global gcc_release 0.14
|
||||
%global gcc_release 0.15
|
||||
%global _unpackaged_files_terminate_build 0
|
||||
%global _performance_build 1
|
||||
%global multilib_64_archs sparc64 ppc64 ppc64p7 s390x x86_64
|
||||
@ -200,6 +200,7 @@ Patch13: gcc5-aarch64-async-unw-tables.patch
|
||||
Patch14: gcc5-libsanitize-aarch64-va42.patch
|
||||
Patch15: gcc5-pr32219-revert.patch
|
||||
Patch16: gcc5-pr65074-test.patch
|
||||
Patch17: gcc5-pr65087.patch
|
||||
|
||||
# On ARM EABI systems, we do want -gnueabi to be part of the
|
||||
# target triple.
|
||||
@ -753,6 +754,7 @@ rm -f libgo/go/crypto/elliptic/p224{,_test}.go
|
||||
%patch16 -p0 -b .pr65074-test~
|
||||
rm -f gcc/testsuite/gcc.target/i386/pr32219-*.c
|
||||
rm -f gcc/testsuite/gcc.dg/visibility-2{2,3}.c
|
||||
%patch17 -p0 -b .pr65087~
|
||||
|
||||
%if 0%{?_enable_debug_packages}
|
||||
mkdir dwz-wrapper
|
||||
@ -2938,6 +2940,12 @@ fi
|
||||
%doc rpm.doc/changelogs/libcc1/ChangeLog*
|
||||
|
||||
%changelog
|
||||
* Tue Feb 16 2015 Jakub Jelinek <jakub@redhat.com> 5.0.0-0.15
|
||||
- update from the trunk
|
||||
- PRs bootstrap/48009, c++/65075, c++/65080, c/65066, ipa/64963, ipa/65059,
|
||||
target/53348, target/65058, tree-optimization/63593,
|
||||
tree-optimization/65077
|
||||
|
||||
* Mon Feb 16 2015 Jakub Jelinek <jakub@redhat.com> 5.0.0-0.14
|
||||
- update from the trunk
|
||||
- PRs c/64768, testsuite/64850
|
||||
|
41
gcc5-pr65087.patch
Normal file
41
gcc5-pr65087.patch
Normal file
@ -0,0 +1,41 @@
|
||||
2015-02-17 Jakub Jelinek <jakub@redhat.com>
|
||||
|
||||
PR ipa/65087
|
||||
* cgraphclones.c (cgraph_node::create_virtual_clone): Only copy
|
||||
section if !implicit_section.
|
||||
(cgraph_node::create_version_clone_with_body): Likewise.
|
||||
* trans-mem.c (ipa_tm_create_version): Likewise.
|
||||
|
||||
--- gcc/cgraphclones.c.jj 2015-02-16 20:16:43.000000000 +0100
|
||||
+++ gcc/cgraphclones.c 2015-02-17 09:35:19.682184215 +0100
|
||||
@@ -617,7 +617,7 @@ cgraph_node::create_virtual_clone (vec<c
|
||||
ABI support for this. */
|
||||
set_new_clone_decl_and_node_flags (new_node);
|
||||
new_node->clone.tree_map = tree_map;
|
||||
- if (!DECL_ONE_ONLY (old_decl))
|
||||
+ if (!implicit_section)
|
||||
new_node->set_section (get_section ());
|
||||
|
||||
/* Clones of global symbols or symbols with unique names are unique. */
|
||||
@@ -1011,7 +1011,8 @@ cgraph_node::create_version_clone_with_b
|
||||
new_version_node->externally_visible = 0;
|
||||
new_version_node->local.local = 1;
|
||||
new_version_node->lowered = true;
|
||||
- new_version_node->set_section (get_section ());
|
||||
+ if (!implicit_section)
|
||||
+ new_version_node->set_section (get_section ());
|
||||
/* Clones of global symbols or symbols with unique names are unique. */
|
||||
if ((TREE_PUBLIC (old_decl)
|
||||
&& !DECL_EXTERNAL (old_decl)
|
||||
--- gcc/trans-mem.c.jj 2015-02-16 20:16:43.000000000 +0100
|
||||
+++ gcc/trans-mem.c 2015-02-17 09:35:19.682184215 +0100
|
||||
@@ -4967,7 +4967,8 @@ ipa_tm_create_version (struct cgraph_nod
|
||||
new_node->externally_visible = old_node->externally_visible;
|
||||
new_node->lowered = true;
|
||||
new_node->tm_clone = 1;
|
||||
- new_node->set_section (old_node->get_section ());
|
||||
+ if (!old_node->implicit_section)
|
||||
+ new_node->set_section (old_node->get_section ());
|
||||
get_cg_data (&old_node, true)->clone = new_node;
|
||||
|
||||
if (old_node->get_availability () >= AVAIL_INTERPOSABLE)
|
Loading…
Reference in New Issue
Block a user