4.3.0-0.9
This commit is contained in:
parent
cbffc05bdd
commit
96e022d38e
@ -1,2 +1,2 @@
|
||||
gcc-4.3.0-20080212.tar.bz2
|
||||
gcc-4.3.0-20080214.tar.bz2
|
||||
fastjar-0.95.tar.gz
|
||||
|
@ -54,7 +54,7 @@
|
||||
+ $(SHLIB_DIR)/$(SHLIB_SONAME).backup; \
|
||||
+ else true; fi && \
|
||||
+ gcc -O2 -o $(SHLIB_DIR)/$(SHLIB_SONAME).tweak \
|
||||
+ $(srcdir)/config/ia64/change-symver.c -lelf && \
|
||||
+ $$(gcc_srcdir)/config/ia64/change-symver.c -lelf && \
|
||||
+ $(SHLIB_DIR)/$(SHLIB_SONAME).tweak $(SHLIB_DIR)/$(SHLIB_SONAME).tmp \
|
||||
+ GCC_3.4.2 _GLOBAL_ \
|
||||
+ _Unwind_GetGR _Unwind_RaiseException _Unwind_GetRegionStart _Unwind_SetIP \
|
||||
|
38
gcc43-pr35136-revert.patch
Normal file
38
gcc43-pr35136-revert.patch
Normal file
@ -0,0 +1,38 @@
|
||||
2008-02-14 Eric Botcazou <ebotcazou@adacore.com>
|
||||
|
||||
PR middle-end/35136
|
||||
* gimplify.c (force_gimple_operand_bsi): Revert 2008-02-12 change.
|
||||
(force_gimple_operand): Likewise.
|
||||
|
||||
--- gcc/gimplify.c (revision 132267)
|
||||
+++ gcc/gimplify.c (working copy)
|
||||
@@ -6629,14 +6629,6 @@ force_gimple_operand (tree expr, tree *s
|
||||
|
||||
pop_gimplify_context (NULL);
|
||||
|
||||
- if (*stmts && gimple_in_ssa_p (cfun))
|
||||
- {
|
||||
- tree_stmt_iterator tsi;
|
||||
-
|
||||
- for (tsi = tsi_start (*stmts); !tsi_end_p (tsi); tsi_next (&tsi))
|
||||
- mark_symbols_for_renaming (tsi_stmt (tsi));
|
||||
- }
|
||||
-
|
||||
return expr;
|
||||
}
|
||||
|
||||
@@ -6656,6 +6648,14 @@ force_gimple_operand_bsi (block_stmt_ite
|
||||
expr = force_gimple_operand (expr, &stmts, simple_p, var);
|
||||
if (stmts)
|
||||
{
|
||||
+ if (gimple_in_ssa_p (cfun))
|
||||
+ {
|
||||
+ tree_stmt_iterator tsi;
|
||||
+
|
||||
+ for (tsi = tsi_start (stmts); !tsi_end_p (tsi); tsi_next (&tsi))
|
||||
+ mark_symbols_for_renaming (tsi_stmt (tsi));
|
||||
+ }
|
||||
+
|
||||
if (before)
|
||||
bsi_insert_before (bsi, stmts, m);
|
||||
else
|
@ -1,67 +0,0 @@
|
||||
2008-02-12 Jakub Jelinek <jakub@redhat.com>
|
||||
|
||||
PR c++/35138
|
||||
* parser.c (cp_parser_pseudo_destructor_name): If next token
|
||||
is CPP_NAME, not followed by template argument list nor
|
||||
::~, return before calling cp_parser_type_name.
|
||||
|
||||
* g++.dg/template/member8.C: New test.
|
||||
|
||||
--- gcc/cp/parser.c.jj 2008-02-12 14:49:55.000000000 +0100
|
||||
+++ gcc/cp/parser.c 2008-02-12 20:47:09.000000000 +0100
|
||||
@@ -5164,6 +5164,27 @@ cp_parser_pseudo_destructor_name (cp_par
|
||||
additional qualification. */
|
||||
else if (cp_lexer_next_token_is_not (parser->lexer, CPP_COMPL))
|
||||
{
|
||||
+ /* If postfix-expression before . or -> token was dependent,
|
||||
+ this might be actually a normal class access rather than
|
||||
+ pseudo destructor. As cp_parser_type_name can report
|
||||
+ errors, first make sure the type name is followed
|
||||
+ by `::~'. */
|
||||
+ cp_token *token = cp_lexer_peek_token (parser->lexer);
|
||||
+ if (token->type != CPP_NAME && token->type != CPP_TEMPLATE_ID)
|
||||
+ {
|
||||
+ cp_parser_error (parser, "expected class-name");
|
||||
+ return;
|
||||
+ }
|
||||
+
|
||||
+ if (token->type == CPP_NAME
|
||||
+ && !cp_parser_nth_token_starts_template_argument_list_p (parser, 2)
|
||||
+ && (cp_lexer_peek_nth_token (parser->lexer, 2)->type != CPP_SCOPE
|
||||
+ || cp_lexer_peek_nth_token (parser->lexer, 3)->type != CPP_COMPL))
|
||||
+ {
|
||||
+ cp_parser_error (parser, "not a pseudo destructor");
|
||||
+ return;
|
||||
+ }
|
||||
+
|
||||
/* Look for the type-name. */
|
||||
*scope = TREE_TYPE (cp_parser_type_name (parser));
|
||||
|
||||
--- gcc/testsuite/g++.dg/template/member8.C.jj 2008-02-12 18:32:14.000000000 +0100
|
||||
+++ gcc/testsuite/g++.dg/template/member8.C 2008-02-12 18:19:23.000000000 +0100
|
||||
@@ -0,0 +1,25 @@
|
||||
+// PR c++/35138
|
||||
+// { dg-do compile }
|
||||
+
|
||||
+namespace N1 { struct A { }; }
|
||||
+namespace N2 { struct A { }; }
|
||||
+using namespace N1;
|
||||
+using namespace N2;
|
||||
+
|
||||
+template <typename T> int
|
||||
+foo (T const &t)
|
||||
+{
|
||||
+ return t.A;
|
||||
+}
|
||||
+
|
||||
+struct B
|
||||
+{
|
||||
+ int A;
|
||||
+};
|
||||
+
|
||||
+int
|
||||
+main ()
|
||||
+{
|
||||
+ B b;
|
||||
+ foo (b);
|
||||
+}
|
14
gcc43.spec
14
gcc43.spec
@ -1,6 +1,6 @@
|
||||
%define DATE 20080212
|
||||
%define DATE 20080214
|
||||
%define gcc_version 4.3.0
|
||||
%define gcc_release 0.8
|
||||
%define gcc_release 0.9
|
||||
%define _unpackaged_files_terminate_build 0
|
||||
%define multilib_64_archs sparc64 ppc64 s390x x86_64
|
||||
%define include_gappletviewer 1
|
||||
@ -141,7 +141,7 @@ Patch11: gcc43-rh341221.patch
|
||||
Patch12: gcc43-cpp-pragma.patch
|
||||
Patch13: gcc43-java-debug-iface-type.patch
|
||||
Patch14: gcc43-pr35130.patch
|
||||
Patch15: gcc43-pr35138.patch
|
||||
Patch15: gcc43-pr35136-revert.patch
|
||||
|
||||
# On ARM EABI systems, we do want -gnueabi to be part of the
|
||||
# target triple.
|
||||
@ -439,7 +439,7 @@ which are required to run programs compiled with the GNAT.
|
||||
%patch12 -p0 -b .cpp-pragma~
|
||||
%patch13 -p0 -b .java-debug-iface-type~
|
||||
%patch14 -p0 -b .pr35130~
|
||||
%patch15 -p0 -b .pr35138~
|
||||
%patch15 -p0 -b .pr35136-revert~
|
||||
|
||||
tar xzf %{SOURCE4}
|
||||
|
||||
@ -1653,6 +1653,12 @@ fi
|
||||
%doc rpm.doc/changelogs/libmudflap/ChangeLog*
|
||||
|
||||
%changelog
|
||||
* Thu Feb 14 2008 Jakub Jelinek <jakub@redhat.com> 4.3.0-0.9
|
||||
- update to trunk
|
||||
- PRs middle-end/29673, ada/35143, c++/34774, c++/34824, c++/34962, c++/34937,
|
||||
c++/34939, debug/35065, other/35148, target/34393
|
||||
- fix ia64 build (#432068)
|
||||
|
||||
* Tue Feb 12 2008 Jakub Jelinek <jakub@redhat.com> 4.3.0-0.8
|
||||
- update to trunk
|
||||
- PRs bootstrap/33781, bootstrap/34922, bootstrap/35051, bootstrap/35115,
|
||||
|
Loading…
Reference in New Issue
Block a user