11.0.0-0.18
This commit is contained in:
parent
9087b59fd4
commit
931429764e
1
.gitignore
vendored
1
.gitignore
vendored
@ -31,3 +31,4 @@
|
||||
/gcc-11.0.0-20210116.tar.xz
|
||||
/gcc-11.0.0-20210119.tar.xz
|
||||
/gcc-11.0.0-20210123.tar.xz
|
||||
/gcc-11.0.0-20210130.tar.xz
|
||||
|
24
gcc.spec
24
gcc.spec
@ -1,5 +1,5 @@
|
||||
%global DATE 20210123
|
||||
%global gitrev 6efa61bd94ae86200aaed7ec513de6b3726220bf
|
||||
%global DATE 20210130
|
||||
%global gitrev 17ea13f46910e81a4891636c35aec2b3dabe5879
|
||||
%global gcc_version 11.0.0
|
||||
%global gcc_major 11
|
||||
# Note, gcc_release must be integer, if you want to add suffixes to
|
||||
@ -119,7 +119,7 @@
|
||||
Summary: Various compilers (C, C++, Objective-C, ...)
|
||||
Name: gcc
|
||||
Version: %{gcc_version}
|
||||
Release: %{gcc_release}.17%{?dist}.1
|
||||
Release: %{gcc_release}.18%{?dist}
|
||||
# libgcc, libgfortran, libgomp, libstdc++ and crtstuff have
|
||||
# GCC Runtime Exception.
|
||||
License: GPLv3+ and GPLv3+ with exceptions and GPLv2+ with exceptions and LGPLv2+ and BSD
|
||||
@ -272,7 +272,6 @@ Patch9: gcc11-Wno-format-security.patch
|
||||
Patch10: gcc11-rh1574936.patch
|
||||
Patch11: gcc11-d-shared-libphobos.patch
|
||||
Patch12: gcc11-pr98338-workaround.patch
|
||||
Patch13: gcc11-pr98681.patch
|
||||
|
||||
# On ARM EABI systems, we do want -gnueabi to be part of the
|
||||
# target triple.
|
||||
@ -784,7 +783,6 @@ to NVidia PTX capable devices if available.
|
||||
%endif
|
||||
%patch11 -p0 -b .d-shared-libphobos~
|
||||
%patch12 -p0 -b .pr98338-workaround~
|
||||
%patch13 -p0 -b .pr98681~
|
||||
|
||||
rm -f libgomp/testsuite/*/*task-detach*
|
||||
|
||||
@ -3071,8 +3069,20 @@ end
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 11.0.0-0.17.1
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||
* Sat Jan 30 2021 Jakub Jelinek <jakub@redhat.com> 11.0.0-0.18
|
||||
- update from trunk
|
||||
- PRs ada/98228, bootstrap/98839, c++/33661, c++/88548, c++/94775,
|
||||
c++/96137, c++/97474, c++/97566, c++/97874, c++/98463, c++/98646,
|
||||
c++/98770, c++/98841, c++/98843, c++/98847, d/98806, debug/98331,
|
||||
debug/98811, fortran/67539, fortran/70070, fortran/86470,
|
||||
fortran/93924, fortran/93925, fortran/96843, fortran/98472,
|
||||
fortran/98517, libstdc++/66414, lto/85574, middle-end/98726,
|
||||
middle-end/98807, rtl-optimization/80960, rtl-optimization/97684,
|
||||
rtl-optimization/98144, rtl-optimization/98863, sanitizer/98828,
|
||||
target/97701, target/98730, target/98799, target/98827, target/98833,
|
||||
target/98849, target/98853, testsuite/98771, testsuite/98870,
|
||||
tree-optimization/97260, tree-optimization/97627,
|
||||
tree-optimization/98854, tree-optimization/98866
|
||||
|
||||
* Sat Jan 23 2021 Jakub Jelinek <jakub@redhat.com> 11.0.0-0.17
|
||||
- update from trunk
|
||||
|
@ -1,48 +0,0 @@
|
||||
2021-01-22 Jakub Jelinek <jakub@redhat.com>
|
||||
|
||||
PR target/98681
|
||||
* config/aarch64/aarch64.c (aarch64_mask_and_shift_for_ubfiz_p):
|
||||
Use UINTVAL (shft_amnt) and UINTVAL (mask) instead of INTVAL (shft_amnt)
|
||||
and INTVAL (mask). Add && INTVAL (mask) > 0 condition.
|
||||
|
||||
* gcc.c-torture/execute/pr98681.c: New test.
|
||||
|
||||
--- gcc/config/aarch64/aarch64.c.jj 2021-01-13 11:36:27.069888393 +0100
|
||||
+++ gcc/config/aarch64/aarch64.c 2021-01-22 18:53:18.611518461 +0100
|
||||
@@ -12060,10 +12060,11 @@ aarch64_mask_and_shift_for_ubfiz_p (scal
|
||||
rtx shft_amnt)
|
||||
{
|
||||
return CONST_INT_P (mask) && CONST_INT_P (shft_amnt)
|
||||
- && INTVAL (shft_amnt) < GET_MODE_BITSIZE (mode)
|
||||
- && exact_log2 ((INTVAL (mask) >> INTVAL (shft_amnt)) + 1) >= 0
|
||||
- && (INTVAL (mask)
|
||||
- & ((HOST_WIDE_INT_1U << INTVAL (shft_amnt)) - 1)) == 0;
|
||||
+ && INTVAL (mask) > 0
|
||||
+ && UINTVAL (shft_amnt) < GET_MODE_BITSIZE (mode)
|
||||
+ && exact_log2 ((UINTVAL (mask) >> UINTVAL (shft_amnt)) + 1) >= 0
|
||||
+ && (UINTVAL (mask)
|
||||
+ & ((HOST_WIDE_INT_1U << UINTVAL (shft_amnt)) - 1)) == 0;
|
||||
}
|
||||
|
||||
/* Return true if the masks and a shift amount from an RTX of the form
|
||||
--- gcc/testsuite/gcc.c-torture/execute/pr98681.c.jj 2021-01-22 16:45:05.102070501 +0100
|
||||
+++ gcc/testsuite/gcc.c-torture/execute/pr98681.c 2021-01-22 16:44:34.165416961 +0100
|
||||
@@ -0,0 +1,18 @@
|
||||
+/* PR target/98681 */
|
||||
+
|
||||
+__attribute__((noipa)) int
|
||||
+foo (int x)
|
||||
+{
|
||||
+ if (x > 32)
|
||||
+ return (x << -64) & 255;
|
||||
+ else
|
||||
+ return x;
|
||||
+}
|
||||
+
|
||||
+int
|
||||
+main ()
|
||||
+{
|
||||
+ if (foo (32) != 32 || foo (-150) != -150)
|
||||
+ __builtin_abort ();
|
||||
+ return 0;
|
||||
+}
|
2
sources
2
sources
@ -1,3 +1,3 @@
|
||||
SHA512 (gcc-11.0.0-20210123.tar.xz) = 0c1ee7eab7ef8380c168e4841360667fe7f07d93df54c2f5c814d7830ec812f6087e0ded2761db5f316e1a16772fbc5c39c31a3b2862a3e455c44edc29eb624b
|
||||
SHA512 (gcc-11.0.0-20210130.tar.xz) = 8f7a43910a8097a146987c1f336cd51fff2c236ecdf3e1e46b87a6f0336f40483922d997d8a95f26b35b97e91879fbb3a3840492ef823110a280f29745d437f8
|
||||
SHA512 (newlib-cygwin-50e2a63b04bdd018484605fbb954fd1bd5147fa0.tar.xz) = 002a48a7b689a81abbf16161bcaec001a842e67dfbe372e9e109092703bfc666675f16198f60ca429370e8850d564547dc505df81bc3aaca4ce6defbc014ad6c
|
||||
SHA512 (nvptx-tools-5f6f343a302d620b0868edab376c00b15741e39e.tar.xz) = f6d10db94fa1570ae0f94df073fa3c73c8e5ee16d59070b53d94f7db0de8a031bc44d7f3f1852533da04b625ce758e022263855ed43cfc6867e0708d001e53c7
|
||||
|
Loading…
Reference in New Issue
Block a user