7.1.1-5
This commit is contained in:
parent
9e8f689b47
commit
90cceafa81
1
.gitignore
vendored
1
.gitignore
vendored
@ -19,3 +19,4 @@
|
||||
/gcc-7.1.1-20170526.tar.bz2
|
||||
/gcc-7.1.1-20170622.tar.bz2
|
||||
/gcc-7.1.1-20170708.tar.bz2
|
||||
/gcc-7.1.1-20170711.tar.bz2
|
||||
|
13
gcc.spec
13
gcc.spec
@ -1,10 +1,10 @@
|
||||
%global DATE 20170708
|
||||
%global SVNREV 250082
|
||||
%global DATE 201707011
|
||||
%global SVNREV 250136
|
||||
%global gcc_version 7.1.1
|
||||
%global gcc_major 7
|
||||
# Note, gcc_release must be integer, if you want to add suffixes to
|
||||
# %{release}, append them after %{gcc_release} on Release: line.
|
||||
%global gcc_release 4
|
||||
%global gcc_release 5
|
||||
%global nvptx_tools_gitrev c28050f60193b3b95a18866a96f03334e874e78f
|
||||
%global nvptx_newlib_gitrev aadc8eb0ec43b7cd0dd2dfb484bae63c8b05ef24
|
||||
%global _unpackaged_files_terminate_build 0
|
||||
@ -233,6 +233,7 @@ Patch9: gcc7-aarch64-async-unw-tables.patch
|
||||
Patch10: gcc7-foffload-default.patch
|
||||
Patch11: gcc7-Wno-format-security.patch
|
||||
Patch12: gcc7-rh1467526.patch
|
||||
Patch13: gcc7-pr81066.patch
|
||||
|
||||
Patch1000: nvptx-tools-no-ptxas.patch
|
||||
Patch1001: nvptx-tools-build.patch
|
||||
@ -823,6 +824,7 @@ package or when debugging this package.
|
||||
%patch10 -p0 -b .foffload-default~
|
||||
%patch11 -p0 -b .Wno-format-security~
|
||||
%patch12 -p0 -b .rh1467526~
|
||||
%patch13 -p0 -b .pr81066~
|
||||
|
||||
cd nvptx-tools-%{nvptx_tools_gitrev}
|
||||
%patch1000 -p1 -b .nvptx-tools-no-ptxas~
|
||||
@ -3240,6 +3242,11 @@ fi
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Tue Jul 11 2017 Jakub Jelinek <jakub@redhat.com> 7.1.1-5
|
||||
- update from the 7 branch
|
||||
- PRs libstdc++/80316, target/81375
|
||||
- fix libsanitizer build against recent glibc (PR sanitizer/81066)
|
||||
|
||||
* Sun Jul 9 2017 Jakub Jelinek <jakub@redhat.com> 7.1.1-4
|
||||
- update from the 7 branch
|
||||
- PRs c++/54769, c++/61022, c++/72801, c++/79056, c++/81164, c++/81180,
|
||||
|
66
gcc7-pr81066.patch
Normal file
66
gcc7-pr81066.patch
Normal file
@ -0,0 +1,66 @@
|
||||
2017-07-11 Jakub Jelinek <jakub@redhat.com>
|
||||
|
||||
PR sanitizer/81066
|
||||
* sanitizer_common/sanitizer_linux.cc (internal_sigaltstack): Use void
|
||||
instead of struct sigaltstack.
|
||||
* sanitizer_common/sanitizer_linux.h (internal_sigaltstack): Likewise.
|
||||
(struct sigaltstack): Remove forward declaration.
|
||||
* sanitizer_common/sanitizer_stoptheworld_linux_libcdep.cc
|
||||
(TracerThread): Use stack_t instead of struct sigaltstack.
|
||||
* tsan/tsan_platform_linux.cc (ExtractResolvFDs): Use struct
|
||||
__res_state instead of just __res_state.
|
||||
|
||||
--- libsanitizer/sanitizer_common/sanitizer_linux.cc.jj 2016-11-09 18:26:30.000000000 +0100
|
||||
+++ libsanitizer/sanitizer_common/sanitizer_linux.cc 2017-07-11 13:02:10.440483783 +0200
|
||||
@@ -605,8 +605,7 @@ uptr internal_prctl(int option, uptr arg
|
||||
}
|
||||
#endif
|
||||
|
||||
-uptr internal_sigaltstack(const struct sigaltstack *ss,
|
||||
- struct sigaltstack *oss) {
|
||||
+uptr internal_sigaltstack(const void *ss, void *oss) {
|
||||
return internal_syscall(SYSCALL(sigaltstack), (uptr)ss, (uptr)oss);
|
||||
}
|
||||
|
||||
--- libsanitizer/sanitizer_common/sanitizer_stoptheworld_linux_libcdep.cc.jj 2016-11-09 18:26:30.322873896 +0100
|
||||
+++ libsanitizer/sanitizer_common/sanitizer_stoptheworld_linux_libcdep.cc 2017-07-11 13:02:50.027011510 +0200
|
||||
@@ -273,7 +273,7 @@ static int TracerThread(void* argument)
|
||||
|
||||
// Alternate stack for signal handling.
|
||||
InternalScopedBuffer<char> handler_stack_memory(kHandlerStackSize);
|
||||
- struct sigaltstack handler_stack;
|
||||
+ stack_t handler_stack;
|
||||
internal_memset(&handler_stack, 0, sizeof(handler_stack));
|
||||
handler_stack.ss_sp = handler_stack_memory.data();
|
||||
handler_stack.ss_size = kHandlerStackSize;
|
||||
--- libsanitizer/sanitizer_common/sanitizer_linux.h.jj 2016-11-09 18:26:30.000000000 +0100
|
||||
+++ libsanitizer/sanitizer_common/sanitizer_linux.h 2017-07-11 13:00:23.671757549 +0200
|
||||
@@ -19,7 +19,6 @@
|
||||
#include "sanitizer_platform_limits_posix.h"
|
||||
|
||||
struct link_map; // Opaque type returned by dlopen().
|
||||
-struct sigaltstack;
|
||||
|
||||
namespace __sanitizer {
|
||||
// Dirent structure for getdents(). Note that this structure is different from
|
||||
@@ -28,8 +27,7 @@ struct linux_dirent;
|
||||
|
||||
// Syscall wrappers.
|
||||
uptr internal_getdents(fd_t fd, struct linux_dirent *dirp, unsigned int count);
|
||||
-uptr internal_sigaltstack(const struct sigaltstack* ss,
|
||||
- struct sigaltstack* oss);
|
||||
+uptr internal_sigaltstack(const void* ss, void* oss);
|
||||
uptr internal_sigprocmask(int how, __sanitizer_sigset_t *set,
|
||||
__sanitizer_sigset_t *oldset);
|
||||
|
||||
--- libsanitizer/tsan/tsan_platform_linux.cc.jj 2016-11-09 18:26:31.000000000 +0100
|
||||
+++ libsanitizer/tsan/tsan_platform_linux.cc 2017-07-11 13:03:39.944415988 +0200
|
||||
@@ -287,7 +287,7 @@ void InitializePlatform() {
|
||||
int ExtractResolvFDs(void *state, int *fds, int nfd) {
|
||||
#if SANITIZER_LINUX && !SANITIZER_ANDROID
|
||||
int cnt = 0;
|
||||
- __res_state *statp = (__res_state*)state;
|
||||
+ struct __res_state *statp = (struct __res_state*)state;
|
||||
for (int i = 0; i < MAXNS && cnt < nfd; i++) {
|
||||
if (statp->_u._ext.nsaddrs[i] && statp->_u._ext.nssocks[i] != -1)
|
||||
fds[cnt++] = statp->_u._ext.nssocks[i];
|
2
sources
2
sources
@ -1,3 +1,3 @@
|
||||
SHA512 (gcc-7.1.1-20170708.tar.bz2) = 30a93b618f0288e8e9741c253cb5ea35fee150eaca4418d3467aff2b3a4eec8e2728ee40610ef38fba123abd7960b53dce42b7f2aff7f17d6beedb25cd73f1c9
|
||||
SHA512 (gcc-7.1.1-20170711.tar.bz2) = 23d3867081d06b2e7f4bbfb50ca48ed17368f06425b0dc0913d91477a9ded4bcbcc9b343862059421eba7e330fe65c82c47a760665ba504f55ef81e268e0b718
|
||||
SHA512 (nvptx-newlib-aadc8eb0ec43b7cd0dd2dfb484bae63c8b05ef24.tar.bz2) = 38f97c9297ad108568352a4d28277455a3c01fd8b7864e798037e5006b6f757022e874bbf3f165775fe3b873781bc108137bbeb42dd5ed3c7d3e6747746fa918
|
||||
SHA512 (nvptx-tools-c28050f60193b3b95a18866a96f03334e874e78f.tar.bz2) = 95b577a06a93bb044dbc8033e550cb36bcf2ab2687da030a7318cdc90e7467ed49665e247dcafb5ff4a7e92cdc264291d19728bd17fab902fb64b22491269330
|
||||
|
Loading…
Reference in New Issue
Block a user