4.6.0-0.15
This commit is contained in:
parent
88f5aeebda
commit
8d5e77f9e5
1
.gitignore
vendored
1
.gitignore
vendored
@ -8,3 +8,4 @@
|
||||
/gcc-4.6.0-20110304.tar.bz2
|
||||
/gcc-4.6.0-20110315.tar.bz2
|
||||
/gcc-4.6.0-20110318.tar.bz2
|
||||
/gcc-4.6.0-20110321.tar.bz2
|
||||
|
11
gcc.spec
11
gcc.spec
@ -1,9 +1,9 @@
|
||||
%global DATE 20110318
|
||||
%global SVNREV 171160
|
||||
%global DATE 20110321
|
||||
%global SVNREV 171264
|
||||
%global gcc_version 4.6.0
|
||||
# Note, gcc_release must be integer, if you want to add suffixes to
|
||||
# %{release}, append them after %{gcc_release} on Release: line.
|
||||
%global gcc_release 0.14
|
||||
%global gcc_release 0.15
|
||||
%global _unpackaged_files_terminate_build 0
|
||||
%global multilib_64_archs sparc64 ppc64 s390x x86_64
|
||||
%ifarch %{ix86} x86_64 ia64 ppc ppc64 alpha
|
||||
@ -2340,6 +2340,11 @@ fi
|
||||
%{_prefix}/lib/gcc/%{gcc_target_platform}/%{gcc_version}/plugin
|
||||
|
||||
%changelog
|
||||
* Mon Mar 21 2011 Jakub Jelinek <jakub@redhat.com> 4.6.0-0.15
|
||||
- update from the 4.6 branch
|
||||
- PRs bootstrap/45381, bootstrap/48135
|
||||
- fix s390 ICE during address delegitimization (PR target/48213, #689266)
|
||||
|
||||
* Fri Mar 18 2011 Jakub Jelinek <jakub@redhat.com> 4.6.0-0.14
|
||||
- update from the 4.6 branch
|
||||
- PRs bootstrap/48161, c++/48113, c++/48115, c++/48132, debug/47510,
|
||||
|
@ -49,39 +49,39 @@ gcc/
|
||||
#endif
|
||||
--- configure.ac (revision 169207)
|
||||
+++ configure.ac (revision 169206)
|
||||
@@ -1668,9 +1668,9 @@ ENABLE_PPL_CHECK=yes)
|
||||
if test "x$with_ppl" != "xno" -a "${ENABLE_PPL_CHECK}" = "yes"; then
|
||||
saved_CFLAGS="$CFLAGS"
|
||||
CFLAGS="$CFLAGS $pplinc $gmpinc"
|
||||
- AC_MSG_CHECKING([for version 0.11 (or later revision) of PPL])
|
||||
+ AC_MSG_CHECKING([for version 0.10 (or later revision) of PPL])
|
||||
AC_TRY_COMPILE([#include "ppl_c.h"],[
|
||||
- #if PPL_VERSION_MAJOR != 0 || PPL_VERSION_MINOR < 11
|
||||
+ #if PPL_VERSION_MAJOR != 0 || PPL_VERSION_MINOR < 10
|
||||
choke me
|
||||
#endif
|
||||
], [AC_MSG_RESULT([yes])], [AC_MSG_RESULT([no]); ppllibs= ; pplinc= ; with_ppl=no ])
|
||||
@@ -1688,9 +1688,9 @@ if test "x$with_ppl" != xno; then
|
||||
if test "$enable_ppl_version_check" != no; then
|
||||
saved_CFLAGS="$CFLAGS"
|
||||
CFLAGS="$CFLAGS $pplinc $gmpinc"
|
||||
- AC_MSG_CHECKING([for version 0.11 (revision 0 or later) of PPL])
|
||||
+ AC_MSG_CHECKING([for version 0.10 (revision 0 or later) of PPL])
|
||||
AC_TRY_COMPILE([#include "ppl_c.h"],[
|
||||
- #if PPL_VERSION_MAJOR != 0 || PPL_VERSION_MINOR < 11
|
||||
+ #if PPL_VERSION_MAJOR != 0 || PPL_VERSION_MINOR < 10
|
||||
choke me
|
||||
#endif
|
||||
], [AC_MSG_RESULT([yes])], [AC_MSG_RESULT([no]); ppllibs= ; pplinc= ; with_ppl=no ])
|
||||
--- configure (revision 169207)
|
||||
+++ configure (revision 169206)
|
||||
@@ -5716,8 +5716,8 @@ fi
|
||||
if test "x$with_ppl" != "xno" -a "${ENABLE_PPL_CHECK}" = "yes"; then
|
||||
saved_CFLAGS="$CFLAGS"
|
||||
CFLAGS="$CFLAGS $pplinc $gmpinc"
|
||||
- { $as_echo "$as_me:${as_lineno-$LINENO}: checking for version 0.11 (or later revision) of PPL" >&5
|
||||
-$as_echo_n "checking for version 0.11 (or later revision) of PPL... " >&6; }
|
||||
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking for version 0.10 (or later revision) of PPL" >&5
|
||||
+$as_echo_n "checking for version 0.10 (or later revision) of PPL... " >&6; }
|
||||
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
|
||||
@@ -5775,8 +5775,8 @@ fi
|
||||
if test "$enable_ppl_version_check" != no; then
|
||||
saved_CFLAGS="$CFLAGS"
|
||||
CFLAGS="$CFLAGS $pplinc $gmpinc"
|
||||
- { $as_echo "$as_me:${as_lineno-$LINENO}: checking for version 0.11 (revision 0 or later) of PPL" >&5
|
||||
-$as_echo_n "checking for version 0.11 (revision 0 or later) of PPL... " >&6; }
|
||||
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking for version 0.10 (revision 0 or later) of PPL" >&5
|
||||
+$as_echo_n "checking for version 0.10 (revision 0 or later) of PPL... " >&6; }
|
||||
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
|
||||
/* end confdefs.h. */
|
||||
#include "ppl_c.h"
|
||||
@@ -5725,7 +5725,7 @@ int
|
||||
@@ -5784,7 +5784,7 @@ int
|
||||
main ()
|
||||
{
|
||||
|
||||
- #if PPL_VERSION_MAJOR != 0 || PPL_VERSION_MINOR < 11
|
||||
+ #if PPL_VERSION_MAJOR != 0 || PPL_VERSION_MINOR < 10
|
||||
choke me
|
||||
#endif
|
||||
- #if PPL_VERSION_MAJOR != 0 || PPL_VERSION_MINOR < 11
|
||||
+ #if PPL_VERSION_MAJOR != 0 || PPL_VERSION_MINOR < 10
|
||||
choke me
|
||||
#endif
|
||||
|
||||
--- gcc/testsuite/gcc.dg/graphite/interchange-11.c.jj 2011-01-28 09:38:11.000000000 +0100
|
||||
+++ gcc/testsuite/gcc.dg/graphite/interchange-11.c 2011-01-28 11:06:56.461429848 +0100
|
||||
|
Loading…
Reference in New Issue
Block a user