Merge remote-tracking branch 'up/master' into master-riscv64
This commit is contained in:
commit
8d1ed6b2bc
1
.gitignore
vendored
1
.gitignore
vendored
@ -51,3 +51,4 @@
|
||||
/gcc-8.1.1-20180626.tar.xz
|
||||
/gcc-8.1.1-20180712.tar.xz
|
||||
/gcc-8.2.1-20180726.tar.xz
|
||||
/gcc-8.2.1-20180801.tar.xz
|
||||
|
32
gcc.spec
32
gcc.spec
@ -1,26 +1,26 @@
|
||||
%global DATE 20180726
|
||||
%global SVNREV 263019
|
||||
%global DATE 20180801
|
||||
%global SVNREV 263232.
|
||||
%global gcc_version 8.2.1
|
||||
%global gcc_major 8
|
||||
# Note, gcc_release must be integer, if you want to add suffixes to
|
||||
# %%{release}, append them after %%{gcc_release} on Release: line.
|
||||
%global gcc_release 1
|
||||
%global gcc_release 2
|
||||
%global nvptx_tools_gitrev c28050f60193b3b95a18866a96f03334e874e78f
|
||||
%global nvptx_newlib_gitrev aadc8eb0ec43b7cd0dd2dfb484bae63c8b05ef24
|
||||
%global _unpackaged_files_terminate_build 0
|
||||
%global _performance_build 1
|
||||
# Hardening slows the compiler way too much.
|
||||
%undefine _hardened_build
|
||||
%if 0%{?fedora} > 27 || 0%{?rhel} >= 8
|
||||
%if 0%{?fedora} > 27 || 0%{?rhel} > 7
|
||||
# Until annobin is fixed (#1519165).
|
||||
%undefine _annotated_build
|
||||
%endif
|
||||
%if 0%{?rhel} >= 8
|
||||
%global multilib_64_archs sparc64 ppc64 ppc64p7 s390x x86_64
|
||||
%if 0%{?rhel} > 7
|
||||
%global build_ada 0
|
||||
%global build_objc 0
|
||||
%global build_go 0
|
||||
%else
|
||||
%global multilib_64_archs sparc64 ppc64 ppc64p7 s390x x86_64
|
||||
%ifarch %{ix86} x86_64 ia64 ppc %{power64} alpha s390x %{arm} aarch64
|
||||
%global build_ada 1
|
||||
%else
|
||||
@ -68,7 +68,7 @@
|
||||
%else
|
||||
%global build_libitm 0
|
||||
%endif
|
||||
%if 0%{?rhel} >= 8
|
||||
%if 0%{?rhel} > 7
|
||||
%global build_libmpx 0
|
||||
%else
|
||||
%ifarch %{ix86} x86_64
|
||||
@ -143,7 +143,7 @@ URL: http://gcc.gnu.org
|
||||
# Need binutils which support -plugin
|
||||
# Need binutils which support .loc view >= 2.30
|
||||
# Need binutils which support --generate-missing-build-notes=yes >= 2.31
|
||||
%if 0%{?fedora} >= 29 || 0%{?rhel} >= 8
|
||||
%if 0%{?fedora} >= 29 || 0%{?rhel} > 7
|
||||
BuildRequires: binutils >= 2.31
|
||||
%else
|
||||
BuildRequires: binutils >= 2.24
|
||||
@ -216,7 +216,7 @@ Requires: cpp = %{version}-%{release}
|
||||
# Need binutils that support -plugin
|
||||
# Need binutils that support .loc view >= 2.30
|
||||
# Need binutils which support --generate-missing-build-notes=yes >= 2.31
|
||||
%if 0%{?fedora} >= 29 || 0%{?rhel} >= 8
|
||||
%if 0%{?fedora} >= 29 || 0%{?rhel} > 7
|
||||
Requires: binutils >= 2.31
|
||||
%else
|
||||
Requires: binutils >= 2.24
|
||||
@ -498,7 +498,7 @@ This package contains shared library with GCC JIT front-end.
|
||||
%package -n libgccjit-devel
|
||||
Summary: Support for embedding GCC inside programs and libraries
|
||||
Group: Development/Libraries
|
||||
%if 0%{?fedora} > 27 || 0%{?rhel} >= 8
|
||||
%if 0%{?fedora} > 27 || 0%{?rhel} > 7
|
||||
BuildRequires: python3-sphinx
|
||||
%else
|
||||
BuildRequires: python-sphinx
|
||||
@ -835,7 +835,7 @@ to NVidia PTX capable devices if available.
|
||||
%if 0%{?fedora} == 28
|
||||
%patch12 -p0 -b .mcet~
|
||||
%endif
|
||||
%if 0%{?fedora} >= 29 || 0%{?rhel} >= 8
|
||||
%if 0%{?fedora} >= 29 || 0%{?rhel} > 7
|
||||
%patch13 -p0 -b .rh1574936~
|
||||
%endif
|
||||
|
||||
@ -1047,7 +1047,7 @@ CONFIGURE_OPTS="\
|
||||
%endif
|
||||
%ifarch s390 s390x
|
||||
%if 0%{?rhel} >= 7
|
||||
%if 0%{?rhel} >= 8
|
||||
%if 0%{?rhel} > 7
|
||||
--with-arch=zEC12 --with-tune=z13 \
|
||||
%else
|
||||
--with-arch=z196 --with-tune=zEC12 \
|
||||
@ -1967,7 +1967,7 @@ cd obj-%{gcc_target_platform}
|
||||
|
||||
# run the tests.
|
||||
make %{?_smp_mflags} -k check ALT_CC_UNDER_TEST=gcc ALT_CXX_UNDER_TEST=g++ \
|
||||
%if 0%{?fedora} >= 20 || 0%{?rhel} >= 8
|
||||
%if 0%{?fedora} >= 20 || 0%{?rhel} > 7
|
||||
RUNTESTFLAGS="--target_board=unix/'{,-fstack-protector-strong}'" || :
|
||||
%else
|
||||
RUNTESTFLAGS="--target_board=unix/'{,-fstack-protector}'" || :
|
||||
@ -3152,6 +3152,12 @@ fi
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Wed Aug 1 2018 Jakub Jelinek <jakub@redhat.com> 8.2.1-2
|
||||
- update from the 8 branch
|
||||
- PRs bootstrap/86724, c/85704, c/86617, libstdc++/84654, libstdc++/85672,
|
||||
libstdc++/86734, sanitizer/86759, target/86511, target/86612,
|
||||
target/86651
|
||||
|
||||
* Thu Jul 26 2018 Jakub Jelinek <jakub@redhat.com> 8.2.1-1
|
||||
- update from the 8 branch
|
||||
- GCC 8.2 release
|
||||
|
@ -27,10 +27,10 @@
|
||||
# and compile them.
|
||||
--- gcc/graphite.h.jj 2016-01-27 12:44:06.000000000 +0100
|
||||
+++ gcc/graphite.h 2016-01-27 13:26:38.309876856 +0100
|
||||
@@ -37,6 +37,590 @@ along with GCC; see the file COPYING3.
|
||||
#include <isl/schedule.h>
|
||||
#include <isl/ast_build.h>
|
||||
@@ -39,6 +39,590 @@ along with GCC; see the file COPYING3.
|
||||
#include <isl/schedule_node.h>
|
||||
#include <isl/id.h>
|
||||
#include <isl/space.h>
|
||||
+#include <isl/version.h>
|
||||
+#include <dlfcn.h>
|
||||
+
|
||||
|
2
sources
2
sources
@ -1,3 +1,3 @@
|
||||
SHA512 (gcc-8.2.1-20180726.tar.xz) = 7eca02af21f809d084c2069376be1dca0a47357ca9c7f1e6d3dd4069ce4adf766df4e3ca2cc96762e4285813babffb562b89d46456f2b55277246a450f1cecc5
|
||||
SHA512 (gcc-8.2.1-20180801.tar.xz) = d093cdca710d7c009787a1f11e1761c803f3b645b91f4b1ef40ea1bd70b07b7a566ebc4c331f8092374444cd5bd351b3dd914b5571d9296b66d0dbe76749ce23
|
||||
SHA512 (nvptx-newlib-aadc8eb0ec43b7cd0dd2dfb484bae63c8b05ef24.tar.xz) = 94f7089365296f7dfa485107b4143bebc850a81586f3460fd896bbbb6ba099a00217d4042133424fd2183b352132f4fd367e6a60599bdae2a26dfd48a77d0e04
|
||||
SHA512 (nvptx-tools-c28050f60193b3b95a18866a96f03334e874e78f.tar.xz) = a688cb12cf805950a5abbb13b52f45c81dbee98e310b7ed57ae20e76dbfa5964a16270148374a6426d177db71909d28360490f091c86a5d19d4faa5127beeee1
|
||||
|
Loading…
Reference in New Issue
Block a user