8.0.1-0.7
This commit is contained in:
parent
3139eaf997
commit
7a1512fd56
1
.gitignore
vendored
1
.gitignore
vendored
@ -32,3 +32,4 @@
|
|||||||
/nvptx-newlib-aadc8eb0ec43b7cd0dd2dfb484bae63c8b05ef24.tar.xz
|
/nvptx-newlib-aadc8eb0ec43b7cd0dd2dfb484bae63c8b05ef24.tar.xz
|
||||||
/nvptx-tools-c28050f60193b3b95a18866a96f03334e874e78f.tar.xz
|
/nvptx-tools-c28050f60193b3b95a18866a96f03334e874e78f.tar.xz
|
||||||
/gcc-8.0.1-20180830.tar.xz
|
/gcc-8.0.1-20180830.tar.xz
|
||||||
|
/gcc-8.0.1-20180130.tar.xz
|
||||||
|
3
gcc.spec
3
gcc.spec
@ -236,6 +236,7 @@ Patch10: gcc8-foffload-default.patch
|
|||||||
Patch11: gcc8-Wno-format-security.patch
|
Patch11: gcc8-Wno-format-security.patch
|
||||||
Patch12: gcc8-aarch64-sanitizer-fix.patch
|
Patch12: gcc8-aarch64-sanitizer-fix.patch
|
||||||
Patch13: gcc8-rh1512529-aarch64.patch
|
Patch13: gcc8-rh1512529-aarch64.patch
|
||||||
|
Patch14: gcc8-pr84131.patch
|
||||||
|
|
||||||
Patch1000: nvptx-tools-no-ptxas.patch
|
Patch1000: nvptx-tools-no-ptxas.patch
|
||||||
Patch1001: nvptx-tools-build.patch
|
Patch1001: nvptx-tools-build.patch
|
||||||
@ -777,6 +778,7 @@ to NVidia PTX capable devices if available.
|
|||||||
%patch12 -p0 -b .aarch64-sanitizer-fix~
|
%patch12 -p0 -b .aarch64-sanitizer-fix~
|
||||||
%endif
|
%endif
|
||||||
%patch13 -p0 -b .rh1512529-aarch64~
|
%patch13 -p0 -b .rh1512529-aarch64~
|
||||||
|
%patch14 -p0 -b .pr84131~
|
||||||
|
|
||||||
cd nvptx-tools-%{nvptx_tools_gitrev}
|
cd nvptx-tools-%{nvptx_tools_gitrev}
|
||||||
%patch1000 -p1 -b .nvptx-tools-no-ptxas~
|
%patch1000 -p1 -b .nvptx-tools-no-ptxas~
|
||||||
@ -3047,6 +3049,7 @@ fi
|
|||||||
target/83828, target/84112, testsuite/81010, tree-optimization/81611,
|
target/83828, target/84112, testsuite/81010, tree-optimization/81611,
|
||||||
tree-optimization/83008, tree-optimization/84057,
|
tree-optimization/83008, tree-optimization/84057,
|
||||||
tree-optimization/84086, tree-optimization/84111
|
tree-optimization/84086, tree-optimization/84111
|
||||||
|
- fix fortran debuginfo (PR debug/84131)
|
||||||
|
|
||||||
* Sat Jan 27 2018 Jakub Jelinek <jakub@redhat.com> 8.0.1-0.6
|
* Sat Jan 27 2018 Jakub Jelinek <jakub@redhat.com> 8.0.1-0.6
|
||||||
- update from the trunk
|
- update from the trunk
|
||||||
|
17
gcc8-pr84131.patch
Normal file
17
gcc8-pr84131.patch
Normal file
@ -0,0 +1,17 @@
|
|||||||
|
2018-01-30 Jakub Jelinek <jakub@redhat.com>
|
||||||
|
|
||||||
|
PR debug/84131
|
||||||
|
* trans-array.c (gfc_get_descriptor_offsets_for_info): Set *data_off
|
||||||
|
to DATA_FIELD's offset rather than OFFSET_FIELD's offset.
|
||||||
|
|
||||||
|
--- gcc/fortran/trans-array.c.jj 2018-01-26 12:43:25.164922494 +0100
|
||||||
|
+++ gcc/fortran/trans-array.c 2018-01-30 19:34:01.844232363 +0100
|
||||||
|
@@ -511,7 +511,7 @@ gfc_get_descriptor_offsets_for_info (con
|
||||||
|
tree type;
|
||||||
|
|
||||||
|
type = TYPE_MAIN_VARIANT (desc_type);
|
||||||
|
- field = gfc_advance_chain (TYPE_FIELDS (type), OFFSET_FIELD);
|
||||||
|
+ field = gfc_advance_chain (TYPE_FIELDS (type), DATA_FIELD);
|
||||||
|
*data_off = byte_position (field);
|
||||||
|
field = gfc_advance_chain (TYPE_FIELDS (type), DTYPE_FIELD);
|
||||||
|
*dtype_off = byte_position (field);
|
2
sources
2
sources
@ -1,3 +1,3 @@
|
|||||||
SHA512 (gcc-8.0.1-20180830.tar.xz) = 4ce6a9babd0f79e7c8e8a35633ed1029f24c3db4ed8ed854d9f72bbd36a693106dd5a8345b1c317699f855d94368b43fbc8e788a9f042a060c30b4486614e7c8
|
SHA512 (gcc-8.0.1-20180130.tar.xz) = 86e6bf74a009eb0ec9ac1eeddc0961759fce6bc0436826a0b55671bb000724a0ce6ca822c4a9df7c70121d98cbb881cd65f7e2d2dbfbba1b6dc2d02ebffd2516
|
||||||
SHA512 (nvptx-newlib-aadc8eb0ec43b7cd0dd2dfb484bae63c8b05ef24.tar.xz) = 94f7089365296f7dfa485107b4143bebc850a81586f3460fd896bbbb6ba099a00217d4042133424fd2183b352132f4fd367e6a60599bdae2a26dfd48a77d0e04
|
SHA512 (nvptx-newlib-aadc8eb0ec43b7cd0dd2dfb484bae63c8b05ef24.tar.xz) = 94f7089365296f7dfa485107b4143bebc850a81586f3460fd896bbbb6ba099a00217d4042133424fd2183b352132f4fd367e6a60599bdae2a26dfd48a77d0e04
|
||||||
SHA512 (nvptx-tools-c28050f60193b3b95a18866a96f03334e874e78f.tar.xz) = a688cb12cf805950a5abbb13b52f45c81dbee98e310b7ed57ae20e76dbfa5964a16270148374a6426d177db71909d28360490f091c86a5d19d4faa5127beeee1
|
SHA512 (nvptx-tools-c28050f60193b3b95a18866a96f03334e874e78f.tar.xz) = a688cb12cf805950a5abbb13b52f45c81dbee98e310b7ed57ae20e76dbfa5964a16270148374a6426d177db71909d28360490f091c86a5d19d4faa5127beeee1
|
||||||
|
Loading…
Reference in New Issue
Block a user