7.0.1-0.4
This commit is contained in:
parent
98a12cbd71
commit
6ed6e5a4c3
4
gcc.spec
4
gcc.spec
@ -231,7 +231,6 @@ Patch11: gcc7-s390-asan.patch
|
|||||||
Patch12: gcc7-pr79197.patch
|
Patch12: gcc7-pr79197.patch
|
||||||
Patch13: gcc7-pr79232.patch
|
Patch13: gcc7-pr79232.patch
|
||||||
Patch14: gcc7-pr79288.patch
|
Patch14: gcc7-pr79288.patch
|
||||||
Patch15: gcc7-pr79170-workaround.patch
|
|
||||||
|
|
||||||
Patch1000: nvptx-tools-no-ptxas.patch
|
Patch1000: nvptx-tools-no-ptxas.patch
|
||||||
Patch1001: nvptx-tools-build.patch
|
Patch1001: nvptx-tools-build.patch
|
||||||
@ -823,7 +822,6 @@ package or when debugging this package.
|
|||||||
%patch12 -p0 -b .pr79197~
|
%patch12 -p0 -b .pr79197~
|
||||||
%patch13 -p0 -b .pr79232~
|
%patch13 -p0 -b .pr79232~
|
||||||
%patch14 -p0 -b .pr79288~
|
%patch14 -p0 -b .pr79288~
|
||||||
%patch15 -p0 -b .pr79170-workaround~
|
|
||||||
|
|
||||||
cd nvptx-tools-%{nvptx_tools_gitrev}
|
cd nvptx-tools-%{nvptx_tools_gitrev}
|
||||||
%patch1000 -p1 -b .nvptx-tools-no-ptxas~
|
%patch1000 -p1 -b .nvptx-tools-no-ptxas~
|
||||||
@ -3251,8 +3249,6 @@ fi
|
|||||||
(PR target/79197)
|
(PR target/79197)
|
||||||
- fix C++ ICE with comma expression on lhs of assignment (PR c++/79232)
|
- fix C++ ICE with comma expression on lhs of assignment (PR c++/79232)
|
||||||
- fix default TLS model for C++ non-inline static data members (PR c++/79288)
|
- fix default TLS model for C++ non-inline static data members (PR c++/79288)
|
||||||
- add workaround for powerpc constant size memcmp expansion bug (#1417753,
|
|
||||||
PR target/79170)
|
|
||||||
- libcp1plugin.so added to gcc-gdb-plugin for C++ support
|
- libcp1plugin.so added to gcc-gdb-plugin for C++ support
|
||||||
|
|
||||||
* Sat Jan 28 2017 Jakub Jelinek <jakub@redhat.com> 7.0.1-0.3
|
* Sat Jan 28 2017 Jakub Jelinek <jakub@redhat.com> 7.0.1-0.3
|
||||||
|
@ -1,16 +0,0 @@
|
|||||||
2017-01-31 Jakub Jelinek <jakub@redhat.com>
|
|
||||||
|
|
||||||
PR target/79170
|
|
||||||
* config/rs6000/rs6000.c (expand_block_compare): Temporarily disable.
|
|
||||||
|
|
||||||
--- gcc/config/rs6000/rs6000.c.jj 2017-01-31 09:25:59.000000000 +0100
|
|
||||||
+++ gcc/config/rs6000/rs6000.c 2017-01-31 10:17:21.131929670 +0100
|
|
||||||
@@ -19462,7 +19462,7 @@ expand_block_compare (rtx operands[])
|
|
||||||
with carry instructions do not generate the 64-bit
|
|
||||||
carry and so we must emit code to calculate it ourselves.
|
|
||||||
We choose not to implement this yet. */
|
|
||||||
- if (TARGET_32BIT && TARGET_POWERPC64)
|
|
||||||
+ if ((TARGET_32BIT && TARGET_POWERPC64) || 1)
|
|
||||||
return false;
|
|
||||||
|
|
||||||
/* If this is not a fixed size compare, just call memcmp. */
|
|
Loading…
Reference in New Issue
Block a user