Merge remote-tracking branch 'up/master' into master-riscv64
Signed-off-by: David Abdurachmanov <david.abdurachmanov@gmail.com>
This commit is contained in:
commit
6e5ee46df7
4
.gitignore
vendored
4
.gitignore
vendored
@ -71,3 +71,7 @@
|
||||
/gcc-9.0.1-20190312.tar.xz
|
||||
/gcc-9.0.1-20190320.tar.xz
|
||||
/gcc-9.0.1-20190328.tar.xz
|
||||
/gcc-9.0.1-20190415.tar.xz
|
||||
/gcc-9.0.1-20190418.tar.xz
|
||||
/gcc-9.0.1-20190426.tar.xz
|
||||
/gcc-9.0.1-20190430.tar.xz
|
||||
|
82
gcc.spec
82
gcc.spec
@ -1,10 +1,10 @@
|
||||
%global DATE 20190328
|
||||
%global SVNREV 270000
|
||||
%global DATE 20190430
|
||||
%global SVNREV 270701
|
||||
%global gcc_version 9.0.1
|
||||
%global gcc_major 9
|
||||
# Note, gcc_release must be integer, if you want to add suffixes to
|
||||
# %%{release}, append them after %%{gcc_release} on Release: line.
|
||||
%global gcc_release 0.12
|
||||
%global gcc_release 0.16
|
||||
%global nvptx_tools_gitrev c28050f60193b3b95a18866a96f03334e874e78f
|
||||
%global nvptx_newlib_gitrev aadc8eb0ec43b7cd0dd2dfb484bae63c8b05ef24
|
||||
%global _unpackaged_files_terminate_build 0
|
||||
@ -33,7 +33,7 @@
|
||||
%else
|
||||
%global build_go 0
|
||||
%endif
|
||||
%ifarch %{ix86} x86_64 %{arm} %{mips} riscv64
|
||||
%ifarch %{ix86} x86_64 %{arm} %{mips} s390 s390x riscv64
|
||||
%global build_d 1
|
||||
%else
|
||||
%global build_d 0
|
||||
@ -151,7 +151,7 @@ BuildRequires: zlib-devel, gettext, dejagnu, bison, flex, sharutils
|
||||
BuildRequires: texinfo, texinfo-tex, /usr/bin/pod2man
|
||||
BuildRequires: systemtap-sdt-devel >= 1.3
|
||||
BuildRequires: gmp-devel >= 4.1.2-8, mpfr-devel >= 2.2.1, libmpc-devel >= 0.8.1
|
||||
BuildRequires: python2-devel, python3-devel
|
||||
BuildRequires: python2-devel, python3-devel, /usr/bin/python
|
||||
BuildRequires: gcc, gcc-c++
|
||||
%if %{build_go}
|
||||
BuildRequires: hostname, procps
|
||||
@ -254,7 +254,6 @@ Patch8: gcc9-foffload-default.patch
|
||||
Patch9: gcc9-Wno-format-security.patch
|
||||
Patch10: gcc9-rh1574936.patch
|
||||
Patch11: gcc9-d-shared-libphobos.patch
|
||||
Patch12: gcc9-pr89093.patch
|
||||
|
||||
Patch30: libphobos-enable-riscv-v3.patch
|
||||
# Backport
|
||||
@ -770,7 +769,6 @@ to NVidia PTX capable devices if available.
|
||||
%patch10 -p0 -b .rh1574936~
|
||||
%endif
|
||||
%patch11 -p0 -b .d-shared-libphobos~
|
||||
%patch12 -p0 -b .pr89093~
|
||||
|
||||
%patch30 -p1 -b .libphobos-riscv~
|
||||
%patch31 -p1 -b .compressed-riscv~
|
||||
@ -2985,6 +2983,76 @@ end
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Tue Apr 30 2019 Jakub Jelinek <jakub@redhat.com> 9.0.1-0.16
|
||||
- update from 9 branch
|
||||
- gcc 9.1-rc2
|
||||
- PRs middle-end/90258, target/86538, translation/90274,
|
||||
tree-optimization/90273
|
||||
- enable D on s390{,x} and riscv64
|
||||
|
||||
* Fri Apr 26 2019 Jakub Jelinek <jakub@redhat.com> 9.0.1-0.15
|
||||
- update from trunk and 9 branch
|
||||
- gcc 9.1-rc1
|
||||
- PRs c++/87366, c++/87554, c++/89900, c++/90108, c++/90138, c++/90171,
|
||||
c++/90190, c++/90227, c++/90236, c/89888, d/88431, d/88654, d/89293,
|
||||
d/89432, d/90086, d/90250, debug/90131, fortran/57284, fortran/90166,
|
||||
ipa/85051, libstdc++/90165, libstdc++/90220, libstdc++/90239,
|
||||
middle-end/85164, middle-end/89765, middle-end/89797,
|
||||
middle-end/90139, middle-end/90194, middle-end/90213, other/90257,
|
||||
rtl-optimization/84032, rtl-optimization/87871,
|
||||
rtl-optimization/87979, target/89929, target/89952, target/90187,
|
||||
target/90193, translation/90118, tree-optimization/88055,
|
||||
tree-optimization/90021, tree-optimization/90037,
|
||||
tree-optimization/90078, tree-optimization/90208,
|
||||
tree-optimization/90211, tree-optimization/90240
|
||||
|
||||
* Thu Apr 18 2019 Jakub Jelinek <jakub@redhat.com> 9.0.1-0.14
|
||||
- update from trunk
|
||||
- PRs bootstrap/89864, c++/86953, c++/89325, c++/90047, c++/90124,
|
||||
debug/89528, fortran/90048, fortran/90067, fortran/90114,
|
||||
libstdc++/90105, middle-end/90095, rtl-optimization/86438,
|
||||
rtl-optimization/90082, target/17108, target/84369, target/90096,
|
||||
target/90125, translation/79183, tree-optimization/56049,
|
||||
tree-optimization/90090
|
||||
- buildrequire /usr/bin/python for better dg-extract-results.sh
|
||||
|
||||
* Mon Apr 15 2019 Jakub Jelinek <jakub@redhat.com> 9.0.1-0.13
|
||||
- update from trunk
|
||||
- PRs bootstrap/89980, c++/47488, c++/56643, c++/61327, c++/62207,
|
||||
c++/65619, c++/66548, c++/81506, c++/81866, c++/86586, c++/86946,
|
||||
c++/86986, c++/87145, c++/87603, c++/89331, c++/89612, c++/89744,
|
||||
c++/89833, c++/89836, c++/89852, c++/89871, c++/89876, c++/89878,
|
||||
c++/89914, c++/89917, c++/89948, c++/89966, c++/89973, c++/89974,
|
||||
c++/90010, c/71598, c/88383, c/89288, c/89685, c/89797, c/89798,
|
||||
c/89872, c/89933, c/89946, c/89985, d/87799, d/88150, d/88462,
|
||||
d/89255, d/89823, debug/89892, debug/89905, driver/89861,
|
||||
fortran/68567, fortran/79842, fortran/83515, fortran/85448,
|
||||
fortran/85797, fortran/87352, fortran/89375, fortran/89841,
|
||||
fortran/89842, fortran/89843, fortran/89846, fortran/89866,
|
||||
fortran/89904, fortran/89981, fortran/90022, gcov-profile/89959,
|
||||
gcov-profile/89961, ipa/88936, ipa/pr89693, libstdc++/85184,
|
||||
libstdc++/87431, libstdc++/89851, libstdc++/89986, libstdc++/90008,
|
||||
libstdc++/90046, lto/89358, lto/89896, middle-end/89621,
|
||||
middle-end/89911, middle-end/89934, middle-end/89957,
|
||||
middle-end/89970, middle-end/90025, other/89394,
|
||||
rtl-optimization/46590, rtl-optimization/81025,
|
||||
rtl-optimization/84206, rtl-optimization/85412,
|
||||
rtl-optimization/85876, rtl-optimization/86928,
|
||||
rtl-optimization/87273, rtl-optimization/87485,
|
||||
rtl-optimization/89399, rtl-optimization/89862,
|
||||
rtl-optimization/89865, rtl-optimization/89965,
|
||||
rtl-optimization/90026, sanitizer/89869, sanitizer/89941,
|
||||
target/83033, target/89623, target/89848, target/89865, target/89902,
|
||||
target/89903, target/89945, target/90015, target/90016, target/90024,
|
||||
testsuite/89907, testsuite/89916, translation/89912,
|
||||
translation/89936, translation/89939, translation/90011,
|
||||
translation/90035, translation/90041, tree-optimization/46590,
|
||||
tree-optimization/84101, tree-optimization/89725,
|
||||
tree-optimization/89730, tree-optimization/89956,
|
||||
tree-optimization/89998, tree-optimization/90006,
|
||||
tree-optimization/90018, tree-optimization/90020
|
||||
- PRs rtl-optimization/89794, tree-optimization/90071, debug/90074
|
||||
|
||||
* Thu Mar 28 2019 Jakub Jelinek <jakub@redhat.com> 9.0.1-0.12
|
||||
- update from trunk
|
||||
- PRs ada/89583, bootstrap/89829, c++/60702, c++/78645, c++/82643,
|
||||
|
@ -70,7 +70,7 @@ libgomp/
|
||||
+
|
||||
if (!compiler)
|
||||
fatal_error (input_location,
|
||||
"could not find %s in %s (consider using '-B')\n", suffix + 1,
|
||||
"could not find %s in %s (consider using %<-B%>)\n",
|
||||
@@ -883,6 +890,7 @@ compile_images_for_offload_targets (unsi
|
||||
unsigned num_targets = parse_env_var (target_names, &names, NULL);
|
||||
|
||||
|
@ -1,118 +0,0 @@
|
||||
2019-01-29 Ramana Radhakrishnan <ramana.radhakrishnan@arm.com>
|
||||
|
||||
PR target/89093
|
||||
* config/arm/arm-cpus.in: Add -mfpu=none support.
|
||||
* config/arm/arm-tables.opt: Likewise.
|
||||
* config/arm/arm.c (arm_options_perform_arch_sanity_checks): Remove
|
||||
error for no FPU.
|
||||
|
||||
* config/arm/pr-support.c: Add #pragma GCC target ("fpu=none").
|
||||
* config/arm/unwind-arm.c: Likewise.
|
||||
* unwind-c.c: Likewise, #ifdef __arm__ only.
|
||||
|
||||
* libsupc++/eh_personality.cc: Add #pragma GCC target ("fpu=none")
|
||||
for __arm__.
|
||||
|
||||
--- gcc/config/arm/arm-cpus.in
|
||||
+++ gcc/config/arm/arm-cpus.in
|
||||
@@ -128,6 +128,7 @@ define feature cmse
|
||||
|
||||
# Floating point and Neon extensions.
|
||||
# VFPv1 is not supported in GCC.
|
||||
+define feature nofp
|
||||
|
||||
# Vector floating point v2.
|
||||
define feature vfpv2
|
||||
@@ -258,6 +259,7 @@ define fgroup ARMv8m_main ARMv7m armv8 cmse
|
||||
define fgroup ARMv8r ARMv8a
|
||||
|
||||
# Useful combinations.
|
||||
+define fgroup NONE nofp
|
||||
define fgroup VFPv2 vfpv2
|
||||
define fgroup VFPv3 VFPv2 vfpv3
|
||||
define fgroup VFPv4 VFPv3 vfpv4 fp16conv
|
||||
@@ -1394,6 +1396,9 @@ end cpu cortex-r52
|
||||
# begin fpu <name>
|
||||
# isa <isa-flags-list>
|
||||
# end fpu <name>
|
||||
+begin fpu none
|
||||
+isa NONE FP_DBL
|
||||
+end fpu none
|
||||
|
||||
begin fpu vfp
|
||||
isa VFPv2 FP_DBL
|
||||
--- gcc/config/arm/arm-tables.opt
|
||||
+++ gcc/config/arm/arm-tables.opt
|
||||
@@ -353,6 +353,9 @@ Enum
|
||||
Name(arm_fpu) Type(enum fpu_type)
|
||||
Known ARM FPUs (for use with the -mfpu= option):
|
||||
|
||||
+EnumValue
|
||||
+Enum(arm_fpu) String(none) Value(TARGET_FPU_none)
|
||||
+
|
||||
EnumValue
|
||||
Enum(arm_fpu) String(vfp) Value(TARGET_FPU_vfp)
|
||||
|
||||
--- gcc/config/arm/arm.c
|
||||
+++ gcc/config/arm/arm.c
|
||||
@@ -3761,11 +3761,7 @@ arm_options_perform_arch_sanity_checks (
|
||||
if (arm_abi == ARM_ABI_IWMMXT)
|
||||
arm_pcs_default = ARM_PCS_AAPCS_IWMMXT;
|
||||
else if (TARGET_HARD_FLOAT_ABI)
|
||||
- {
|
||||
- arm_pcs_default = ARM_PCS_AAPCS_VFP;
|
||||
- if (!bitmap_bit_p (arm_active_target.isa, isa_bit_vfpv2))
|
||||
- error ("%<-mfloat-abi=hard%>: selected processor lacks an FPU");
|
||||
- }
|
||||
+ arm_pcs_default = ARM_PCS_AAPCS_VFP;
|
||||
else
|
||||
arm_pcs_default = ARM_PCS_AAPCS;
|
||||
}
|
||||
--- libgcc/config/arm/pr-support.c
|
||||
+++ libgcc/config/arm/pr-support.c
|
||||
@@ -21,6 +21,8 @@
|
||||
see the files COPYING3 and COPYING.RUNTIME respectively. If not, see
|
||||
<http://www.gnu.org/licenses/>. */
|
||||
|
||||
+#pragma GCC target ("fpu=none")
|
||||
+
|
||||
#include "unwind.h"
|
||||
|
||||
/* We add a prototype for abort here to avoid creating a dependency on
|
||||
--- libgcc/config/arm/unwind-arm.c
|
||||
+++ libgcc/config/arm/unwind-arm.c
|
||||
@@ -21,6 +21,8 @@
|
||||
see the files COPYING3 and COPYING.RUNTIME respectively. If not, see
|
||||
<http://www.gnu.org/licenses/>. */
|
||||
|
||||
+#pragma GCC target ("fpu=none")
|
||||
+
|
||||
#include "unwind.h"
|
||||
|
||||
/* Misc constants. */
|
||||
--- libgcc/unwind-c.c
|
||||
+++ libgcc/unwind-c.c
|
||||
@@ -24,6 +24,10 @@ a copy of the GCC Runtime Library Except
|
||||
see the files COPYING3 and COPYING.RUNTIME respectively. If not, see
|
||||
<http://www.gnu.org/licenses/>. */
|
||||
|
||||
+#ifdef __arm__
|
||||
+#pragma GCC target ("fpu=none")
|
||||
+#endif
|
||||
+
|
||||
#include "tconfig.h"
|
||||
#include "tsystem.h"
|
||||
#include "auto-target.h"
|
||||
--- libstdc++-v3/libsupc++/eh_personality.cc
|
||||
+++ libstdc++-v3/libsupc++/eh_personality.cc
|
||||
@@ -22,6 +22,10 @@
|
||||
// see the files COPYING3 and COPYING.RUNTIME respectively. If not, see
|
||||
// <http://www.gnu.org/licenses/>.
|
||||
|
||||
+#ifdef __arm__
|
||||
+#pragma GCC target ("fpu=none")
|
||||
+#endif
|
||||
+
|
||||
#include <bits/c++config.h>
|
||||
#include <cstdlib>
|
||||
#include <bits/exception_defines.h>
|
2
sources
2
sources
@ -1,3 +1,3 @@
|
||||
SHA512 (gcc-9.0.1-20190328.tar.xz) = 5f1dc1f7434e2de40f2f0486db3c5818e168452c0d612d6b35164ab6a1e1b2a63e5e4a899af86c5fe15cde33fb750e768f3f723c4062a0d97fb909b039f30b39
|
||||
SHA512 (gcc-9.0.1-20190430.tar.xz) = c1b6cfa8be2478aa6df3d7be247fcd5098f8d402e4c70ff65c6a439533dc327fd3249a48b357dd9e242afd67a1b4ea60b71baa709802716952a22677320fae9f
|
||||
SHA512 (nvptx-newlib-aadc8eb0ec43b7cd0dd2dfb484bae63c8b05ef24.tar.xz) = 94f7089365296f7dfa485107b4143bebc850a81586f3460fd896bbbb6ba099a00217d4042133424fd2183b352132f4fd367e6a60599bdae2a26dfd48a77d0e04
|
||||
SHA512 (nvptx-tools-c28050f60193b3b95a18866a96f03334e874e78f.tar.xz) = a688cb12cf805950a5abbb13b52f45c81dbee98e310b7ed57ae20e76dbfa5964a16270148374a6426d177db71909d28360490f091c86a5d19d4faa5127beeee1
|
||||
|
Loading…
Reference in New Issue
Block a user