10.2.1-4
This commit is contained in:
parent
d10315732b
commit
6b90f86714
26
gcc.spec
26
gcc.spec
@ -269,13 +269,12 @@ Patch9: gcc10-Wno-format-security.patch
|
|||||||
Patch10: gcc10-rh1574936.patch
|
Patch10: gcc10-rh1574936.patch
|
||||||
Patch11: gcc10-d-shared-libphobos.patch
|
Patch11: gcc10-d-shared-libphobos.patch
|
||||||
Patch12: gcc10-pr96383.patch
|
Patch12: gcc10-pr96383.patch
|
||||||
Patch13: gcc10-pr96385.patch
|
Patch13: gcc10-pr96690.patch
|
||||||
Patch14: gcc10-pr96690.patch
|
Patch14: gcc10-pr96939.patch
|
||||||
Patch15: gcc10-pr96939.patch
|
Patch15: gcc10-pr96939-2.patch
|
||||||
Patch16: gcc10-pr96939-2.patch
|
Patch16: gcc10-pr96939-3.patch
|
||||||
Patch17: gcc10-pr96939-3.patch
|
Patch17: gcc10-pr97032.patch
|
||||||
Patch18: gcc10-pr97032.patch
|
Patch18: gcc10-pr97060.patch
|
||||||
Patch19: gcc10-pr97060.patch
|
|
||||||
|
|
||||||
# On ARM EABI systems, we do want -gnueabi to be part of the
|
# On ARM EABI systems, we do want -gnueabi to be part of the
|
||||||
# target triple.
|
# target triple.
|
||||||
@ -788,13 +787,12 @@ to NVidia PTX capable devices if available.
|
|||||||
%endif
|
%endif
|
||||||
%patch11 -p0 -b .d-shared-libphobos~
|
%patch11 -p0 -b .d-shared-libphobos~
|
||||||
%patch12 -p0 -b .pr96383~
|
%patch12 -p0 -b .pr96383~
|
||||||
%patch13 -p0 -b .pr96385~
|
%patch13 -p0 -b .pr96690~
|
||||||
%patch14 -p0 -b .pr96690~
|
%patch14 -p0 -b .pr96939~
|
||||||
%patch15 -p0 -b .pr96939~
|
%patch15 -p0 -b .pr96939-2~
|
||||||
%patch16 -p0 -b .pr96939-2~
|
%patch16 -p0 -b .pr96939-3~
|
||||||
%patch17 -p0 -b .pr96939-3~
|
%patch17 -p0 -b .pr97032~
|
||||||
%patch18 -p0 -b .pr97032~
|
%patch18 -p0 -b .pr97060~
|
||||||
%patch19 -p0 -b .pr97060~
|
|
||||||
find gcc/testsuite -name \*.pr96939~ | xargs rm -f
|
find gcc/testsuite -name \*.pr96939~ | xargs rm -f
|
||||||
|
|
||||||
echo 'Red Hat %{version}-%{gcc_release}' > gcc/DEV-PHASE
|
echo 'Red Hat %{version}-%{gcc_release}' > gcc/DEV-PHASE
|
||||||
|
@ -1,22 +0,0 @@
|
|||||||
2020-08-03 Richard Biener <rguenther@suse.de>
|
|
||||||
|
|
||||||
PR lto/96385
|
|
||||||
libiberty/
|
|
||||||
* simple-object-elf.c
|
|
||||||
(simple_object_elf_copy_lto_debug_sections): Localize global
|
|
||||||
UNDEFs and reuse the prevailing name.
|
|
||||||
|
|
||||||
--- libiberty/simple-object-elf.c
|
|
||||||
+++ libiberty/simple-object-elf.c
|
|
||||||
@@ -1467,6 +1467,11 @@ simple_object_elf_copy_lto_debug_sections (simple_object_read *sobj,
|
|
||||||
&& st_shndx < shnum
|
|
||||||
&& pfnret[st_shndx - 1] == -1)
|
|
||||||
discard = 1;
|
|
||||||
+ /* We also need to remove global UNDEFs which can
|
|
||||||
+ cause link fails later. */
|
|
||||||
+ else if (st_shndx == SHN_UNDEF
|
|
||||||
+ && ELF_ST_BIND (*st_info) == STB_GLOBAL)
|
|
||||||
+ discard = 1;
|
|
||||||
|
|
||||||
if (discard)
|
|
||||||
{
|
|
Loading…
Reference in New Issue
Block a user