4.9.1-5
This commit is contained in:
parent
cc74938640
commit
69c89853de
1
.gitignore
vendored
1
.gitignore
vendored
@ -18,3 +18,4 @@
|
||||
/gcc-4.9.1-20140716.tar.bz2
|
||||
/gcc-4.9.1-20140717.tar.bz2
|
||||
/gcc-4.9.1-20140801.tar.bz2
|
||||
/gcc-4.9.1-20140807.tar.bz2
|
||||
|
14
gcc.spec
14
gcc.spec
@ -1,9 +1,9 @@
|
||||
%global DATE 20140801
|
||||
%global SVNREV 213428
|
||||
%global DATE 20140807
|
||||
%global SVNREV 213696
|
||||
%global gcc_version 4.9.1
|
||||
# Note, gcc_release must be integer, if you want to add suffixes to
|
||||
# %{release}, append them after %{gcc_release} on Release: line.
|
||||
%global gcc_release 3
|
||||
%global gcc_release 5
|
||||
%global _unpackaged_files_terminate_build 0
|
||||
%global _performance_build 1
|
||||
%global multilib_64_archs sparc64 ppc64 ppc64p7 s390x x86_64
|
||||
@ -197,7 +197,6 @@ Patch14: gcc49-pr56493.patch
|
||||
Patch15: gcc49-color-auto.patch
|
||||
Patch16: gcc49-libgo-p224.patch
|
||||
Patch17: gcc49-aarch64-async-unw-tables.patch
|
||||
Patch18: gcc49-rh1117799.patch
|
||||
|
||||
Patch1100: cloog-%{cloog_version}-ppc64le-config.patch
|
||||
|
||||
@ -725,7 +724,6 @@ package or when debugging this package.
|
||||
%patch16 -p0 -b .libgo-p224~
|
||||
rm -f libgo/go/crypto/elliptic/p224{,_test}.go
|
||||
%patch17 -p0 -b .aarch64-async-unw-tables~
|
||||
%patch18 -p0 -b .rh1117799~
|
||||
|
||||
%if 0%{?_enable_debug_packages}
|
||||
cat > split-debuginfo.sh <<\EOF
|
||||
@ -2798,6 +2796,12 @@ fi
|
||||
%{_prefix}/libexec/gcc/%{gcc_target_platform}/%{gcc_version}/plugin
|
||||
|
||||
%changelog
|
||||
* Thu Aug 7 2014 Jakub Jelinek <jakub@redhat.com> 4.9.1-5
|
||||
- update from the 4.9 branch
|
||||
- PRs debug/61923, libstdc++/58962, libstdc++/61374, libstdc++/61390,
|
||||
libstdc++/61946, middle-end/61455, other/61963, target/60102,
|
||||
tree-optimization/61320, tree-optimization/61375
|
||||
|
||||
* Fri Aug 1 2014 Jakub Jelinek <jakub@redhat.com> 4.9.1-3
|
||||
- update from the 4.9 branch
|
||||
- PRs fortran/61780, libobjc/61920, libstdc++/60037, target/47230,
|
||||
|
@ -1,28 +0,0 @@
|
||||
2014-07-11 Vladimir Makarov <vmakarov@redhat.com>
|
||||
|
||||
* lra-constraints.c (remove_inheritance_pseudos): Process
|
||||
destination pseudo too.
|
||||
|
||||
--- gcc/lra-constraints.c
|
||||
+++ gcc/lra-constraints.c
|
||||
@@ -5697,6 +5697,20 @@ remove_inheritance_pseudos (bitmap remove_pseudos)
|
||||
SUBREG_REG (SET_SRC (set)) = SET_SRC (prev_set);
|
||||
else
|
||||
SET_SRC (set) = SET_SRC (prev_set);
|
||||
+ /* As we are finishing with processing the insn
|
||||
+ here, check the destination too as it might
|
||||
+ inheritance pseudo for another pseudo. */
|
||||
+ if (bitmap_bit_p (remove_pseudos, dregno)
|
||||
+ && bitmap_bit_p (&lra_inheritance_pseudos, dregno)
|
||||
+ && (restore_regno
|
||||
+ = lra_reg_info[dregno].restore_regno) >= 0)
|
||||
+ {
|
||||
+ if (GET_CODE (SET_DEST (set)) == SUBREG)
|
||||
+ SUBREG_REG (SET_DEST (set))
|
||||
+ = regno_reg_rtx[restore_regno];
|
||||
+ else
|
||||
+ SET_DEST (set) = regno_reg_rtx[restore_regno];
|
||||
+ }
|
||||
lra_push_insn_and_update_insn_regno_info (curr_insn);
|
||||
lra_set_used_insn_alternative_by_uid
|
||||
(INSN_UID (curr_insn), -1);
|
Loading…
Reference in New Issue
Block a user