aarch64: fix cc1plus segfault using pch (#1058991), PR pch/60010
This commit is contained in:
parent
cf2421524e
commit
57702a0fa8
7
gcc.spec
7
gcc.spec
@ -3,7 +3,7 @@
|
|||||||
%global gcc_version 4.8.2
|
%global gcc_version 4.8.2
|
||||||
# Note, gcc_release must be integer, if you want to add suffixes to
|
# Note, gcc_release must be integer, if you want to add suffixes to
|
||||||
# %{release}, append them after %{gcc_release} on Release: line.
|
# %{release}, append them after %{gcc_release} on Release: line.
|
||||||
%global gcc_release 13
|
%global gcc_release 14
|
||||||
%global _unpackaged_files_terminate_build 0
|
%global _unpackaged_files_terminate_build 0
|
||||||
%global _performance_build 1
|
%global _performance_build 1
|
||||||
%global multilib_64_archs sparc64 ppc64 ppc64p7 s390x x86_64
|
%global multilib_64_archs sparc64 ppc64 ppc64p7 s390x x86_64
|
||||||
@ -198,6 +198,7 @@ Patch13: gcc48-pr56564.patch
|
|||||||
Patch14: gcc48-pr56493.patch
|
Patch14: gcc48-pr56493.patch
|
||||||
Patch15: gcc48-color-auto.patch
|
Patch15: gcc48-color-auto.patch
|
||||||
Patch16: gcc48-pr28865.patch
|
Patch16: gcc48-pr28865.patch
|
||||||
|
Patch17: gcc48-aarch64-define-TRY_EMPTY_VM_SPACE.patch
|
||||||
|
|
||||||
Patch1000: fastjar-0.97-segfault.patch
|
Patch1000: fastjar-0.97-segfault.patch
|
||||||
Patch1001: fastjar-0.97-len1.patch
|
Patch1001: fastjar-0.97-len1.patch
|
||||||
@ -758,6 +759,7 @@ package or when debugging this package.
|
|||||||
%patch15 -p0 -b .color-auto~
|
%patch15 -p0 -b .color-auto~
|
||||||
%endif
|
%endif
|
||||||
%patch16 -p0 -b .pr28865~
|
%patch16 -p0 -b .pr28865~
|
||||||
|
%patch17 -p1 -b .aarch64-pch~
|
||||||
|
|
||||||
%if 0%{?_enable_debug_packages}
|
%if 0%{?_enable_debug_packages}
|
||||||
cat > split-debuginfo.sh <<\EOF
|
cat > split-debuginfo.sh <<\EOF
|
||||||
@ -3025,6 +3027,9 @@ fi
|
|||||||
%{_prefix}/libexec/gcc/%{gcc_target_platform}/%{gcc_version}/plugin
|
%{_prefix}/libexec/gcc/%{gcc_target_platform}/%{gcc_version}/plugin
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Jan 31 2014 Kyle McMartin <kyle@redhat.com> 4.8.2-14
|
||||||
|
- aarch64: fix cc1plus segfault using pch (#1058991), PR pch/60010
|
||||||
|
|
||||||
* Tue Jan 21 2014 Jakub Jelinek <jakub@redhat.com> 4.8.2-13
|
* Tue Jan 21 2014 Jakub Jelinek <jakub@redhat.com> 4.8.2-13
|
||||||
- when removing -Wall from CXXFLAGS, if -Werror=format-security
|
- when removing -Wall from CXXFLAGS, if -Werror=format-security
|
||||||
is present, add -Wformat to it, so that GCC builds on F21
|
is present, add -Wformat to it, so that GCC builds on F21
|
||||||
|
14
gcc48-aarch64-define-TRY_EMPTY_VM_SPACE.patch
Normal file
14
gcc48-aarch64-define-TRY_EMPTY_VM_SPACE.patch
Normal file
@ -0,0 +1,14 @@
|
|||||||
|
http://gcc.gnu.org/bugzilla/show_bug.cgi?id=60010
|
||||||
|
https://bugzilla.redhat.com/show_bug.cgi?id=1058991
|
||||||
|
|
||||||
|
--- a/gcc/config/host-linux.c
|
||||||
|
+++ b/gcc/config/host-linux.c
|
||||||
|
@@ -86,6 +86,8 @@
|
||||||
|
# define TRY_EMPTY_VM_SPACE 0x60000000
|
||||||
|
#elif defined(__mc68000__)
|
||||||
|
# define TRY_EMPTY_VM_SPACE 0x40000000
|
||||||
|
+#elif defined(__aarch64__)
|
||||||
|
+# define TRY_EMPTY_VM_SPACE 0x1000000000
|
||||||
|
#elif defined(__ARM_EABI__)
|
||||||
|
# define TRY_EMPTY_VM_SPACE 0x60000000
|
||||||
|
#elif defined(__mips__) && defined(__LP64__)
|
Loading…
Reference in New Issue
Block a user