4.1.1-7
This commit is contained in:
parent
221d72a81a
commit
4b67b8f3bd
@ -1 +1 @@
|
||||
gcc-4.1.1-20060629.tar.bz2
|
||||
gcc-4.1.1-20060711.tar.bz2
|
||||
|
136
gcc41-hash-style-gnu.patch
Normal file
136
gcc41-hash-style-gnu.patch
Normal file
@ -0,0 +1,136 @@
|
||||
2006-07-11 Jakub Jelinek <jakub@redhat.com>
|
||||
|
||||
* config/i386/linux.h (LINK_SPEC): Add --hash-style=gnu.
|
||||
* config/i386/linux64.h (LINK_SPEC): Likewise.
|
||||
* config/rs6000/sysv4.h (LINK_OS_LINUX_SPEC): Likewise.
|
||||
* config/rs6000/linux64.h (LINK_OS_LINUX_SPEC32,
|
||||
LINK_OS_LINUX_SPEC64): Likewise.
|
||||
* config/s390/linux.h (LINK_SPEC): Likewise.
|
||||
* config/ia64/linux.h (LINK_SPEC): Likewise.
|
||||
* config/sparc/linux.h (LINK_SPEC): Likewise.
|
||||
* config/sparc/linux64.h (LINK_SPEC, LINK_ARCH32_SPEC,
|
||||
LINK_ARCH64_SPEC): Likewise.
|
||||
* config/alpha/linux-elf.h (LINK_SPEC): Likewise.
|
||||
|
||||
--- gcc/config/rs6000/sysv4.h.jj 2006-07-11 10:54:00.000000000 +0200
|
||||
+++ gcc/config/rs6000/sysv4.h 2006-07-11 12:51:39.000000000 +0200
|
||||
@@ -1039,7 +1039,7 @@ extern int fixuplabelno;
|
||||
|
||||
#define LINK_START_LINUX_SPEC ""
|
||||
|
||||
-#define LINK_OS_LINUX_SPEC "-m elf32ppclinux %{!shared: %{!static: \
|
||||
+#define LINK_OS_LINUX_SPEC "-m elf32ppclinux --hash-style=gnu %{!shared: %{!static: \
|
||||
%{rdynamic:-export-dynamic} \
|
||||
%{!dynamic-linker:-dynamic-linker /lib/ld.so.1}}}"
|
||||
|
||||
--- gcc/config/rs6000/linux64.h.jj 2006-07-11 10:54:00.000000000 +0200
|
||||
+++ gcc/config/rs6000/linux64.h 2006-07-11 12:52:14.000000000 +0200
|
||||
@@ -337,11 +337,11 @@ extern int dot_symbols;
|
||||
#undef LINK_OS_DEFAULT_SPEC
|
||||
#define LINK_OS_DEFAULT_SPEC "%(link_os_linux)"
|
||||
|
||||
-#define LINK_OS_LINUX_SPEC32 "-m elf32ppclinux %{!shared: %{!static: \
|
||||
+#define LINK_OS_LINUX_SPEC32 "-m elf32ppclinux --hash-style=gnu %{!shared: %{!static: \
|
||||
%{rdynamic:-export-dynamic} \
|
||||
%{!dynamic-linker:-dynamic-linker /lib/ld.so.1}}}"
|
||||
|
||||
-#define LINK_OS_LINUX_SPEC64 "-m elf64ppc %{!shared: %{!static: \
|
||||
+#define LINK_OS_LINUX_SPEC64 "-m elf64ppc --hash-style=gnu %{!shared: %{!static: \
|
||||
%{rdynamic:-export-dynamic} \
|
||||
%{!dynamic-linker:-dynamic-linker /lib64/ld64.so.1}}}"
|
||||
|
||||
--- gcc/config/alpha/linux-elf.h.jj 2006-07-11 10:54:01.000000000 +0200
|
||||
+++ gcc/config/alpha/linux-elf.h 2006-07-11 12:53:48.000000000 +0200
|
||||
@@ -29,7 +29,7 @@ Boston, MA 02110-1301, USA. */
|
||||
|
||||
#define ELF_DYNAMIC_LINKER "/lib/ld-linux.so.2"
|
||||
|
||||
-#define LINK_SPEC "-m elf64alpha %{G*} %{relax:-relax} \
|
||||
+#define LINK_SPEC "-m elf64alpha --hash-style=gnu %{G*} %{relax:-relax} \
|
||||
%{O*:-O3} %{!O*:-O1} \
|
||||
%{shared:-shared} \
|
||||
%{!shared: \
|
||||
--- gcc/config/s390/linux.h.jj 2006-07-11 10:54:02.000000000 +0200
|
||||
+++ gcc/config/s390/linux.h 2006-07-11 12:52:39.000000000 +0200
|
||||
@@ -79,7 +79,7 @@ Software Foundation, 51 Franklin Street,
|
||||
|
||||
#undef LINK_SPEC
|
||||
#define LINK_SPEC \
|
||||
- "%{m31:-m elf_s390}%{m64:-m elf64_s390} \
|
||||
+ "%{m31:-m elf_s390}%{m64:-m elf64_s390} --hash-style=gnu \
|
||||
%{shared:-shared} \
|
||||
%{!shared: \
|
||||
%{static:-static} \
|
||||
--- gcc/config/sparc/linux.h.jj 2006-07-11 10:54:03.000000000 +0200
|
||||
+++ gcc/config/sparc/linux.h 2006-07-11 12:54:16.000000000 +0200
|
||||
@@ -127,7 +127,7 @@ Boston, MA 02110-1301, USA. */
|
||||
/* If ELF is the default format, we should not use /lib/elf. */
|
||||
|
||||
#undef LINK_SPEC
|
||||
-#define LINK_SPEC "-m elf32_sparc -Y P,/usr/lib %{shared:-shared} \
|
||||
+#define LINK_SPEC "-m elf32_sparc --hash-style=gnu -Y P,/usr/lib %{shared:-shared} \
|
||||
%{!mno-relax:%{!r:-relax}} \
|
||||
%{!shared: \
|
||||
%{!ibcs: \
|
||||
--- gcc/config/sparc/linux64.h.jj 2006-07-11 10:54:03.000000000 +0200
|
||||
+++ gcc/config/sparc/linux64.h 2006-07-11 12:55:10.000000000 +0200
|
||||
@@ -157,7 +157,7 @@ Boston, MA 02110-1301, USA. */
|
||||
{ "link_arch_default", LINK_ARCH_DEFAULT_SPEC }, \
|
||||
{ "link_arch", LINK_ARCH_SPEC },
|
||||
|
||||
-#define LINK_ARCH32_SPEC "-m elf32_sparc -Y P,/usr/lib %{shared:-shared} \
|
||||
+#define LINK_ARCH32_SPEC "-m elf32_sparc --hash-style=gnu -Y P,/usr/lib %{shared:-shared} \
|
||||
%{!shared: \
|
||||
%{!ibcs: \
|
||||
%{!static: \
|
||||
@@ -166,7 +166,7 @@ Boston, MA 02110-1301, USA. */
|
||||
%{static:-static}}} \
|
||||
"
|
||||
|
||||
-#define LINK_ARCH64_SPEC "-m elf64_sparc -Y P,/usr/lib64 %{shared:-shared} \
|
||||
+#define LINK_ARCH64_SPEC "-m elf64_sparc --hash-style=gnu -Y P,/usr/lib64 %{shared:-shared} \
|
||||
%{!shared: \
|
||||
%{!ibcs: \
|
||||
%{!static: \
|
||||
@@ -247,7 +247,7 @@ Boston, MA 02110-1301, USA. */
|
||||
#else /* !SPARC_BI_ARCH */
|
||||
|
||||
#undef LINK_SPEC
|
||||
-#define LINK_SPEC "-m elf64_sparc -Y P,/usr/lib64 %{shared:-shared} \
|
||||
+#define LINK_SPEC "-m elf64_sparc --hash-style=gnu -Y P,/usr/lib64 %{shared:-shared} \
|
||||
%{!shared: \
|
||||
%{!ibcs: \
|
||||
%{!static: \
|
||||
--- gcc/config/i386/linux.h.jj 2006-07-11 10:54:05.000000000 +0200
|
||||
+++ gcc/config/i386/linux.h 2006-07-11 12:44:45.000000000 +0200
|
||||
@@ -113,7 +113,7 @@ Boston, MA 02110-1301, USA. */
|
||||
{ "dynamic_linker", DYNAMIC_LINKER }
|
||||
|
||||
#undef LINK_SPEC
|
||||
-#define LINK_SPEC "-m %(link_emulation) %{shared:-shared} \
|
||||
+#define LINK_SPEC "-m %(link_emulation) --hash-style=gnu %{shared:-shared} \
|
||||
%{!shared: \
|
||||
%{!ibcs: \
|
||||
%{!static: \
|
||||
--- gcc/config/i386/linux64.h.jj 2006-07-11 10:54:04.000000000 +0200
|
||||
+++ gcc/config/i386/linux64.h 2006-07-11 12:45:02.000000000 +0200
|
||||
@@ -55,7 +55,7 @@ Boston, MA 02110-1301, USA. */
|
||||
done. */
|
||||
|
||||
#undef LINK_SPEC
|
||||
-#define LINK_SPEC "%{!m32:-m elf_x86_64} %{m32:-m elf_i386} \
|
||||
+#define LINK_SPEC "%{!m32:-m elf_x86_64} %{m32:-m elf_i386} --hash-style=gnu \
|
||||
%{shared:-shared} \
|
||||
%{!shared: \
|
||||
%{!static: \
|
||||
--- gcc/config/ia64/linux.h.jj 2006-07-11 10:54:06.000000000 +0200
|
||||
+++ gcc/config/ia64/linux.h 2006-07-11 12:48:19.000000000 +0200
|
||||
@@ -40,7 +40,7 @@ do { \
|
||||
linux.h file. */
|
||||
|
||||
#undef LINK_SPEC
|
||||
-#define LINK_SPEC "\
|
||||
+#define LINK_SPEC "--hash-style=gnu \
|
||||
%{shared:-shared} \
|
||||
%{!shared: \
|
||||
%{!static: \
|
34
gcc41.spec
34
gcc41.spec
@ -1,6 +1,6 @@
|
||||
%define DATE 20060629
|
||||
%define DATE 20060711
|
||||
%define gcc_version 4.1.1
|
||||
%define gcc_release 6
|
||||
%define gcc_release 7
|
||||
%define _unpackaged_files_terminate_build 0
|
||||
%define multilib_64_archs sparc64 ppc64 s390x x86_64
|
||||
%ifarch %{ix86} x86_64 ia64
|
||||
@ -35,11 +35,13 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
|
||||
# Need binutils which can omit dot symbols and overlap .opd on ppc64 >= 2.15.91.0.2-4
|
||||
# Need binutils which handle -msecure-plt on ppc >= 2.16.91.0.2-2
|
||||
# Need binutils which support .weakref >= 2.16.91.0.3-1
|
||||
BuildRequires: binutils >= 2.16.91.0.3-1
|
||||
# Need binutils which support --hash-style=gnu >= 2.17.50.0.2-7
|
||||
BuildRequires: binutils >= 2.17.50.0.2-7
|
||||
BuildRequires: zlib-devel, gettext, dejagnu, bison, flex, texinfo
|
||||
# Make sure pthread.h doesn't contain __thread tokens
|
||||
# Make sure glibc supports stack protector
|
||||
BuildRequires: glibc-devel >= 2.3.90-2
|
||||
# Make sure glibc supports DT_GNU_HASH
|
||||
BuildRequires: glibc-devel >= 2.4.90-13
|
||||
BuildRequires: elfutils-devel >= 0.72
|
||||
%ifarch ppc ppc64 s390 s390x sparc sparcv9 alpha
|
||||
# Make sure glibc supports TFmode long double
|
||||
@ -64,7 +66,8 @@ Requires: cpp = %{version}-%{release}
|
||||
# On ppc64, need omit dot symbols support and --non-overlapping-opd
|
||||
# Need binutils that owns /usr/bin/c++filt
|
||||
# Need binutils that support .weakref
|
||||
Requires: binutils >= 2.16.91.0.3-1
|
||||
# Need binutils that supports --hash-style=gnu
|
||||
Requires: binutils >= 2.17.50.0.2-7
|
||||
# Make sure gdb will understand DW_FORM_strp
|
||||
Conflicts: gdb < 5.1-2
|
||||
Requires: glibc-devel >= 2.2.90-12
|
||||
@ -123,8 +126,8 @@ Patch21: gcc41-pr25874.patch
|
||||
Patch22: gcc41-pr26881.patch
|
||||
Patch23: gcc41-pr27793.patch
|
||||
Patch24: gcc41-pr26885.patch
|
||||
Patch25: gcc41-pr26991.patch
|
||||
Patch26: gcc41-rh195924.patch
|
||||
Patch25: gcc41-hash-style-gnu.patch
|
||||
Patch26: gcc41-visibility.patch
|
||||
%define _gnu %{nil}
|
||||
%ifarch sparc
|
||||
%define gcc_target_platform sparc64-%{_vendor}-%{_target_os}
|
||||
@ -427,8 +430,8 @@ which are required to run programs compiled with the GNAT.
|
||||
%patch22 -p0 -b .pr26881~
|
||||
%patch23 -p0 -b .pr27793~
|
||||
%patch24 -p0 -b .pr26885~
|
||||
%patch25 -p0 -b .pr26991~
|
||||
%patch26 -p0 -b .rh195924~
|
||||
%patch25 -p0 -b .hash-style-gnu~
|
||||
%patch26 -p0 -b .visibility~
|
||||
|
||||
sed -i -e 's/4\.1\.2/4.1.1/' gcc/BASE-VER gcc/version.c
|
||||
sed -i -e 's/" (Red Hat[^)]*)"/" (Red Hat %{version}-%{gcc_release})"/' gcc/version.c
|
||||
@ -1470,6 +1473,19 @@ fi
|
||||
%doc rpm.doc/changelogs/libmudflap/ChangeLog*
|
||||
|
||||
%changelog
|
||||
* Tue Jul 11 2006 Jakub Jelinek <jakub@redhat.com> 4.1.1-7
|
||||
- update from gcc-4_1-branch (-r115058:115330)
|
||||
- PRs c++/13983, c++/17519, c++/18681, c++/18698, c++/26577, c++/27019,
|
||||
c++/27424, c++/27768, c++/27820, c++/28114, fortran/23420,
|
||||
fortran/23862, fortran/24748, fortran/26801, fortran/27965,
|
||||
fortran/28081, fortran/28094, fortran/28167, fortran/28174,
|
||||
fortran/28213, fortran/28237, middle-end/27428, target/28084,
|
||||
target/28207, tree-optimization/28218
|
||||
- C++ visibility fixes (Jason Merrill, PRs c++/17470, c++/19134,
|
||||
c++/21581, c++/21675, c++/25915, c++/26612, c++/26905, c++/26984,
|
||||
c++/27000, c++/28215, c++/28279)
|
||||
- use --hash-style=gnu by default
|
||||
|
||||
* Thu Jun 29 2006 Jakub Jelinek <jakub@redhat.com> 4.1.1-6
|
||||
- update from gcc-4_1-branch (-r114766:115058)
|
||||
- PRs c++/27821, c++/28109, c++/28110, c++/28112, fortran/16206,
|
||||
|
Loading…
Reference in New Issue
Block a user