4.4.0-0.19
This commit is contained in:
parent
ecb75e16b1
commit
3b4372beb4
@ -1,3 +1,3 @@
|
||||
fastjar-0.97.tar.gz
|
||||
gcc-4.4.0-20090213.tar.bz2
|
||||
gcc-4.4.0-20090216.tar.bz2
|
||||
cloog-ppl-0.15.tar.gz
|
||||
|
14
gcc.spec
14
gcc.spec
@ -1,9 +1,9 @@
|
||||
%define DATE 20090213
|
||||
%define SVNREV 144154
|
||||
%define DATE 20090216
|
||||
%define SVNREV 144214
|
||||
%define gcc_version 4.4.0
|
||||
# Note, gcc_release must be integer, if you want to add suffixes to
|
||||
# %{release}, append them after %{gcc_release} on Release: line.
|
||||
%define gcc_release 0.18
|
||||
%define gcc_release 0.19
|
||||
%define _unpackaged_files_terminate_build 0
|
||||
%define multilib_64_archs sparc64 ppc64 s390x x86_64
|
||||
%define include_gappletviewer 1
|
||||
@ -1762,6 +1762,14 @@ fi
|
||||
%doc rpm.doc/changelogs/libmudflap/ChangeLog*
|
||||
|
||||
%changelog
|
||||
* Mon Feb 16 2009 Jakub Jelinek <jakub@redhat.com> 4.4.0-0.19
|
||||
- update from trunk
|
||||
- PRs c++/39070, fortran/36528, fortran/36703, fortran/38259,
|
||||
libstdc++/39168, target/37049, target/38056, target/39149,
|
||||
target/39162, target/39196
|
||||
- ix86 peephole fix (#485729, PR target/39152)
|
||||
- uglify function parameter names in gthr*.h (#485619)
|
||||
|
||||
* Fri Feb 13 2009 Jakub Jelinek <jakub@redhat.com> 4.4.0-0.18
|
||||
- update from trunk
|
||||
- PRs c++/30111, c++/38950, c++/39153, c/35444, middle-end/39154,
|
||||
|
@ -52,55 +52,6 @@
|
||||
|
||||
# Rules to build gnatlib.
|
||||
.PHONY: gnatlib gnatlib-plain gnatlib-sjlj gnatlib-zcx gnatlib-shared oscons
|
||||
--- libjava/classpath/native/plugin/gcjwebplugin.cc.jj 2009-01-14 12:08:34.000000000 +0100
|
||||
+++ libjava/classpath/native/plugin/gcjwebplugin.cc 2009-01-15 21:20:17.000000000 +0100
|
||||
@@ -45,7 +45,7 @@ exception statement from your version. *
|
||||
|
||||
// Netscape plugin API includes.
|
||||
#include <npapi.h>
|
||||
-#include <npupp.h>
|
||||
+#include <npfunctions.h>
|
||||
|
||||
// GLib includes.
|
||||
#include <glib.h>
|
||||
@@ -827,7 +827,7 @@ GCJ_URLNotify (NPP instance, const char*
|
||||
PLUGIN_DEBUG ("GCJ_URLNotify return");
|
||||
}
|
||||
|
||||
-jref
|
||||
+void *
|
||||
GCJ_GetJavaClass (void)
|
||||
{
|
||||
PLUGIN_DEBUG ("GCJ_GetJavaClass");
|
||||
@@ -1669,17 +1669,17 @@ NP_Initialize (NPNetscapeFuncs* browserT
|
||||
// Return to the browser the plugin functions that we implement.
|
||||
pluginTable->version = (NP_VERSION_MAJOR << 8) + NP_VERSION_MINOR;
|
||||
pluginTable->size = sizeof (NPPluginFuncs);
|
||||
- pluginTable->newp = NewNPP_NewProc (GCJ_New);
|
||||
- pluginTable->destroy = NewNPP_DestroyProc (GCJ_Destroy);
|
||||
- pluginTable->setwindow = NewNPP_SetWindowProc (GCJ_SetWindow);
|
||||
- pluginTable->newstream = NewNPP_NewStreamProc (GCJ_NewStream);
|
||||
- pluginTable->destroystream = NewNPP_DestroyStreamProc (GCJ_DestroyStream);
|
||||
- pluginTable->asfile = NewNPP_StreamAsFileProc (GCJ_StreamAsFile);
|
||||
- pluginTable->writeready = NewNPP_WriteReadyProc (GCJ_WriteReady);
|
||||
- pluginTable->write = NewNPP_WriteProc (GCJ_Write);
|
||||
- pluginTable->print = NewNPP_PrintProc (GCJ_Print);
|
||||
- pluginTable->urlnotify = NewNPP_URLNotifyProc (GCJ_URLNotify);
|
||||
- pluginTable->getvalue = NewNPP_GetValueProc (GCJ_GetValue);
|
||||
+ pluginTable->newp = (NPP_NewProcPtr) (GCJ_New);
|
||||
+ pluginTable->destroy = (NPP_DestroyProcPtr) (GCJ_Destroy);
|
||||
+ pluginTable->setwindow = (NPP_SetWindowProcPtr) (GCJ_SetWindow);
|
||||
+ pluginTable->newstream = (NPP_NewStreamProcPtr) (GCJ_NewStream);
|
||||
+ pluginTable->destroystream = (NPP_DestroyStreamProcPtr) (GCJ_DestroyStream);
|
||||
+ pluginTable->asfile = (NPP_StreamAsFileProcPtr) (GCJ_StreamAsFile);
|
||||
+ pluginTable->writeready = (NPP_WriteReadyProcPtr) (GCJ_WriteReady);
|
||||
+ pluginTable->write = (NPP_WriteProcPtr) (GCJ_Write);
|
||||
+ pluginTable->print = (NPP_PrintProcPtr) (GCJ_Print);
|
||||
+ pluginTable->urlnotify = (NPP_URLNotifyProcPtr) (GCJ_URLNotify);
|
||||
+ pluginTable->getvalue = (NPP_GetValueProcPtr) (GCJ_GetValue);
|
||||
|
||||
initialized = true;
|
||||
|
||||
--- gcc/ada/make.adb 2008-11-07 23:00:32.000000000 +0100
|
||||
+++ gcc/ada/make.adb 2009-01-16 17:55:02.000000000 +0100
|
||||
@@ -8039,6 +8039,7 @@ package body Make is
|
||||
|
Loading…
Reference in New Issue
Block a user