15.0.0-0.4
This commit is contained in:
parent
f7d926bced
commit
33699f47c3
1
.gitignore
vendored
1
.gitignore
vendored
@ -2,3 +2,4 @@
|
|||||||
/nvptx-tools-87ce9dc5999e5fca2e1d3478a30888d9864c9804.tar.xz
|
/nvptx-tools-87ce9dc5999e5fca2e1d3478a30888d9864c9804.tar.xz
|
||||||
/gcc-15.0.0-20250109.tar.xz
|
/gcc-15.0.0-20250109.tar.xz
|
||||||
/newlib-cygwin-2e4db338ac125579d555aeee516e48588a628a16.tar.xz
|
/newlib-cygwin-2e4db338ac125579d555aeee516e48588a628a16.tar.xz
|
||||||
|
/gcc-15.0.0-20250111.tar.xz
|
||||||
|
21
gcc.spec
21
gcc.spec
@ -1,5 +1,5 @@
|
|||||||
%global DATE 20250109
|
%global DATE 20250111
|
||||||
%global gitrev f890bd2c90be240213d8f1023aed4ad9647a293c
|
%global gitrev 20e73534b5a3aeac8624799d31783f12f24e29cb
|
||||||
%global gcc_version 15.0.0
|
%global gcc_version 15.0.0
|
||||||
%global gcc_major 15
|
%global gcc_major 15
|
||||||
# Note, gcc_release must be integer, if you want to add suffixes to
|
# Note, gcc_release must be integer, if you want to add suffixes to
|
||||||
@ -143,7 +143,7 @@
|
|||||||
Summary: Various compilers (C, C++, Objective-C, ...)
|
Summary: Various compilers (C, C++, Objective-C, ...)
|
||||||
Name: gcc
|
Name: gcc
|
||||||
Version: %{gcc_version}
|
Version: %{gcc_version}
|
||||||
Release: %{gcc_release}.3%{?dist}
|
Release: %{gcc_release}.4%{?dist}
|
||||||
# License notes for some of the less obvious ones:
|
# License notes for some of the less obvious ones:
|
||||||
# gcc/doc/cppinternals.texi: Linux-man-pages-copyleft-2-para
|
# gcc/doc/cppinternals.texi: Linux-man-pages-copyleft-2-para
|
||||||
# isl: MIT, BSD-2-Clause
|
# isl: MIT, BSD-2-Clause
|
||||||
@ -299,7 +299,6 @@ Patch9: gcc15-Wno-format-security.patch
|
|||||||
Patch10: gcc15-rh1574936.patch
|
Patch10: gcc15-rh1574936.patch
|
||||||
Patch11: gcc15-d-shared-libphobos.patch
|
Patch11: gcc15-d-shared-libphobos.patch
|
||||||
Patch12: gcc15-pr118206.patch
|
Patch12: gcc15-pr118206.patch
|
||||||
Patch13: gcc15-pr118362.patch
|
|
||||||
|
|
||||||
Patch50: isl-rh2155127.patch
|
Patch50: isl-rh2155127.patch
|
||||||
|
|
||||||
@ -915,7 +914,6 @@ so that there cannot be any synchronization problems.
|
|||||||
%endif
|
%endif
|
||||||
%patch -P11 -p0 -b .d-shared-libphobos~
|
%patch -P11 -p0 -b .d-shared-libphobos~
|
||||||
%patch -P12 -p0 -b .pr118206~
|
%patch -P12 -p0 -b .pr118206~
|
||||||
%patch -P13 -p0 -b .pr118362~
|
|
||||||
|
|
||||||
%patch -P50 -p0 -b .rh2155127~
|
%patch -P50 -p0 -b .rh2155127~
|
||||||
touch -r isl-0.24/m4/ax_prog_cxx_for_build.m4 isl-0.24/m4/ax_prog_cc_for_build.m4
|
touch -r isl-0.24/m4/ax_prog_cxx_for_build.m4 isl-0.24/m4/ax_prog_cc_for_build.m4
|
||||||
@ -3675,5 +3673,18 @@ end
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sat Jan 11 2025 Jakub Jelinek <jakub@redhat.com> 15.0.0-0.4
|
||||||
|
- update from trunk
|
||||||
|
- PRs ada/18765, ada/118274, c/116060, c/117866, c/118376, c++/117792,
|
||||||
|
c++/117887, c++/117925, c++/117937, c++/117993, c++/118060,
|
||||||
|
c++/118277, c++/118387, c++/118391, fortran/108434, fortran/118337,
|
||||||
|
ipa/118138, rtl-optimization/117186, rtl-optimization/117467,
|
||||||
|
rtl-optimization/117934, rtl-optimization/118266, target/65181,
|
||||||
|
target/118017, target/118131, target/118188, target/118332,
|
||||||
|
target/118362, testsuite/118025, tree-optimization/88575,
|
||||||
|
tree-optimization/116126, tree-optimization/117927,
|
||||||
|
tree-optimization/118206, tree-optimization/118211,
|
||||||
|
tree-optimization/118344
|
||||||
|
|
||||||
* Thu Jan 9 2025 Jakub Jelinek <jakub@redhat.com> 15.0.0-0.3
|
* Thu Jan 9 2025 Jakub Jelinek <jakub@redhat.com> 15.0.0-0.3
|
||||||
- new package
|
- new package
|
||||||
|
@ -1,17 +0,0 @@
|
|||||||
2025-01-09 Stefan Schulze Frielinghaus <stefansf@gcc.gnu.org>
|
|
||||||
|
|
||||||
PR target/118362
|
|
||||||
* config/s390/s390.cc (s390_constant_via_vgbm_p): Punt on
|
|
||||||
CONST_VECTOR with modes larger than 16 bytes.
|
|
||||||
|
|
||||||
--- gcc/config/s390/s390.cc.jj 2025-01-07 18:30:20.697392148 +0100
|
|
||||||
+++ gcc/config/s390/s390.cc 2025-01-09 09:41:57.428250479 +0100
|
|
||||||
@@ -2818,7 +2818,7 @@ s390_constant_via_vgbm_p (rtx op, unsign
|
|
||||||
unsigned tmp_mask = 0;
|
|
||||||
int nunit, unit_size;
|
|
||||||
|
|
||||||
- if (GET_CODE (op) == CONST_VECTOR)
|
|
||||||
+ if (GET_CODE (op) == CONST_VECTOR && GET_MODE_SIZE (GET_MODE (op)) <= 16)
|
|
||||||
{
|
|
||||||
if (GET_MODE_INNER (GET_MODE (op)) == TImode
|
|
||||||
|| GET_MODE_INNER (GET_MODE (op)) == TFmode)
|
|
2
sources
2
sources
@ -1,4 +1,4 @@
|
|||||||
SHA512 (gcc-15.0.0-20250109.tar.xz) = 3dc995fc2492494f62977a176bd83e3b08ef87024253060f46681dc483037d8528abecaadd9f0202e2a994239a52d4cc78b3aa3cdad7011ad4c789d789082717
|
SHA512 (gcc-15.0.0-20250111.tar.xz) = 4a34058f92167ccfb08ddbbac0b4aa78599b98fd5768ecc02cf89e35e8609b5dcb9e276bf98dd854d24f965795d79497dbd4a3c8ef93d816ee689945689daf07
|
||||||
SHA512 (isl-0.24.tar.bz2) = aab3bddbda96b801d0f56d2869f943157aad52a6f6e6a61745edd740234c635c38231af20bc3f1a08d416a5e973a90e18249078ed8e4ae2f1d5de57658738e95
|
SHA512 (isl-0.24.tar.bz2) = aab3bddbda96b801d0f56d2869f943157aad52a6f6e6a61745edd740234c635c38231af20bc3f1a08d416a5e973a90e18249078ed8e4ae2f1d5de57658738e95
|
||||||
SHA512 (newlib-cygwin-2e4db338ac125579d555aeee516e48588a628a16.tar.xz) = 839bb0c45b5023a83e1a5bf8773050af46bd075754502fc49a62ab860144c9a6bdc0a7d52e6c7ded87ba13ce58192755dd3f83333bc7c61ffb184fef4142a808
|
SHA512 (newlib-cygwin-2e4db338ac125579d555aeee516e48588a628a16.tar.xz) = 839bb0c45b5023a83e1a5bf8773050af46bd075754502fc49a62ab860144c9a6bdc0a7d52e6c7ded87ba13ce58192755dd3f83333bc7c61ffb184fef4142a808
|
||||||
SHA512 (nvptx-tools-87ce9dc5999e5fca2e1d3478a30888d9864c9804.tar.xz) = 941e763af8601b89f0e4ec48a2d68ae0a8e70ee1e6ba6859394b021ad7bd7d143cc529f3c35c08d7f84e5554980ddcc97cf05b6c4755c2bc36c91161b79e8cea
|
SHA512 (nvptx-tools-87ce9dc5999e5fca2e1d3478a30888d9864c9804.tar.xz) = 941e763af8601b89f0e4ec48a2d68ae0a8e70ee1e6ba6859394b021ad7bd7d143cc529f3c35c08d7f84e5554980ddcc97cf05b6c4755c2bc36c91161b79e8cea
|
||||||
|
Loading…
x
Reference in New Issue
Block a user