4.4.0-0.12
This commit is contained in:
parent
e6636958bd
commit
32effdcb3a
4
gcc.spec
4
gcc.spec
@ -3,7 +3,7 @@
|
||||
%define gcc_version 4.4.0
|
||||
# Note, gcc_release must be integer, if you want to add suffixes to
|
||||
# %{release}, append them after %{gcc_release} on Release: line.
|
||||
%define gcc_release 0.11
|
||||
%define gcc_release 0.12
|
||||
%define _unpackaged_files_terminate_build 0
|
||||
%define multilib_64_archs sparc64 ppc64 s390x x86_64
|
||||
%define include_gappletviewer 1
|
||||
@ -1747,7 +1747,7 @@ fi
|
||||
%doc rpm.doc/changelogs/libmudflap/ChangeLog*
|
||||
|
||||
%changelog
|
||||
* Tue Jan 27 2009 Jakub Jelinek <jakub@redhat.com> 4.4.0-0.11
|
||||
* Tue Jan 27 2009 Jakub Jelinek <jakub@redhat.com> 4.4.0-0.12
|
||||
- update from trunk
|
||||
- add graphite support
|
||||
- change gcc default ISA and tuning:
|
||||
|
@ -2,6 +2,7 @@
|
||||
|
||||
* toplev.c (save_argv): No longer static.
|
||||
* Makefile.in (BACKENDLIBS): Link against -ldl instead of -lcloog -lppl.
|
||||
(graphite.o): Force -O, remove -fkeep-inline-functions.
|
||||
* graphite.c: Include <dlfcn.h>. Reference libcloog and libppl symbols
|
||||
through pointers in cloog_pointers variable.
|
||||
(init_cloog_pointers): New function.
|
||||
@ -30,6 +31,16 @@
|
||||
# Any system libraries needed just for GNAT.
|
||||
SYSLIBS = @GNAT_LIBEXC@
|
||||
|
||||
@@ -3076,6 +3076,9 @@ $(out_object_file): $(out_file) $(CONFIG
|
||||
$(CC) -c $(ALL_CFLAGS) $(ALL_CPPFLAGS) \
|
||||
$(out_file) $(OUTPUT_OPTION)
|
||||
|
||||
+graphite.o : \
|
||||
+ ALL_CFLAGS := -O $(filter-out -fkeep-inline-functions, $(ALL_CFLAGS))
|
||||
+
|
||||
# Build auxiliary files that support ecoff format.
|
||||
mips-tfile: mips-tfile.o version.o $(LIBDEPS)
|
||||
$(CC) $(CFLAGS) $(LDFLAGS) -o $@ mips-tfile.o version.o $(LIBS)
|
||||
--- gcc/graphite.c.jj 2009-01-24 19:59:02.000000000 +0100
|
||||
+++ gcc/graphite.c 2009-01-27 14:52:08.000000000 +0100
|
||||
@@ -59,6 +59,138 @@ along with GCC; see the file COPYING3.
|
||||
|
Loading…
Reference in New Issue
Block a user