Remove obsolete patch
Signed-off-by: David Abdurachmanov <davidlt@rivosinc.com>
This commit is contained in:
parent
c83daf80c7
commit
30ea9e3a62
@ -1,61 +0,0 @@
|
|||||||
From 45d05567b776686843da39bde28b8adf0e14a2fa Mon Sep 17 00:00:00 2001
|
|
||||||
From: David Abdurachmanov <davidlt@rivosinc.com>
|
|
||||||
Date: Sun, 31 Jul 2022 08:00:50 +0300
|
|
||||||
Subject: [PATCH] Fix for glibc 2.36
|
|
||||||
|
|
||||||
See:
|
|
||||||
https://github.com/llvm/llvm-project/commit/9cf13067cb5088626ba7ee1ec4c42ec59c7995a0
|
|
||||||
https://github.com/gcc-mirror/gcc/commit/f35d65517a59565758107c5b1a51a5fa382f8d1a
|
|
||||||
|
|
||||||
Signed-off-by: David Abdurachmanov <davidlt@rivosinc.com>
|
|
||||||
---
|
|
||||||
libgo/sysinfo.c | 3 ---
|
|
||||||
.../sanitizer_platform_limits_posix.cpp | 10 ++++++----
|
|
||||||
2 files changed, 6 insertions(+), 7 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/libgo/sysinfo.c b/libgo/sysinfo.c
|
|
||||||
index 8ce061e2f..336a59837 100644
|
|
||||||
--- a/libgo/sysinfo.c
|
|
||||||
+++ b/libgo/sysinfo.c
|
|
||||||
@@ -158,9 +158,6 @@
|
|
||||||
#if defined(HAVE_LINUX_ETHER_H)
|
|
||||||
#include <linux/ether.h>
|
|
||||||
#endif
|
|
||||||
-#if defined(HAVE_LINUX_FS_H)
|
|
||||||
-#include <linux/fs.h>
|
|
||||||
-#endif
|
|
||||||
#if defined(HAVE_LINUX_REBOOT_H)
|
|
||||||
#include <linux/reboot.h>
|
|
||||||
#endif
|
|
||||||
diff --git a/libsanitizer/sanitizer_common/sanitizer_platform_limits_posix.cpp b/libsanitizer/sanitizer_common/sanitizer_platform_limits_posix.cpp
|
|
||||||
index 025e575b5..5743516c0 100644
|
|
||||||
--- a/libsanitizer/sanitizer_common/sanitizer_platform_limits_posix.cpp
|
|
||||||
+++ b/libsanitizer/sanitizer_common/sanitizer_platform_limits_posix.cpp
|
|
||||||
@@ -72,7 +72,9 @@
|
|
||||||
#include <sys/vt.h>
|
|
||||||
#include <linux/cdrom.h>
|
|
||||||
#include <linux/fd.h>
|
|
||||||
+#if SANITIZER_ANDROID
|
|
||||||
#include <linux/fs.h>
|
|
||||||
+#endif
|
|
||||||
#include <linux/hdreg.h>
|
|
||||||
#include <linux/input.h>
|
|
||||||
#include <linux/ioctl.h>
|
|
||||||
@@ -828,10 +830,10 @@ unsigned struct_ElfW_Phdr_sz = sizeof(Elf_Phdr);
|
|
||||||
unsigned IOCTL_EVIOCGPROP = IOCTL_NOT_PRESENT;
|
|
||||||
unsigned IOCTL_EVIOCSKEYCODE_V2 = IOCTL_NOT_PRESENT;
|
|
||||||
#endif
|
|
||||||
- unsigned IOCTL_FS_IOC_GETFLAGS = FS_IOC_GETFLAGS;
|
|
||||||
- unsigned IOCTL_FS_IOC_GETVERSION = FS_IOC_GETVERSION;
|
|
||||||
- unsigned IOCTL_FS_IOC_SETFLAGS = FS_IOC_SETFLAGS;
|
|
||||||
- unsigned IOCTL_FS_IOC_SETVERSION = FS_IOC_SETVERSION;
|
|
||||||
+ unsigned IOCTL_FS_IOC_GETFLAGS = _IOR('f', 1, long);
|
|
||||||
+ unsigned IOCTL_FS_IOC_GETVERSION = _IOR('v', 1, long);
|
|
||||||
+ unsigned IOCTL_FS_IOC_SETFLAGS = _IOW('f', 2, long);
|
|
||||||
+ unsigned IOCTL_FS_IOC_SETVERSION = _IOW('v', 2, long);
|
|
||||||
unsigned IOCTL_GIO_CMAP = GIO_CMAP;
|
|
||||||
unsigned IOCTL_GIO_FONT = GIO_FONT;
|
|
||||||
unsigned IOCTL_GIO_UNIMAP = GIO_UNIMAP;
|
|
||||||
--
|
|
||||||
2.35.1
|
|
||||||
|
|
7
gcc.spec
7
gcc.spec
@ -281,8 +281,6 @@ Patch101: gcc12-fortran-flogical-as-integer.patch
|
|||||||
Patch102: gcc12-fortran-fdec-override-kind.patch
|
Patch102: gcc12-fortran-fdec-override-kind.patch
|
||||||
Patch103: gcc12-fortran-fdec-non-logical-if.patch
|
Patch103: gcc12-fortran-fdec-non-logical-if.patch
|
||||||
|
|
||||||
Patch200: 0001-Fix-for-glibc-2.36.patch
|
|
||||||
|
|
||||||
# On ARM EABI systems, we do want -gnueabi to be part of the
|
# On ARM EABI systems, we do want -gnueabi to be part of the
|
||||||
# target triple.
|
# target triple.
|
||||||
%ifnarch %{arm}
|
%ifnarch %{arm}
|
||||||
@ -812,10 +810,6 @@ so that there cannot be any synchronization problems.
|
|||||||
%patch103 -p1 -b .fortran-fdec-non-logical-if~
|
%patch103 -p1 -b .fortran-fdec-non-logical-if~
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%ifarch riscv64
|
|
||||||
%patch200 -p1 -b .fix-glibc236~
|
|
||||||
%endif
|
|
||||||
|
|
||||||
%ifarch %{arm}
|
%ifarch %{arm}
|
||||||
rm -f gcc/testsuite/go.test/test/fixedbugs/issue19182.go
|
rm -f gcc/testsuite/go.test/test/fixedbugs/issue19182.go
|
||||||
%endif
|
%endif
|
||||||
@ -3227,6 +3221,7 @@ end
|
|||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
* Mon Aug 15 2022 David Abdurachmanov <davidlt@rivosinc.com> 12.1.1-4.1.riscv64
|
* Mon Aug 15 2022 David Abdurachmanov <davidlt@rivosinc.com> 12.1.1-4.1.riscv64
|
||||||
|
- Update config.{sub,guess} scripts for ISL
|
||||||
|
|
||||||
* Wed Aug 8 2022 Jakub Jelinek <jakub@redhat.com> 12.1.1-4
|
* Wed Aug 8 2022 Jakub Jelinek <jakub@redhat.com> 12.1.1-4
|
||||||
- update from releases/gcc-12 branch
|
- update from releases/gcc-12 branch
|
||||||
|
Loading…
Reference in New Issue
Block a user