Merge remote-tracking branch 'up/master' into master-riscv64
This commit is contained in:
commit
1cff41dd07
1
.gitignore
vendored
1
.gitignore
vendored
@ -76,3 +76,4 @@
|
||||
/gcc-9.0.1-20190426.tar.xz
|
||||
/gcc-9.0.1-20190430.tar.xz
|
||||
/gcc-9.1.1-20190503.tar.xz
|
||||
/gcc-9.1.1-20190605.tar.xz
|
||||
|
22
gcc.spec
22
gcc.spec
@ -1,10 +1,10 @@
|
||||
%global DATE 20190503
|
||||
%global SVNREV 270850
|
||||
%global DATE 20190605
|
||||
%global SVNREV 271961
|
||||
%global gcc_version 9.1.1
|
||||
%global gcc_major 9
|
||||
# Note, gcc_release must be integer, if you want to add suffixes to
|
||||
# %%{release}, append them after %%{gcc_release} on Release: line.
|
||||
%global gcc_release 1
|
||||
%global gcc_release 2
|
||||
%global nvptx_tools_gitrev c28050f60193b3b95a18866a96f03334e874e78f
|
||||
%global nvptx_newlib_gitrev aadc8eb0ec43b7cd0dd2dfb484bae63c8b05ef24
|
||||
%global _unpackaged_files_terminate_build 0
|
||||
@ -248,7 +248,6 @@ Patch8: gcc9-foffload-default.patch
|
||||
Patch9: gcc9-Wno-format-security.patch
|
||||
Patch10: gcc9-rh1574936.patch
|
||||
Patch11: gcc9-d-shared-libphobos.patch
|
||||
Patch12: gcc9-pr90303.patch
|
||||
|
||||
Patch1000: nvptx-tools-no-ptxas.patch
|
||||
Patch1001: nvptx-tools-build.patch
|
||||
@ -765,7 +764,6 @@ to NVidia PTX capable devices if available.
|
||||
%patch10 -p0 -b .rh1574936~
|
||||
%endif
|
||||
%patch11 -p0 -b .d-shared-libphobos~
|
||||
%patch12 -p0 -b .pr90303~
|
||||
|
||||
cd nvptx-tools-%{nvptx_tools_gitrev}
|
||||
%patch1000 -p1 -b .nvptx-tools-no-ptxas~
|
||||
@ -2977,6 +2975,20 @@ end
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Wed Jun 5 2019 Jakub Jelinek <jakub@redhat.com> 9.1.1-2
|
||||
- update from 9 branch
|
||||
- PRs bootstrap/90543, c++/78010, c++/90173, c++/90265, c++/90383,
|
||||
c++/90484, c++/90532, c++/90548, c++/90572, c++/90598, debug/90197,
|
||||
debug/90733, fortran/54613, fortran/90093, fortran/90329,
|
||||
fortran/90351, fortran/90352, fortran/90355, fortran/90498,
|
||||
gcov-profile/90380, libfortran/90038, libgomp/90527, libgomp/90585,
|
||||
libgomp/90641, libstdc++/81266, libstdc++/90299, libstdc++/90397,
|
||||
libstdc++/90454, libstdc++/90557, libstdc++/90634, libstdc++/90686,
|
||||
libstdc++/90700, pch/90326, sanitizer/90312, sanitizer/90570,
|
||||
target/82920, target/89424, target/89765, target/90357, target/90379,
|
||||
target/90530, target/90547, testsuite/81058, tree-optimization/90385,
|
||||
tree-optimization/90416
|
||||
|
||||
* Fri May 3 2019 Jakub Jelinek <jakub@redhat.com> 9.1.1-1
|
||||
- update from 9 branch
|
||||
- GCC 9.1 release
|
||||
|
@ -1,39 +0,0 @@
|
||||
2019-05-03 Jakub Jelinek <jakub@redhat.com>
|
||||
|
||||
PR tree-optimization/90303
|
||||
* ipa-devirt.c (obj_type_ref_class, get_odr_type): Don't use
|
||||
TYPE_CANONICAL for TYPE_STRUCTURAL_EQUALITY_P types in !in_lto_p mode.
|
||||
|
||||
* g++.target/i386/pr90303.C: New test.
|
||||
|
||||
--- gcc/ipa-devirt.c (revision 270834)
|
||||
+++ gcc/ipa-devirt.c (revision 270835)
|
||||
@@ -2020,7 +2020,7 @@ obj_type_ref_class (const_tree ref)
|
||||
ref = TREE_VALUE (TYPE_ARG_TYPES (ref));
|
||||
gcc_checking_assert (TREE_CODE (ref) == POINTER_TYPE);
|
||||
tree ret = TREE_TYPE (ref);
|
||||
- if (!in_lto_p)
|
||||
+ if (!in_lto_p && !TYPE_STRUCTURAL_EQUALITY_P (ret))
|
||||
ret = TYPE_CANONICAL (ret);
|
||||
else
|
||||
ret = get_odr_type (ret)->type;
|
||||
@@ -2042,7 +2042,7 @@ get_odr_type (tree type, bool insert)
|
||||
int base_id = -1;
|
||||
|
||||
type = TYPE_MAIN_VARIANT (type);
|
||||
- if (!in_lto_p)
|
||||
+ if (!in_lto_p && !TYPE_STRUCTURAL_EQUALITY_P (type))
|
||||
type = TYPE_CANONICAL (type);
|
||||
|
||||
gcc_checking_assert (can_be_name_hashed_p (type)
|
||||
--- gcc/testsuite/g++.target/i386/pr90303.C (nonexistent)
|
||||
+++ gcc/testsuite/g++.target/i386/pr90303.C (revision 270835)
|
||||
@@ -0,0 +1,8 @@
|
||||
+// PR tree-optimization/90303
|
||||
+// { dg-do compile { target ia32 } }
|
||||
+// { dg-additional-options "-O2" }
|
||||
+
|
||||
+struct A { virtual void foo (); };
|
||||
+template <class> class B : A {};
|
||||
+typedef void (__attribute__((fastcall)) F) ();
|
||||
+B<F> e;
|
2
sources
2
sources
@ -1,3 +1,3 @@
|
||||
SHA512 (gcc-9.1.1-20190503.tar.xz) = 9787c7f4bc6a2e918cafa5ef0bc21dd29eb88541297168049cffea150d08f50023e6b639bc24fe53daf6f603db286a7a8dd17357d139f0d0cfb3cee2850fee8b
|
||||
SHA512 (gcc-9.1.1-20190605.tar.xz) = 05c7624b403e92e455acec9ba3fa2185327de63dbc585fb8f391c522735639b6403cf20555daa50fb0c8ce153f9dfbe7efc1f45b2227f90761a690bfb966ac96
|
||||
SHA512 (nvptx-newlib-aadc8eb0ec43b7cd0dd2dfb484bae63c8b05ef24.tar.xz) = 94f7089365296f7dfa485107b4143bebc850a81586f3460fd896bbbb6ba099a00217d4042133424fd2183b352132f4fd367e6a60599bdae2a26dfd48a77d0e04
|
||||
SHA512 (nvptx-tools-c28050f60193b3b95a18866a96f03334e874e78f.tar.xz) = a688cb12cf805950a5abbb13b52f45c81dbee98e310b7ed57ae20e76dbfa5964a16270148374a6426d177db71909d28360490f091c86a5d19d4faa5127beeee1
|
||||
|
Loading…
Reference in New Issue
Block a user