12.2.1-3
This commit is contained in:
parent
78accc2a93
commit
146fdc1878
2
gcc.spec
2
gcc.spec
@ -921,7 +921,7 @@ ISL_FLAG_PIC=-fPIC
|
|||||||
ISL_FLAG_PIC=-fpic
|
ISL_FLAG_PIC=-fpic
|
||||||
%endif
|
%endif
|
||||||
cd isl-build
|
cd isl-build
|
||||||
sed -i 's|libisl|libgcc12privateisl|g' \
|
sed -i 's|libisl\([^-]\)|libgcc12privateisl\1|g' \
|
||||||
../../isl-%{isl_version}/Makefile.{am,in}
|
../../isl-%{isl_version}/Makefile.{am,in}
|
||||||
../../isl-%{isl_version}/configure \
|
../../isl-%{isl_version}/configure \
|
||||||
CC=/usr/bin/gcc CXX=/usr/bin/g++ \
|
CC=/usr/bin/gcc CXX=/usr/bin/g++ \
|
||||||
|
@ -26,7 +26,7 @@
|
|||||||
# Generate header and source files from the machine description,
|
# Generate header and source files from the machine description,
|
||||||
# and compile them.
|
# and compile them.
|
||||||
--- gcc/graphite.h.jj 2016-01-27 12:44:06.000000000 +0100
|
--- gcc/graphite.h.jj 2016-01-27 12:44:06.000000000 +0100
|
||||||
+++ gcc/graphite.h 2016-01-27 13:26:38.309876856 +0100
|
+++ gcc/graphite.h 2022-11-03 19:14:50.369690720 +0100
|
||||||
@@ -24,6 +24,591 @@ along with GCC; see the file COPYING3.
|
@@ -24,6 +24,591 @@ along with GCC; see the file COPYING3.
|
||||||
|
|
||||||
#include "sese.h"
|
#include "sese.h"
|
||||||
@ -41,15 +41,15 @@
|
|||||||
+ DYNSYM (isl_aff_set_coefficient_si); \
|
+ DYNSYM (isl_aff_set_coefficient_si); \
|
||||||
+ DYNSYM (isl_aff_set_constant_si); \
|
+ DYNSYM (isl_aff_set_constant_si); \
|
||||||
+ DYNSYM (isl_aff_zero_on_domain); \
|
+ DYNSYM (isl_aff_zero_on_domain); \
|
||||||
+ DYNSYM (isl_band_free); \
|
+ /* DYNSYM (isl_band_free); */ \
|
||||||
+ DYNSYM (isl_band_get_children); \
|
+ /* DYNSYM (isl_band_get_children); */ \
|
||||||
+ DYNSYM (isl_band_get_partial_schedule); \
|
+ /* DYNSYM (isl_band_get_partial_schedule); */ \
|
||||||
+ DYNSYM (isl_band_has_children); \
|
+ /* DYNSYM (isl_band_has_children); */ \
|
||||||
+ DYNSYM (isl_band_list_free); \
|
+ /* DYNSYM (isl_band_list_free); */ \
|
||||||
+ DYNSYM (isl_band_list_get_band); \
|
+ /* DYNSYM (isl_band_list_get_band); */ \
|
||||||
+ DYNSYM (isl_band_list_get_ctx); \
|
+ /* DYNSYM (isl_band_list_get_ctx); */ \
|
||||||
+ DYNSYM (isl_band_list_n_band); \
|
+ /* DYNSYM (isl_band_list_n_band); */ \
|
||||||
+ DYNSYM (isl_band_n_member); \
|
+ /* DYNSYM (isl_band_n_member); */ \
|
||||||
+ DYNSYM (isl_basic_map_add_constraint); \
|
+ DYNSYM (isl_basic_map_add_constraint); \
|
||||||
+ DYNSYM (isl_basic_map_project_out); \
|
+ DYNSYM (isl_basic_map_project_out); \
|
||||||
+ DYNSYM (isl_basic_map_universe); \
|
+ DYNSYM (isl_basic_map_universe); \
|
||||||
@ -91,7 +91,7 @@
|
|||||||
+ DYNSYM (isl_map_is_empty); \
|
+ DYNSYM (isl_map_is_empty); \
|
||||||
+ DYNSYM (isl_map_lex_ge); \
|
+ DYNSYM (isl_map_lex_ge); \
|
||||||
+ DYNSYM (isl_map_lex_le); \
|
+ DYNSYM (isl_map_lex_le); \
|
||||||
+ DYNSYM (isl_map_n_out); \
|
+ /* DYNSYM (isl_map_n_out); */ \
|
||||||
+ DYNSYM (isl_map_range); \
|
+ DYNSYM (isl_map_range); \
|
||||||
+ DYNSYM (isl_map_set_tuple_id); \
|
+ DYNSYM (isl_map_set_tuple_id); \
|
||||||
+ DYNSYM (isl_map_universe); \
|
+ DYNSYM (isl_map_universe); \
|
||||||
@ -124,7 +124,7 @@
|
|||||||
+ DYNSYM (isl_pw_aff_sub); \
|
+ DYNSYM (isl_pw_aff_sub); \
|
||||||
+ DYNSYM (isl_pw_aff_zero_set); \
|
+ DYNSYM (isl_pw_aff_zero_set); \
|
||||||
+ DYNSYM (isl_schedule_free); \
|
+ DYNSYM (isl_schedule_free); \
|
||||||
+ DYNSYM (isl_schedule_get_band_forest); \
|
+ /* DYNSYM (isl_schedule_get_band_forest); */ \
|
||||||
+ DYNSYM (isl_set_add_constraint); \
|
+ DYNSYM (isl_set_add_constraint); \
|
||||||
+ DYNSYM (isl_set_add_dims); \
|
+ DYNSYM (isl_set_add_dims); \
|
||||||
+ DYNSYM (isl_set_apply); \
|
+ DYNSYM (isl_set_apply); \
|
||||||
@ -641,7 +641,7 @@
|
|||||||
+
|
+
|
||||||
+ if (isl_pointers__.inited)
|
+ if (isl_pointers__.inited)
|
||||||
+ return isl_pointers__.h != NULL;
|
+ return isl_pointers__.h != NULL;
|
||||||
+ h = dlopen ("libisl.so.15", RTLD_LAZY);
|
+ h = dlopen ("libisl.so.23", RTLD_LAZY);
|
||||||
+ isl_pointers__.h = h;
|
+ isl_pointers__.h = h;
|
||||||
+ if (h == NULL)
|
+ if (h == NULL)
|
||||||
+ return false;
|
+ return false;
|
||||||
|
@ -2,7 +2,7 @@
|
|||||||
|
|
||||||
* toplev.cc (toplev_main_argv): New variable.
|
* toplev.cc (toplev_main_argv): New variable.
|
||||||
(toplev_main): Initialize it.
|
(toplev_main): Initialize it.
|
||||||
* graphite.cc (init_isl_pointers): Load libisl.so.15 from gcc's private
|
* graphite.cc (init_isl_pointers): Load libisl.so.23 from gcc's private
|
||||||
directory.
|
directory.
|
||||||
|
|
||||||
--- gcc/toplev.cc.jj 2008-12-09 23:59:10.000000000 +0100
|
--- gcc/toplev.cc.jj 2008-12-09 23:59:10.000000000 +0100
|
||||||
@ -39,12 +39,12 @@
|
|||||||
|
|
||||||
if (isl_pointers__.inited)
|
if (isl_pointers__.inited)
|
||||||
return isl_pointers__.h != NULL;
|
return isl_pointers__.h != NULL;
|
||||||
- h = dlopen ("libisl.so.15", RTLD_LAZY);
|
- h = dlopen ("libisl.so.23", RTLD_LAZY);
|
||||||
+ len = progname - toplev_main_argv[0];
|
+ len = progname - toplev_main_argv[0];
|
||||||
+ buf = XALLOCAVAR (char, len + sizeof "libisl.so.15");
|
+ buf = XALLOCAVAR (char, len + sizeof "libisl.so.23");
|
||||||
+ memcpy (buf, toplev_main_argv[0], len);
|
+ memcpy (buf, toplev_main_argv[0], len);
|
||||||
+ strcpy (buf + len, "libisl.so.15");
|
+ strcpy (buf + len, "libisl.so.23");
|
||||||
+ len += sizeof "libisl.so.15";
|
+ len += sizeof "libisl.so.23";
|
||||||
+ p = strstr (buf, "/libexec/");
|
+ p = strstr (buf, "/libexec/");
|
||||||
+ if (p != NULL)
|
+ if (p != NULL)
|
||||||
+ {
|
+ {
|
||||||
@ -61,7 +61,7 @@
|
|||||||
+ {
|
+ {
|
||||||
+ len = progname - toplev_main_argv[0];
|
+ len = progname - toplev_main_argv[0];
|
||||||
+ memcpy (buf, toplev_main_argv[0], len);
|
+ memcpy (buf, toplev_main_argv[0], len);
|
||||||
+ strcpy (buf + len, "libisl.so.15");
|
+ strcpy (buf + len, "libisl.so.23");
|
||||||
+ }
|
+ }
|
||||||
+ }
|
+ }
|
||||||
+ if (h == NULL)
|
+ if (h == NULL)
|
||||||
|
Loading…
Reference in New Issue
Block a user