4.3.0-0.2
This commit is contained in:
parent
3daebbc617
commit
080629bad7
30
gcc43-libjava-gcjpath.patch
Normal file
30
gcc43-libjava-gcjpath.patch
Normal file
@ -0,0 +1,30 @@
|
||||
--- libjava/classpath/configure.ac (revision 130691)
|
||||
+++ libjava/classpath/configure.ac (working copy)
|
||||
@@ -294,14 +294,14 @@ CLASSPATH_TOOLEXECLIBDIR
|
||||
dnl -----------------------------------------------------------
|
||||
dnl Sets the native libraries installation dir
|
||||
dnl -----------------------------------------------------------
|
||||
-dnl GCJ LOCAL: default to ${toolexeclibdir}/gcj-${gcc_version}-${libgcj_soversion}
|
||||
+dnl GCJ LOCAL: default to ${toolexeclibdir}/gcj-${gcc_version}
|
||||
AC_ARG_WITH([native-libdir],
|
||||
[AS_HELP_STRING(--with-native-libdir,sets the installation directory for native libraries [default='${libdir}/${PACKAGE}'])],
|
||||
[
|
||||
nativeexeclibdir=${withval}
|
||||
],
|
||||
[
|
||||
- nativeexeclibdir='${toolexeclibdir}/gcj-'`cat ${srcdir}/../../gcc/BASE-VER`-`awk -F: '/^[[^#]].*:/ { print $1 }' ${srcdir}/../libtool-version`
|
||||
+ nativeexeclibdir='${toolexeclibdir}/gcj-'`cat ${srcdir}/../../gcc/BASE-VER`
|
||||
])
|
||||
|
||||
AC_SUBST(nativeexeclibdir)
|
||||
--- libjava/classpath/configure (revision 130691)
|
||||
+++ libjava/classpath/configure (working copy)
|
||||
@@ -4771,7 +4771,7 @@ if test "${with_native_libdir+set}" = se
|
||||
|
||||
else
|
||||
|
||||
- nativeexeclibdir='${toolexeclibdir}/gcj-'`cat ${srcdir}/../../gcc/BASE-VER`-`awk -F: '/^[^#].*:/ { print $1 }' ${srcdir}/../libtool-version`
|
||||
+ nativeexeclibdir='${toolexeclibdir}/gcj-'`cat ${srcdir}/../../gcc/BASE-VER`
|
||||
|
||||
fi;
|
||||
|
@ -139,6 +139,7 @@ Patch11: gcc43-rh330771.patch
|
||||
Patch12: gcc43-rh341221.patch
|
||||
Patch13: gcc43-libjava-test.patch
|
||||
Patch14: gcc43-pr34427.patch
|
||||
Patch15: gcc43-libjava-gcjpath.patch
|
||||
|
||||
# On ARM EABI systems, we do want -gnueabi to be part of the
|
||||
# target triple.
|
||||
@ -436,6 +437,7 @@ which are required to run programs compiled with the GNAT.
|
||||
%patch12 -p0 -b .rh341221~
|
||||
%patch13 -p0 -b .libjava-test~
|
||||
%patch14 -p0 -E -b .pr34427~
|
||||
%patch15 -p0 -b .libjava-gcjpath~
|
||||
|
||||
%if %{bootstrap_java}
|
||||
tar xjf %{SOURCE10}
|
||||
|
Loading…
Reference in New Issue
Block a user