4.9.0-6
This commit is contained in:
parent
99dddb3746
commit
033def827b
2
gcc.spec
2
gcc.spec
@ -196,7 +196,6 @@ Patch12: gcc49-no-add-needed.patch
|
|||||||
Patch14: gcc49-pr56493.patch
|
Patch14: gcc49-pr56493.patch
|
||||||
Patch15: gcc49-color-auto.patch
|
Patch15: gcc49-color-auto.patch
|
||||||
Patch16: gcc49-libgo-p224.patch
|
Patch16: gcc49-libgo-p224.patch
|
||||||
Patch17: gcc49-aarch64-ada.patch
|
|
||||||
|
|
||||||
Patch1100: cloog-%{cloog_version}-ppc64le-config.patch
|
Patch1100: cloog-%{cloog_version}-ppc64le-config.patch
|
||||||
|
|
||||||
@ -723,7 +722,6 @@ package or when debugging this package.
|
|||||||
%endif
|
%endif
|
||||||
%patch16 -p0 -b .libgo-p224~
|
%patch16 -p0 -b .libgo-p224~
|
||||||
rm -f libgo/go/crypto/elliptic/p224{,_test}.go
|
rm -f libgo/go/crypto/elliptic/p224{,_test}.go
|
||||||
%patch17 -p0 -b .aarch64-ada~
|
|
||||||
|
|
||||||
%if 0%{?_enable_debug_packages}
|
%if 0%{?_enable_debug_packages}
|
||||||
cat > split-debuginfo.sh <<\EOF
|
cat > split-debuginfo.sh <<\EOF
|
||||||
|
@ -1,34 +0,0 @@
|
|||||||
2014-04-22 Richard Henderson <rth@redhat.com>
|
|
||||||
|
|
||||||
* init.c [__linux__] (HAVE_GNAT_ALTERNATE_STACK): New define.
|
|
||||||
(__gnat_alternate_stack): Enable for all linux except ia64.
|
|
||||||
|
|
||||||
--- gcc/ada/init.c
|
|
||||||
+++ gcc/ada/init.c
|
|
||||||
@@ -556,9 +556,14 @@ __gnat_error_handler (int sig, siginfo_t *si ATTRIBUTE_UNUSED, void *ucontext)
|
|
||||||
Raise_From_Signal_Handler (exception, msg);
|
|
||||||
}
|
|
||||||
|
|
||||||
-#if defined (i386) || defined (__x86_64__) || defined (__powerpc__)
|
|
||||||
-/* This must be in keeping with System.OS_Interface.Alternate_Stack_Size. */
|
|
||||||
-char __gnat_alternate_stack[16 * 1024]; /* 2 * SIGSTKSZ */
|
|
||||||
+#ifndef __ia64__
|
|
||||||
+#define HAVE_GNAT_ALTERNATE_STACK 1
|
|
||||||
+/* This must be in keeping with System.OS_Interface.Alternate_Stack_Size.
|
|
||||||
+ It must be larger than MINSIGSTKSZ and hopefully near 2 * SIGSTKSZ. */
|
|
||||||
+# if 16 * 1024 < MINSIGSTKSZ
|
|
||||||
+# error "__gnat_alternate_stack too small"
|
|
||||||
+# endif
|
|
||||||
+char __gnat_alternate_stack[16 * 1024];
|
|
||||||
#endif
|
|
||||||
|
|
||||||
#ifdef __XENO__
|
|
||||||
@@ -612,7 +617,7 @@ __gnat_install_handler (void)
|
|
||||||
sigaction (SIGBUS, &act, NULL);
|
|
||||||
if (__gnat_get_interrupt_state (SIGSEGV) != 's')
|
|
||||||
{
|
|
||||||
-#if defined (i386) || defined (__x86_64__) || defined (__powerpc__)
|
|
||||||
+#ifdef HAVE_GNAT_ALTERNATE_STACK
|
|
||||||
/* Setup an alternate stack region for the handler execution so that
|
|
||||||
stack overflows can be handled properly, avoiding a SEGV generation
|
|
||||||
from stack usage by the handler itself. */
|
|
Loading…
Reference in New Issue
Block a user