Fix build failure because of missing destdir in extension Makefile

This commit is contained in:
Ondřej Vašík 2014-04-21 11:59:54 +02:00
parent 94596434f7
commit e3282563da
2 changed files with 26 additions and 0 deletions

View File

@ -0,0 +1,24 @@
diff -urNp gawk-4.1.1-bak/extension/Makefile.am gawk-4.1.1/extension/Makefile.am
--- gawk-4.1.1-bak/extension/Makefile.am 2014-02-20 19:42:25.000000000 +0100
+++ gawk-4.1.1/extension/Makefile.am 2014-04-21 11:56:49.227755196 +0200
@@ -100,7 +100,7 @@ testext_la_LIBADD = $(MY_LIBS)
install-data-hook:
for i in $(pkgextension_LTLIBRARIES) ; do \
- $(RM) $(pkgextensiondir)/$$i ; \
+ $(RM) ${DESTDIR}$(pkgextensiondir)/$$i ; \
done
# Keep the uninstall check working:
diff -urNp gawk-4.1.1-bak/extension/Makefile.in gawk-4.1.1/extension/Makefile.in
--- gawk-4.1.1-bak/extension/Makefile.in 2014-04-08 18:13:03.000000000 +0200
+++ gawk-4.1.1/extension/Makefile.in 2014-04-21 11:57:54.884756674 +0200
@@ -1231,7 +1231,7 @@ uninstall-man: uninstall-man3
install-data-hook:
for i in $(pkgextension_LTLIBRARIES) ; do \
- $(RM) $(pkgextensiondir)/$$i ; \
+ $(RM) $(DESTDIR)$(pkgextensiondir)/$$i ; \
done
# Keep the uninstall check working:

View File

@ -9,6 +9,7 @@ License: GPLv3+ and GPL and LGPLv3+ and LGPL and BSD
Group: Applications/Text
URL: http://www.gnu.org/software/gawk/gawk.html
Source0: http://ftp.gnu.org/gnu/gawk/gawk-%{version}.tar.xz
Patch1: gawk-4.1.1-build-baddest.patch
Requires(post): /sbin/install-info
Requires(preun): /sbin/install-info
Conflicts: filesystem < 3
@ -26,6 +27,7 @@ considered to be a standard Linux tool for processing text.
%prep
%setup -q
%patch1 -p1 -b .baddest
%build
%configure --with-libsigsegv-prefix=no