Version 4.11.0.

Also:
- Drop upstreamed -immutable patch.
- Drop libtool Requires from the -devel subpackage.
- Drop testing workaround for s390x, fixed upstream.
This commit is contained in:
Jerry James 2020-03-13 16:43:07 -06:00
parent 687b2b3d2c
commit 675b5b673b
8 changed files with 61 additions and 49 deletions

View File

@ -1,6 +1,6 @@
--- lib/system.g.orig 2018-11-01 16:56:15.000000000 -0600
+++ lib/system.g 2019-01-24 09:33:07.685657846 -0700
@@ -30,9 +30,6 @@ BIND_GLOBAL( "GAPInfo", rec(
--- lib/system.g.orig 2020-02-29 02:02:12.000000000 -0700
+++ lib/system.g 2020-03-10 16:21:40.631418863 -0600
@@ -31,9 +31,6 @@ BIND_GLOBAL( "GAPInfo", rec(
Dependencies := MakeImmutable(rec(
NeededOtherPackages := [
[ "gapdoc", ">= 1.2" ],

View File

@ -1,6 +1,6 @@
--- cnf/gac.in.orig 2018-11-01 16:56:12.000000000 -0600
+++ cnf/gac.in 2019-01-25 16:28:32.995611111 -0700
@@ -51,18 +51,18 @@
--- cnf/gac.in.orig 2020-02-29 02:02:09.000000000 -0700
+++ cnf/gac.in 2020-03-10 16:24:49.245316438 -0600
@@ -56,18 +56,18 @@
SHELL="@SHELL@"
# absolute path of the directory in which GAP was compiled
@ -23,9 +23,9 @@
CC="@CC@"
# These three should be filled in by the standard autoconf procedures
@@ -431,6 +431,5 @@ fi
#Remove temporary directory.
#We may assume it is empty at this stage.
@@ -440,6 +440,5 @@ fi
# Remove temporary directory.
# We may assume it is empty at this stage.
if [ "$savetemps" = "false" ]; then
- rm -rf "${gactmp}/.libs"
- rmdir "${gactmp}"

View File

@ -1,6 +1,6 @@
--- lib/helpdef.gi.orig 2018-11-01 16:56:12.000000000 -0600
+++ lib/helpdef.gi 2019-01-21 09:11:54.961416746 -0700
@@ -402,6 +402,11 @@ HELP_BOOK_HANDLER.default.ReadSix := fun
--- lib/helpdef.gi.orig 2020-02-29 02:02:10.000000000 -0700
+++ lib/helpdef.gi 2020-03-10 16:23:08.773969047 -0600
@@ -403,6 +403,11 @@ HELP_BOOK_HANDLER.default.ReadSix := fun
res.pdffile := ShallowCopy(fname);
Add(res.formats, "pdf");
fi;
@ -12,9 +12,9 @@
fi;
res.directories := [ Directory(fname{[1..Length(fname)-10]}) ];
return res;
--- lib/helpview.gi.orig 2018-11-01 16:56:12.000000000 -0600
+++ lib/helpview.gi 2019-01-21 09:11:54.985416307 -0700
@@ -436,6 +436,27 @@ if IsHPCGAP then
--- lib/helpview.gi.orig 2020-02-29 02:02:10.000000000 -0700
+++ lib/helpview.gi 2020-03-10 16:23:08.774969030 -0600
@@ -437,6 +437,27 @@ if IsHPCGAP then
MakeReadOnlyObj(HELP_VIEWER_INFO);
fi;

View File

@ -1,11 +0,0 @@
--- lib/ctblfuns.gi.orig 2018-11-01 16:56:12.000000000 -0600
+++ lib/ctblfuns.gi 2019-02-12 08:43:52.769804253 -0700
@@ -4319,7 +4319,7 @@ InstallGlobalFunction( ReductionToFinite
if k <> 1 then
- primes:= PrimeDivisors( m );
+ primes:= ShallowCopy( PrimeDivisors( m ) );
sol:= fail;
while not IsEmpty( primes ) do

31
gap.rpmlintrc Normal file
View File

@ -0,0 +1,31 @@
# THIS FILE IS FOR WHITELISTING RPMLINT ERRORS AND WARNINGS IN TASKOTRON
# https://fedoraproject.org/wiki/Taskotron/Tasks/dist.rpmlint#Whitelisting_errors
# The dictionary is missing some technical terms
addFilter(r'W: spelling-error .* combinatorial')
# These packages have no binary bits
addFilter(r'gap-(core|devel|libs|online-help)\.[^:]+: W: only-non-binary-in-usr-lib')
# The documentation is in the online-help subpackage
addFilter(r'gap-(libs|online-help)\.noarch: W: no-documentation')
addFilter(r'libgap(-devel)?\.[^:]+: W: no-documentation')
# This file is zero-length on purpose. It grows as packages are installed.
addFilter(r'E: zero-length /var/lib/gap/workspace.gz')
# These files are deliberately empty.
addFilter(r'E: zero-length /usr/lib/gap/tst/example-dir/dir-test/(A|B|C|D)')
addFilter(r'E: zero-length /usr/lib/gap/tst/mockpkg/doc/chap0\.html')
addFilter(r'E: zero-length /usr/lib/gap/tst/testinstall/files/empty\.txt')
addFilter(r'E: zero-length /usr/lib/gap/tst/testspecial/empty\.tst')
# The package Requires gmp-devel so the symlink will not dangle.
addFilter(r'W: dangling-symlink .* /usr/include/gmp\.h')
# These are not libraries in the C sense of the word.
addFilter(r'E: explicit-lib-dependency gap-pkg-(ctbl|tom)lib')
# We use /usr/lib on purpose to avoid placing the large number of noarch
# gap-pkg-* packages into an arch-specific path.
addFilter(r'gap\.spec:[^:]+: E: hardcoded-library-path in %{_prefix}/lib/gap')

View File

@ -14,7 +14,7 @@
%global gapcpu %{_build}
%endif
%endif
%global gaparch %{gapcpu}-%{gapbits}-kv3
%global gaparch %{gapcpu}-%{gapbits}-kv7
# When bootstrapping a new architecture, there are no GAPDoc, gap-pkg-primgrp,
# gap-pkg-smallgrp, or gap-pkg-transgrp packages yet, but the gap binary
@ -30,8 +30,8 @@
%bcond_with bootstrap
Name: gap
Version: 4.10.2
Release: 3%{?dist}
Version: 4.11.0
Release: 1%{?dist}
Summary: Computational discrete algebra
%global majver %(cut -d. -f1-2 <<< %{version})
@ -59,8 +59,6 @@ Patch2: %{name}-escape.patch
Patch3: %{name}-ref.patch
# Fix paths in gac
Patch4: %{name}-gac.patch
# Ctbl code tries to change an immutable object
Patch5: %{name}-immutable.patch
BuildRequires: desktop-file-utils
BuildRequires: gcc-c++
@ -70,8 +68,9 @@ BuildRequires: libtool
BuildRequires: netpbm-progs
BuildRequires: parallel
BuildRequires: perl-generators
BuildRequires: pkgconfig(readline)
BuildRequires: pkgconfig(zlib)
BuildRequires: procps
BuildRequires: readline-devel
BuildRequires: tex(color.sty)
BuildRequires: tex(english.ldf)
BuildRequires: tex(enumitem.sty)
@ -86,7 +85,6 @@ BuildRequires: tex-latex-bin
BuildRequires: tex-rsfs
BuildRequires: tex-symbol
BuildRequires: tex-times
BuildRequires: zlib-devel
Requires: %{name}-core%{?_isa} = %{version}-%{release}
Requires: %{name}-online-help = %{version}-%{release}
@ -103,7 +101,7 @@ of algebraic objects. GAP is used in research and teaching for studying
groups and their representations, rings, vector spaces, algebras,
combinatorial structures, and more.
This package contains the commandline application.
This package contains the command line application.
%package libs
Summary: Essential GAP libraries
@ -140,7 +138,6 @@ online help system.
Summary: GAP compiler and development files
Requires: %{name}%{?_isa} = %{version}-%{release}
Requires: gmp-devel%{?_isa}
Requires: libtool
%description devel
This package contains the GAP compiler (gac) and the header files necessary
@ -188,7 +185,7 @@ Requires: libgap = %{version}-%{release}
Headers and library links for libgap.
%prep
%setup -q
%autosetup -N
%if %{with bootstrap}
%patch0
%endif
@ -196,7 +193,6 @@ Headers and library links for libgap.
%patch2
%patch3
%patch4
%patch5
# Get the README
cp -p %{SOURCE1} README.fedora
@ -362,16 +358,6 @@ fi
%if %{without bootstrap}
%check
%ifarch s390x
# Some test results depend on the results of a hash algorithm. The algorithm
# output depends on the exact order of the bytes fed into it. We feed in the
# same bytes, but in different orders, on little and big endian machines.
# However, the test checks for the little endian output. Fix that on big
# endian machines.
sed -e 's/260581/402746/;s/773594/109657/;s/567548/351540/' \
-i tst/testinstall/pperm.tst
%endif
export LC_ALL=C.UTF-8
sed -e "s|GAP_DIR=.*|GAP_DIR=$PWD|" \
-e "s|GAP_EXE=.*|GAP_EXE=$PWD|" \
@ -455,6 +441,12 @@ make check
%{_libdir}/libgap.so
%changelog
* Fri Mar 13 2020 Jerry James <loganjerry@gmail.com> - 4.11.0-1
- Version 4.11.0
- Drop upstreamed -immutable patch
- Drop libtool Requires from the -devel subpackage
- Drop testing workaround for s390x, fixed upstream
* Tue Jan 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 4.10.2-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild

View File

@ -1 +1 @@
autocmd BufRead,BufNewFile *.g,*.gap,*.gi,*.gd,*.grp set filetype=gap
autocmd BufRead,BufNewFile *.g,*.gap,*.gi,*.gd,*.grp set filetype=gap comments=s:##\ \ ,m:##\ \ ,e:##\ \ b:#

View File

@ -1 +1 @@
SHA512 (gap-4.10.2.tar.bz2) = e6a65fa6e9ddda6f2b803f90f35ad3a4fc52ef1b1007f29a9f01e656a5c8ddedc48163fc2862307e948b1cf0f7aaa029079123118643695e06410f1b09633632
SHA512 (gap-4.11.0.tar.bz2) = 1627a19dc9a156752773d24cd624ee1ebbf5c94180f7cc59502022597d3eac2fff4bbf6d5dc57b1a5c1e4d94e93105e354ba46ef959dfdfd699c87d8d2809761