New upstream release

This commit is contained in:
Richard Hughes 2022-11-09 14:18:12 +00:00
parent eee67d4414
commit 85767e1509
5 changed files with 103 additions and 3 deletions

1
.gitignore vendored
View File

@ -98,3 +98,4 @@
/fwupd-1.8.4.tar.xz
/fwupd-1.8.5.tar.xz
/fwupd-1.8.6.tar.xz
/fwupd-1.8.7.tar.xz

View File

@ -0,0 +1,40 @@
From 73a63b89a051dda3c149b16ffc0f4759e1611715 Mon Sep 17 00:00:00 2001
From: Richard Hughes <richard@hughsie.com>
Date: Wed, 9 Nov 2022 15:51:27 +0000
Subject: [PATCH] trivial: Fix lvfs-testing remote file
---
data/remotes.d/meson.build | 12 +++++++-----
1 file changed, 7 insertions(+), 5 deletions(-)
diff --git a/data/remotes.d/meson.build b/data/remotes.d/meson.build
index 4ef0266f0..c20a1a05e 100644
--- a/data/remotes.d/meson.build
+++ b/data/remotes.d/meson.build
@@ -1,9 +1,4 @@
if build_standalone and get_option('lvfs') != 'false'
- install_data([
- 'lvfs-testing.conf',
- ],
- install_dir: join_paths(sysconfdir, 'fwupd', 'remotes.d')
- )
con3 = configuration_data()
if get_option('lvfs') == 'disabled'
con3.set('enabled', 'false')
@@ -22,6 +17,13 @@ if build_standalone and get_option('lvfs') != 'false'
install: true,
install_dir: join_paths(sysconfdir, 'fwupd', 'remotes.d'),
)
+ configure_file(
+ input: 'lvfs-testing.conf',
+ output: 'lvfs-testing.conf',
+ configuration: con3,
+ install: true,
+ install_dir: join_paths(sysconfdir, 'fwupd', 'remotes.d'),
+ )
i18n.merge_file(
input: 'lvfs.metainfo.xml',
output: 'org.freedesktop.fwupd.remotes.lvfs.metainfo.xml',
--
2.37.3

View File

@ -0,0 +1,40 @@
From 1a31c35732db748af7af8d7d123d148582376251 Mon Sep 17 00:00:00 2001
From: Richard Hughes <richard@hughsie.com>
Date: Wed, 9 Nov 2022 15:28:06 +0000
Subject: [PATCH] trivial: Fix the tests on s390x
---
plugins/synaptics-mst/fu-self-test.c | 10 ++++++++++
1 file changed, 10 insertions(+)
diff --git a/plugins/synaptics-mst/fu-self-test.c b/plugins/synaptics-mst/fu-self-test.c
index ffdaa7a5b..29a05e9c5 100644
--- a/plugins/synaptics-mst/fu-self-test.c
+++ b/plugins/synaptics-mst/fu-self-test.c
@@ -81,6 +81,11 @@ fu_plugin_synaptics_mst_none_func(void)
g_ptr_array_new_with_free_func((GDestroyNotify)g_object_unref);
g_autofree gchar *filename = NULL;
+#if defined(__s390x__)
+ g_test_skip("Skipping HWID test on s390x due missing HwIDs");
+ return;
+#endif
+
ret = fu_context_load_quirks(ctx, FU_QUIRKS_LOAD_FLAG_NO_CACHE, &error);
g_assert_no_error(error);
g_assert_true(ret);
@@ -124,6 +129,11 @@ fu_plugin_synaptics_mst_tb16_func(void)
g_ptr_array_new_with_free_func((GDestroyNotify)g_object_unref);
g_autofree gchar *filename = NULL;
+#if defined(__s390x__)
+ g_test_skip("Skipping HWID test on s390x due missing HwIDs");
+ return;
+#endif
+
ret = fu_context_load_quirks(ctx, FU_QUIRKS_LOAD_FLAG_NO_CACHE, &error);
g_assert_no_error(error);
g_assert_true(ret);
--
2.37.3

View File

@ -53,12 +53,15 @@
Summary: Firmware update daemon
Name: fwupd
Version: 1.8.6
Release: 1%{?dist}
Version: 1.8.7
Release: 2%{?dist}
License: LGPLv2+
URL: https://github.com/fwupd/fwupd
Source0: http://people.freedesktop.org/~hughsient/releases/%{name}-%{version}.tar.xz
Patch1: 0001-trivial-Fix-the-tests-on-s390x.patch
Patch2: 0001-trivial-Fix-lvfs-testing-remote-file.patch
BuildRequires: gettext
BuildRequires: glib2-devel >= %{glib2_version}
BuildRequires: libxmlb-devel >= %{libxmlb_version}
@ -428,6 +431,22 @@ done
%endif
%changelog
* Wed Nov 09 2022 Richard Hughes <richard@hughsie.com> 1.8.7-2
- Fix the lvfs-testing remote
* Wed Nov 09 2022 Richard Hughes <richard@hughsie.com> 1.8.7-1
- New upstream release
- Add a new HSI check for the leaked Lenovo 'Key Manifest' hashes
- Allow parsing metadata more than 1MB in size
- Do not follow symlinks when searching for ESP devices
- Fix a regression when using fwuptool install-blob with FMAP firmware
- Measure system integrity when installing UEFI updates
- Only count the Microsoft hashes when getting the dbx version
- Only use the IFD when the system is Intel-based
- Record more host DMI data when submitting a report for dbx failures
- Support loading CoSWID when only one role has been set
- Use xz-compressed metadata to reduce bandwidth used by ~25%
* Fri Oct 07 2022 Richard Hughes <richard@hughsie.com> 1.8.6-1
- New upstream release
- Allow disabling a DFU device when required

View File

@ -1 +1 @@
SHA512 (fwupd-1.8.6.tar.xz) = c04c9f9e0d46b42c4c4c56738bd9c53a7e17a873defaebe5e262953314f6311937cd0c38db21d4bc9b481760e490024e6c4c059bb73206ed02f24216dd65a74d
SHA512 (fwupd-1.8.7.tar.xz) = 374339178a1fbf85bc25b47077d0db351b3664a02ec9478c4a5381228125f3bd65ef0be9eb526574bd09ab665aadd6cd9e39f01ebbfebbd338ec191ba24c5a36