- Upgrade to upstream release 2.4.2.

This commit is contained in:
Joost van der Sluis 2011-01-05 13:57:18 +01:00 committed by joost
parent 0d47658ca2
commit a07eb118b3
5 changed files with 9 additions and 113 deletions

1
.gitignore vendored
View File

@ -1,2 +1,3 @@
fpcbuild-2.4.0.tar.gz
/fpcbuild-2.4.2rc1.tar.gz
/fpcbuild-2.4.2.tar.gz

View File

@ -1,82 +0,0 @@
Index: fpcdocs/Makefile
===================================================================
--- fpcdocs/Makefile (revision 716)
+++ fpcdocs/Makefile (working copy)
@@ -1,8 +1,8 @@
#
-# Don't edit, this file is generated by FPCMake Version 2.0.0 [2010/02/04]
+# Don't edit, this file is generated by FPCMake Version 2.0.0 [2010/10/16]
#
default: help
-MAKEFILETARGETS=i386-linux i386-go32v2 i386-win32 i386-os2 i386-freebsd i386-beos i386-haiku i386-netbsd i386-solaris i386-qnx i386-netware i386-openbsd i386-wdosx i386-darwin i386-emx i386-watcom i386-netwlibc i386-wince i386-embedded i386-symbian i386-nativent m68k-linux m68k-freebsd m68k-netbsd m68k-amiga m68k-atari m68k-openbsd m68k-palmos m68k-embedded powerpc-linux powerpc-netbsd powerpc-amiga powerpc-macos powerpc-darwin powerpc-morphos powerpc-embedded sparc-linux sparc-netbsd sparc-solaris sparc-embedded x86_64-linux x86_64-freebsd x86_64-solaris x86_64-darwin x86_64-win64 x86_64-embedded arm-linux arm-palmos arm-darwin arm-wince arm-gba arm-nds arm-embedded arm-symbian powerpc64-linux powerpc64-darwin powerpc64-embedded avr-embedded armeb-linux armeb-embedded mipsel-linux
+MAKEFILETARGETS=i386-linux i386-go32v2 i386-win32 i386-os2 i386-freebsd i386-beos i386-haiku i386-netbsd i386-solaris i386-qnx i386-netware i386-openbsd i386-wdosx i386-darwin i386-emx i386-watcom i386-netwlibc i386-wince i386-embedded i386-symbian i386-nativent i386-iphonesim m68k-linux m68k-freebsd m68k-netbsd m68k-amiga m68k-atari m68k-openbsd m68k-palmos m68k-embedded powerpc-linux powerpc-netbsd powerpc-amiga powerpc-macos powerpc-darwin powerpc-morphos powerpc-embedded sparc-linux sparc-netbsd sparc-solaris sparc-embedded x86_64-linux x86_64-freebsd x86_64-solaris x86_64-darwin x86_64-win64 x86_64-embedded arm-linux arm-palmos arm-darwin arm-wince arm-gba arm-nds arm-embedded arm-symbian powerpc64-linux powerpc64-darwin powerpc64-embedded avr-embedded armeb-linux armeb-embedded mipsel-linux
BSDs = freebsd netbsd openbsd darwin
UNIXs = linux $(BSDs) solaris qnx haiku
LIMIT83fs = go32v2 os2 emx watcom
@@ -244,7 +244,7 @@
ifndef CROSSBINDIR
CROSSBINDIR:=$(wildcard $(FPCDIR)/bin/$(TARGETSUFFIX))
endif
-ifeq ($(OS_TARGET),darwin)
+ifneq ($(findstring $(OS_TARGET),darwin iphonesim),)
ifeq ($(OS_SOURCE),darwin)
DARWIN2DARWIN=1
endif
@@ -330,6 +330,9 @@
ifeq ($(FULL_TARGET),i386-nativent)
override TARGET_PROGRAMS+=cleanxml relinkdocs
endif
+ifeq ($(FULL_TARGET),i386-iphonesim)
+override TARGET_PROGRAMS+=cleanxml relinkdocs
+endif
ifeq ($(FULL_TARGET),m68k-linux)
override TARGET_PROGRAMS+=cleanxml relinkdocs
endif
@@ -513,6 +516,9 @@
ifeq ($(FULL_TARGET),i386-nativent)
override TARGET_UNITS+=relinkhtml
endif
+ifeq ($(FULL_TARGET),i386-iphonesim)
+override TARGET_UNITS+=relinkhtml
+endif
ifeq ($(FULL_TARGET),m68k-linux)
override TARGET_UNITS+=relinkhtml
endif
@@ -960,7 +966,7 @@
SHORTSUFFIX=mac
IMPORTLIBPREFIX=imp
endif
-ifeq ($(OS_TARGET),darwin)
+ifneq ($(findstring $(OS_TARGET),darwin iphonesim),)
BATCHEXT=.sh
EXEEXT=
HASSHAREDLIB=1
@@ -2516,9 +2522,9 @@
chart.chk: $(INCLUDES) chart.tex
html: fpc_all comphelp.inc $(INCLUDES) $(CHK)
chm:
- $(MAKE) html HTMLFMT=chm
+ $(MAKE) html HTMLFMT=chm
ipf:
- $(MAKE) html HTMLFMT=ipf
+ $(MAKE) html HTMLFMT=ipf
endif # INSTALLDEBUG
hevea:
$(MAKE) html USEHEVEA=1
Index: fpcdocs/Makefile.fpc
===================================================================
--- fpcdocs/Makefile.fpc (revision 716)
+++ fpcdocs/Makefile.fpc (working copy)
@@ -754,10 +754,10 @@
html: fpc_all comphelp.inc $(INCLUDES) $(CHK)
chm:
- $(MAKE) html HTMLFMT=chm
+ $(MAKE) html HTMLFMT=chm
ipf:
- $(MAKE) html HTMLFMT=ipf
+ $(MAKE) html HTMLFMT=ipf
endif # INSTALLDEBUG
#######################################################################

View File

@ -1,22 +0,0 @@
Index: packages/fcl-passrc/src/pparser.pp
===================================================================
--- fpcsrc/packages/fcl-passrc/src/pparser.pp (revision 16197)
+++ fpcsrc/packages/fcl-passrc/src/pparser.pp (revision 16198)
@@ -119,7 +119,7 @@
AParent: TPasElement): TPasElement;overload;
function CreateElement(AClass: TPTreeElement; const AName: String;
AParent: TPasElement; AVisibility: TPasMemberVisibility): TPasElement;overload;
- Function IsHint(Const S : String; AHint : TPasMemberHint) : Boolean;
+ Function IsHint(Const S : String; var AHint : TPasMemberHint) : Boolean;
Function CheckHint(Element : TPasElement; ExpectSemiColon : Boolean) : TPasMemberHints;
public
Options : set of TPOptions;
@@ -334,7 +334,7 @@
Result:=ParseType(Parent,'');
end;
-Function TPasParser.IsHint(Const S : String; AHint : TPasMemberHint) : Boolean;
+Function TPasParser.IsHint(Const S : String; var AHint : TPasMemberHint) : Boolean;
Var
T : string;

View File

@ -1,12 +1,12 @@
Name: fpc
Version: 2.4.2
Release: 0.1.rc1%{?dist}
Release: 1%{?dist}
Summary: Free Pascal Compiler
Group: Development/Languages
License: GPLv2+ and LGPLv2+ with exceptions
URL: http://www.freepascal.org/
Source0: ftp://ftp.freepascal.org/pub/fpc/dist/${version}/source/fpcbuild-%{version}rc1.tar.gz
Source0: ftp://ftp.freepascal.org/pub/fpc/dist/${version}/source/fpcbuild-%{version}.tar.gz
# This is only needed when useprebuiltcompiler is defined.
# But it's not in an 'if defined' block, since the file has to be included in the srpm
# Thus you should enable this line when useprebuildcompiler is defined for any target
@ -14,8 +14,6 @@ Source0: ftp://ftp.freepascal.org/pub/fpc/dist/${version}/source/fpcbuild
Patch0: fpc-2.4.2-samplecfg_32and64bit.patch
Patch1: fpc-2.4.2-build-id.patch
Patch2: fpc-2.4.2-r15671.patch
Patch3: fpc-2.4.2-r16198.patch
Patch4: fpc-2.4.2-makefilespaces.patch
Requires: gpm, ncurses, binutils
%if ! %{defined useprebuiltcompiler}
@ -70,15 +68,13 @@ automatical-code generation purposes.
%prep
%if %{defined useprebuiltcompiler}
%setup -a1 -n fpcbuild-%{version}rc1 -q
%setup -a1 -n fpcbuild-%{version} -q
%else
%setup -n fpcbuild-%{version}rc1 -q
%setup -n fpcbuild-%{version} -q
%endif
%patch0
%patch1
%patch2
%patch3
%patch4
%build
# The source-files:
@ -179,6 +175,9 @@ rm -rf %{buildroot}
%{_datadir}/fpcsrc
%changelog
* Wed Jan 5 2011 Joost van der Sluis <joost@cnoc.nl> - 2.4.2-1
- Upgrade to upstream release 2.4.2.
* Sat Oct 23 2010 Joost van der Sluis <joost@cnoc.nl> - 2.4.2-0.1.rc1
- Upgrade to upstream release 2.4.2rc1.

View File

@ -1 +1 @@
0e8ef45bbb6b788f009e6eeed9003250 fpcbuild-2.4.2rc1.tar.gz
35ff506cca77b999097ffed61705be95 fpcbuild-2.4.2.tar.gz