- Updated to version 2.2.4

This commit is contained in:
Joost van der Sluis 2009-04-12 19:47:04 +00:00
parent fbde4916a0
commit 51ff7c08b7
8 changed files with 57 additions and 126 deletions

View File

@ -1 +1 @@
fpcbuild-2.2.2.tar.gz
fpcbuild-2.2.4.tar.gz

View File

@ -1,26 +0,0 @@
Index: fpcdocs/Makefile.fpc
===================================================================
--- fpcdocs/Makefile.fpc
+++ fpcdocs/Makefile.fpc
@@ -258,7 +258,7 @@
comphelp.inc:
echo "% Automatically generated. Do not edit" > comphelp.inc
echo "\begin{verbatim}" >> comphelp.inc
- fpc -h >>comphelp.inc
+ $(FPC) -h >>comphelp.inc
echo "\end{verbatim}" >> comphelp.inc
# Local copy of the required styles
Index: fpcdocs/Makefile
===================================================================
--- fpcdocs/Makefile
+++ fpcdocs/Makefile
@@ -1867,7 +1882,7 @@
comphelp.inc:
echo "% Automatically generated. Do not edit" > comphelp.inc
echo "\begin{verbatim}" >> comphelp.inc
- fpc -h >>comphelp.inc
+ $(FPC) -h >>comphelp.inc
echo "\end{verbatim}" >> comphelp.inc
syntax.sty: styles/syntax.sty
cp $(wildcard styles/*.sty) .

View File

@ -1,62 +0,0 @@
Index: fpcsrc/packages/gtk2/src/gtk+/gtk/gtk2.pas
===================================================================
--- fpcsrc/packages/gtk2/src/gtk+/gtk/gtk2.pas (revision 11650)
+++ fpcsrc/packages/gtk2/src/gtk+/gtk/gtk2.pas (revision 11651)
@@ -63,6 +63,8 @@
{$DEFINE HasGTK2_8}
{$ENDIF}
+// {$define HasGTK_FileSystem}
+
interface
uses
Index: fpcsrc/packages/gtk2/src/gtk+/gtk/gtkfilesystem.inc
===================================================================
--- fpcsrc/packages/gtk2/src/gtk+/gtk/gtkfilesystem.inc (revision 11650)
+++ fpcsrc/packages/gtk2/src/gtk+/gtk/gtkfilesystem.inc (revision 11651)
@@ -115,17 +115,14 @@
{$IFDEF read_interface_rest}
+{$ifdef HasGTK_FileSystem}
{ GError enumeration for GtkFileSystem }
function GTK_FILE_SYSTEM_ERROR : TGQuark;
-
-
function gtk_file_system_error_quark:TGQuark;cdecl;external gtklib name 'gtk_file_system_error_quark';
-
-
{ Boxed-type for gtk_file_folder_get_info() results }
function GTK_TYPE_FILE_INFO : GType;
@@ -244,11 +241,16 @@
{ GtkFileSystem modules support }
function _gtk_file_system_create(file_system_name:Pchar):PGtkFileSystem;cdecl;external gtklib name '_gtk_file_system_create';
+
+{$endif HasGTK_FileSystem}
+
{$endif} {read_interface_rest}
{$ifdef read_implementation}
+{$ifdef HasGTK_FileSystem}
+
function GTK_FILE_SYSTEM_ERROR : TGQuark;
begin
GTK_FILE_SYSTEM_ERROR:=gtk_file_system_error_quark;
@@ -307,6 +309,8 @@
GTK_FILE_FOLDER_GET_IFACE:=G_TYPE_INSTANCE_GET_INTERFACE(inst,GTK_TYPE_FILE_FOLDER);
end;
+{$endif HasGTK_FileSystem}
+
function gtk_file_path_new_dup(str : Pgchar) : PGtkFilePath;
begin
gtk_file_path_new_dup:=PGtkFilePath(g_strdup(str));

View File

@ -1,8 +1,8 @@
Index: fpcsrc/compiler/utils/samplecfg
===================================================================
--- fpcsrc/compiler/utils/samplecfg (revision 8809)
--- fpcsrc/compiler/utils/samplecfg (version 2.2.4)
+++ fpcsrc/compiler/utils/samplecfg (working copy)
@@ -290,6 +290,11 @@
@@ -360,6 +360,11 @@
# to perform
# -----------------------

View File

@ -1,36 +1,56 @@
Index: fpcsrc/compiler/utils/samplecfg
===================================================================
--- fpcsrc/compiler/utils/samplecfg (version 2.2.2)
--- fpcsrc/compiler/utils/samplecfg (version 2.2.4)
+++ fpcsrc/compiler/utils/samplecfg (working copy)
@@ -17,7 +17,7 @@
setgccdirarch() {
# First argument is fpc define for CPU type; remaining args are passed to gcc to set corresponding architecture
-FPCDEFINE=$1
+FPCDEFINE="$1"/"$libdir"/fpc
shift
setgccdir $@
@@ -35,7 +35,7 @@
if [ $# = 0 ]; then
echo 'Usage :'
echo 'samplecfg fpcdir confdir'
- echo 'fpcdir = Path where FPC is installed'
+ echo 'fpcdir = Prefix where FPC is installed (/usr, /usr/local)'
+ echo 'fpcdir = Prefix where FPC is installed (/usr/., /usr/local/.)'
echo 'confdir = Path to /etc'
exit 1
fi
@@ -45,7 +45,7 @@
@@ -45,9 +45,16 @@
else
sysdir=/etc
fi
-FPCBIN=`dirname "$1"`/../../bin/fpc
+FPCBIN=`dirname "$1"`/bin/fpc
# Detect if we have write permission in root.
if [ -w "$sysdir" ] ; then
@@ -155,7 +155,8 @@
-FPBIN=`dirname "$1"`/../../bin/fp
-sysfpdirbase=`dirname "$1"`/`$FPCBIN -iV`
+FPCBIN="$1"/bin/fpc
+FPBIN="$1"/bin/fp
+fpctargetproc=`$FPCBIN -iTP`
+echo "$fpctargetproc"
+if [ "$fpctargetproc" = "x86_64" -o "$fpctargetproc" = "powerpc64" ]; then
+ libdir=lib64
+else
+ libdir=lib
+fi
+sysfpdirbase="$1"/"$libdir"/fpc/`$FPCBIN -iV`
sysfpdirbase2=$sysfpdirbase/ide
sysfpdir=$sysfpdirbase2/text
fpctargetos=`$FPCBIN -iTO`
@@ -223,7 +230,8 @@
# set right path to FPC with $fpcversion
-FPCPATH=`dirname "$1"`/\$fpcversion
+FPCPATH32=`dirname "$1"`/lib/fpc/\$fpcversion
+FPCPATH64=`dirname "$1"`/lib64/fpc/\$fpcversion
+FPCPATH32="$1"/lib/fpc/\$fpcversion
+FPCPATH64="$1"/lib64/fpc/\$fpcversion
# Write the file
echo Writing sample configuration file to $thefile
@@ -291,26 +292,48 @@
# Write (.)fpc.cfg
echo Writing sample configuration file to $fpccfgfile
@@ -359,26 +367,48 @@
# path to the messagefile, not necessary anymore but can be used to override
# the default language
@ -45,26 +65,26 @@ Index: fpcsrc/compiler/utils/samplecfg
#-Fi/pp/inc;/pp/rtl/inc
#IFDEF FPCAPACHE_1_3
--Fu$FPCPATH/units/\$fpctarget/httpd-1.3/
--Fu$FPCPATH/units/\$fpctarget/httpd13/
+#IFDEF CPU64
+-Fu$FPCPATH64/units/\$fpctarget/httpd-1.3/
+-Fu$FPCPATH64/units/\$fpctarget/httpd13/
+#ELSE
+-Fu$FPCPATH32/units/\$fpctarget/httpd-1.3/
+-Fu$FPCPATH32/units/\$fpctarget/httpd13/
+#ENDIF
#ELSE
#IFDEF FPCAPACHE_2_0
--Fu$FPCPATH/units/\$fpctarget/httpd-2.0
--Fu$FPCPATH/units/\$fpctarget/httpd20
+#IFDEF CPU64
+-Fu$FPCPATH64/units/\$fpctarget/httpd-2.0
+-Fu$FPCPATH64/units/\$fpctarget/httpd20
+#ELSE
+-Fu$FPCPATH32/units/\$fpctarget/httpd-2.0
+-Fu$FPCPATH32/units/\$fpctarget/httpd20
+#ENDIF
#ELSE
--Fu$FPCPATH/units/\$fpctarget/httpd-2.2
+#IFDEF CPU64
+-Fu$FPCPATH64/units/\$fpctarget/httpd-2.2
+#ELSE
+-Fu$FPCPATH32/units/\$fpctarget/httpd-2.2
+#IFDEF CPU64
+-Fu$FPCPATH64/units/\$fpctarget/httpd22
#ELSE
--Fu$FPCPATH/units/\$fpctarget/httpd22
+-Fu$FPCPATH32/units/\$fpctarget/httpd22
+#ENDIF
#ENDIF
#ENDIF

View File

@ -1,8 +1,8 @@
Index: fpcsrc/compiler/utils/samplecfg
===================================================================
--- fpcsrc/compiler/utils/samplecfg (version 2.2.2)
--- fpcsrc/compiler/utils/samplecfg (version 2.2.4)
+++ fpcsrc/compiler/utils/samplecfg (working copy)
@@ -289,6 +289,11 @@
@@ -365,6 +365,11 @@
-k--build-id
# -----------------------

View File

@ -1,6 +1,6 @@
Name: fpc
Version: 2.2.2
Release: 4%{?dist}
Version: 2.2.4
Release: 1%{?dist}
Summary: Free Pascal Compiler
Group: Development/Languages
@ -13,16 +13,14 @@ Source0: ftp://ftp.freepascal.org/pub/fpc/dist/source-%{version}/%{name}b
# Source1: http://www.cnoc.nl/fpc/%{name}-%{version}.compiler.bin.tar.gz
Patch0: %{name}-%{version}-samplecfg_32and64bit.patch
Patch1: %{name}-%{version}-build-id.patch
Patch2: %{name}-%{version}-fpcdocs.patch
Patch3: %{name}-%{version}-stackexecute.patch
Patch4: %{name}-%{version}-gtk2-r11651.patch
Patch2: %{name}-%{version}-stackexecute.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
Requires: gpm, glibc, ncurses, binutils
%if ! %{defined useprebuiltcompiler}
BuildRequires: fpc
%endif
BuildRequires: tetex, tetex-latex, tetex-fonts, binutils, gpm-devel, glibc-devel
BuildRequires: tetex, tetex-latex, tetex-fonts, binutils, glibc-devel
%description
@ -78,8 +76,6 @@ automatical-code generation purposes.
%patch0
%patch1
%patch2
%patch3
%patch4
%build
# The source-files:
@ -179,6 +175,9 @@ rm -rf %{buildroot}
%{_datadir}/fpcsrc
%changelog
* Sun Apr 12 2009 Joost van der Sluis <joost@cnoc.nl> 2.2.4-1
- Updated to version 2.2.4
* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.2.2-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild

View File

@ -1 +1 @@
ec3d463ec9859da4122e9edfa2ab992d fpcbuild-2.2.2.tar.gz
20bb9a4a9f1449e2249c80d7aba7c245 fpcbuild-2.2.4.tar.gz