- 4.0.0.
This commit is contained in:
parent
322c31ee8d
commit
cad1f575ee
@ -70,3 +70,6 @@ foomatic-db-engine-3.0-20090110.tar.gz
|
|||||||
foomatic-db-3.0-20090110.tar.gz
|
foomatic-db-3.0-20090110.tar.gz
|
||||||
foomatic-db-hpijs-20090110.tar.gz
|
foomatic-db-hpijs-20090110.tar.gz
|
||||||
foomatic-filters-3.0-20090110.tar.gz
|
foomatic-filters-3.0-20090110.tar.gz
|
||||||
|
foomatic-db-4.0-20090115.tar.gz
|
||||||
|
foomatic-db-engine-4.0.0.tar.gz
|
||||||
|
foomatic-filters-4.0.0.tar.gz
|
||||||
|
@ -1,11 +0,0 @@
|
|||||||
diff -up foomatic-filters-3.0-20080710/foomatic-gswrapper.in.fontpath foomatic-filters-3.0-20080710/foomatic-gswrapper.in
|
|
||||||
--- foomatic-filters-3.0-20080710/foomatic-gswrapper.in.fontpath 2008-07-10 08:20:17.000000000 +0100
|
|
||||||
+++ foomatic-filters-3.0-20080710/foomatic-gswrapper.in 2008-09-02 13:14:12.000000000 +0100
|
|
||||||
@@ -24,6 +24,7 @@ my $execpath = "@EXECPATH@";
|
|
||||||
# Get execution path from config file
|
|
||||||
$execpath = $conf{execpath} if defined(%conf) and defined $conf{execpath};
|
|
||||||
$ENV{'PATH'} = $execpath;
|
|
||||||
+$ENV{'GS_FONTPATH'} = '/usr/share/fonts';
|
|
||||||
|
|
||||||
# Check whether we have a Ghostscript version with redirection of the
|
|
||||||
# standard output of the PostScript programs via '-sstdout=%stderr'
|
|
@ -1,29 +1,12 @@
|
|||||||
diff -up foomatic-filters-3.0-20080710/configure.ac.libdir foomatic-filters-3.0-20080710/configure.ac
|
diff -up foomatic-filters-4.0.0/configure.ac.libdir foomatic-filters-4.0.0/configure.ac
|
||||||
--- foomatic-filters-3.0-20080710/configure.ac.libdir 2008-07-10 08:20:16.000000000 +0100
|
--- foomatic-filters-4.0.0/configure.ac.libdir 2009-01-14 19:23:15.000000000 +0000
|
||||||
+++ foomatic-filters-3.0-20080710/configure.ac 2008-09-02 13:13:36.000000000 +0100
|
+++ foomatic-filters-4.0.0/configure.ac 2009-01-15 10:57:55.000000000 +0000
|
||||||
@@ -13,7 +13,7 @@ AC_PROG_LN_S
|
@@ -43,7 +43,7 @@ AC_CHECK_FUNCS([dup2 getcwd gethostname
|
||||||
AC_PROG_MAKE_SET
|
|
||||||
|
|
||||||
ETCSEARCHPATH=${prefix}/etc:/usr/etc:/usr/local/etc
|
ETCSEARCHPATH=${prefix}/etc:/usr/etc:/usr/local/etc
|
||||||
-LIBSEARCHPATH=${prefix}/lib:/usr/lib:/usr/local/lib:${prefix}/libexec:/usr/libexec:/usr/local/libexec
|
-LIBSEARCHPATH=${prefix}/lib:${prefix}/lib64:/usr/lib:/usr/lib64:/usr/local/lib:${prefix}/libexec:/usr/libexec:/usr/local/libexec
|
||||||
+LIBSEARCHPATH=$libdir:/usr/local/lib:${prefix}/libexec:/usr/libexec:/usr/local/libexec
|
+LIBSEARCHPATH=${libdir}:/usr/lib:/usr/lib64:/usr/local/lib:${prefix}/libexec:/usr/libexec:/usr/local/libexec
|
||||||
|
|
||||||
dnl Get the operating system and version number...
|
|
||||||
uname=`uname`
|
uname=`uname`
|
||||||
@@ -47,13 +47,13 @@ dnl Check for /usr/lib/cups/backend
|
uversion=`uname -r | sed -e '1,$s/[[^0-9]]//g'`
|
||||||
AC_PATH_DIR(CUPS_BACKENDS,cups/backend,/usr/lib/cups/backend,$LIBSEARCHPATH)
|
|
||||||
|
|
||||||
dnl Check for /usr/lib/ppr
|
|
||||||
-AC_PATH_DIR(PPR,ppr,/usr/lib/ppr,$LIBSEARCHPATH)
|
|
||||||
+AC_PATH_DIR(PPR,ppr,$libdir/ppr,$LIBSEARCHPATH)
|
|
||||||
|
|
||||||
dnl Check for /usr/lib/ppr/interfaces
|
|
||||||
-AC_PATH_DIR(PPR_INTERFACES,ppr/interfaces,/usr/lib/ppr/interfaces,$LIBSEARCHPATH)
|
|
||||||
+AC_PATH_DIR(PPR_INTERFACES,ppr/interfaces,$libdir/ppr/interfaces,$LIBSEARCHPATH)
|
|
||||||
|
|
||||||
dnl Check for /usr/lib/ppr/lib
|
|
||||||
-AC_PATH_DIR(PPR_LIB,ppr/lib,/usr/lib/ppr/lib,$LIBSEARCHPATH)
|
|
||||||
+AC_PATH_DIR(PPR_LIB,ppr/lib,$libdir/ppr/lib,$LIBSEARCHPATH)
|
|
||||||
|
|
||||||
AC_ARG_ENABLE(file-converter-check, [ --enable-file-converter-check check whether a file converter is installed [default=yes]],
|
|
||||||
[if eval "test x${enableval} = xno"; then
|
|
||||||
|
@ -1,54 +0,0 @@
|
|||||||
diff -up foomatic-filters-3.0-20080211/foomatic-rip.in.sigpipe foomatic-filters-3.0-20080211/foomatic-rip.in
|
|
||||||
--- foomatic-filters-3.0-20080211/foomatic-rip.in.sigpipe 2008-05-07 16:40:10.000000000 +0100
|
|
||||||
+++ foomatic-filters-3.0-20080211/foomatic-rip.in 2008-05-07 16:45:16.000000000 +0100
|
|
||||||
@@ -3599,6 +3599,7 @@ sub getrendererhandle {
|
|
||||||
|
|
||||||
close KID3;
|
|
||||||
|
|
||||||
+ $SIG{PIPE} = 'DEFAULT';
|
|
||||||
pipe KID4_IN, KID4;
|
|
||||||
KID4->autoflush(1);
|
|
||||||
$kid4 = fork();
|
|
||||||
@@ -3779,11 +3780,15 @@ sub getrendererhandle {
|
|
||||||
# When arrived here the renderer command line was successful
|
|
||||||
# So exit with zero exit value here and inform the main process
|
|
||||||
close KID_MESSAGE;
|
|
||||||
- print KID_MESSAGE_IN "3 $EXIT_PRINTED\n";
|
|
||||||
- close KID_MESSAGE_IN;
|
|
||||||
# Wait for postpipe/output child
|
|
||||||
waitpid($kid4, 0);
|
|
||||||
- print $logh "KID3 finished\n";
|
|
||||||
+ if ($? != 0) {
|
|
||||||
+ print KID_MESSAGE_IN "3 $EXIT_SIGNAL\n";
|
|
||||||
+ } else {
|
|
||||||
+ print KID_MESSAGE_IN "3 $EXIT_PRINTED\n";
|
|
||||||
+ }
|
|
||||||
+ close KID_MESSAGE_IN;
|
|
||||||
+ print $logh "KID3 finished with $?\n";
|
|
||||||
exit $EXIT_PRINTED;
|
|
||||||
} else {
|
|
||||||
$kidgeneration += 1;
|
|
||||||
@@ -4132,6 +4137,7 @@ sub getfileconverterhandle {
|
|
||||||
# converter
|
|
||||||
close KID1_IN;
|
|
||||||
|
|
||||||
+ $SIG{PIPE} = 'DEFAULT';
|
|
||||||
pipe KID2_IN, KID2;
|
|
||||||
KID2->autoflush(1);
|
|
||||||
$kid2 = fork();
|
|
||||||
@@ -4603,6 +4609,7 @@ sub getdocgeneratorhandle {
|
|
||||||
# we are the kid; we generate the documentation page
|
|
||||||
|
|
||||||
close KID0_IN;
|
|
||||||
+ $SIG{PIPE} = 'DEFAULT';
|
|
||||||
|
|
||||||
# Kill data on STDIN to satisfy PPR
|
|
||||||
if (($spooler eq 'ppr_int') || ($spooler eq 'ppr')) {
|
|
||||||
@@ -6661,6 +6668,7 @@ sub modern_system {
|
|
||||||
# will be members of this process group and so by killing this
|
|
||||||
# process group we can kill all subprocesses and so we can
|
|
||||||
# cleanly cancel print jobs
|
|
||||||
+ $SIG{PIPE} = 'DEFAULT';
|
|
||||||
eval("setpgrp()");
|
|
||||||
# Stop catching signals
|
|
||||||
#use sigtrap qw(die normal-signals error-signals
|
|
@ -1,12 +1,13 @@
|
|||||||
%define dbver 20090110
|
%define dbver_rel 4.0
|
||||||
%define enginever 3.0-20090110
|
%define dbver_snap 20090115
|
||||||
%define filtersver 20090110
|
%define enginever 4.0.0
|
||||||
|
%define filtersver 4.0.0
|
||||||
%define hpijsver 20090110
|
%define hpijsver 20090110
|
||||||
|
|
||||||
Summary: Database of printers and printer drivers
|
Summary: Database of printers and printer drivers
|
||||||
Name: foomatic
|
Name: foomatic
|
||||||
Version: 3.0.2
|
Version: %{enginever}
|
||||||
Release: 70%{?dist}
|
Release: 1%{?dist}
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
|
|
||||||
@ -16,22 +17,17 @@ Group: System Environment/Libraries
|
|||||||
# tar cjf foomatic-1.9-$NOW.tar.bz2 foomatic
|
# tar cjf foomatic-1.9-$NOW.tar.bz2 foomatic
|
||||||
Source0: http://www.openprinting.org/download/foomatic/foomatic-db-engine-%{enginever}.tar.gz
|
Source0: http://www.openprinting.org/download/foomatic/foomatic-db-engine-%{enginever}.tar.gz
|
||||||
|
|
||||||
Source1: http://www.linuxprinting.org/download/foomatic/foomatic-filters-3.0-%{filtersver}.tar.gz
|
Source1: http://www.linuxprinting.org/download/foomatic/foomatic-filters-%{filtersver}.tar.gz
|
||||||
Source2: http://www.linuxprinting.org/download/foomatic/foomatic-db-3.0-%{dbver}.tar.gz
|
Source2: http://www.linuxprinting.org/download/foomatic/foomatic-db-%{dbver_rel}-%{dbver_snap}.tar.gz
|
||||||
Source3: http://www.linuxprinting.org/download/foomatic/foomatic-db-hpijs-%{hpijsver}.tar.gz
|
Source3: http://www.linuxprinting.org/download/foomatic/foomatic-db-hpijs-%{hpijsver}.tar.gz
|
||||||
|
|
||||||
# Use libdir.
|
# Use libdir.
|
||||||
Patch1: foomatic-filters-libdir.patch
|
Patch1: foomatic-filters-libdir.patch
|
||||||
Patch2: foomatic-db-engine-libdir.patch
|
Patch2: foomatic-db-engine-libdir.patch
|
||||||
|
|
||||||
# Set GS_FONTPATH in gs wrapper (bug #81410).
|
|
||||||
Patch5: foomatic-2.0.2-fontpath.patch
|
|
||||||
|
|
||||||
# Handle non-UTF-8 encodings in imported PPD files.
|
# Handle non-UTF-8 encodings in imported PPD files.
|
||||||
Patch15: foomatic-bad-utf8.patch
|
Patch15: foomatic-bad-utf8.patch
|
||||||
|
|
||||||
Patch18: foomatic-sigpipe.patch
|
|
||||||
|
|
||||||
Url: http://www.linuxprinting.org
|
Url: http://www.linuxprinting.org
|
||||||
BuildRequires: perl >= 3:5.8.1
|
BuildRequires: perl >= 3:5.8.1
|
||||||
BuildRequires: perl(ExtUtils::MakeMaker)
|
BuildRequires: perl(ExtUtils::MakeMaker)
|
||||||
@ -72,24 +68,20 @@ The site http://www.linuxprinting.org/ is based on this database.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q -c -a 1 -a 2 -a 3
|
%setup -q -c -a 1 -a 2 -a 3
|
||||||
|
|
||||||
pushd foomatic-filters-3.0-%{filtersver}
|
pushd foomatic-filters-%{filtersver}
|
||||||
%patch1 -p1 -b .libdir
|
%patch1 -p1 -b .libdir
|
||||||
%patch5 -p1 -b .fontpath
|
|
||||||
%patch18 -p1 -b .sigpipe
|
|
||||||
./make_configure
|
|
||||||
popd
|
popd
|
||||||
|
|
||||||
pushd foomatic-db-engine-%{enginever}
|
pushd foomatic-db-engine-%{enginever}
|
||||||
chmod a+x mkinstalldirs
|
chmod a+x mkinstalldirs
|
||||||
%patch2 -p1 -b .libdir
|
%patch2 -p1 -b .libdir
|
||||||
%patch15 -p1
|
%patch15 -p1
|
||||||
./make_configure
|
|
||||||
popd
|
popd
|
||||||
|
|
||||||
pushd foomatic-db-hpijs-%{hpijsver}
|
pushd foomatic-db-hpijs-%{hpijsver}
|
||||||
popd
|
popd
|
||||||
|
|
||||||
pushd foomatic-db-%{dbver}
|
pushd foomatic-db-%{dbver_snap}
|
||||||
|
|
||||||
cd db/source
|
cd db/source
|
||||||
|
|
||||||
@ -121,7 +113,7 @@ export CUPS_BACKENDS=/usr/lib/cups/backend # /usr/lib NOT libdir
|
|||||||
export CUPS_FILTERS=/usr/lib/cups/filter # /usr/lib NOT libdir
|
export CUPS_FILTERS=/usr/lib/cups/filter # /usr/lib NOT libdir
|
||||||
export CUPS_PPDS=%{_datadir}/cups/model
|
export CUPS_PPDS=%{_datadir}/cups/model
|
||||||
|
|
||||||
pushd foomatic-filters-3.0-%{filtersver}
|
pushd foomatic-filters-%{filtersver}
|
||||||
%configure
|
%configure
|
||||||
make PREFIX=%{_prefix} CFLAGS="$RPM_OPT_FLAGS"
|
make PREFIX=%{_prefix} CFLAGS="$RPM_OPT_FLAGS"
|
||||||
popd
|
popd
|
||||||
@ -131,7 +123,7 @@ pushd foomatic-db-engine-%{enginever}
|
|||||||
make PREFIX=%{_prefix} CFLAGS="$RPM_OPT_FLAGS"
|
make PREFIX=%{_prefix} CFLAGS="$RPM_OPT_FLAGS"
|
||||||
popd
|
popd
|
||||||
|
|
||||||
pushd foomatic-db-%{dbver}
|
pushd foomatic-db-%{dbver_snap}
|
||||||
%configure
|
%configure
|
||||||
make PREFIX=%{_prefix} CFLAGS="$RPM_OPT_FLAGS"
|
make PREFIX=%{_prefix} CFLAGS="$RPM_OPT_FLAGS"
|
||||||
popd
|
popd
|
||||||
@ -144,7 +136,7 @@ popd
|
|||||||
%install
|
%install
|
||||||
rm -rf $RPM_BUILD_ROOT
|
rm -rf $RPM_BUILD_ROOT
|
||||||
|
|
||||||
pushd foomatic-filters-3.0-%{filtersver}
|
pushd foomatic-filters-%{filtersver}
|
||||||
eval `perl '-V:installvendorlib' '-V:installvendorarch'`
|
eval `perl '-V:installvendorlib' '-V:installvendorarch'`
|
||||||
mkdir -p $RPM_BUILD_ROOT/$installvendorlib
|
mkdir -p $RPM_BUILD_ROOT/$installvendorlib
|
||||||
export INSTALLSITELIB=$RPM_BUILD_ROOT/$installvendorlib
|
export INSTALLSITELIB=$RPM_BUILD_ROOT/$installvendorlib
|
||||||
@ -152,7 +144,7 @@ export INSTALLSITEARCH=$RPM_BUILD_ROOT/$installvendorarch
|
|||||||
make DESTDIR=%buildroot PREFIX=%{_prefix} \
|
make DESTDIR=%buildroot PREFIX=%{_prefix} \
|
||||||
INSTALLSITELIB=$RPM_BUILD_ROOT/$installvendorlib \
|
INSTALLSITELIB=$RPM_BUILD_ROOT/$installvendorlib \
|
||||||
INSTALLSITEARCH=$RPM_BUILD_ROOT/$installvendorarch \
|
INSTALLSITEARCH=$RPM_BUILD_ROOT/$installvendorarch \
|
||||||
install
|
install-main install-cups
|
||||||
popd
|
popd
|
||||||
|
|
||||||
pushd foomatic-db-engine-%{enginever}
|
pushd foomatic-db-engine-%{enginever}
|
||||||
@ -162,7 +154,7 @@ make DESTDIR=%buildroot PREFIX=%{_prefix} \
|
|||||||
install
|
install
|
||||||
popd
|
popd
|
||||||
|
|
||||||
pushd foomatic-db-%{dbver}
|
pushd foomatic-db-%{dbver_snap}
|
||||||
make DESTDIR=%buildroot PREFIX=%{_prefix} \
|
make DESTDIR=%buildroot PREFIX=%{_prefix} \
|
||||||
INSTALLSITELIB=$RPM_BUILD_ROOT/$installvendorlib \
|
INSTALLSITELIB=$RPM_BUILD_ROOT/$installvendorlib \
|
||||||
INSTALLSITEARCH=$RPM_BUILD_ROOT/$installvendorarch \
|
INSTALLSITEARCH=$RPM_BUILD_ROOT/$installvendorarch \
|
||||||
@ -232,6 +224,9 @@ rm -fr %buildroot $RPM_BUILD_DIR/%{name}
|
|||||||
%{_var}/cache/foomatic
|
%{_var}/cache/foomatic
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Jan 15 2009 Tim Waugh <twaugh@redhat.com> 4.0.0-1
|
||||||
|
- 4.0.0.
|
||||||
|
|
||||||
* Mon Jan 12 2009 Tim Waugh <twaugh@redhat.com> 3.0.2-70
|
* Mon Jan 12 2009 Tim Waugh <twaugh@redhat.com> 3.0.2-70
|
||||||
- Major gutenprint version is 5.2.
|
- Major gutenprint version is 5.2.
|
||||||
|
|
||||||
|
6
sources
6
sources
@ -1,4 +1,4 @@
|
|||||||
cfd3335798141fa5892693b39c71f71c foomatic-db-engine-3.0-20090110.tar.gz
|
|
||||||
8948e38765cb108221cfb3d1c9af0dd0 foomatic-db-3.0-20090110.tar.gz
|
|
||||||
aa6b0fd89f33fcef91a3a7081b44fc36 foomatic-db-hpijs-20090110.tar.gz
|
aa6b0fd89f33fcef91a3a7081b44fc36 foomatic-db-hpijs-20090110.tar.gz
|
||||||
0d8702e00187a54d5cfd4cdfbab682e1 foomatic-filters-3.0-20090110.tar.gz
|
a349bc055d92a47bfbd8b7812beba690 foomatic-db-4.0-20090115.tar.gz
|
||||||
|
7e2281ef8b96557afd0cd87400176805 foomatic-db-engine-4.0.0.tar.gz
|
||||||
|
1c77a8c86a8fb19012cd79f735564ea2 foomatic-filters-4.0.0.tar.gz
|
||||||
|
Loading…
Reference in New Issue
Block a user