fmt/doc-build-use-python3.patch
Kefu Chai 591078f81f update to 5.2.1
- split fmt_build_doc_system.patch into smaller patches, to simplify
  the patch management
- drop fmt_test8_segfault.patch, as it does not apply anymore
- add patches to avoid accessing to internet via installed document
- use python3 packages to adapt fedora python3 migration
- drop fmt-static package, as it's non-trivial to build static and
  shared libraries in a single run. and it's not encouraged to ship
  static library, see
https://fedoraproject.org/wiki/Packaging:Guidelines#Packaging_Static_Libraries_2
- package ChangeLog.rst README.rst in fmt package, to help use
  to understand the latest changes, and to silence rpmlint warnings
- pass cmake options in multiple lines, to have less code churn of
  future changes.
- drop DCMAKE_SKIP_RPATH=OFF, as RHEL6 is not supported anymore
- use %make_build and %make_install macros, see
  https://fedoraproject.org/wiki/Packaging:Cmake
- bump up packaged fmt to v5.2.1

Signed-off-by: Kefu Chai <tchaikov@gmail.com>
2018-10-13 11:21:59 +08:00

33 lines
990 B
Diff

From 21955af0e5a30f0cabbdf128cb27acc1ea6c28c4 Mon Sep 17 00:00:00 2001
From: Kefu Chai <tchaikov@gmail.com>
Date: Fri, 12 Oct 2018 18:10:07 +0800
Subject: doc: build use python3
use python3 as an alternative of python (python2)
---
doc/CMakeLists.txt | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)
diff --git a/doc/CMakeLists.txt b/doc/CMakeLists.txt
index 66b4bd1..87ad9ec 100644
--- a/doc/CMakeLists.txt
+++ b/doc/CMakeLists.txt
@@ -4,11 +4,13 @@ if (NOT DOXYGEN)
return ()
endif ()
+find_package(PythonInterp
+ QUIET REQUIRED)
find_program(SPHINX_EXECUTABLE
NAMES sphinx-build sphinx-build-3)
add_custom_target(doc
COMMAND ${CMAKE_COMMAND} -E env SPHINX_EXECUTABLE=${SPHINX_EXECUTABLE}
- ${CMAKE_CURRENT_SOURCE_DIR}/build.py ${FMT_VERSION}
+ ${PYTHON_EXECUTABLE} ${CMAKE_CURRENT_SOURCE_DIR}/build.py ${FMT_VERSION}
SOURCES api.rst syntax.rst build.py conf.py _templates/layout.html)
install(DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}/html/
--
2.19.1