Updated to version 6.1.2.

This commit is contained in:
Vitaly Zaitsev 2019-12-18 14:04:58 +01:00
parent cdff9e94cb
commit c039beac00
No known key found for this signature in database
GPG Key ID: BF99FC6DD45AB90A
10 changed files with 63 additions and 91 deletions

1
.gitignore vendored
View File

@ -4,3 +4,4 @@
/fmt-3.0.2.tar.gz
/5.2.1.tar.gz
/5.3.0.tar.gz
/6.1.2.tar.gz

View File

@ -1,13 +1,5 @@
From: "Eugene V. Lyubimkin" <jackyf@iki.fi>
Date: Sat, 7 Nov 2015 19:49:54 +0100
Subject: doc: _templates: layout: stripped Google Analytics
---
doc/_templates/layout.html | 10 ----------
1 file changed, 10 deletions(-)
diff --git a/doc/_templates/layout.html b/doc/_templates/layout.html
index 0ac2dec..8f5dfd9 100644
index d5f4b70d..8ff160de 100644
--- a/doc/_templates/layout.html
+++ b/doc/_templates/layout.html
@@ -5,16 +5,6 @@
@ -27,3 +19,6 @@ index 0ac2dec..8f5dfd9 100644
{% endblock %}
{%- macro searchform(classes, button) %}
--
2.24.1

View File

@ -1,20 +1,8 @@
From: "Eugene V. Lyubimkin" <jackyf@iki.fi>
Date: Sat, 7 Nov 2015 19:53:09 +0100
Subject: doc: _templates: layout: stripped download links
---
doc/_templates/layout.html | 29 +----------------------------
1 file changed, 1 insertion(+), 28 deletions(-)
diff --git a/doc/_templates/layout.html b/doc/_templates/layout.html
index 8f5dfd9..7bc00fc 100644
index 8ff160de..85eba08d 100644
--- a/doc/_templates/layout.html
+++ b/doc/_templates/layout.html
@@ -38,20 +38,9 @@
</button>
<a class="navbar-brand" href="index.html">{fmt}</a>
</div>
-
@@ -42,16 +42,6 @@
{# Collect the nav links, forms, and other content for toggling #}
<div class="collapse navbar-collapse">
<ul class="nav navbar-nav">
@ -24,18 +12,18 @@ index 8f5dfd9..7bc00fc 100644
- <span class="caret"></span></a>
- <ul class="dropdown-menu" role="menu">
- {% for v in versions.split(',') %}
- <li><a href="http://fmtlib.net/{{v}}">{{v}}</a></li>
- <li><a href="https://fmt.dev/{{v}}">{{v}}</a></li>
- {% endfor %}
- </ul>
- </li>
{% for name in ['Contents', 'Usage', 'API', 'Syntax'] %}
{% if pagename == name.lower() %}
<li class="active"><a href="{{name.lower()}}.html">{{name}}
@@ -74,23 +63,7 @@
@@ -74,23 +64,7 @@
<div class="jumbotron">
<div class="tb-container">
<h1>{fmt}</h1>
- <p class="lead">Small, safe and fast formatting library</p>
- <p class="lead">A modern formatting library</p>
- <div class="btn-group" role="group">
- {% set name = 'fmt' if version.split('.')[0]|int >= 3 else 'cppformat' %}
- <a class="btn btn-success"
@ -56,3 +44,6 @@ index 8f5dfd9..7bc00fc 100644
</div>
</div>
{% endif %}
--
2.24.1

View File

@ -1,9 +1,10 @@
diff -up fmt-5.3.0/doc/build.py.orig fmt-5.3.0/doc/build.py
--- fmt-5.3.0/doc/build.py.orig 2019-06-10 14:38:07.646072524 +0200
+++ fmt-5.3.0/doc/build.py 2019-06-10 14:38:23.793201765 +0200
@@ -7,16 +7,6 @@ from subprocess import check_call, check
diff --git a/doc/build.py b/doc/build.py
index f46d483e..517d9f39 100755
--- a/doc/build.py
+++ b/doc/build.py
@@ -7,16 +7,6 @@ from subprocess import check_call, check_output, CalledProcessError, Popen, PIPE
versions = ['1.0.0', '1.1.0', '2.0.0', '3.0.2', '4.0.0', '4.1.0', '5.0.0', '5.1.0', '5.2.0', '5.2.1', '5.3.0']
versions = ['1.0.0', '1.1.0', '2.0.0', '3.0.2', '4.0.0', '4.1.0', '5.0.0', '5.1.0', '5.2.0', '5.2.1', '5.3.0', '6.0.0', '6.1.0', '6.1.1', '6.1.2']
-def create_build_env(dirname='virtualenv'):
- # Create virtualenv.
@ -18,9 +19,12 @@ diff -up fmt-5.3.0/doc/build.py.orig fmt-5.3.0/doc/build.py
def build_docs(version='dev', **kwargs):
doc_dir = kwargs.get('doc_dir', os.path.dirname(os.path.realpath(__file__)))
work_dir = kwargs.get('work_dir', '.')
@@ -79,5 +69,4 @@ def build_docs(version='dev', **kwargs):
@@ -78,5 +68,4 @@ def build_docs(version='dev', **kwargs):
return html_dir
if __name__ == '__main__':
- create_build_env()
build_docs(sys.argv[1])
--
2.24.1

View File

@ -1,13 +1,14 @@
diff -up fmt-5.3.0/doc/build.py.orig fmt-5.3.0/doc/build.py
--- fmt-5.3.0/doc/build.py.orig 2019-06-10 14:34:44.351430493 +0200
+++ fmt-5.3.0/doc/build.py 2019-06-10 14:36:25.608248599 +0200
diff --git a/doc/build.py b/doc/build.py
index 31049716..f46d483e 100755
--- a/doc/build.py
+++ b/doc/build.py
@@ -4,27 +4,9 @@
from __future__ import print_function
import errno, os, shutil, sys, tempfile
from subprocess import check_call, check_output, CalledProcessError, Popen, PIPE
-from distutils.version import LooseVersion
versions = ['1.0.0', '1.1.0', '2.0.0', '3.0.2', '4.0.0', '4.1.0', '5.0.0', '5.1.0', '5.2.0', '5.2.1', '5.3.0']
versions = ['1.0.0', '1.1.0', '2.0.0', '3.0.2', '4.0.0', '4.1.0', '5.0.0', '5.1.0', '5.2.0', '5.2.1', '5.3.0', '6.0.0', '6.1.0', '6.1.1', '6.1.2']
-def pip_install(package, commit=None, **kwargs):
- "Install package using pip."
@ -29,7 +30,7 @@ diff -up fmt-5.3.0/doc/build.py.orig fmt-5.3.0/doc/build.py
def create_build_env(dirname='virtualenv'):
# Create virtualenv.
if not os.path.exists(dirname):
@@ -34,30 +16,6 @@ def create_build_env(dirname='virtualenv
@@ -34,30 +16,6 @@ def create_build_env(dirname='virtualenv'):
activate_this_file = os.path.join(dirname, scripts_dir, 'activate_this.py')
with open(activate_this_file) as f:
exec(f.read(), dict(__file__=activate_this_file))
@ -60,3 +61,6 @@ diff -up fmt-5.3.0/doc/build.py.orig fmt-5.3.0/doc/build.py
def build_docs(version='dev', **kwargs):
doc_dir = kwargs.get('doc_dir', os.path.dirname(os.path.realpath(__file__)))
--
2.24.1

View File

@ -1,15 +1,5 @@
From 21955af0e5a30f0cabbdf128cb27acc1ea6c28c4 Mon Sep 17 00:00:00 2001
From: Kefu Chai <tchaikov@gmail.com>
Date: Fri, 12 Oct 2018 18:10:07 +0800
Subject: doc: build use python3
use python3 as an alternative of python (python2)
---
doc/CMakeLists.txt | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)
diff --git a/doc/CMakeLists.txt b/doc/CMakeLists.txt
index 66b4bd1..87ad9ec 100644
index 2af32d53..0ad2d602 100644
--- a/doc/CMakeLists.txt
+++ b/doc/CMakeLists.txt
@@ -4,11 +4,13 @@ if (NOT DOXYGEN)
@ -24,9 +14,9 @@ index 66b4bd1..87ad9ec 100644
COMMAND ${CMAKE_COMMAND} -E env SPHINX_EXECUTABLE=${SPHINX_EXECUTABLE}
- ${CMAKE_CURRENT_SOURCE_DIR}/build.py ${FMT_VERSION}
+ ${PYTHON_EXECUTABLE} ${CMAKE_CURRENT_SOURCE_DIR}/build.py ${FMT_VERSION}
SOURCES api.rst syntax.rst build.py conf.py _templates/layout.html)
SOURCES api.rst syntax.rst usage.rst build.py conf.py _templates/layout.html)
install(DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}/html/
--
2.19.1
2.24.1

View File

@ -1,16 +1,5 @@
From f8091ad4f1fc8140dd133fa12e20435583658dbe Mon Sep 17 00:00:00 2001
From: Kefu Chai <tchaikov@gmail.com>
Date: Fri, 12 Oct 2018 14:04:04 +0800
Subject: doc: build: use sphinx-build-3
use sphinx-build-3 as an alternative of sphinx-build.
---
doc/CMakeLists.txt | 5 ++++-
doc/build.py | 3 ++-
2 files changed, 6 insertions(+), 2 deletions(-)
diff --git a/doc/CMakeLists.txt b/doc/CMakeLists.txt
index c16427a..66b4bd1 100644
index f3dae606..2af32d53 100644
--- a/doc/CMakeLists.txt
+++ b/doc/CMakeLists.txt
@@ -4,8 +4,11 @@ if (NOT DOXYGEN)
@ -23,14 +12,14 @@ index c16427a..66b4bd1 100644
- COMMAND ${CMAKE_CURRENT_SOURCE_DIR}/build.py ${FMT_VERSION}
+ COMMAND ${CMAKE_COMMAND} -E env SPHINX_EXECUTABLE=${SPHINX_EXECUTABLE}
+ ${CMAKE_CURRENT_SOURCE_DIR}/build.py ${FMT_VERSION}
SOURCES api.rst syntax.rst build.py conf.py _templates/layout.html)
SOURCES api.rst syntax.rst usage.rst build.py conf.py _templates/layout.html)
install(DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}/html/
diff --git a/doc/build.py b/doc/build.py
index f745ee0..19093d3 100755
index 517d9f39..2c80ed5a 100755
--- a/doc/build.py
+++ b/doc/build.py
@@ -47,7 +47,8 @@ def build_docs(version='dev', **kwargs):
@@ -49,7 +49,8 @@ def build_docs(version='dev', **kwargs):
raise CalledProcessError(p.returncode, cmd)
html_dir = os.path.join(work_dir, 'html')
main_versions = reversed(versions[-3:])
@ -41,5 +30,5 @@ index f745ee0..19093d3 100755
'-Dversion=' + version, '-Drelease=' + version,
'-Aversion=' + version, '-Aversions=' + ','.join(main_versions),
--
2.19.1
2.24.1

View File

@ -1,19 +1,12 @@
From: "Eugene V. Lyubimkin" <jackyf@iki.fi>
Date: Sun, 15 Oct 2017 22:28:11 +0200
Subject: doc: index: removed GitHub iframe
---
doc/index.rst | 8 --------
1 file changed, 8 deletions(-)
diff --git a/doc/index.rst b/doc/index.rst
index ce9b7bf..1363779 100644
index cbc9154d..b1782c3d 100644
--- a/doc/index.rst
+++ b/doc/index.rst
@@ -196,11 +196,3 @@ a single header file and a single source file and no external dependencies.
A permissive BSD `license <https://github.com/fmtlib/fmt#license>`_ allows
@@ -191,12 +191,3 @@ Ease of Use
just three header files and no external dependencies.
A permissive MIT `license <https://github.com/fmtlib/fmt#license>`_ allows
using the library both in open-source and commercial projects.
-
-.. raw:: html
-
- <a class="btn btn-success" href="https://github.com/fmtlib/fmt">GitHub Repository</a>
@ -22,3 +15,6 @@ index ce9b7bf..1363779 100644
- <iframe src="http://ghbtns.com/github-btn.html?user=fmtlib&amp;repo=fmt&amp;type=watch&amp;count=true"
- class="github-btn" width="100" height="20"></iframe>
- </div>
--
2.24.1

View File

@ -1,6 +1,6 @@
Name: fmt
Version: 5.3.0
Release: 2%{?dist}
Version: 6.1.2
Release: 1%{?dist}
Summary: Small, safe and fast formatting library for C++
License: BSD
@ -66,9 +66,9 @@ This package contains documentation for developer documentation for %{name}.
%prep
%autosetup -p1
mkdir build
%build
mkdir build
pushd build
%if 0%{?rhel} && 0%{?rhel} <= 7
%cmake3 .. \
@ -89,30 +89,32 @@ rm -rf ../build/doc/html/{.buildinfo,.doctrees,objects.inv}
%install
%make_install -C build
%ldconfig_scriptlets
%check
pushd build
ctest -VV %{?_smp_mflags}
popd
%files
%{_libdir}/libfmt.so.5*
%{!?_licensedir:%global license %%doc}
%license LICENSE.rst
%doc ChangeLog.rst README.rst
%{_libdir}/lib%{name}.so.6*
%files devel
%{_includedir}/fmt/
%{_libdir}/libfmt.so
%{_datadir}/cmake/fmt/
%{_datadir}/pkgconfig/fmt.pc
%{_includedir}/%{name}
%{_libdir}/lib%{name}.so
%{_datadir}/cmake/%{name}
%{_libdir}/pkgconfig/%{name}.pc
%files doc
%doc %{_datadir}/doc/fmt/
%doc %{_datadir}/doc/%{name}
%license doc/python-license.txt
%changelog
* Wed Dec 18 2019 Vitaly Zaitsev <vitaly@easycoding.org> - 6.1.2-1
- Updated to version 6.1.2.
- Recreated all documentation patches.
- SPEC file cleanup.
* Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 5.3.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild

View File

@ -1 +1 @@
SHA512 (5.3.0.tar.gz) = 9ef0f3d328681253c1e1776576d54d67dec49c19fd7fc422ae63c3610b01a3f05f6e83cdf5e913dfd09bac42e52fe35c38ebe1ea91f4207d226a32aaf69eb4a8
SHA512 (6.1.2.tar.gz) = 8770bf4bd2bb6d938e75e0cf1e665c41930dbd9d2a6825274a5a43cd1d85b9c9ca621bb040ed099429f0e16bddbc3399361c453eb1bf3fc01376e6ad9dd875b7