Arm build fix
This commit is contained in:
parent
c1906be036
commit
fbaa2451d8
13
firefox.spec
13
firefox.spec
@ -107,7 +107,7 @@
|
||||
Summary: Mozilla Firefox Web browser
|
||||
Name: firefox
|
||||
Version: 36.0.1
|
||||
Release: 1%{?pre_tag}%{?dist}
|
||||
Release: 2%{?pre_tag}%{?dist}
|
||||
URL: http://www.mozilla.org/projects/firefox/
|
||||
License: MPLv1.1 or GPLv2+ or LGPLv2+
|
||||
Group: Applications/Internet
|
||||
@ -127,7 +127,6 @@ Source24: mozilla-api-key
|
||||
Patch0: firefox-install-dir.patch
|
||||
Patch1: firefox-build.patch
|
||||
Patch3: mozilla-build-arm.patch
|
||||
Patch4: mozilla-build-arm-webrtc.patch
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=814879#c3
|
||||
Patch18: xulrunner-24.0-jemalloc-ppc.patch
|
||||
# workaround linking issue on s390 (JSContext::updateMallocCounter(size_t) not found)
|
||||
@ -281,10 +280,9 @@ cd %{tarballdir}
|
||||
%patch0 -p1
|
||||
%patch1 -p2 -b .build
|
||||
|
||||
#%ifarch %{arm}
|
||||
%patch3 -p2 -b .arm-build
|
||||
%patch4 -p2 -b .arm
|
||||
#%endif
|
||||
%ifarch %{arm}
|
||||
%patch3 -p2 -b .arm
|
||||
%endif
|
||||
|
||||
%patch18 -p2 -b .jemalloc-ppc
|
||||
%patch19 -p2 -b .s390-inlines
|
||||
@ -769,6 +767,9 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
||||
#---------------------------------------------------------------------
|
||||
|
||||
%changelog
|
||||
* Tue Mar 10 2015 Martin Stransky <stransky@redhat.com> - 36.0.1-2
|
||||
- Arm build fix
|
||||
|
||||
* Mon Mar 9 2015 Jan Horak <jhorak@redhat.com> - 36.0.1-1
|
||||
- Update to 36.0.1
|
||||
|
||||
|
@ -10,3 +10,56 @@ diff -up firefox-29.0/mozilla-release/gfx/ycbcr/moz.build.arm firefox-29.0/mozil
|
||||
SOURCES += [
|
||||
'yuv_row_arm.s',
|
||||
]
|
||||
diff -up firefox-36.0.1/mozilla-release/gfx/skia/generate_mozbuild.py.arm firefox-36.0.1/mozilla-release/gfx/skia/generate_mozbuild.py
|
||||
--- firefox-36.0.1/mozilla-release/gfx/skia/generate_mozbuild.py.arm 2015-03-09 10:02:17.000000000 +0100
|
||||
+++ firefox-36.0.1/mozilla-release/gfx/skia/generate_mozbuild.py 2015-03-10 09:16:18.532740641 +0100
|
||||
@@ -27,7 +27,7 @@ footer = """
|
||||
# can we find a better way of dealing with asm sources?
|
||||
|
||||
# left out of UNIFIED_SOURCES for now; that's not C++ anyway, nothing else to unify it with
|
||||
-if not CONFIG['INTEL_ARCHITECTURE'] and CONFIG['CPU_ARCH'] == 'arm' and CONFIG['GNU_CC']:
|
||||
+if not CONFIG['INTEL_ARCHITECTURE'] and CONFIG['GNU_CC']:
|
||||
SOURCES += [
|
||||
'trunk/src/opts/memset.arm.S',
|
||||
]
|
||||
@@ -123,7 +123,7 @@ if CONFIG['INTEL_ARCHITECTURE'] and CONF
|
||||
SOURCES['trunk/src/opts/SkMorphology_opts_SSE2.cpp'].flags += CONFIG['SSE2_FLAGS']
|
||||
SOURCES['trunk/src/opts/SkUtils_opts_SSE2.cpp'].flags += CONFIG['SSE2_FLAGS']
|
||||
SOURCES['trunk/src/opts/SkXfermode_opts_SSE2.cpp'].flags += CONFIG['SSE2_FLAGS']
|
||||
-elif CONFIG['CPU_ARCH'] == 'arm' and CONFIG['GNU_CC'] and CONFIG['BUILD_ARM_NEON']:
|
||||
+elif CONFIG['GNU_CC'] and CONFIG['BUILD_ARM_NEON']:
|
||||
DEFINES['__ARM_HAVE_OPTIONAL_NEON_SUPPORT'] = 1
|
||||
DEFINES['USE_ANDROID_NDK_CPU_FEATURES'] = 0
|
||||
elif CONFIG['CLANG_CL']:
|
||||
@@ -440,7 +440,7 @@ def write_mozbuild(includes, sources):
|
||||
f.write("if CONFIG['INTEL_ARCHITECTURE']:\n")
|
||||
write_sources(f, sources['intel'], 4)
|
||||
|
||||
- f.write("elif CONFIG['CPU_ARCH'] == 'arm' and CONFIG['GNU_CC']:\n")
|
||||
+ f.write("elif CONFIG['GNU_CC']:\n")
|
||||
write_sources(f, sources['arm'], 4)
|
||||
|
||||
f.write(" if CONFIG['BUILD_ARM_NEON']:\n")
|
||||
diff -up firefox-36.0.1/mozilla-release/media/webrtc/trunk/webrtc/build/common.gypi.arm firefox-36.0.1/mozilla-release/media/webrtc/trunk/webrtc/build/common.gypi
|
||||
--- firefox-36.0.1/mozilla-release/media/webrtc/trunk/webrtc/build/common.gypi.arm 2015-03-05 11:28:19.000000000 +0100
|
||||
+++ firefox-36.0.1/mozilla-release/media/webrtc/trunk/webrtc/build/common.gypi 2015-03-09 10:02:17.875243261 +0100
|
||||
@@ -235,19 +235,6 @@
|
||||
'defines': [
|
||||
'WEBRTC_ARCH_ARM',
|
||||
],
|
||||
- 'conditions': [
|
||||
- ['arm_version==7', {
|
||||
- 'defines': ['WEBRTC_ARCH_ARM_V7',
|
||||
- 'WEBRTC_BUILD_NEON_LIBS'],
|
||||
- 'conditions': [
|
||||
- ['arm_neon==1', {
|
||||
- 'defines': ['WEBRTC_ARCH_ARM_NEON',],
|
||||
- }, {
|
||||
- 'defines': ['WEBRTC_DETECT_ARM_NEON',],
|
||||
- }],
|
||||
- ],
|
||||
- }],
|
||||
- ],
|
||||
}],
|
||||
['os_bsd==1', {
|
||||
'defines': [
|
||||
|
Loading…
Reference in New Issue
Block a user