Updated to 110.0
This commit is contained in:
parent
ee371f01de
commit
c5357ea592
2
.gitignore
vendored
2
.gitignore
vendored
@ -557,3 +557,5 @@ firefox-3.6.4.source.tar.bz2
|
||||
/firefox-langpacks-109.0-20230111.tar.xz
|
||||
/firefox-109.0.1.source.tar.xz
|
||||
/firefox-langpacks-109.0.1-20230201.tar.xz
|
||||
/firefox-110.0.source.tar.xz
|
||||
/firefox-langpacks-110.0-20230210.tar.xz
|
||||
|
75
D166324.diff
75
D166324.diff
@ -1,75 +0,0 @@
|
||||
diff --git a/dom/media/platforms/ffmpeg/FFmpegVideoDecoder.h b/dom/media/platforms/ffmpeg/FFmpegVideoDecoder.h
|
||||
--- a/dom/media/platforms/ffmpeg/FFmpegVideoDecoder.h
|
||||
+++ b/dom/media/platforms/ffmpeg/FFmpegVideoDecoder.h
|
||||
@@ -175,11 +175,10 @@
|
||||
|
||||
PtsCorrectionContext mPtsContext;
|
||||
|
||||
DurationMap mDurationMap;
|
||||
const bool mLowLatency;
|
||||
- AVDiscard mFrameDrop = AVDISCARD_DEFAULT;
|
||||
const Maybe<TrackingId> mTrackingId;
|
||||
PerformanceRecorderMulti<DecodeStage> mPerformanceRecorder;
|
||||
|
||||
// True if we're allocating shmem for ffmpeg decode buffer.
|
||||
Maybe<Atomic<bool>> mIsUsingShmemBufferForDecode;
|
||||
diff --git a/dom/media/platforms/ffmpeg/FFmpegVideoDecoder.cpp b/dom/media/platforms/ffmpeg/FFmpegVideoDecoder.cpp
|
||||
--- a/dom/media/platforms/ffmpeg/FFmpegVideoDecoder.cpp
|
||||
+++ b/dom/media/platforms/ffmpeg/FFmpegVideoDecoder.cpp
|
||||
@@ -850,17 +850,10 @@
|
||||
packet.dts = aSample->mTimecode.ToMicroseconds();
|
||||
packet.pts = aSample->mTime.ToMicroseconds();
|
||||
packet.flags = aSample->mKeyframe ? AV_PKT_FLAG_KEY : 0;
|
||||
packet.pos = aSample->mOffset;
|
||||
|
||||
- mCodecContext->skip_frame = mFrameDrop;
|
||||
-#if MOZ_LOGGING
|
||||
- if (mFrameDrop == AVDISCARD_NONREF) {
|
||||
- FFMPEG_LOG("Frame skip AVDISCARD_NONREF");
|
||||
- }
|
||||
-#endif
|
||||
-
|
||||
mTrackingId.apply([&](const auto& aId) {
|
||||
MediaInfoFlag flag = MediaInfoFlag::None;
|
||||
flag |= (aSample->mKeyframe ? MediaInfoFlag::KeyFrame
|
||||
: MediaInfoFlag::NonKeyFrame);
|
||||
flag |= (IsHardwareAccelerated() ? MediaInfoFlag::HardwareDecoding
|
||||
@@ -943,22 +936,10 @@
|
||||
return MediaResult(
|
||||
NS_ERROR_DOM_MEDIA_DECODE_ERR,
|
||||
RESULT_DETAIL("avcodec_receive_frame error: %s", errStr));
|
||||
}
|
||||
|
||||
- if (mFrameDrop == AVDISCARD_NONREF) {
|
||||
- FFMPEG_LOG("Requested pts %" PRId64 " decoded frame pts %" PRId64,
|
||||
- packet.pts, GetFramePts(mFrame) + mFrame->pkt_duration);
|
||||
- // Switch back to default frame skip policy if we hit correct
|
||||
- // decode times. 5 ms treshold is taken from mpv project which
|
||||
- // use similar approach after seek (feed_packet() at f_decoder_wrapper.c).
|
||||
- if (packet.pts - 5000 <= GetFramePts(mFrame) + mFrame->pkt_duration) {
|
||||
- FFMPEG_LOG("Set frame drop to AVDISCARD_DEFAULT.");
|
||||
- mFrameDrop = AVDISCARD_DEFAULT;
|
||||
- }
|
||||
- }
|
||||
-
|
||||
UpdateDecodeTimes(decodeStart);
|
||||
decodeStart = TimeStamp::Now();
|
||||
|
||||
MediaResult rv;
|
||||
# ifdef MOZ_WAYLAND_USE_VAAPI
|
||||
@@ -1366,14 +1347,10 @@
|
||||
FFMPEG_LOG("ProcessFlush()");
|
||||
MOZ_ASSERT(mTaskQueue->IsOnCurrentThread());
|
||||
mPtsContext.Reset();
|
||||
mDurationMap.Clear();
|
||||
mPerformanceRecorder.Record(std::numeric_limits<int64_t>::max());
|
||||
- // Discard non-ref frames on HW accelerated backend to avoid decode artifacts.
|
||||
- if (IsHardwareAccelerated()) {
|
||||
- mFrameDrop = AVDISCARD_NONREF;
|
||||
- }
|
||||
return FFmpegDataDecoder::ProcessFlush();
|
||||
}
|
||||
|
||||
AVCodecID FFmpegVideoDecoder<LIBAV_VER>::GetCodecId(
|
||||
const nsACString& aMimeType) {
|
||||
|
19
D167194.diff
Normal file
19
D167194.diff
Normal file
@ -0,0 +1,19 @@
|
||||
diff --git a/js/src/irregexp/moz.build b/js/src/irregexp/moz.build
|
||||
--- a/js/src/irregexp/moz.build
|
||||
+++ b/js/src/irregexp/moz.build
|
||||
@@ -12,10 +12,14 @@
|
||||
include("../js-config.mozbuild")
|
||||
include("../js-cxxflags.mozbuild")
|
||||
|
||||
CXXFLAGS += ["-Wno-error=type-limits", "-Wno-error=return-type"]
|
||||
|
||||
+# Suppress spurious warnings in third-party code. See bug 1810584.
|
||||
+if CONFIG["CC_TYPE"] == "gcc":
|
||||
+ CXXFLAGS += ["-Wno-error=nonnull"]
|
||||
+
|
||||
UNIFIED_SOURCES += [
|
||||
"imported/regexp-bytecode-generator.cc",
|
||||
"imported/regexp-bytecode-peephole.cc",
|
||||
"imported/regexp-bytecodes.cc",
|
||||
"imported/regexp-compiler-tonode.cc",
|
||||
|
13
firefox.spec
13
firefox.spec
@ -172,13 +172,13 @@ ExcludeArch: i686
|
||||
|
||||
Summary: Mozilla Firefox Web browser
|
||||
Name: firefox
|
||||
Version: 109.0.1
|
||||
Release: 2%{?pre_tag}%{?dist}
|
||||
Version: 110.0
|
||||
Release: 1%{?pre_tag}%{?dist}
|
||||
URL: https://www.mozilla.org/firefox/
|
||||
License: MPLv1.1 or GPLv2+ or LGPLv2+
|
||||
Source0: https://archive.mozilla.org/pub/firefox/releases/%{version}%{?pre_version}/source/firefox-%{version}%{?pre_version}.source.tar.xz
|
||||
%if %{with langpacks}
|
||||
Source1: firefox-langpacks-%{version}%{?pre_version}-20230201.tar.xz
|
||||
Source1: firefox-langpacks-%{version}%{?pre_version}-20230210.tar.xz
|
||||
%endif
|
||||
Source2: cbindgen-vendor.tar.xz
|
||||
Source10: firefox-mozconfig
|
||||
@ -226,6 +226,7 @@ Patch61: firefox-glibc-dynstack.patch
|
||||
Patch71: 0001-GLIBCXX-fix-for-GCC-12.patch
|
||||
Patch78: firefox-i686-build.patch
|
||||
Patch79: firefox-gcc-13-build.patch
|
||||
Patch80: D167194.diff
|
||||
|
||||
# Test patches
|
||||
# Generate without context by
|
||||
@ -250,7 +251,6 @@ Patch402: mozilla-1196777.patch
|
||||
Patch407: mozilla-1667096.patch
|
||||
Patch408: mozilla-1663844.patch
|
||||
Patch415: mozilla-1670333.patch
|
||||
Patch417: D166324.diff
|
||||
Patch418: mozilla-1813500.patch
|
||||
|
||||
# PGO/LTO patches
|
||||
@ -505,6 +505,7 @@ This package contains results of tests executed during build.
|
||||
%patch71 -p1 -b .0001-GLIBCXX-fix-for-GCC-12
|
||||
%patch78 -p1 -b .firefox-i686
|
||||
%patch79 -p1 -b .firefox-gcc-13-build
|
||||
%patch80 -p1 -b .D167194
|
||||
|
||||
# Test patches
|
||||
#%patch100 -p1 -b .firefox-tests-xpcshell
|
||||
@ -527,7 +528,6 @@ This package contains results of tests executed during build.
|
||||
%patch407 -p1 -b .1667096
|
||||
%patch408 -p1 -b .1663844
|
||||
%patch415 -p1 -b .1670333
|
||||
%patch417 -p1 -b .D166324
|
||||
%patch418 -p1 -b .1813500
|
||||
|
||||
# PGO patches
|
||||
@ -1082,6 +1082,9 @@ fi
|
||||
#---------------------------------------------------------------------
|
||||
|
||||
%changelog
|
||||
* Thu Feb 9 2023 Martin Stransky <stransky@redhat.com>- 110.0-1
|
||||
- Updated to 110.0
|
||||
|
||||
* Tue Feb 7 2023 Martin Stransky <stransky@redhat.com>- 109.0.1-2
|
||||
- Rawhide build fix
|
||||
|
||||
|
4
sources
4
sources
@ -1,4 +1,4 @@
|
||||
SHA512 (cbindgen-vendor.tar.xz) = 0d45c1decfd7aaee853748745c9f5a907c0c6a0cf809c2387aac1cdcf680b0844b1ef4d05148e0527de4ff6e4d4666110bea317bd00b7d73a1210eb58a815563
|
||||
SHA512 (mochitest-python.tar.gz) = e0a2c569dafe013b6a4c073516388549a8f398d8aa4538a3bc69dcda44737a3a3cf070285e9fa040a15d7a62446665c6158d42a1b6dc3e8d7f4680bc2ef17a16
|
||||
SHA512 (firefox-109.0.1.source.tar.xz) = 58b21449a16a794152888f50e7fe9488c28739a7e067729acdc1de9f2e8384e6316cffdfe89f690f0d211189668d940825b4f8a26b8100468ae120772df99d72
|
||||
SHA512 (firefox-langpacks-109.0.1-20230201.tar.xz) = d8497c53466650d06db44382b6e8a1ac337205c820f67b9a635a7ecc7001eaa4b9391de3f7e88e2f3602510150c54e128723915366438c296f7e15e729f87fb2
|
||||
SHA512 (firefox-110.0.source.tar.xz) = a5f0642b7efe36f4be7cf70fb4f29785569ced39076359730a86670e4703bb4c7a6ec1358aa6b4b75f91b5770e1c05d586e4fb7200be72ce3a592ffd17b32945
|
||||
SHA512 (firefox-langpacks-110.0-20230210.tar.xz) = 081b96ebfa64ef020b577b3a469e63292b0c62c1da97a7d7c1a4f9689a7a1841a8e53e64f22d690f1193ba9b8e14c0b59bf9575f042e9c5e0fdc88776d8cedaa
|
||||
|
Loading…
Reference in New Issue
Block a user