Updated to 104.0
This commit is contained in:
parent
b65f309bcd
commit
babecc662f
2
.gitignore
vendored
2
.gitignore
vendored
@ -523,3 +523,5 @@ firefox-3.6.4.source.tar.bz2
|
||||
/firefox-langpacks-103.0.1-20220802.tar.xz
|
||||
/firefox-103.0.2.source.tar.xz
|
||||
/firefox-langpacks-103.0.2-20220812.tar.xz
|
||||
/firefox-104.0.source.tar.xz
|
||||
/firefox-langpacks-104.0-20220816.tar.xz
|
||||
|
@ -1,18 +0,0 @@
|
||||
diff -up firefox-102.0/widget/gtk/DMABufLibWrapper.cpp.vaapi firefox-102.0/widget/gtk/DMABufLibWrapper.cpp
|
||||
--- firefox-102.0/widget/gtk/DMABufLibWrapper.cpp.vaapi 2022-07-01 09:49:50.215536872 +0200
|
||||
+++ firefox-102.0/widget/gtk/DMABufLibWrapper.cpp 2022-07-01 09:50:43.036306610 +0200
|
||||
@@ -283,10 +283,11 @@ bool nsDMABufDevice::IsDMABufTexturesEna
|
||||
bool nsDMABufDevice::IsDMABufVAAPIEnabled() {
|
||||
LOGDMABUF(
|
||||
("nsDMABufDevice::IsDMABufVAAPIEnabled: EGL %d "
|
||||
- "media_ffmpeg_vaapi_enabled %d CanUseHardwareVideoDecoding %d "
|
||||
+ "CanUseHardwareVideoDecoding %d "
|
||||
"XRE_IsRDDProcess %d\n",
|
||||
- gfx::gfxVars::UseEGL(), StaticPrefs::media_ffmpeg_vaapi_enabled(),
|
||||
- gfx::gfxVars::CanUseHardwareVideoDecoding(), XRE_IsRDDProcess()));
|
||||
+ gfx::gfxVars::UseEGL(),
|
||||
+ gfx::gfxVars::CanUseHardwareVideoDecoding(),
|
||||
+ XRE_IsRDDProcess()));
|
||||
return gfx::gfxVars::UseVAAPI() && XRE_IsRDDProcess() &&
|
||||
gfx::gfxVars::CanUseHardwareVideoDecoding();
|
||||
}
|
@ -1,18 +1,20 @@
|
||||
diff -up firefox-103.0/gfx/thebes/gfxPlatformGtk.cpp.enable-vaapi firefox-103.0/gfx/thebes/gfxPlatformGtk.cpp
|
||||
--- firefox-103.0/gfx/thebes/gfxPlatformGtk.cpp.enable-vaapi 2022-07-18 20:44:04.000000000 +0200
|
||||
+++ firefox-103.0/gfx/thebes/gfxPlatformGtk.cpp 2022-08-04 11:41:18.109583874 +0200
|
||||
@@ -232,13 +232,8 @@ void gfxPlatformGtk::InitDmabufConfig()
|
||||
void gfxPlatformGtk::InitVAAPIConfig() {
|
||||
FeatureState& feature = gfxConfig::GetFeature(Feature::VAAPI);
|
||||
#ifdef MOZ_WAYLAND
|
||||
-# ifdef NIGHTLY_BUILD
|
||||
feature.EnableByDefault();
|
||||
-# else
|
||||
- feature.DisableByDefault(FeatureStatus::Disabled,
|
||||
- "VAAPI is disabled by default",
|
||||
- "FEATURE_VAAPI_DISABLED"_ns);
|
||||
-# endif
|
||||
+
|
||||
nsCString failureId;
|
||||
int32_t status;
|
||||
nsCOMPtr<nsIGfxInfo> gfxInfo = components::GfxInfo::Service();
|
||||
diff -up firefox-104.0/gfx/thebes/gfxPlatformGtk.cpp.firefox-enable-vaapi firefox-104.0/gfx/thebes/gfxPlatformGtk.cpp
|
||||
diff -up firefox-104.0/widget/gtk/GfxInfo.cpp.firefox-enable-vaapi firefox-104.0/widget/gtk/GfxInfo.cpp
|
||||
--- firefox-104.0/widget/gtk/GfxInfo.cpp.firefox-enable-vaapi 2022-08-16 15:14:53.014042400 +0200
|
||||
+++ firefox-104.0/widget/gtk/GfxInfo.cpp 2022-08-16 15:15:30.482301677 +0200
|
||||
@@ -873,15 +873,6 @@ const nsTArray<GfxDriverInfo>& GfxInfo::
|
||||
nsIGfxInfo::FEATURE_BLOCKED_DEVICE, DRIVER_COMPARISON_IGNORED,
|
||||
V(0, 0, 0, 0), "FEATURE_HARDWARE_VIDEO_DECODING_NO_LINUX_AMD", "");
|
||||
|
||||
- // Disable on Release/late Beta
|
||||
-#if !defined(EARLY_BETA_OR_EARLIER)
|
||||
- APPEND_TO_DRIVER_BLOCKLIST(OperatingSystem::Linux, DeviceFamily::All,
|
||||
- nsIGfxInfo::FEATURE_HARDWARE_VIDEO_DECODING,
|
||||
- nsIGfxInfo::FEATURE_BLOCKED_DEVICE,
|
||||
- DRIVER_COMPARISON_IGNORED, V(0, 0, 0, 0),
|
||||
- "FEATURE_HARDWARE_VIDEO_DECODING_DISABLE", "");
|
||||
-#endif
|
||||
-
|
||||
////////////////////////////////////
|
||||
// FEATURE_WEBRENDER_PARTIAL_PRESENT
|
||||
APPEND_TO_DRIVER_BLOCKLIST_EXT(
|
||||
|
10
firefox.spec
10
firefox.spec
@ -180,13 +180,13 @@ ExcludeArch: aarch64
|
||||
|
||||
Summary: Mozilla Firefox Web browser
|
||||
Name: firefox
|
||||
Version: 103.0.2
|
||||
Version: 104.0
|
||||
Release: 1%{?pre_tag}%{?dist}
|
||||
URL: https://www.mozilla.org/firefox/
|
||||
License: MPLv1.1 or GPLv2+ or LGPLv2+
|
||||
Source0: https://archive.mozilla.org/pub/firefox/releases/%{version}%{?pre_version}/source/firefox-%{version}%{?pre_version}.source.tar.xz
|
||||
%if %{with langpacks}
|
||||
Source1: firefox-langpacks-%{version}%{?pre_version}-20220812.tar.xz
|
||||
Source1: firefox-langpacks-%{version}%{?pre_version}-20220816.tar.xz
|
||||
%endif
|
||||
Source2: cbindgen-vendor.tar.xz
|
||||
Source10: firefox-mozconfig
|
||||
@ -260,7 +260,6 @@ Patch402: mozilla-1196777.patch
|
||||
Patch407: mozilla-1667096.patch
|
||||
Patch408: mozilla-1663844.patch
|
||||
Patch415: mozilla-1670333.patch
|
||||
Patch448: firefox-102.0-pref-print.patch
|
||||
|
||||
# PGO/LTO patches
|
||||
Patch600: pgo.patch
|
||||
@ -524,8 +523,6 @@ This package contains results of tests executed during build.
|
||||
%patch408 -p1 -b .1663844
|
||||
%patch415 -p1 -b .1670333
|
||||
|
||||
%patch448 -p1 -b .pref-print
|
||||
|
||||
# PGO patches
|
||||
%if %{build_with_pgo}
|
||||
%if !%{build_with_clang}
|
||||
@ -1122,6 +1119,9 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
||||
#---------------------------------------------------------------------
|
||||
|
||||
%changelog
|
||||
* Tue Aug 16 2022 Martin Stransky <stransky@redhat.com>- 104.0-1
|
||||
- Updated to 104.0
|
||||
|
||||
* Fri Aug 12 2022 Martin Stransky <stransky@redhat.com>- 103.0.2-1
|
||||
- Updated to 103.0.2
|
||||
|
||||
|
4
sources
4
sources
@ -1,4 +1,4 @@
|
||||
SHA512 (mochitest-python.tar.gz) = 18e1aeb475df5fbf1fe3838897d5ac2f3114aa349030713fc2be27af087b1b12f57642621b87bd052f324a7cb7fbae5f36b21502191d85692f62c8cdd69c8bf2
|
||||
SHA512 (cbindgen-vendor.tar.xz) = 0d45c1decfd7aaee853748745c9f5a907c0c6a0cf809c2387aac1cdcf680b0844b1ef4d05148e0527de4ff6e4d4666110bea317bd00b7d73a1210eb58a815563
|
||||
SHA512 (firefox-103.0.2.source.tar.xz) = f13984bb551039c80ef731931f08a284f070142ecb479b31a4caad026a6b535e3fc7ae506b629e933ba5f5a1676f14b6b36d031d22584170492676f8727c822a
|
||||
SHA512 (firefox-langpacks-103.0.2-20220812.tar.xz) = f81f80cffabd6fe8809ec1bce705ebf89208f5a2b92ca1636dc8c82f452bed4f5386e33e441639ede8ba5bd165fa9855e91a560bd3e62c8f5e7f7502be4f3383
|
||||
SHA512 (firefox-104.0.source.tar.xz) = 818759eeda6cd103998bbfec80e917a3598aebec1c055699bcf6eac612816e899e360f6f7b0b4a1eabebaed312208d6765b84242a310cfc35587e6fb19a74c59
|
||||
SHA512 (firefox-langpacks-104.0-20220816.tar.xz) = 63ae80626ae4ad641460639f60cfa378ea3293a24e897d7e7a7e2b3dddf57de93be7328361f750de693c0601a438fff09624a0eae6ec19ddca9e0a08200455be
|
||||
|
Loading…
Reference in New Issue
Block a user