Added libproxy support (rhbz#2177806), Added build fixes on arm
This commit is contained in:
parent
701cde858b
commit
b35d0d6682
22
D172126.diff
Normal file
22
D172126.diff
Normal file
@ -0,0 +1,22 @@
|
||||
diff --git a/dom/media/webaudio/AudioNodeEngineGeneric.h b/dom/media/webaudio/AudioNodeEngineGeneric.h
|
||||
--- a/dom/media/webaudio/AudioNodeEngineGeneric.h
|
||||
+++ b/dom/media/webaudio/AudioNodeEngineGeneric.h
|
||||
@@ -203,14 +203,14 @@
|
||||
MOZ_ASSERT((aSize % xsimd::batch<float, Arch>::size == 0),
|
||||
"requires tail processing");
|
||||
|
||||
MOZ_UNROLL(2)
|
||||
for (unsigned i = 0; i < aSize * 2;
|
||||
- i += 2 * xsimd::batch<std::complex<float>>::size) {
|
||||
- auto in1 = xsimd::batch<std::complex<float>>::load_aligned(
|
||||
+ i += 2 * xsimd::batch<std::complex<float>, Arch>::size) {
|
||||
+ auto in1 = xsimd::batch<std::complex<float>, Arch>::load_aligned(
|
||||
reinterpret_cast<const std::complex<float>*>(&aInput[i]));
|
||||
- auto in2 = xsimd::batch<std::complex<float>>::load_aligned(
|
||||
+ auto in2 = xsimd::batch<std::complex<float>, Arch>::load_aligned(
|
||||
reinterpret_cast<const std::complex<float>*>(&aScale[i]));
|
||||
auto out = in1 * in2;
|
||||
out.store_aligned(reinterpret_cast<std::complex<float>*>(&aOutput[i]));
|
||||
}
|
||||
};
|
||||
|
@ -16,6 +16,7 @@ ac_add_options --enable-js-shell
|
||||
ac_add_options --with-unsigned-addon-scopes=app,system
|
||||
ac_add_options --without-sysroot
|
||||
ac_add_options --without-wasm-sandboxed-libraries
|
||||
ac_add_options --enable-libproxy
|
||||
|
||||
export BUILD_OFFICIAL=1
|
||||
export MOZILLA_OFFICIAL=1
|
||||
|
12
firefox.spec
12
firefox.spec
@ -6,9 +6,6 @@
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=2129720
|
||||
ExcludeArch: i686
|
||||
|
||||
# Excluded due to build failure on F36
|
||||
ExcludeArch: armv7hl
|
||||
|
||||
# Run Mozilla test suite as a part of compile rpm section. Turn off when
|
||||
# building locally and don't want to spend 24 hours waiting for results.
|
||||
%global run_firefox_tests 0
|
||||
@ -176,7 +173,7 @@ ExcludeArch: armv7hl
|
||||
Summary: Mozilla Firefox Web browser
|
||||
Name: firefox
|
||||
Version: 111.0
|
||||
Release: 1%{?pre_tag}%{?dist}
|
||||
Release: 2%{?pre_tag}%{?dist}
|
||||
URL: https://www.mozilla.org/firefox/
|
||||
License: MPLv1.1 or GPLv2+ or LGPLv2+
|
||||
Source0: https://archive.mozilla.org/pub/firefox/releases/%{version}%{?pre_version}/source/firefox-%{version}%{?pre_version}.source.tar.xz
|
||||
@ -229,6 +226,7 @@ Patch61: firefox-glibc-dynstack.patch
|
||||
Patch71: 0001-GLIBCXX-fix-for-GCC-12.patch
|
||||
Patch78: firefox-i686-build.patch
|
||||
Patch79: firefox-gcc-13-build.patch
|
||||
Patch80: D172126.diff
|
||||
|
||||
# Test patches
|
||||
# Generate without context by
|
||||
@ -416,6 +414,7 @@ BuildRequires: xorg-x11-fonts-misc
|
||||
BuildRequires: make
|
||||
BuildRequires: pciutils-libs
|
||||
BuildRequires: mesa-libgbm-devel
|
||||
BuildRequires: libproxy-devel
|
||||
|
||||
Obsoletes: mozilla <= 37:1.7.13
|
||||
Provides: webclient
|
||||
@ -503,6 +502,7 @@ This package contains results of tests executed during build.
|
||||
%patch71 -p1 -b .0001-GLIBCXX-fix-for-GCC-12
|
||||
%patch78 -p1 -b .firefox-i686
|
||||
%patch79 -p1 -b .firefox-gcc-13-build
|
||||
%patch80 -p1 -b .D172126
|
||||
|
||||
# Test patches
|
||||
#%patch100 -p1 -b .firefox-tests-xpcshell
|
||||
@ -1073,6 +1073,10 @@ fi
|
||||
#---------------------------------------------------------------------
|
||||
|
||||
%changelog
|
||||
* Tue Mar 21 2023 Martin Stransky <stransky@redhat.com>- 111.0-2
|
||||
- Added libproxy support (rhbz#2177806)
|
||||
- Added build fixes on arm
|
||||
|
||||
* Mon Mar 20 2023 Martin Stransky <stransky@redhat.com>- 111.0-1
|
||||
- Updated to 111.0
|
||||
- Disabled arm on F36
|
||||
|
Loading…
Reference in New Issue
Block a user