Update to 112.0.2
This commit is contained in:
parent
33aaf8942f
commit
ad7ecb97b8
2
.gitignore
vendored
2
.gitignore
vendored
@ -569,3 +569,5 @@ firefox-3.6.4.source.tar.bz2
|
||||
/firefox-langpacks-112.0-20230406.tar.xz
|
||||
/firefox-langpacks-112.0.1-20230417.tar.xz
|
||||
/firefox-112.0.1.source.tar.xz
|
||||
/firefox-langpacks-112.0.2-20230427.tar.xz
|
||||
/firefox-112.0.2.source.tar.xz
|
||||
|
11
firefox.spec
11
firefox.spec
@ -175,13 +175,13 @@ ExcludeArch: i686
|
||||
|
||||
Summary: Mozilla Firefox Web browser
|
||||
Name: firefox
|
||||
Version: 112.0.1
|
||||
Version: 112.0.2
|
||||
Release: 1%{?pre_tag}%{?dist}
|
||||
URL: https://www.mozilla.org/firefox/
|
||||
License: MPLv1.1 or GPLv2+ or LGPLv2+
|
||||
Source0: https://archive.mozilla.org/pub/firefox/releases/%{version}%{?pre_version}/source/firefox-%{version}%{?pre_version}.source.tar.xz
|
||||
%if %{with langpacks}
|
||||
Source1: firefox-langpacks-%{version}%{?pre_version}-20230417.tar.xz
|
||||
Source1: firefox-langpacks-%{version}%{?pre_version}-20230427.tar.xz
|
||||
%endif
|
||||
Source2: cbindgen-vendor.tar.xz
|
||||
Source10: firefox-mozconfig
|
||||
@ -257,8 +257,6 @@ Patch408: mozilla-1663844.patch
|
||||
Patch415: mozilla-1670333.patch
|
||||
# https://phabricator.services.mozilla.com/D173021
|
||||
Patch416: libwebrtc-pipewire-capturer-import-dmabuf-directly-into-desktop-frame.patch
|
||||
Patch417: mozilla-1826583.patch
|
||||
Patch418: mozilla-1827429.patch
|
||||
|
||||
# PGO/LTO patches
|
||||
Patch600: pgo.patch
|
||||
@ -544,8 +542,6 @@ This package contains results of tests executed during build.
|
||||
%patch408 -p1 -b .1663844
|
||||
%patch415 -p1 -b .1670333
|
||||
%patch416 -p1 -b .libwebrtc-pipewire-capturer-import-dmabuf-directly-into-desktop-frame
|
||||
%patch417 -p1 -b .1826583
|
||||
%patch418 -p1 -b .1827429
|
||||
|
||||
# PGO patches
|
||||
%if %{build_with_pgo}
|
||||
@ -1099,6 +1095,9 @@ fi
|
||||
#---------------------------------------------------------------------
|
||||
|
||||
%changelog
|
||||
* Thu Apr 27 2023 Martin Stransky <stransky@redhat.com>- 112.0.2-1
|
||||
- Updated to 112.0.2
|
||||
|
||||
* Tue Apr 18 2023 Martin Stransky <stransky@redhat.com>- 112.0.1-1
|
||||
- Updated to 112.0.1
|
||||
- Added fix for rhbz#2187000
|
||||
|
@ -1,14 +0,0 @@
|
||||
diff -up firefox-112.0/widget/gtk/nsWaylandDisplay.cpp.old firefox-112.0/widget/gtk/nsWaylandDisplay.cpp
|
||||
--- firefox-112.0/widget/gtk/nsWaylandDisplay.cpp.old 2023-04-06 19:35:44.744731593 +0200
|
||||
+++ firefox-112.0/widget/gtk/nsWaylandDisplay.cpp 2023-04-06 19:35:23.650016723 +0200
|
||||
@@ -271,8 +271,8 @@ bool nsWaylandDisplay::Matches(wl_displa
|
||||
return mThreadId == PR_GetCurrentThread() && aDisplay == mDisplay;
|
||||
}
|
||||
|
||||
-static void WlCrashHandler(const char* format, va_list args) {
|
||||
- MOZ_CRASH_UNSAFE(g_strdup_vprintf(format, args));
|
||||
+static void WlCrashHandler(const char* format, va_list args) {
|
||||
+ vfprintf(stderr, format, args);
|
||||
}
|
||||
|
||||
nsWaylandDisplay::nsWaylandDisplay(wl_display* aDisplay)
|
@ -1,33 +0,0 @@
|
||||
changeset: 659713:2cf85addfa7a
|
||||
tag: tip
|
||||
parent: 659711:25045b498bff
|
||||
user: stransky <stransky@redhat.com>
|
||||
date: Tue Apr 11 16:34:42 2023 +0200
|
||||
files: widget/gtk/nsWindow.cpp
|
||||
description:
|
||||
Bug 1827429 [Wayland] Call NotifyOcclusionState(OcclusionState::VISIBLE) from nsWindow::OnExposeEvent() as we know the window is visible r?emilio
|
||||
|
||||
Differential Revision: https://phabricator.services.mozilla.com/D175138
|
||||
|
||||
|
||||
diff --git a/widget/gtk/nsWindow.cpp b/widget/gtk/nsWindow.cpp
|
||||
--- a/widget/gtk/nsWindow.cpp
|
||||
+++ b/widget/gtk/nsWindow.cpp
|
||||
@@ -3730,9 +3730,14 @@ void nsWindow::CreateCompositorVsyncDisp
|
||||
|
||||
gboolean nsWindow::OnExposeEvent(cairo_t* cr) {
|
||||
// Send any pending resize events so that layout can update.
|
||||
- // May run event loop.
|
||||
+ // May run event loop and destroy us.
|
||||
MaybeDispatchResized();
|
||||
-
|
||||
+ if (mIsDestroyed) {
|
||||
+ return FALSE;
|
||||
+ }
|
||||
+
|
||||
+ // This might destroy us.
|
||||
+ NotifyOcclusionState(OcclusionState::VISIBLE);
|
||||
if (mIsDestroyed) {
|
||||
return FALSE;
|
||||
}
|
||||
|
4
sources
4
sources
@ -1,4 +1,4 @@
|
||||
SHA512 (cbindgen-vendor.tar.xz) = 0d45c1decfd7aaee853748745c9f5a907c0c6a0cf809c2387aac1cdcf680b0844b1ef4d05148e0527de4ff6e4d4666110bea317bd00b7d73a1210eb58a815563
|
||||
SHA512 (mochitest-python.tar.gz) = e0a2c569dafe013b6a4c073516388549a8f398d8aa4538a3bc69dcda44737a3a3cf070285e9fa040a15d7a62446665c6158d42a1b6dc3e8d7f4680bc2ef17a16
|
||||
SHA512 (firefox-langpacks-112.0.1-20230417.tar.xz) = 9cee5362c549170568f37e74bab90c18c2540298947d9dd1423839cd11e2f5c0f484665c03fa90924b1c304bfc78b8e5d40a8ed6e08d3c6533d514aa50b8a897
|
||||
SHA512 (firefox-112.0.1.source.tar.xz) = 23a5cd9c1f165275d8ca7465bebce86018441c72292421f4ed56d7ad8ada9402dc8d22a08467d9d0ef3ef8c62338006dfa3bcbddf12cb8a59eafa0bd7d0cda50
|
||||
SHA512 (firefox-langpacks-112.0.2-20230427.tar.xz) = 20a1bd9c9de131fd544d379a2867294cd6d9812bf7d66e8e2237c40eb86e1a44a1c5bc194f9f38e1249ded947d00ae9d0c695ea2813a46997ec64ced7b07e89e
|
||||
SHA512 (firefox-112.0.2.source.tar.xz) = 2cd7adeb6c9a39ad4c5366982e0e58382d7f205e6f2cee02b8ec2867034d1c0c884eeeb870a35db35cba60fa9c84aea73f8c77cfd9f36b5146dde06464aaabd1
|
||||
|
Loading…
Reference in New Issue
Block a user