Updated to 50.1.0
This commit is contained in:
parent
5f619866d5
commit
a1fc3a52e1
2
.gitignore
vendored
2
.gitignore
vendored
@ -216,3 +216,5 @@ firefox-3.6.4.source.tar.bz2
|
||||
/firefox-langpacks-50.0.1-20161128.tar.xz
|
||||
/firefox-50.0.2.source.tar.xz
|
||||
/firefox-langpacks-50.0.2-20161130.tar.xz
|
||||
/firefox-50.1.0.source.tar.xz
|
||||
/firefox-langpacks-50.1.0-20161213.tar.xz
|
||||
|
15
firefox.spec
15
firefox.spec
@ -93,14 +93,14 @@
|
||||
|
||||
Summary: Mozilla Firefox Web browser
|
||||
Name: firefox
|
||||
Version: 50.0.2
|
||||
Release: 2%{?pre_tag}%{?dist}
|
||||
Version: 50.1.0
|
||||
Release: 1%{?pre_tag}%{?dist}
|
||||
URL: https://www.mozilla.org/firefox/
|
||||
License: MPLv1.1 or GPLv2+ or LGPLv2+
|
||||
Group: Applications/Internet
|
||||
Source0: https://archive.mozilla.org/pub/firefox/releases/%{version}%{?pre_version}/source/firefox-%{version}%{?pre_version}.source.tar.xz
|
||||
%if %{build_langpacks}
|
||||
Source1: firefox-langpacks-%{version}%{?pre_version}-20161130.tar.xz
|
||||
Source1: firefox-langpacks-%{version}%{?pre_version}-20161213.tar.xz
|
||||
%endif
|
||||
Source10: firefox-mozconfig
|
||||
Source12: firefox-redhat-default-prefs.js
|
||||
@ -128,7 +128,6 @@ Patch204: rhbz-966424.patch
|
||||
Patch215: firefox-enable-addons.patch
|
||||
Patch219: rhbz-1173156.patch
|
||||
Patch221: firefox-fedora-ua.patch
|
||||
Patch223: rhbz-1291190-appchooser-crash.patch
|
||||
Patch224: mozilla-1170092.patch
|
||||
Patch225: mozilla-1005640-accept-lang.patch
|
||||
|
||||
@ -139,7 +138,6 @@ Patch406: mozilla-256180.patch
|
||||
# Rebase Gtk3 widget code to latest trunk to
|
||||
# fix various rendering problems
|
||||
Patch407: widget-rebase.patch
|
||||
Patch408: mozilla-1271100.patch
|
||||
|
||||
# Debian patches
|
||||
Patch500: mozilla-440908.patch
|
||||
@ -274,9 +272,6 @@ cd %{tarballdir}
|
||||
%patch215 -p1 -b .addons
|
||||
%patch219 -p2 -b .rhbz-1173156
|
||||
%patch221 -p2 -b .fedora-ua
|
||||
%if 0%{?fedora} > 22
|
||||
%patch223 -p1 -b .appchooser-crash
|
||||
%endif
|
||||
%patch224 -p1 -b .1170092
|
||||
%patch225 -p1 -b .1005640-accept-lang
|
||||
%patch304 -p1 -b .1253216
|
||||
@ -285,7 +280,6 @@ cd %{tarballdir}
|
||||
# Rebase Gtk3 widget code to latest trunk to
|
||||
# fix various rendering problems
|
||||
%patch407 -p1 -b .widget-rebase
|
||||
%patch408 -p1 -b .1271100
|
||||
|
||||
# Debian extension patch
|
||||
%patch500 -p1 -b .440908
|
||||
@ -794,6 +788,9 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
||||
#---------------------------------------------------------------------
|
||||
|
||||
%changelog
|
||||
* Tue Dec 13 2016 Martin Stransky <stransky@redhat.com> - 50.1.0-1
|
||||
- Updated to 50.1.0
|
||||
|
||||
* Wed Nov 30 2016 Martin Stransky <stransky@redhat.com> - 50.0.2-2
|
||||
- Added fix for "ABORT: X_ShmAttach: BadAccess" crashes
|
||||
(mozbz#1271100)
|
||||
|
@ -1,37 +0,0 @@
|
||||
# HG changeset patch
|
||||
# User Lee Salzman <lsalzman@mozilla.com>
|
||||
# Date 1480470918 18000
|
||||
# Tue Nov 29 20:55:18 2016 -0500
|
||||
# Node ID ffc92a98adee4c3ebb1f3b8c593e913a74ef6a4a
|
||||
# Parent 8d8846f63b74eb930e48b410730ae088e9bdbee8
|
||||
work around race in system Cairo's XShm usage
|
||||
|
||||
MozReview-Commit-ID: VGee6ungCz
|
||||
|
||||
diff --git a/widget/gtk/mozgtk/mozgtk.c b/widget/gtk/mozgtk/mozgtk.c
|
||||
--- a/widget/gtk/mozgtk/mozgtk.c
|
||||
+++ b/widget/gtk/mozgtk/mozgtk.c
|
||||
@@ -606,8 +606,23 @@ STUB(gdk_window_set_back_pixmap)
|
||||
STUB(gdk_x11_colormap_foreign_new)
|
||||
STUB(gdk_x11_colormap_get_xcolormap)
|
||||
STUB(gdk_x11_drawable_get_xdisplay)
|
||||
STUB(gdk_x11_drawable_get_xid)
|
||||
STUB(gdk_x11_window_get_drawable_impl)
|
||||
STUB(gdkx_visual_get)
|
||||
STUB(gtk_object_get_type)
|
||||
#endif
|
||||
+
|
||||
+#include <X11/Xlib.h>
|
||||
+// Bug 1271100
|
||||
+// We need to trick system Cairo into not using the XShm extension due to
|
||||
+// a race condition in it that results in frequent BadAccess errors. Cairo
|
||||
+// relies upon XShmQueryExtension to initially detect if XShm is available.
|
||||
+// So we define our own stub that always indicates XShm not being present.
|
||||
+// mozgtk loads before libXext/libcairo and so this stub will take priority.
|
||||
+// Our tree usage goes through xcb and remains unaffected by this.
|
||||
+MOZ_EXPORT Bool
|
||||
+XShmQueryExtension(Display* aDisplay)
|
||||
+{
|
||||
+ return False;
|
||||
+}
|
||||
+
|
@ -1,14 +0,0 @@
|
||||
diff -up firefox-46.0.1/widget/gtk/nsApplicationChooser.cpp.appchooser-crash firefox-46.0.1/widget/gtk/nsApplicationChooser.cpp
|
||||
--- firefox-46.0.1/widget/gtk/nsApplicationChooser.cpp.appchooser-crash 2016-05-03 07:31:12.000000000 +0200
|
||||
+++ firefox-46.0.1/widget/gtk/nsApplicationChooser.cpp 2016-05-12 12:17:44.043729262 +0200
|
||||
@@ -112,7 +112,9 @@ void nsApplicationChooser::Done(GtkWidge
|
||||
|
||||
// A "response" signal won't be sent again but "destroy" will be.
|
||||
g_signal_handlers_disconnect_by_func(chooser, FuncToGpointer(OnDestroy), this);
|
||||
- gtk_widget_destroy(chooser);
|
||||
+ // GTK >= 3.18 has a problem with destroying dialog at this stage for some reason.
|
||||
+ // We're going to hide the dialog in this case as a workaround.
|
||||
+ gtk_widget_hide(chooser);
|
||||
|
||||
if (mCallback) {
|
||||
mCallback->Done(localHandler);
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
11b4f60e31007caf2a34aeed11b74b2d firefox-50.0.2.source.tar.xz
|
||||
f2b664e327927b9de8a6da9b2e3ba8df firefox-langpacks-50.0.2-20161130.tar.xz
|
||||
SHA512 (firefox-50.1.0.source.tar.xz) = 370d2e9b8c4b1b59c3394659c3a7f0f79e6a911ccd9f32095b50b3a22d087132b1f7cb87b734f7497c4381b1df6df80d120b4b87c13eecc425cc66f56acccba5
|
||||
SHA512 (firefox-langpacks-50.1.0-20161213.tar.xz) = 0d3b70079255bacaef11c38604ea6cd049b74e4db321c0b0bf9f75f8579c97dc2d8dc0d3655143a71a21b6875e2e3f2c70a74cb14abc7fb4d58e7e7587cc36dc
|
||||
|
Loading…
Reference in New Issue
Block a user