Added a workaround for rhbz#2063961
This commit is contained in:
parent
a3c8768d1f
commit
97fc0b9c63
@ -1,44 +0,0 @@
|
||||
From efd5bc0715e5477318be95a76811cda0a89e8289 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Emilio=20Cobos=20=C3=81lvarez?= <emilio@crisal.io>
|
||||
Date: Fri, 4 Mar 2022 12:00:26 +0100
|
||||
Subject: [PATCH] GLIBCXX fix for GCC 12?
|
||||
|
||||
---
|
||||
build/unix/stdc++compat/stdc++compat.cpp | 14 ++++++++++++++
|
||||
1 file changed, 14 insertions(+)
|
||||
|
||||
diff --git a/build/unix/stdc++compat/stdc++compat.cpp b/build/unix/stdc++compat/stdc++compat.cpp
|
||||
index 0180f6bcfa998..8d7a542ff11f0 100644
|
||||
--- a/build/unix/stdc++compat/stdc++compat.cpp
|
||||
+++ b/build/unix/stdc++compat/stdc++compat.cpp
|
||||
@@ -24,6 +24,7 @@
|
||||
GLIBCXX_3.4.27 is from gcc 10
|
||||
GLIBCXX_3.4.28 is from gcc 10
|
||||
GLIBCXX_3.4.29 is from gcc 11
|
||||
+ GLIBCXX_3.4.30 is from gcc 12
|
||||
|
||||
This file adds the necessary compatibility tricks to avoid symbols with
|
||||
version GLIBCXX_3.4.20 and bigger, keeping binary compatibility with
|
||||
@@ -69,6 +70,19 @@ void __attribute__((weak)) __throw_bad_array_new_length() { MOZ_CRASH(); }
|
||||
} // namespace std
|
||||
#endif
|
||||
|
||||
+#if _GLIBCXX_RELEASE >= 12
|
||||
+namespace std {
|
||||
+
|
||||
+/* This avoids the GLIBCXX_3.4.30 symbol version. */
|
||||
+void __attribute__((weak))
|
||||
+__glibcxx_assert_fail(const char* __file, int __line, const char* __function,
|
||||
+ const char* __condition) {
|
||||
+ MOZ_CRASH();
|
||||
+}
|
||||
+
|
||||
+} // namespace std
|
||||
+#endif
|
||||
+
|
||||
/* While we generally don't build with exceptions, we have some host tools
|
||||
* that do use them. libstdc++ from GCC 5.0 added exception constructors with
|
||||
* char const* argument. Older versions only have a constructor with
|
||||
--
|
||||
2.35.1
|
||||
|
5110
crossbeam-downgrade-rhbz2063961.patch
Normal file
5110
crossbeam-downgrade-rhbz2063961.patch
Normal file
File diff suppressed because it is too large
Load Diff
11
firefox.spec
11
firefox.spec
@ -163,7 +163,7 @@ ExcludeArch: aarch64
|
||||
Summary: Mozilla Firefox Web browser
|
||||
Name: firefox
|
||||
Version: 98.0
|
||||
Release: 2%{?pre_tag}%{?dist}
|
||||
Release: 3%{?pre_tag}%{?dist}
|
||||
URL: https://www.mozilla.org/firefox/
|
||||
License: MPLv1.1 or GPLv2+ or LGPLv2+
|
||||
Source0: https://archive.mozilla.org/pub/firefox/releases/%{version}%{?pre_version}/source/firefox-%{version}%{?pre_version}.source.tar.xz
|
||||
@ -224,7 +224,7 @@ Patch66: D139078.diff
|
||||
Patch67: D139088.diff
|
||||
Patch68: D139703.diff
|
||||
Patch69: D139704.diff
|
||||
Patch70: 0001-GLIBCXX-fix-for-GCC-12.patch
|
||||
Patch70: crossbeam-downgrade-rhbz2063961.patch
|
||||
|
||||
# Test patches
|
||||
# Generate without context by
|
||||
@ -478,7 +478,9 @@ This package contains results of tests executed during build.
|
||||
%patch67 -p1 -b .D139088
|
||||
%patch68 -p1 -b .D139703
|
||||
%patch69 -p1 -b .D139704
|
||||
%patch70 -p1 -b .0001-GLIBCXX-fix-for-GCC-12
|
||||
%ifarch aarch64
|
||||
%patch70 -p1 -b .crossbeam-downgrade-rhbz2063961
|
||||
%endif
|
||||
|
||||
# Test patches
|
||||
#%patch100 -p1 -b .firefox-tests-xpcshell
|
||||
@ -1075,6 +1077,9 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
||||
#---------------------------------------------------------------------
|
||||
|
||||
%changelog
|
||||
* Wed Mar 15 2022 Martin Stransky <stransky@redhat.com> - 98.0-3
|
||||
- Added a workaround for rhbz#2063961
|
||||
|
||||
* Wed Mar 2 2022 Martin Stransky <stransky@redhat.com> - 98.0-2
|
||||
- Added support for ffmpeg 5.0
|
||||
- Spec tweaks
|
||||
|
Loading…
Reference in New Issue
Block a user