Updated to 124.0
This commit is contained in:
parent
7a484647f4
commit
8e2f33c0dc
2
.gitignore
vendored
2
.gitignore
vendored
@ -623,3 +623,5 @@ firefox-3.6.4.source.tar.bz2
|
|||||||
/firefox-123.0.source.tar.xz
|
/firefox-123.0.source.tar.xz
|
||||||
/firefox-123.0.1.source.tar.xz
|
/firefox-123.0.1.source.tar.xz
|
||||||
/firefox-langpacks-123.0.1-20240307.tar.xz
|
/firefox-langpacks-123.0.1-20240307.tar.xz
|
||||||
|
/firefox-124.0.source.tar.xz
|
||||||
|
/firefox-langpacks-124.0-20240313.tar.xz
|
||||||
|
@ -1,31 +1,17 @@
|
|||||||
diff -up firefox-120.0/toolkit/xre/nsAppRunner.cpp.fedora-customization firefox-120.0/toolkit/xre/nsAppRunner.cpp
|
diff -up firefox-124.0/toolkit/xre/nsAppRunner.cpp.fedora-customization firefox-124.0/toolkit/xre/nsAppRunner.cpp
|
||||||
--- firefox-120.0/toolkit/xre/nsAppRunner.cpp.fedora-customization 2023-11-13 21:48:38.000000000 +0100
|
diff -up firefox-124.0/widget/gtk/nsWindow.cpp.fedora-customization firefox-124.0/widget/gtk/nsWindow.cpp
|
||||||
+++ firefox-120.0/toolkit/xre/nsAppRunner.cpp 2023-11-14 10:39:13.001603081 +0100
|
--- firefox-124.0/widget/gtk/nsWindow.cpp.fedora-customization 2024-03-13 12:35:57.098591719 +0100
|
||||||
@@ -5765,6 +5765,12 @@ int XREMain::XRE_main(int argc, char* ar
|
+++ firefox-124.0/widget/gtk/nsWindow.cpp 2024-03-13 12:43:17.375928494 +0100
|
||||||
if (!mAppData->remotingName) {
|
@@ -3459,6 +3459,12 @@ nsresult nsWindow::SetTitle(const nsAStr
|
||||||
mAppData->remotingName = mAppData->name;
|
return NS_OK;
|
||||||
}
|
}
|
||||||
+
|
|
||||||
+ const char* appRemotingName = getenv("MOZ_APP_REMOTINGNAME");
|
|
||||||
+ if (appRemotingName) {
|
|
||||||
+ mAppData->remotingName = strdup(appRemotingName);
|
|
||||||
+ }
|
|
||||||
+
|
|
||||||
// used throughout this file
|
|
||||||
gAppData = mAppData.get();
|
|
||||||
|
|
||||||
diff -up firefox-120.0/widget/gtk/nsWindow.cpp.fedora-customization firefox-120.0/widget/gtk/nsWindow.cpp
|
|
||||||
--- firefox-120.0/widget/gtk/nsWindow.cpp.fedora-customization 2023-11-14 10:39:13.003603150 +0100
|
|
||||||
+++ firefox-120.0/widget/gtk/nsWindow.cpp 2023-11-14 10:41:06.339532735 +0100
|
|
||||||
@@ -3457,6 +3457,11 @@ void* nsWindow::GetNativeData(uint32_t a
|
|
||||||
nsresult nsWindow::SetTitle(const nsAString& aTitle) {
|
|
||||||
if (!mShell) return NS_OK;
|
|
||||||
|
|
||||||
+ const char* appTitle = getenv("MOZ_APP_TITLE");
|
+ const char* appTitle = getenv("MOZ_APP_TITLE");
|
||||||
+ if (appTitle) {
|
+ if (appTitle) {
|
||||||
+ gtk_window_set_title(GTK_WINDOW(mShell), appTitle);
|
+ gtk_window_set_title(GTK_WINDOW(mShell), appTitle);
|
||||||
+ return NS_OK;
|
+ return NS_OK;
|
||||||
+ }
|
+ }
|
||||||
// convert the string into utf8 and set the title.
|
+
|
||||||
|
// convert the string into utf8 and set the title.
|
||||||
#define UTF8_FOLLOWBYTE(ch) (((ch) & 0xC0) == 0x80)
|
#define UTF8_FOLLOWBYTE(ch) (((ch) & 0xC0) == 0x80)
|
||||||
NS_ConvertUTF16toUTF8 titleUTF8(aTitle);
|
NS_ConvertUTF16toUTF8 titleUTF8(aTitle);
|
||||||
|
16
firefox.spec
16
firefox.spec
@ -177,13 +177,13 @@ ExcludeArch: i686
|
|||||||
|
|
||||||
Summary: Mozilla Firefox Web browser
|
Summary: Mozilla Firefox Web browser
|
||||||
Name: firefox
|
Name: firefox
|
||||||
Version: 123.0.1
|
Version: 124.0
|
||||||
Release: 1%{?pre_tag}%{?dist}
|
Release: 1%{?pre_tag}%{?dist}
|
||||||
URL: https://www.mozilla.org/firefox/
|
URL: https://www.mozilla.org/firefox/
|
||||||
License: MPLv1.1 or GPLv2+ or LGPLv2+
|
License: MPLv1.1 or GPLv2+ or LGPLv2+
|
||||||
Source0: https://archive.mozilla.org/pub/firefox/releases/%{version}%{?pre_version}/source/firefox-%{version}%{?pre_version}.source.tar.xz
|
Source0: https://archive.mozilla.org/pub/firefox/releases/%{version}%{?pre_version}/source/firefox-%{version}%{?pre_version}.source.tar.xz
|
||||||
%if %{with langpacks}
|
%if %{with langpacks}
|
||||||
Source1: firefox-langpacks-%{version}%{?pre_version}-20240307.tar.xz
|
Source1: firefox-langpacks-%{version}%{?pre_version}-20240313.tar.xz
|
||||||
%endif
|
%endif
|
||||||
Source2: cbindgen-vendor.tar.xz
|
Source2: cbindgen-vendor.tar.xz
|
||||||
Source3: dump_syms-vendor.tar.xz
|
Source3: dump_syms-vendor.tar.xz
|
||||||
@ -259,12 +259,6 @@ Patch242: 0026-Add-KDE-integration-to-Firefox.patch
|
|||||||
Patch402: mozilla-1196777.patch
|
Patch402: mozilla-1196777.patch
|
||||||
Patch407: mozilla-1667096.patch
|
Patch407: mozilla-1667096.patch
|
||||||
|
|
||||||
# Firefox 124 patches for PipeWire camera support
|
|
||||||
# https://phabricator.services.mozilla.com/D200142
|
|
||||||
Patch421: libwebrtc-allow-videocapturemodulepipewire-be-shared-with-more-consumers.patch
|
|
||||||
# https://phabricator.services.mozilla.com/D201328
|
|
||||||
Patch422: libwebrtc-simplify-thread-and-lock-annotations.patch
|
|
||||||
|
|
||||||
# PGO/LTO patches
|
# PGO/LTO patches
|
||||||
Patch600: pgo.patch
|
Patch600: pgo.patch
|
||||||
Patch602: mozilla-1516803.patch
|
Patch602: mozilla-1516803.patch
|
||||||
@ -568,9 +562,6 @@ This package contains results of tests executed during build.
|
|||||||
%patch402 -p1 -b .1196777
|
%patch402 -p1 -b .1196777
|
||||||
%patch407 -p1 -b .1667096
|
%patch407 -p1 -b .1667096
|
||||||
|
|
||||||
%patch421 -p1 -b .libwebrtc-allow-videocapturemodulepipewire-be-shared-with-more-consumers
|
|
||||||
%patch422 -p1 -b .libwebrtc-simplify-thread-and-lock-annotations
|
|
||||||
|
|
||||||
# PGO patches
|
# PGO patches
|
||||||
%if %{build_with_pgo}
|
%if %{build_with_pgo}
|
||||||
%if !%{build_with_clang}
|
%if !%{build_with_clang}
|
||||||
@ -1192,6 +1183,9 @@ fi
|
|||||||
#---------------------------------------------------------------------
|
#---------------------------------------------------------------------
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Mar 13 2024 Martin Stransky <stransky@redhat.com>- 124.0-1
|
||||||
|
- Updated to 124.0
|
||||||
|
|
||||||
* Thu Mar 07 2024 Martin Stransky <stransky@redhat.com>- 123.0.1-1
|
* Thu Mar 07 2024 Martin Stransky <stransky@redhat.com>- 123.0.1-1
|
||||||
- Updated to 123.0.1
|
- Updated to 123.0.1
|
||||||
|
|
||||||
|
4
sources
4
sources
@ -1,5 +1,5 @@
|
|||||||
SHA512 (mochitest-python.tar.gz) = 089b1593068b76f4572af0086eaccf52a6a1299bfffb58593206d19bf021ae381f2380bbfeb4371586cd53706ff6dde3d240238b2caf19b96c57dfc2f4524e36
|
SHA512 (mochitest-python.tar.gz) = 089b1593068b76f4572af0086eaccf52a6a1299bfffb58593206d19bf021ae381f2380bbfeb4371586cd53706ff6dde3d240238b2caf19b96c57dfc2f4524e36
|
||||||
SHA512 (cbindgen-vendor.tar.xz) = 3e7eaff088db918e95f5505e5feeb06e8b7b95cc62042a6d163a708fc76baea43d21bf49cf7e02bc64fdfc61e8d7704057dbb225098de56e110783104d166c54
|
SHA512 (cbindgen-vendor.tar.xz) = 3e7eaff088db918e95f5505e5feeb06e8b7b95cc62042a6d163a708fc76baea43d21bf49cf7e02bc64fdfc61e8d7704057dbb225098de56e110783104d166c54
|
||||||
SHA512 (dump_syms-vendor.tar.xz) = 5769c052fa874a965eb8837776b01fb097e8930f45d0d0d2a93997c4fae8726184a192aee52302bde62e62897801b1463cae9283563d9d60e8b8ee80a250f2a3
|
SHA512 (dump_syms-vendor.tar.xz) = 5769c052fa874a965eb8837776b01fb097e8930f45d0d0d2a93997c4fae8726184a192aee52302bde62e62897801b1463cae9283563d9d60e8b8ee80a250f2a3
|
||||||
SHA512 (firefox-123.0.1.source.tar.xz) = e9af61c1ca800edd16ab7a0d24c9a36bbb34813ed0a11ff62389aa38fa83deba394bca5d95cdaad55ad29ffa3c0e5d3dd15ac1099f7fa3649f4b6c835b7498c2
|
SHA512 (firefox-124.0.source.tar.xz) = 028c1a447bc2e608e1ba06cc66b1a33e0a4179744f0e8406d6f2b7317bf99fdd84eb97de0e96d4adcef9f2498b083bac38ccbf2d55e213a4a7e8ff6d94974cfc
|
||||||
SHA512 (firefox-langpacks-123.0.1-20240307.tar.xz) = 1e79f5f286d6e7f72f95965935339a6176b57ebad1c96eb824a2922963058dcb7bf9299bb4edee4fd00e86425fb89ff926da41c030e25c2b322168dc3e33a2e7
|
SHA512 (firefox-langpacks-124.0-20240313.tar.xz) = 60cb79fc9e8acf34030d6e0b1ea6c119583f9332a424cb551644c89aa074fe7cdb336e53e5f9abc38ac1cfd489fadc697c1cd8e8d7e2020f5372ba861e8650ab
|
||||||
|
Loading…
x
Reference in New Issue
Block a user