Build fix
This commit is contained in:
parent
14c907c375
commit
7a8a230f84
@ -1,5 +1,12 @@
|
|||||||
diff -up firefox-60.0/media/libyuv/libyuv/tools_libyuv/autoroller/unittests/testdata/DEPS.chromium.old firefox-60.0/media/libyuv/libyuv/tools_libyuv/autoroller/unittests/testdata/DEPS.chromium
|
This is a composition of these patches for Firefox 60:
|
||||||
diff -up firefox-60.0/media/webrtc/trunk/Makefile.old firefox-60.0/media/webrtc/trunk/Makefile
|
|
||||||
|
https://bugzilla.mozilla.org/show_bug.cgi?id=1441665
|
||||||
|
https://bugzilla.mozilla.org/show_bug.cgi?id=1456898
|
||||||
|
https://bugzilla.mozilla.org/show_bug.cgi?id=1457309
|
||||||
|
https://bugzilla.mozilla.org/show_bug.cgi?id=1457691
|
||||||
|
|
||||||
|
which fix popup window placement at CSD window mode.
|
||||||
|
|
||||||
diff -up firefox-60.0/widget/gtk/gtk3drawing.cpp.old firefox-60.0/widget/gtk/gtk3drawing.cpp
|
diff -up firefox-60.0/widget/gtk/gtk3drawing.cpp.old firefox-60.0/widget/gtk/gtk3drawing.cpp
|
||||||
--- firefox-60.0/widget/gtk/gtk3drawing.cpp.old 2018-04-26 22:07:36.000000000 +0200
|
--- firefox-60.0/widget/gtk/gtk3drawing.cpp.old 2018-04-26 22:07:36.000000000 +0200
|
||||||
+++ firefox-60.0/widget/gtk/gtk3drawing.cpp 2018-04-30 11:59:06.750866104 +0200
|
+++ firefox-60.0/widget/gtk/gtk3drawing.cpp 2018-04-30 11:59:06.750866104 +0200
|
||||||
@ -210,3 +217,29 @@ diff -up firefox-60.0/widget/gtk/nsWindow.h.old firefox-60.0/widget/gtk/nsWindow
|
|||||||
GtkWidget *mShell;
|
GtkWidget *mShell;
|
||||||
MozContainer *mContainer;
|
MozContainer *mContainer;
|
||||||
GdkWindow *mGdkWindow;
|
GdkWindow *mGdkWindow;
|
||||||
|
diff -up firefox-60.0/widget/gtk/WidgetStyleCache.cpp.old firefox-60.0/widget/gtk/WidgetStyleCache.cpp
|
||||||
|
--- firefox-60.0/widget/gtk/WidgetStyleCache.cpp.old 2018-04-26 22:07:35.000000000 +0200
|
||||||
|
+++ firefox-60.0/widget/gtk/WidgetStyleCache.cpp 2018-04-30 13:07:04.170056312 +0200
|
||||||
|
@@ -1285,6 +1285,22 @@ GetCssNodeStyleInternal(WidgetNodeType a
|
||||||
|
"MOZ_GTK_HEADER_BAR_BUTTON_RESTORE is used as an icon only!");
|
||||||
|
return nullptr;
|
||||||
|
}
|
||||||
|
+ case MOZ_GTK_WINDOW_DECORATION:
|
||||||
|
+ {
|
||||||
|
+ GtkStyleContext* parentStyle =
|
||||||
|
+ CreateSubStyleWithClass(MOZ_GTK_WINDOW, "csd");
|
||||||
|
+ style = CreateCSSNode("decoration", parentStyle);
|
||||||
|
+ g_object_unref(parentStyle);
|
||||||
|
+ break;
|
||||||
|
+ }
|
||||||
|
+ case MOZ_GTK_WINDOW_DECORATION_SOLID:
|
||||||
|
+ {
|
||||||
|
+ GtkStyleContext* parentStyle =
|
||||||
|
+ CreateSubStyleWithClass(MOZ_GTK_WINDOW, "solid-csd");
|
||||||
|
+ style = CreateCSSNode("decoration", parentStyle);
|
||||||
|
+ g_object_unref(parentStyle);
|
||||||
|
+ break;
|
||||||
|
+ }
|
||||||
|
default:
|
||||||
|
return GetWidgetRootStyle(aNodeType);
|
||||||
|
}
|
||||||
|
Loading…
Reference in New Issue
Block a user