Update to 5.0
This commit is contained in:
parent
73632afa5b
commit
77ec8e7377
2
.gitignore
vendored
2
.gitignore
vendored
@ -24,3 +24,5 @@ firefox-3.6.4.source.tar.bz2
|
||||
/firefox-langpacks-4.0-20110322.tar.xz
|
||||
/firefox-4.0.1.source.tar.bz2
|
||||
/firefox-langpacks-4.0.1-20110428.tar.xz
|
||||
/firefox-5.0.source.tar.bz2
|
||||
/firefox-langpacks-5.0-20110621.tar.xz
|
||||
|
60
firefox-5.0-cache-build.patch
Normal file
60
firefox-5.0-cache-build.patch
Normal file
@ -0,0 +1,60 @@
|
||||
# HG changeset patch
|
||||
# User Michael Wu <mwu@mozilla.com>
|
||||
# Parent 4d0e9de89591f6494d80b28a82aa360cf2638ff2
|
||||
Bug 633645 - Add startup cache to omnijar during make package, r= a= try: -b o -p macosx,macosx64 -u all -t none
|
||||
|
||||
|
||||
diff -up firefox-5.0/mozilla-release/browser/installer/Makefile.in.cache firefox-5.0/mozilla-release/browser/installer/Makefile.in
|
||||
--- firefox-5.0/mozilla-release/browser/installer/Makefile.in.cache 2011-06-15 23:57:18.000000000 +0200
|
||||
+++ firefox-5.0/mozilla-release/browser/installer/Makefile.in 2011-06-21 16:28:07.513443952 +0200
|
||||
@@ -117,20 +119,6 @@ ifndef LIBXUL_SDK
|
||||
INSTALL_SDK = 1
|
||||
endif
|
||||
|
||||
-ifneq (1_,$(if $(CROSS_COMPILE),1,0)_$(UNIVERSAL_BINARY))
|
||||
-ifdef RUN_TEST_PROGRAM
|
||||
-_ABS_RUN_TEST_PROGRAM = $(call core_abspath,$(RUN_TEST_PROGRAM))
|
||||
-endif
|
||||
-
|
||||
-GENERATE_CACHE = \
|
||||
- $(_ABS_RUN_TEST_PROGRAM) $(_ABS_DIST)/bin/xpcshell$(BIN_SUFFIX) -g "$$PWD" -f $(topsrcdir)/browser/installer/precompile_cache.js -e 'populate_startupcache("omni.jar", "startupCache.zip");' && \
|
||||
- rm -rf jsloader && \
|
||||
- $(UNZIP) startupCache.zip && \
|
||||
- rm startupCache.zip && \
|
||||
- find jsloader | xargs touch -t 201001010000 && \
|
||||
- $(ZIP) -r9mX omni.jar jsloader
|
||||
-endif
|
||||
-
|
||||
include $(topsrcdir)/toolkit/mozapps/installer/packager.mk
|
||||
|
||||
ifeq (bundle, $(MOZ_FS_LAYOUT))
|
||||
diff -up firefox-5.0/mozilla-release/browser/installer/package-manifest.in.cache firefox-5.0/mozilla-release/browser/installer/package-manifest.in
|
||||
--- firefox-5.0/mozilla-release/browser/installer/package-manifest.in.cache 2011-06-15 23:58:10.000000000 +0200
|
||||
+++ firefox-5.0/mozilla-release/browser/installer/package-manifest.in 2011-06-21 16:27:14.003407707 +0200
|
||||
@@ -88,6 +88,7 @@
|
||||
|
||||
[browser]
|
||||
; [Base Browser Files]
|
||||
+@BINPATH@/jsloader/
|
||||
#ifndef XP_UNIX
|
||||
@BINPATH@/@MOZ_APP_NAME@.exe
|
||||
#else
|
||||
diff -up firefox-5.0/mozilla-release/toolkit/mozapps/installer/packager.mk.cache firefox-5.0/mozilla-release/toolkit/mozapps/installer/packager.mk
|
||||
--- firefox-5.0/mozilla-release/toolkit/mozapps/installer/packager.mk.cache 2011-06-15 23:58:10.000000000 +0200
|
||||
+++ firefox-5.0/mozilla-release/toolkit/mozapps/installer/packager.mk 2011-06-21 16:28:29.785042798 +0200
|
||||
@@ -380,7 +380,6 @@ MAKE_SDK = $(CREATE_FINAL_TAR) - $(MOZ_A
|
||||
endif
|
||||
|
||||
ifdef MOZ_OMNIJAR
|
||||
-GENERATE_CACHE ?= true
|
||||
|
||||
OMNIJAR_FILES = \
|
||||
chrome \
|
||||
@@ -409,7 +408,6 @@ PACK_OMNIJAR = \
|
||||
mv components.manifest components && \
|
||||
find . | xargs touch -t 201001010000 && \
|
||||
zip -r9mX omni.jar $(OMNIJAR_FILES) -x $(NON_OMNIJAR_FILES) && \
|
||||
- $(GENERATE_CACHE) && \
|
||||
$(OPTIMIZE_JARS_CMD) --optimize $(_ABS_DIST)/jarlog/ ./ ./ && \
|
||||
mv binary.manifest components && \
|
||||
printf "manifest components/binary.manifest\n" > chrome.manifest
|
@ -31,6 +31,7 @@ ac_add_options --disable-updater
|
||||
ac_add_options --enable-url-classifier
|
||||
ac_add_options --enable-gio
|
||||
ac_add_options --disable-gnomevfs
|
||||
ac_add_options --enable-chrome-format=omni
|
||||
|
||||
export BUILD_OFFICIAL=1
|
||||
export MOZILLA_OFFICIAL=1
|
||||
|
19
firefox.spec
19
firefox.spec
@ -9,15 +9,15 @@
|
||||
%define default_bookmarks_file %{_datadir}/bookmarks/default-bookmarks.html
|
||||
%define firefox_app_id \{ec8030f7-c20a-464f-9b0e-13a3a9e97384\}
|
||||
|
||||
%global firefox_dir_ver 4
|
||||
%global gecko_version 2.0.1
|
||||
%global firefox_dir_ver 5
|
||||
%global gecko_version 5.0
|
||||
%global alpha_version 0
|
||||
%global beta_version 0
|
||||
%global rc_version 0
|
||||
|
||||
%global mozappdir %{_libdir}/%{name}-%{firefox_dir_ver}
|
||||
%global langpackdir %{mozappdir}/langpacks
|
||||
%global tarballdir mozilla-2.0
|
||||
%global tarballdir mozilla-release
|
||||
|
||||
%define official_branding 1
|
||||
%define build_langpacks 1
|
||||
@ -44,14 +44,14 @@
|
||||
|
||||
Summary: Mozilla Firefox Web browser
|
||||
Name: firefox
|
||||
Version: 4.0.1
|
||||
Release: 2%{?pre_tag}%{?dist}
|
||||
Version: 5.0
|
||||
Release: 1%{?pre_tag}%{?dist}
|
||||
URL: http://www.mozilla.org/projects/firefox/
|
||||
License: MPLv1.1 or GPLv2+ or LGPLv2+
|
||||
Group: Applications/Internet
|
||||
Source0: ftp://ftp.mozilla.org/pub/firefox/releases/%{version}%{?pre_version}/source/firefox-%{version}%{?pre_version}.source.tar.bz2
|
||||
%if %{build_langpacks}
|
||||
Source1: firefox-langpacks-%{version}%{?pre_version}-20110428.tar.xz
|
||||
Source1: firefox-langpacks-%{version}%{?pre_version}-20110621.tar.xz
|
||||
%endif
|
||||
Source10: firefox-mozconfig
|
||||
Source11: firefox-mozconfig-branded
|
||||
@ -63,6 +63,7 @@ Source23: firefox.1
|
||||
|
||||
#Build patches
|
||||
Patch0: firefox-version.patch
|
||||
Patch1: firefox-5.0-cache-build.patch
|
||||
|
||||
# Fedora patches
|
||||
Patch12: firefox-stub.patch
|
||||
@ -115,6 +116,9 @@ sed -e 's/__RPM_VERSION_INTERNAL__/%{firefox_dir_ver}/' %{P:%%PATCH0} \
|
||||
%{__patch} -p1 -b --suffix .version --fuzz=0 < version.patch
|
||||
|
||||
|
||||
# Build patches
|
||||
%patch1 -p2 -b .cache
|
||||
|
||||
# For branding specific patches.
|
||||
|
||||
# Fedora patches
|
||||
@ -355,6 +359,9 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
||||
#---------------------------------------------------------------------
|
||||
|
||||
%changelog
|
||||
* Tue Jun 21 2011 Martin Stransky <stransky@redhat.com> - 5.0-1
|
||||
- Update to 5.0
|
||||
|
||||
* Tue May 10 2011 Martin Stransky <stransky@redhat.com> - 4.0.1-2
|
||||
- Fixed rhbz#676183 - "firefox -g" is broken
|
||||
|
||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
9abda7d23151e97913c8555a64c13f34 firefox-4.0.1.source.tar.bz2
|
||||
409894961e0124c53142af94978a7ae3 firefox-langpacks-4.0.1-20110428.tar.xz
|
||||
9f64a01e86a5d424e12a8e3305c5debe firefox-5.0.source.tar.bz2
|
||||
15f3c8273fb50a1f8b150d7bf19726ec firefox-langpacks-5.0-20110621.tar.xz
|
||||
|
Loading…
Reference in New Issue
Block a user