Merge branch 'master' into f26
This commit is contained in:
commit
6f97a62f3a
2
.gitignore
vendored
2
.gitignore
vendored
@ -244,3 +244,5 @@ firefox-3.6.4.source.tar.bz2
|
|||||||
/firefox-langpacks-55.0.1-20170814.tar.xz
|
/firefox-langpacks-55.0.1-20170814.tar.xz
|
||||||
/firefox-55.0.2.source.tar.xz
|
/firefox-55.0.2.source.tar.xz
|
||||||
/firefox-langpacks-55.0.2-20170818.tar.xz
|
/firefox-langpacks-55.0.2-20170818.tar.xz
|
||||||
|
/firefox-55.0.3.source.tar.xz
|
||||||
|
/firefox-langpacks-55.0.3-20170901.tar.xz
|
||||||
|
30
build-jit-atomic-always-lucky.patch
Normal file
30
build-jit-atomic-always-lucky.patch
Normal file
@ -0,0 +1,30 @@
|
|||||||
|
diff -up firefox-55.0.2/js/src/jit/AtomicOperations.h.jit-atomic-lucky firefox-55.0.2/js/src/jit/AtomicOperations.h
|
||||||
|
--- firefox-55.0.2/js/src/jit/AtomicOperations.h.jit-atomic-lucky 2017-07-31 18:20:47.000000000 +0200
|
||||||
|
+++ firefox-55.0.2/js/src/jit/AtomicOperations.h 2017-08-29 12:59:52.870926044 +0200
|
||||||
|
@@ -348,7 +348,7 @@ AtomicOperations::isLockfree(int32_t siz
|
||||||
|
# elif defined(__sh__)
|
||||||
|
# include "jit/none/AtomicOperations-feeling-lucky.h"
|
||||||
|
# else
|
||||||
|
-# include "jit/none/AtomicOperations-none.h" // These MOZ_CRASH() always
|
||||||
|
+# include "jit/none/AtomicOperations-feeling-lucky.h"
|
||||||
|
# endif
|
||||||
|
#elif defined(JS_CODEGEN_X86) || defined(JS_CODEGEN_X64)
|
||||||
|
# include "jit/x86-shared/AtomicOperations-x86-shared.h"
|
||||||
|
diff -up firefox-55.0.2/js/src/jit/none/AtomicOperations-feeling-lucky.h.jit-atomic-lucky firefox-55.0.2/js/src/jit/none/AtomicOperations-feeling-lucky.h
|
||||||
|
--- firefox-55.0.2/js/src/jit/none/AtomicOperations-feeling-lucky.h.jit-atomic-lucky 2017-08-29 14:10:52.665031524 +0200
|
||||||
|
+++ firefox-55.0.2/js/src/jit/none/AtomicOperations-feeling-lucky.h 2017-08-29 14:09:40.756060235 +0200
|
||||||
|
@@ -60,6 +60,14 @@
|
||||||
|
# define GNUC_COMPATIBLE
|
||||||
|
#endif
|
||||||
|
|
||||||
|
+#ifdef __s390__
|
||||||
|
+# define GNUC_COMPATIBLE
|
||||||
|
+#endif
|
||||||
|
+
|
||||||
|
+#ifdef __s390x__
|
||||||
|
+# define GNUC_COMPATIBLE
|
||||||
|
+#endif
|
||||||
|
+
|
||||||
|
// The default implementation tactic for gcc/clang is to use the newer
|
||||||
|
// __atomic intrinsics added for use in C++11 <atomic>. Where that
|
||||||
|
// isn't available, we use GCC's older __sync functions instead.
|
12
build-missing-xlocale-h.patch
Normal file
12
build-missing-xlocale-h.patch
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
diff -up thunderbird-52.3.0/mozilla/intl/icu/source/i18n/digitlst.cpp.xlocale thunderbird-52.3.0/mozilla/intl/icu/source/i18n/digitlst.cpp
|
||||||
|
--- thunderbird-52.3.0/mozilla/intl/icu/source/i18n/digitlst.cpp.xlocale 2017-08-24 14:42:48.634084293 +0200
|
||||||
|
+++ thunderbird-52.3.0/mozilla/intl/icu/source/i18n/digitlst.cpp 2017-08-24 14:42:50.534084676 +0200
|
||||||
|
@@ -64,7 +64,7 @@
|
||||||
|
# if U_PLATFORM_USES_ONLY_WIN32_API || U_PLATFORM == U_PF_CYGWIN
|
||||||
|
# include <locale.h>
|
||||||
|
# else
|
||||||
|
-# include <xlocale.h>
|
||||||
|
+# include <locale.h>
|
||||||
|
# endif
|
||||||
|
#endif
|
||||||
|
|
@ -19,6 +19,7 @@ ac_add_options --enable-chrome-format=omni
|
|||||||
ac_add_options --enable-pulseaudio
|
ac_add_options --enable-pulseaudio
|
||||||
ac_add_options --with-system-icu
|
ac_add_options --with-system-icu
|
||||||
ac_add_options --with-mozilla-api-keyfile=../mozilla-api-key
|
ac_add_options --with-mozilla-api-keyfile=../mozilla-api-key
|
||||||
|
ac_add_options --with-google-api-keyfile=../google-api-key
|
||||||
ac_add_options --enable-release
|
ac_add_options --enable-release
|
||||||
ac_add_options --enable-pie
|
ac_add_options --enable-pie
|
||||||
|
|
||||||
|
33
firefox.spec
33
firefox.spec
@ -27,7 +27,7 @@
|
|||||||
|
|
||||||
# Use system libicu?
|
# Use system libicu?
|
||||||
%if 0%{?fedora} > 27
|
%if 0%{?fedora} > 27
|
||||||
%define system_libicu 1
|
%define system_libicu 0
|
||||||
%else
|
%else
|
||||||
%define system_libicu 0
|
%define system_libicu 0
|
||||||
%endif
|
%endif
|
||||||
@ -67,11 +67,11 @@
|
|||||||
%global nspr_version 4.10.10
|
%global nspr_version 4.10.10
|
||||||
# NSS/NSPR quite often ends in build override, so as requirement the version
|
# NSS/NSPR quite often ends in build override, so as requirement the version
|
||||||
# we're building against could bring us some broken dependencies from time to time.
|
# we're building against could bring us some broken dependencies from time to time.
|
||||||
%global nspr_build_version %{nspr_version}
|
|
||||||
#%global nspr_build_version %(pkg-config --silence-errors --modversion nspr 2>/dev/null || echo 65536)
|
#%global nspr_build_version %(pkg-config --silence-errors --modversion nspr 2>/dev/null || echo 65536)
|
||||||
|
%global nspr_build_version %{nspr_version}
|
||||||
%global nss_version 3.29.3
|
%global nss_version 3.29.3
|
||||||
%global nss_build_version %{nss_version}
|
|
||||||
#%global nss_build_version %(pkg-config --silence-errors --modversion nss 2>/dev/null || echo 65536)
|
#%global nss_build_version %(pkg-config --silence-errors --modversion nss 2>/dev/null || echo 65536)
|
||||||
|
%global nss_build_version %{nss_version}
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%if %{?system_sqlite}
|
%if %{?system_sqlite}
|
||||||
@ -90,20 +90,22 @@
|
|||||||
%define enable_mozilla_crashreporter 0
|
%define enable_mozilla_crashreporter 0
|
||||||
%if !%{debug_build}
|
%if !%{debug_build}
|
||||||
%ifarch %{ix86} x86_64
|
%ifarch %{ix86} x86_64
|
||||||
|
%if 0%{?fedora} < 27
|
||||||
%define enable_mozilla_crashreporter 1
|
%define enable_mozilla_crashreporter 1
|
||||||
%endif
|
%endif
|
||||||
%endif
|
%endif
|
||||||
|
%endif
|
||||||
|
|
||||||
Summary: Mozilla Firefox Web browser
|
Summary: Mozilla Firefox Web browser
|
||||||
Name: firefox
|
Name: firefox
|
||||||
Version: 55.0.2
|
Version: 55.0.3
|
||||||
Release: 3%{?pre_tag}%{?dist}
|
Release: 1%{?pre_tag}%{?dist}
|
||||||
URL: https://www.mozilla.org/firefox/
|
URL: https://www.mozilla.org/firefox/
|
||||||
License: MPLv1.1 or GPLv2+ or LGPLv2+
|
License: MPLv1.1 or GPLv2+ or LGPLv2+
|
||||||
Group: Applications/Internet
|
Group: Applications/Internet
|
||||||
Source0: https://archive.mozilla.org/pub/firefox/releases/%{version}%{?pre_version}/source/firefox-%{version}%{?pre_version}.source.tar.xz
|
Source0: https://archive.mozilla.org/pub/firefox/releases/%{version}%{?pre_version}/source/firefox-%{version}%{?pre_version}.source.tar.xz
|
||||||
%if %{build_langpacks}
|
%if %{build_langpacks}
|
||||||
Source1: firefox-langpacks-%{version}%{?pre_version}-20170818.tar.xz
|
Source1: firefox-langpacks-%{version}%{?pre_version}-20170901.tar.xz
|
||||||
%endif
|
%endif
|
||||||
Source10: firefox-mozconfig
|
Source10: firefox-mozconfig
|
||||||
Source12: firefox-redhat-default-prefs.js
|
Source12: firefox-redhat-default-prefs.js
|
||||||
@ -113,6 +115,7 @@ Source23: firefox.1
|
|||||||
Source24: mozilla-api-key
|
Source24: mozilla-api-key
|
||||||
Source25: firefox-symbolic.svg
|
Source25: firefox-symbolic.svg
|
||||||
Source26: distribution.ini
|
Source26: distribution.ini
|
||||||
|
Source27: google-api-key
|
||||||
|
|
||||||
# Build patches
|
# Build patches
|
||||||
Patch0: firefox-install-dir.patch
|
Patch0: firefox-install-dir.patch
|
||||||
@ -133,6 +136,10 @@ Patch32: build-rust-ppc64le.patch
|
|||||||
Patch33: build-ppc-s390-dom.patch
|
Patch33: build-ppc-s390-dom.patch
|
||||||
Patch34: build-cubeb-pulse-arm.patch
|
Patch34: build-cubeb-pulse-arm.patch
|
||||||
Patch35: build-ppc-jit.patch
|
Patch35: build-ppc-jit.patch
|
||||||
|
Patch36: build-missing-xlocale-h.patch
|
||||||
|
# Always feel lucky for unsupported platforms:
|
||||||
|
# https://bugzilla.mozilla.org/show_bug.cgi?id=1347128
|
||||||
|
Patch37: build-jit-atomic-always-lucky.patch
|
||||||
|
|
||||||
# Fedora specific patches
|
# Fedora specific patches
|
||||||
# Unable to install addons from https pages
|
# Unable to install addons from https pages
|
||||||
@ -147,7 +154,6 @@ Patch226: rhbz-1354671.patch
|
|||||||
Patch229: firefox-nss-version.patch
|
Patch229: firefox-nss-version.patch
|
||||||
|
|
||||||
# Upstream patches
|
# Upstream patches
|
||||||
Patch304: mozilla-1253216.patch
|
|
||||||
Patch402: mozilla-1196777.patch
|
Patch402: mozilla-1196777.patch
|
||||||
Patch406: mozilla-256180.patch
|
Patch406: mozilla-256180.patch
|
||||||
Patch407: mozilla-1348576.patch
|
Patch407: mozilla-1348576.patch
|
||||||
@ -203,6 +209,7 @@ BuildRequires: pkgconfig(gconf-2.0)
|
|||||||
BuildRequires: yasm
|
BuildRequires: yasm
|
||||||
|
|
||||||
Requires: mozilla-filesystem
|
Requires: mozilla-filesystem
|
||||||
|
Requires: p11-kit-trust
|
||||||
%if %{?system_nss}
|
%if %{?system_nss}
|
||||||
Requires: nspr >= %{nspr_build_version}
|
Requires: nspr >= %{nspr_build_version}
|
||||||
Requires: nss >= %{nss_build_version}
|
Requires: nss >= %{nss_build_version}
|
||||||
@ -312,6 +319,7 @@ This package contains results of tests executed during build.
|
|||||||
%ifarch ppc ppc64 ppc64le
|
%ifarch ppc ppc64 ppc64le
|
||||||
%patch35 -p1 -b .ppc-jit
|
%patch35 -p1 -b .ppc-jit
|
||||||
%endif
|
%endif
|
||||||
|
%patch37 -p1 -b .jit-atomic-lucky
|
||||||
|
|
||||||
%patch3 -p1 -b .arm
|
%patch3 -p1 -b .arm
|
||||||
|
|
||||||
@ -329,7 +337,6 @@ This package contains results of tests executed during build.
|
|||||||
%patch226 -p1 -b .1354671
|
%patch226 -p1 -b .1354671
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%patch304 -p1 -b .1253216
|
|
||||||
%patch402 -p1 -b .1196777
|
%patch402 -p1 -b .1196777
|
||||||
%patch406 -p1 -b .256180
|
%patch406 -p1 -b .256180
|
||||||
%ifarch %{arm}
|
%ifarch %{arm}
|
||||||
@ -346,6 +353,7 @@ This package contains results of tests executed during build.
|
|||||||
# Patch for big endian platforms only
|
# Patch for big endian platforms only
|
||||||
%if 0%{?big_endian}
|
%if 0%{?big_endian}
|
||||||
%patch26 -p1 -b .icu
|
%patch26 -p1 -b .icu
|
||||||
|
%patch36 -p2 -b .xlocale
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%{__rm} -f .mozconfig
|
%{__rm} -f .mozconfig
|
||||||
@ -354,6 +362,7 @@ This package contains results of tests executed during build.
|
|||||||
echo "ac_add_options --enable-official-branding" >> .mozconfig
|
echo "ac_add_options --enable-official-branding" >> .mozconfig
|
||||||
%endif
|
%endif
|
||||||
%{__cp} %{SOURCE24} mozilla-api-key
|
%{__cp} %{SOURCE24} mozilla-api-key
|
||||||
|
%{__cp} %{SOURCE27} google-api-key
|
||||||
|
|
||||||
%if %{?system_nss}
|
%if %{?system_nss}
|
||||||
echo "ac_add_options --with-system-nspr" >> .mozconfig
|
echo "ac_add_options --with-system-nspr" >> .mozconfig
|
||||||
@ -453,6 +462,10 @@ echo "ac_add_options --with-system-icu" >> .mozconfig
|
|||||||
%else
|
%else
|
||||||
echo "ac_add_options --without-system-icu" >> .mozconfig
|
echo "ac_add_options --without-system-icu" >> .mozconfig
|
||||||
%endif
|
%endif
|
||||||
|
%ifarch s390 s390x
|
||||||
|
echo "ac_add_options --disable-ion" >> .mozconfig
|
||||||
|
%endif
|
||||||
|
|
||||||
|
|
||||||
#---------------------------------------------------------------------
|
#---------------------------------------------------------------------
|
||||||
|
|
||||||
@ -848,11 +861,15 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
|||||||
%{mozappdir}/libfreeblpriv3.chk
|
%{mozappdir}/libfreeblpriv3.chk
|
||||||
%{mozappdir}/libnssdbm3.chk
|
%{mozappdir}/libnssdbm3.chk
|
||||||
%{mozappdir}/libsoftokn3.chk
|
%{mozappdir}/libsoftokn3.chk
|
||||||
|
%exclude %{mozappdir}/libnssckbi.so
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
#---------------------------------------------------------------------
|
#---------------------------------------------------------------------
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Sep 1 2017 Jan Horak <jhorak@redhat.com> - 55.0.3-1
|
||||||
|
- Update to 55.0.3
|
||||||
|
|
||||||
* Thu Aug 24 2017 Martin Stransky <stransky@redhat.com> - 55.0.2-3
|
* Thu Aug 24 2017 Martin Stransky <stransky@redhat.com> - 55.0.2-3
|
||||||
- Enable to build with nspr-4.16.
|
- Enable to build with nspr-4.16.
|
||||||
|
|
||||||
|
1
google-api-key
Normal file
1
google-api-key
Normal file
@ -0,0 +1 @@
|
|||||||
|
AIzaSyBPGXa4AYD4FC3HJK7LnIKxm4fDusVuuco
|
@ -1,12 +0,0 @@
|
|||||||
diff -up firefox-55.0/js/src/jit/AtomicOperations.h.1253216 firefox-55.0/js/src/jit/AtomicOperations.h
|
|
||||||
--- firefox-55.0/js/src/jit/AtomicOperations.h.1253216 2017-08-02 11:00:24.115991657 +0200
|
|
||||||
+++ firefox-55.0/js/src/jit/AtomicOperations.h 2017-08-02 11:01:17.373817096 +0200
|
|
||||||
@@ -348,7 +348,7 @@ AtomicOperations::isLockfree(int32_t siz
|
|
||||||
# elif defined(__sh__)
|
|
||||||
# include "jit/none/AtomicOperations-feeling-lucky.h"
|
|
||||||
# else
|
|
||||||
-# include "jit/none/AtomicOperations-none.h" // These MOZ_CRASH() always
|
|
||||||
+# include "jit/none/AtomicOperations-ppc.h"
|
|
||||||
# endif
|
|
||||||
#elif defined(JS_CODEGEN_X86) || defined(JS_CODEGEN_X64)
|
|
||||||
# include "jit/x86-shared/AtomicOperations-x86-shared.h"
|
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
|||||||
SHA512 (firefox-55.0.2.source.tar.xz) = a27722cb5840aac89752fea0880a7e093e84b50dc78a36dc8c4bd493ffda10fa61446007f680bfe65db7a0debe4c21e6f0bf9f0de9876bba067abdda6fed7be4
|
SHA512 (firefox-55.0.3.source.tar.xz) = 3cacc87b97871f3a8c5e97c17ef7025079cb5c81f32377d9402cdad45815ac6c4c4762c79187f1e477910161c2377c42d41de62a50b6741d5d7c1cd70e8c6416
|
||||||
SHA512 (firefox-langpacks-55.0.2-20170818.tar.xz) = f7fdc775f83cb0d4ee2a20bd6d9f138c8007b0139a24e55210266804271660cc67ab458b2da674f9f0347e1a078250986074dc9ec71b3d47439743aca23d2965
|
SHA512 (firefox-langpacks-55.0.3-20170901.tar.xz) = 582f104e20be5831bc9a3862910a321f8868c26331c3ed01405e484da7909f3e8ff1f491702c48aafd9bc1d2a2fc6cbb15eb6fa94d083076896b8342b14a3466
|
||||||
|
Loading…
Reference in New Issue
Block a user