Updated to 82.0.2
, Removed mzbz#1668771 due to rhbz#1888920
This commit is contained in:
parent
8d5bd7e350
commit
496994f3a2
2
.gitignore
vendored
2
.gitignore
vendored
@ -426,3 +426,5 @@ firefox-3.6.4.source.tar.bz2
|
||||
/firefox-langpacks-82.0-20201015.tar.xz
|
||||
/firefox-82.0.1.source.tar.xz
|
||||
/firefox-langpacks-82.0.1-20201028.tar.xz
|
||||
/firefox-82.0.2.source.tar.xz
|
||||
/firefox-langpacks-82.0.2-20201029.tar.xz
|
||||
|
10
firefox.spec
10
firefox.spec
@ -110,13 +110,13 @@ ExcludeArch: s390x
|
||||
|
||||
Summary: Mozilla Firefox Web browser
|
||||
Name: firefox
|
||||
Version: 82.0.1
|
||||
Version: 82.0.2
|
||||
Release: 1%{?dist}
|
||||
URL: https://www.mozilla.org/firefox/
|
||||
License: MPLv1.1 or GPLv2+ or LGPLv2+
|
||||
Source0: https://archive.mozilla.org/pub/firefox/releases/%{version}%{?pre_version}/source/firefox-%{version}%{?pre_version}.source.tar.xz
|
||||
%if %{with langpacks}
|
||||
Source1: firefox-langpacks-%{version}%{?pre_version}-20201028.tar.xz
|
||||
Source1: firefox-langpacks-%{version}%{?pre_version}-20201029.tar.xz
|
||||
%endif
|
||||
Source2: cbindgen-vendor.tar.xz
|
||||
Source10: firefox-mozconfig
|
||||
@ -173,7 +173,6 @@ Patch407: mozilla-1667096.patch
|
||||
Patch408: mozilla-1663844.patch
|
||||
Patch409: mozilla-1640567.patch
|
||||
Patch410: mozilla-1661192.patch
|
||||
Patch411: mozilla-1668771.patch
|
||||
Patch412: mozilla-1634404.patch
|
||||
Patch413: mozilla-1669495.patch
|
||||
Patch414: mozilla-1656727.patch
|
||||
@ -384,7 +383,6 @@ This package contains results of tests executed during build.
|
||||
%patch408 -p1 -b .1663844
|
||||
%patch409 -p1 -b .1640567
|
||||
%patch410 -p1 -b .1661192
|
||||
%patch411 -p1 -b .1668771
|
||||
%patch412 -p1 -b .1634404
|
||||
%patch413 -p1 -b .1669495
|
||||
%patch414 -p1 -b .1656727
|
||||
@ -991,6 +989,10 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
||||
#---------------------------------------------------------------------
|
||||
|
||||
%changelog
|
||||
* Thu Oct 29 2020 Martin Stransky <stransky@redhat.com> - 82.0.2-1
|
||||
- Updated to 82.0.2
|
||||
- Removed mzbz#1668771 due to rhbz#1888920
|
||||
|
||||
* Wed Oct 28 2020 Martin Stransky <stransky@redhat.com> - 82.0.1-1
|
||||
- Updated to 82.0.1
|
||||
|
||||
|
@ -1,41 +0,0 @@
|
||||
changeset: 552978:b50cb0696eef
|
||||
tag: tip
|
||||
parent: 552976:2ce12e3e063c
|
||||
user: stransky <stransky@redhat.com>
|
||||
date: Fri Oct 02 12:19:53 2020 +0200
|
||||
files: widget/gtk/WindowSurfaceWayland.cpp
|
||||
description:
|
||||
Bug 1668771 [Wayland] Use timeout for frame callbacks for basic compositor, r?jhorak
|
||||
|
||||
Differential Revision: https://phabricator.services.mozilla.com/D92200
|
||||
|
||||
|
||||
diff --git a/widget/gtk/WindowSurfaceWayland.cpp b/widget/gtk/WindowSurfaceWayland.cpp
|
||||
--- a/widget/gtk/WindowSurfaceWayland.cpp
|
||||
+++ b/widget/gtk/WindowSurfaceWayland.cpp
|
||||
@@ -37,6 +37,9 @@ extern mozilla::LazyLogModule gWidgetWay
|
||||
// Maximal compositing timeout it miliseconds
|
||||
#define COMPOSITING_TIMEOUT 200
|
||||
|
||||
+// Maximal timeout between frame callbacks
|
||||
+#define FRAME_CALLBACK_TIMEOUT 20
|
||||
+
|
||||
namespace mozilla {
|
||||
namespace widget {
|
||||
|
||||
@@ -941,8 +944,12 @@ void WindowSurfaceWayland::CommitWayland
|
||||
if (waylandSurface == mLastCommittedSurface) {
|
||||
LOGWAYLAND((" [%p] wait for frame callback.\n", (void*)this));
|
||||
// We have an active frame callback pending from our recent surface.
|
||||
- // It means we should defer the commit to FrameCallbackHandler().
|
||||
- return;
|
||||
+ // It means we should defer the commit to FrameCallbackHandler(),
|
||||
+ // but only if we're under frame callback timeout range.
|
||||
+ if (mLastCommitTime && (g_get_monotonic_time() / 1000) - mLastCommitTime <
|
||||
+ FRAME_CALLBACK_TIMEOUT) {
|
||||
+ return;
|
||||
+ }
|
||||
}
|
||||
// If our stored wl_surface does not match the actual one it means the frame
|
||||
// callback is no longer active and we should release it.
|
||||
|
4
sources
4
sources
@ -1,3 +1,3 @@
|
||||
SHA512 (cbindgen-vendor.tar.xz) = f0425020e2d43a3d28b03f82bdb9719728112a2c94b1d595da384d0674ca21d0940a6f729a690434d670e598fbc6bb5193c89da0a4633a734c70dd786222e711
|
||||
SHA512 (firefox-82.0.1.source.tar.xz) = a64b209c8844e057bc83c160570bfabbd06aab5b6cd9658c5c6d58fec89417e69a14abe4a47b8cd8c8dba056753b8c1421d833be23bbe0cb9ebcde8bfb32017c
|
||||
SHA512 (firefox-langpacks-82.0.1-20201028.tar.xz) = 6f82befdf9074566effc9d1c82af18008a117717c610972a6953eca85e56670366bd620611aff6de4d0946f88b2540356d4e4439cfcf44b35d3f046f3a1caed4
|
||||
SHA512 (firefox-82.0.2.source.tar.xz) = f38c88d8213552b7bf66d87bd7880761b14f592ca55eae71d4c2587d5598631aefede03b0c6b3163230210ccaf4b50d84821757615da0c150c5c9db258bfc98b
|
||||
SHA512 (firefox-langpacks-82.0.2-20201029.tar.xz) = aa4875809547f428b5d4ce8943925a251a12cb274fb7ab5ec2ffd38c2f77c412336d7284139248d177bf7b099878d76ab4849e8274c63b15cf771197837420ca
|
||||
|
Loading…
Reference in New Issue
Block a user