Update to 15.0
This commit is contained in:
parent
69f696677c
commit
474f5093a6
26
firefox-15.0-enable-addons.patch
Normal file
26
firefox-15.0-enable-addons.patch
Normal file
@ -0,0 +1,26 @@
|
||||
diff -up firefox-15.0/mozilla-beta/browser/app/profile/firefox.js.addons firefox-15.0/mozilla-beta/browser/app/profile/firefox.js
|
||||
--- firefox-15.0/mozilla-beta/browser/app/profile/firefox.js.addons 2012-08-15 07:47:02.000000000 +0200
|
||||
+++ firefox-15.0/mozilla-beta/browser/app/profile/firefox.js 2012-08-21 11:57:35.333981299 +0200
|
||||
@@ -61,7 +61,7 @@ pref("extensions.hotfix.certs.1.sha1Fing
|
||||
|
||||
// Disable add-ons that are not installed by the user in all scopes by default.
|
||||
// See the SCOPE constants in AddonManager.jsm for values to use here.
|
||||
-pref("extensions.autoDisableScopes", 15);
|
||||
+pref("extensions.autoDisableScopes", 0);
|
||||
|
||||
// Dictionary download preference
|
||||
pref("browser.dictionaries.download.url", "https://addons.mozilla.org/%LOCALE%/firefox/dictionaries/");
|
||||
diff -up firefox-15.0/mozilla-beta/toolkit/mozapps/extensions/XPIProvider.jsm.addons firefox-15.0/mozilla-beta/toolkit/mozapps/extensions/XPIProvider.jsm
|
||||
--- firefox-15.0/mozilla-beta/toolkit/mozapps/extensions/XPIProvider.jsm.addons 2012-08-15 07:48:32.000000000 +0200
|
||||
+++ firefox-15.0/mozilla-beta/toolkit/mozapps/extensions/XPIProvider.jsm 2012-08-21 11:56:41.441980035 +0200
|
||||
@@ -1630,8 +1630,8 @@ var XPIProvider = {
|
||||
this.showUpgradeUI();
|
||||
flushCaches = true;
|
||||
}
|
||||
- else if (aAppChanged === undefined) {
|
||||
- // For new profiles we will never need to show the add-on selection UI
|
||||
+ else {
|
||||
+ // For all profiles we will never need to show the add-on selection UI
|
||||
Services.prefs.setBoolPref(PREF_SHOWN_SELECTION_UI, true);
|
||||
}
|
||||
|
@ -1,26 +0,0 @@
|
||||
diff -up firefox-8.0/mozilla-release/browser/app/profile/firefox.js.addons firefox-8.0/mozilla-release/browser/app/profile/firefox.js
|
||||
--- firefox-8.0/mozilla-release/browser/app/profile/firefox.js.addons 2011-11-04 22:33:52.000000000 +0100
|
||||
+++ firefox-8.0/mozilla-release/browser/app/profile/firefox.js 2011-11-15 10:35:31.446869396 +0100
|
||||
@@ -77,7 +77,7 @@ pref("extensions.update.autoUpdateDefaul
|
||||
// Disable add-ons installed into the shared user and shared system areas by
|
||||
// default. This does not include the application directory. See the SCOPE
|
||||
// constants in AddonManager.jsm for values to use here
|
||||
-pref("extensions.autoDisableScopes", 15);
|
||||
+pref("extensions.autoDisableScopes", 0);
|
||||
|
||||
// Dictionary download preference
|
||||
pref("browser.dictionaries.download.url", "https://addons.mozilla.org/%LOCALE%/firefox/dictionaries/");
|
||||
diff -up firefox-8.0/mozilla-release/toolkit/mozapps/extensions/XPIProvider.jsm.addons firefox-8.0/mozilla-release/toolkit/mozapps/extensions/XPIProvider.jsm
|
||||
--- firefox-8.0/mozilla-release/toolkit/mozapps/extensions/XPIProvider.jsm.addons 2011-11-04 22:34:18.000000000 +0100
|
||||
+++ firefox-8.0/mozilla-release/toolkit/mozapps/extensions/XPIProvider.jsm 2011-11-15 10:42:17.866426274 +0100
|
||||
@@ -1591,8 +1591,8 @@ var XPIProvider = {
|
||||
this.showUpgradeUI();
|
||||
flushCaches = true;
|
||||
}
|
||||
- else if (aAppChanged === undefined) {
|
||||
- // For new profiles we will never need to show the add-on selection UI
|
||||
+ else {
|
||||
+ // For all profiles we will never need to show the add-on selection UI
|
||||
Services.prefs.setBoolPref(PREF_SHOWN_SELECTION_UI, true);
|
||||
}
|
||||
|
16
firefox.spec
16
firefox.spec
@ -16,7 +16,7 @@
|
||||
%define default_bookmarks_file %{_datadir}/bookmarks/default-bookmarks.html
|
||||
%define firefox_app_id \{ec8030f7-c20a-464f-9b0e-13a3a9e97384\}
|
||||
|
||||
%global xulrunner_version 14.0.1
|
||||
%global xulrunner_version 15.0
|
||||
%global xulrunner_release 1
|
||||
%global alpha_version 0
|
||||
%global beta_version 0
|
||||
@ -33,14 +33,17 @@
|
||||
%if %{alpha_version} > 0
|
||||
%global pre_version a%{alpha_version}
|
||||
%global pre_name alpha%{alpha_version}
|
||||
%global tarballdir mozilla-alpha
|
||||
%endif
|
||||
%if %{beta_version} > 0
|
||||
%global pre_version b%{beta_version}
|
||||
%global pre_name beta%{beta_version}
|
||||
%global tarballdir mozilla-beta
|
||||
%endif
|
||||
%if %{rc_version} > 0
|
||||
%global pre_version rc%{rc_version}
|
||||
%global pre_name rc%{rc_version}
|
||||
%global tarballdir mozilla-release
|
||||
%endif
|
||||
%if %{defined pre_version}
|
||||
%global xulrunner_verrel %{xulrunner_version}-%{xulrunner_release}%{pre_name}
|
||||
@ -51,14 +54,14 @@
|
||||
|
||||
Summary: Mozilla Firefox Web browser
|
||||
Name: firefox
|
||||
Version: 14.0.1
|
||||
Release: 2%{?pre_tag}%{?dist}
|
||||
Version: 15.0
|
||||
Release: 1%{?pre_tag}%{?dist}
|
||||
URL: http://www.mozilla.org/projects/firefox/
|
||||
License: MPLv1.1 or GPLv2+ or LGPLv2+
|
||||
Group: Applications/Internet
|
||||
Source0: ftp://ftp.mozilla.org/pub/firefox/releases/%{version}%{?pre_version}/source/firefox-%{version}%{?pre_version}.source.tar.bz2
|
||||
%if %{build_langpacks}
|
||||
Source1: firefox-langpacks-%{version}%{?pre_version}-20120716.tar.xz
|
||||
Source1: firefox-langpacks-%{version}%{?pre_version}-20120827.tar.xz
|
||||
%endif
|
||||
Source10: firefox-mozconfig
|
||||
Source11: firefox-mozconfig-branded
|
||||
@ -73,7 +76,7 @@ Patch0: firefox-install-dir.patch
|
||||
|
||||
# Fedora patches
|
||||
Patch14: firefox-5.0-asciidel.patch
|
||||
Patch15: firefox-8.0-enable-addons.patch
|
||||
Patch15: firefox-15.0-enable-addons.patch
|
||||
|
||||
# Upstream patches
|
||||
|
||||
@ -391,6 +394,9 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
||||
#---------------------------------------------------------------------
|
||||
|
||||
%changelog
|
||||
* Mon Aug 27 2012 Martin Stransky <stransky@redhat.com> - 15.0-1
|
||||
- Update to 15.0
|
||||
|
||||
* Wed Aug 1 2012 Martin Stransky <stransky@redhat.com> - 14.0.1-2
|
||||
- removed StartupWMClass (rhbz#844860)
|
||||
|
||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
c2f884f0f6c41c65cf20f678a1ee7191 firefox-14.0.1.source.tar.bz2
|
||||
5b9d27ba6054b9c81e41572898fb813d firefox-langpacks-14.0.1-20120716.tar.xz
|
||||
64220887a349515f16e5aa990acb4db3 firefox-15.0.source.tar.bz2
|
||||
8b93954aa49bff344386b03977b81409 firefox-langpacks-15.0-20120827.tar.xz
|
||||
|
Loading…
Reference in New Issue
Block a user