eliminate the offset in some patches

This commit is contained in:
Kamil Dudka 2010-05-10 16:16:43 +00:00
parent 593142936c
commit e1f9543c9d
2 changed files with 18 additions and 8 deletions

View File

@ -1,3 +1,13 @@
NEWS | 6 +++
doc/find.texi | 17 +++++++
find/Makefile.am | 2 +-
find/defs.h | 6 +++
find/find.1 | 4 ++
find/parser.c | 128 +++++++++++++++++++++++++++++++++++++++++++++++++++++-
find/pred.c | 47 ++++++++++++++++++++
find/tree.c | 2 +
8 files changed, 209 insertions(+), 3 deletions(-)
diff --git a/NEWS b/NEWS
index d00862f..6b8b725 100644
--- a/NEWS
@ -130,7 +140,7 @@ index f9c61a3..27ad1da 100644
A `%' character followed by any other character is discarded, but the
other character is printed (don't rely on this, as further format
diff --git a/find/parser.c b/find/parser.c
index 036ddb8..6b09eee 100644
index 411fd96..3f237eb 100644
--- a/find/parser.c
+++ b/find/parser.c
@@ -53,6 +53,8 @@
@ -323,7 +333,7 @@ index 036ddb8..6b09eee 100644
parse_xdev (const struct parser_table* entry, char **argv, int *arg_ptr)
{
options.stay_on_filesystem = true;
@@ -2815,7 +2934,7 @@ insert_fprintf (struct format_val *vec,
@@ -2812,7 +2931,7 @@ insert_fprintf (struct format_val *vec,
if (*scan2 == '.')
for (scan2++; ISDIGIT (*scan2); scan2++)
/* Do nothing. */ ;
@ -332,7 +342,7 @@ index 036ddb8..6b09eee 100644
{
segmentp = make_segment (segmentp, format, scan2 - format,
KIND_FORMAT, *scan2, 0,
@@ -2945,6 +3064,11 @@ make_segment (struct segment **segment,
@@ -2942,6 +3061,11 @@ make_segment (struct segment **segment,
*fmt++ = 's';
break;

View File

@ -403,7 +403,7 @@ index 838b81f..9945abd 100644
/* If "-exec ... {} +" has been used, there may be some
diff --git a/find/parser.c b/find/parser.c
index 6b09eee..612cf71 100644
index 3f237eb..b96d317 100644
--- a/find/parser.c
+++ b/find/parser.c
@@ -181,7 +181,6 @@ static struct segment **make_segment PARAMS((struct segment **segment,
@ -446,7 +446,7 @@ index 6b09eee..612cf71 100644
}
boolean
@@ -3161,11 +3160,10 @@ check_path_safety(const char *action, char **argv)
@@ -3158,11 +3157,10 @@ check_path_safety(const char *action, char **argv)
/* handles both exec and ok predicate */
static boolean
@ -462,7 +462,7 @@ index 6b09eee..612cf71 100644
{
int start, end; /* Indexes in ARGV of start & end of cmd. */
int i; /* Index into cmd args */
@@ -3186,6 +3184,7 @@ new_insert_exec_ok (const char *action,
@@ -3183,6 +3181,7 @@ new_insert_exec_ok (const char *action,
our_pred->need_type = our_pred->need_stat = false;
execp = &our_pred->args.exec_vec;
@ -470,7 +470,7 @@ index 6b09eee..612cf71 100644
if ((func != pred_okdir) && (func != pred_ok))
{
@@ -3205,13 +3204,14 @@ new_insert_exec_ok (const char *action,
@@ -3202,13 +3201,14 @@ new_insert_exec_ok (const char *action,
if ((func == pred_execdir) || (func == pred_okdir))
{
@ -487,7 +487,7 @@ index 6b09eee..612cf71 100644
}
our_pred->args.exec_vec.multiple = 0;
@@ -3364,17 +3364,6 @@ new_insert_exec_ok (const char *action,
@@ -3361,17 +3361,6 @@ new_insert_exec_ok (const char *action,