- 4.2.25.

This commit is contained in:
Tim Waugh 2005-09-05 10:26:32 +00:00
parent 248647ce69
commit b7ce6594e9
4 changed files with 74 additions and 69 deletions

View File

@ -3,3 +3,4 @@ findutils-4.2.15.tar.gz
findutils-4.2.18.tar.gz findutils-4.2.18.tar.gz
findutils-4.2.20.tar.gz findutils-4.2.20.tar.gz
findutils-4.2.23.tar.gz findutils-4.2.23.tar.gz
findutils-4.2.25.tar.gz

View File

@ -1,6 +1,6 @@
--- findutils-4.2.23/find/util.c.selinux 2005-06-07 23:18:41.000000000 +0100 --- findutils-4.2.25/find/util.c.selinux 2005-06-19 20:01:58.000000000 +0000
+++ findutils-4.2.23/find/util.c 2005-06-20 09:43:21.000000000 +0100 +++ findutils-4.2.25/find/util.c 2005-09-05 10:15:31.000000000 +0000
@@ -70,6 +70,9 @@ @@ -78,6 +78,9 @@
last_pred->need_stat = true; last_pred->need_stat = true;
last_pred->need_type = true; last_pred->need_type = true;
last_pred->args.str = NULL; last_pred->args.str = NULL;
@ -10,9 +10,9 @@
last_pred->pred_next = NULL; last_pred->pred_next = NULL;
last_pred->pred_left = NULL; last_pred->pred_left = NULL;
last_pred->pred_right = NULL; last_pred->pred_right = NULL;
--- findutils-4.2.23/find/find.c.selinux 2005-06-19 09:48:00.000000000 +0100 --- findutils-4.2.25/find/find.c.selinux 2005-08-30 07:40:03.000000000 +0000
+++ findutils-4.2.23/find/find.c 2005-06-20 09:43:21.000000000 +0100 +++ findutils-4.2.25/find/find.c 2005-09-05 10:16:37.000000000 +0000
@@ -239,6 +239,93 @@ @@ -244,6 +244,93 @@
{ {
return lstat(name, p); return lstat(name, p);
} }
@ -106,7 +106,7 @@
#ifdef DEBUG_STAT #ifdef DEBUG_STAT
static uintmax_t stat_count = 0u; static uintmax_t stat_count = 0u;
@@ -267,11 +354,17 @@ @@ -272,11 +359,17 @@
{ {
case SYMLINK_ALWAYS_DEREF: /* -L */ case SYMLINK_ALWAYS_DEREF: /* -L */
options.xstat = optionl_stat; options.xstat = optionl_stat;
@ -124,7 +124,7 @@
/* Can't turn no_leaf_check off because the user might have specified /* Can't turn no_leaf_check off because the user might have specified
* -noleaf anyway * -noleaf anyway
*/ */
@@ -279,6 +372,9 @@ @@ -284,6 +377,9 @@
case SYMLINK_DEREF_ARGSONLY: /* -H */ case SYMLINK_DEREF_ARGSONLY: /* -H */
options.xstat = optionh_stat; options.xstat = optionh_stat;
@ -134,7 +134,7 @@
options.no_leaf_check = true; options.no_leaf_check = true;
} }
@@ -384,6 +480,9 @@ @@ -389,6 +485,9 @@
int int
main (int argc, char **argv) main (int argc, char **argv)
{ {
@ -142,9 +142,9 @@
+ int is_selinux_enabled_flag = is_selinux_enabled()>0; + int is_selinux_enabled_flag = is_selinux_enabled()>0;
+#endif /* WITH_SELINUX */ +#endif /* WITH_SELINUX */
int i; int i;
PARSE_FUNC parse_function; /* Pointer to the function which parses. */ const struct parser_table *parse_entry; /* Pointer to the parsing table entry for this expression. */
struct predicate *cur_pred; struct predicate *cur_pred;
@@ -512,6 +611,14 @@ @@ -537,6 +636,14 @@
if (strchr ("-!(),", argv[i][0]) == NULL) if (strchr ("-!(),", argv[i][0]) == NULL)
usage (_("paths must precede expression")); usage (_("paths must precede expression"));
predicate_name = argv[i]; predicate_name = argv[i];
@ -156,12 +156,12 @@
+ } + }
+ } + }
+#endif +#endif
parse_function = find_parser (predicate_name); parse_entry = find_parser (predicate_name);
if (parse_function == NULL) if (parse_entry == NULL)
/* Command line option not recognized */ {
--- findutils-4.2.23/find/find.1.selinux 2005-06-19 09:48:00.000000000 +0100 --- findutils-4.2.25/find/find.1.selinux 2005-09-02 20:46:48.000000000 +0000
+++ findutils-4.2.23/find/find.1 2005-06-20 09:43:21.000000000 +0100 +++ findutils-4.2.25/find/find.1 2005-09-05 10:15:31.000000000 +0000
@@ -443,6 +443,9 @@ @@ -455,6 +455,9 @@
link to a file of type \fIc\fR; if the \-L option has been given, true link to a file of type \fIc\fR; if the \-L option has been given, true
if \fIc\fR is `l'. In other words, for symbolic links, \-xtype checks if \fIc\fR is `l'. In other words, for symbolic links, \-xtype checks
the type of the file that \-type does not check. the type of the file that \-type does not check.
@ -171,7 +171,7 @@
.SS ACTIONS .SS ACTIONS
.IP "\-delete\fR" .IP "\-delete\fR"
@@ -735,6 +738,8 @@ @@ -753,6 +756,8 @@
File's type (like in ls \-l), U=unknown type (shouldn't happen) File's type (like in ls \-l), U=unknown type (shouldn't happen)
.IP %Y .IP %Y
File's type (like %y), plus follow symlinks: L=loop, N=nonexistent File's type (like %y), plus follow symlinks: L=loop, N=nonexistent
@ -180,19 +180,19 @@
.PP .PP
A `%' character followed by any other character is discarded (but the A `%' character followed by any other character is discarded (but the
other character is printed). other character is printed).
--- findutils-4.2.23/find/Makefile.in.selinux 2005-06-19 12:28:32.000000000 +0100 --- findutils-4.2.25/find/Makefile.in.selinux 2005-09-03 11:17:59.000000000 +0000
+++ findutils-4.2.23/find/Makefile.in 2005-06-20 09:43:21.000000000 +0100 +++ findutils-4.2.25/find/Makefile.in 2005-09-05 10:15:31.000000000 +0000
@@ -175,7 +175,7 @@ @@ -175,7 +175,7 @@
CPP = @CPP@ CROSS_COMPILING_FALSE = @CROSS_COMPILING_FALSE@
CPPFLAGS = @CPPFLAGS@ CROSS_COMPILING_TRUE = @CROSS_COMPILING_TRUE@
CYGPATH_W = @CYGPATH_W@ CYGPATH_W = @CYGPATH_W@
-DEFS = @DEFS@ -DEFS = @DEFS@
+DEFS = @DEFS@ -I. -I$(srcdir) -I.. -DWITH_SELINUX +DEFS = @DEFS@ -I. -I$(srcdir) -I.. -DWITH_SELINUX
DEPDIR = @DEPDIR@ DEPDIR = @DEPDIR@
ECHO_C = @ECHO_C@ ECHO_C = @ECHO_C@
ECHO_N = @ECHO_N@ ECHO_N = @ECHO_N@
@@ -268,7 +268,7 @@ @@ -270,7 +270,7 @@
localedir = $(datadir)/locale # regexprops_SOURCES = regexprops.c
find_SOURCES = find.c fstype.c parser.c pred.c tree.c util.c version.c find_SOURCES = find.c fstype.c parser.c pred.c tree.c util.c version.c
EXTRA_DIST = defs.h $(man_MANS) EXTRA_DIST = defs.h $(man_MANS)
-LDADD = ../lib/libfind.a ../gnulib/lib/libgnulib.a @INTLLIBS@ -LDADD = ../lib/libfind.a ../gnulib/lib/libgnulib.a @INTLLIBS@
@ -200,9 +200,9 @@
man_MANS = find.1 man_MANS = find.1
SUBDIRS = testsuite SUBDIRS = testsuite
all: all-recursive all: all-recursive
--- findutils-4.2.23/find/defs.h.selinux 2005-06-19 09:48:00.000000000 +0100 --- findutils-4.2.25/find/defs.h.selinux 2005-08-30 07:36:24.000000000 +0000
+++ findutils-4.2.23/find/defs.h 2005-06-20 09:44:07.000000000 +0100 +++ findutils-4.2.25/find/defs.h 2005-09-05 10:17:20.000000000 +0000
@@ -130,6 +130,10 @@ @@ -131,6 +131,10 @@
#define MODE_RWX (S_IXUSR | S_IXGRP | S_IXOTH | MODE_RW) #define MODE_RWX (S_IXUSR | S_IXGRP | S_IXOTH | MODE_RW)
#define MODE_ALL (S_ISUID | S_ISGID | S_ISVTX | MODE_RWX) #define MODE_ALL (S_ISUID | S_ISGID | S_ISVTX | MODE_RWX)
@ -213,7 +213,7 @@
#if 1 #if 1
#include <stdbool.h> #include <stdbool.h>
typedef bool boolean; typedef bool boolean;
@@ -318,6 +322,9 @@ @@ -320,6 +324,9 @@
struct dir_id fileid; /* samefile */ struct dir_id fileid; /* samefile */
mode_t type; /* type */ mode_t type; /* type */
FILE *stream; /* ls fls fprint0 */ FILE *stream; /* ls fls fprint0 */
@ -223,7 +223,7 @@
struct format_val printf_vec; /* printf fprintf fprint */ struct format_val printf_vec; /* printf fprintf fprint */
} args; } args;
@@ -451,6 +458,9 @@ @@ -479,6 +486,9 @@
boolean pred_used PARAMS((char *pathname, struct stat *stat_buf, struct predicate *pred_ptr)); boolean pred_used PARAMS((char *pathname, struct stat *stat_buf, struct predicate *pred_ptr));
boolean pred_user PARAMS((char *pathname, struct stat *stat_buf, struct predicate *pred_ptr)); boolean pred_user PARAMS((char *pathname, struct stat *stat_buf, struct predicate *pred_ptr));
boolean pred_xtype PARAMS((char *pathname, struct stat *stat_buf, struct predicate *pred_ptr)); boolean pred_xtype PARAMS((char *pathname, struct stat *stat_buf, struct predicate *pred_ptr));
@ -231,22 +231,23 @@
+boolean pred_scontext PARAMS((char *pathname, struct stat *stat_buf, struct predicate *pred_ptr)); +boolean pred_scontext PARAMS((char *pathname, struct stat *stat_buf, struct predicate *pred_ptr));
+#endif /* WITH_SELINUX */ +#endif /* WITH_SELINUX */
int launch PARAMS((const struct buildcmd_control *ctl,
struct buildcmd_state *buildstate));
@@ -531,6 +541,9 @@ @@ -568,6 +578,10 @@
* flag to open(2). * can be changed with the positional option, -regextype.
*/ */
boolean open_nofollow_available; int regex_options;
+
+#ifdef WITH_SELINUX +#ifdef WITH_SELINUX
+ int (*x_getfilecon) (); + int (*x_getfilecon) ();
+#endif /* WITH_SELINUX */ +#endif /* WITH_SELINUX */
}; };
extern struct options options; extern struct options options;
--- findutils-4.2.23/find/Makefile.am.selinux 2005-06-07 23:18:41.000000000 +0100 --- findutils-4.2.25/find/Makefile.am.selinux 2005-07-03 16:07:16.000000000 +0000
+++ findutils-4.2.23/find/Makefile.am 2005-06-20 09:43:21.000000000 +0100 +++ findutils-4.2.25/find/Makefile.am 2005-09-05 10:15:31.000000000 +0000
@@ -3,8 +3,9 @@ @@ -5,8 +5,9 @@
bin_PROGRAMS = find # regexprops_SOURCES = regexprops.c
find_SOURCES = find.c fstype.c parser.c pred.c tree.c util.c version.c find_SOURCES = find.c fstype.c parser.c pred.c tree.c util.c version.c
EXTRA_DIST = defs.h $(man_MANS) EXTRA_DIST = defs.h $(man_MANS)
+DEFS = @DEFS@ -I. -I$(srcdir) -I.. -DWITH_SELINUX +DEFS = @DEFS@ -I. -I$(srcdir) -I.. -DWITH_SELINUX
@ -256,11 +257,11 @@
man_MANS = find.1 man_MANS = find.1
SUBDIRS = testsuite SUBDIRS = testsuite
--- findutils-4.2.23/find/parser.c.selinux 2005-06-19 09:48:00.000000000 +0100 --- findutils-4.2.25/find/parser.c.selinux 2005-07-31 21:01:54.000000000 +0000
+++ findutils-4.2.23/find/parser.c 2005-06-20 09:43:21.000000000 +0100 +++ findutils-4.2.25/find/parser.c 2005-09-05 10:20:44.000000000 +0000
@@ -45,6 +45,10 @@ @@ -47,6 +47,10 @@
#endif /* We need <unistd.h> for isatty(). */
#include <unistd.h>
+#ifdef WITH_SELINUX +#ifdef WITH_SELINUX
+#include <selinux/selinux.h> +#include <selinux/selinux.h>
@ -269,26 +270,26 @@
#if ENABLE_NLS #if ENABLE_NLS
# include <libintl.h> # include <libintl.h>
# define _(Text) gettext (Text) # define _(Text) gettext (Text)
@@ -148,6 +152,9 @@ @@ -147,6 +151,9 @@
static boolean parse_warn PARAMS((char *argv[], int *arg_ptr)); static boolean parse_warn PARAMS((const struct parser_table*, char *argv[], int *arg_ptr));
static boolean parse_xtype PARAMS((char *argv[], int *arg_ptr)); static boolean parse_xtype PARAMS((const struct parser_table*, char *argv[], int *arg_ptr));
static boolean parse_quit PARAMS((char *argv[], int *arg_ptr)); static boolean parse_quit PARAMS((const struct parser_table*, char *argv[], int *arg_ptr));
+#ifdef WITH_SELINUX +#ifdef WITH_SELINUX
+static boolean parse_scontext PARAMS((char *argv[], int *arg_ptr)); +static boolean parse_scontext PARAMS((char *argv[], int *arg_ptr));
+#endif /*WITH_SELINUX*/ +#endif /*WITH_SELINUX*/
static boolean insert_regex PARAMS((char *argv[], int *arg_ptr, boolean ignore_case));
static boolean insert_type PARAMS((char *argv[], int *arg_ptr, PRED_FUNC which_pred));
@@ -276,6 +283,8 @@ @@ -298,6 +305,8 @@
{ARG_TEST, "wholename", parse_wholename}, /* GNU, replaces -path */ {ARG_TEST, "-help", parse_help, NULL}, /* GNU */
{ARG_OPTION, "xdev", parse_xdev}, {ARG_TEST, "version", parse_version, NULL}, /* GNU */
{ARG_TEST, "xtype", parse_xtype}, /* GNU */ {ARG_TEST, "-version", parse_version, NULL}, /* GNU */
+ {ARG_TEST, "context", parse_scontext}, /* SELinux */ + {ARG_TEST, "context", parse_scontext, NULL}, /* SELinux */
+ {ARG_TEST, "-context", parse_scontext}, /* SELinux */ + {ARG_TEST, "-context", parse_scontext, NULL}, /* SELinux */
{0, 0, 0} {0, 0, 0, 0}
}; };
@@ -755,6 +764,10 @@ @@ -803,6 +812,10 @@
-nouser -nogroup -path PATTERN -perm [+-]MODE -regex PATTERN\n\ -nouser -nogroup -path PATTERN -perm [+-]MODE -regex PATTERN\n\
-wholename PATTERN -size N[bcwkMG] -true -type [bcdpflsD] -uid N\n\ -wholename PATTERN -size N[bcwkMG] -true -type [bcdpflsD] -uid N\n\
-used N -user NAME -xtype [bcdpfls]\n")); -used N -user NAME -xtype [bcdpfls]\n"));
@ -299,8 +300,8 @@
puts (_("\ puts (_("\
actions: -delete -print0 -printf FORMAT -fprintf FILE FORMAT -print \n\ actions: -delete -print0 -printf FORMAT -fprintf FILE FORMAT -print \n\
-fprint0 FILE -fprint FILE -ls -fls FILE -prune -quit\n\ -fprint0 FILE -fprint FILE -ls -fls FILE -prune -quit\n\
@@ -1670,6 +1683,32 @@ @@ -1712,6 +1725,32 @@
return true; exit (0);
} }
+#ifdef WITH_SELINUX +#ifdef WITH_SELINUX
@ -330,9 +331,9 @@
+#endif /*WITH_SELINUX*/ +#endif /*WITH_SELINUX*/
+ +
static boolean static boolean
parse_xtype (char **argv, int *arg_ptr) parse_xdev (const struct parser_table* entry, char **argv, int *arg_ptr)
{ {
@@ -1867,7 +1906,11 @@ @@ -1949,7 +1988,11 @@
if (*scan2 == '.') if (*scan2 == '.')
for (scan2++; ISDIGIT (*scan2); scan2++) for (scan2++; ISDIGIT (*scan2); scan2++)
/* Do nothing. */ ; /* Do nothing. */ ;
@ -344,8 +345,8 @@
{ {
segmentp = make_segment (segmentp, format, scan2 - format, segmentp = make_segment (segmentp, format, scan2 - format,
(int) *scan2); (int) *scan2);
--- findutils-4.2.23/find/pred.c.selinux 2005-06-07 23:18:41.000000000 +0100 --- findutils-4.2.25/find/pred.c.selinux 2005-09-01 20:57:49.000000000 +0000
+++ findutils-4.2.23/find/pred.c 2005-06-20 09:43:21.000000000 +0100 +++ findutils-4.2.25/find/pred.c 2005-09-05 10:15:31.000000000 +0000
@@ -38,6 +38,14 @@ @@ -38,6 +38,14 @@
#include "buildcmd.h" #include "buildcmd.h"
#include "yesno.h" #include "yesno.h"
@ -379,8 +380,8 @@
{0, "none "} {0, "none "}
}; };
@@ -893,6 +903,26 @@ @@ -903,6 +913,26 @@
mode_to_filetype(stat_buf->st_mode & S_IFMT));
} }
break; break;
+#ifdef WITH_SELINUX +#ifdef WITH_SELINUX
@ -405,8 +406,8 @@
+#endif /* WITH_SELINUX */ +#endif /* WITH_SELINUX */
} }
} }
return (true); return true;
@@ -1470,6 +1500,34 @@ @@ -1480,6 +1510,34 @@
*/ */
return (pred_type (pathname, &sbuf, pred_ptr)); return (pred_type (pathname, &sbuf, pred_ptr));
} }

View File

@ -3,7 +3,7 @@
%endif %endif
Summary: The GNU versions of find utilities (find and xargs). Summary: The GNU versions of find utilities (find and xargs).
Name: findutils Name: findutils
Version: 4.2.23 Version: 4.2.25
Release: 1 Release: 1
Epoch: 1 Epoch: 1
License: GPL License: GPL
@ -91,6 +91,9 @@ rm -rf %{buildroot}
%{_infodir}/find.info* %{_infodir}/find.info*
%changelog %changelog
* Mon Sep 5 2005 Tim Waugh <twaugh@redhat.com> 1:4.2.25-1
- 4.2.25.
* Mon Jun 20 2005 Tim Waugh <twaugh@redhat.com> 1:4.2.23-1 * Mon Jun 20 2005 Tim Waugh <twaugh@redhat.com> 1:4.2.23-1
- 4.2.23. - 4.2.23.

View File

@ -1 +1 @@
ecaff8b060e8d69c10eb2391a8032e26 findutils-4.2.23.tar.gz e92fef6714ffa9972f28a1a423066921 findutils-4.2.25.tar.gz