Update to findutils-4.4.0

This commit is contained in:
vcrhonek 2008-04-30 10:02:05 +00:00
parent 5864214a02
commit b6345615f9
8 changed files with 557 additions and 511 deletions

View File

@ -3,3 +3,5 @@ findutils-4.2.29.tar.gz.sig
findutils-4.2.31.tar.gz
findutils-4.2.32.tar.gz
findutils-4.2.33.tar.gz
findutils-4.4.0.tar.gz
findutils-4.4.0.tar.gz.sig

View File

@ -1,22 +0,0 @@
--- findutils-4.2.31/Makefile.am_old 2007-03-02 01:14:25.000000000 +0100
+++ findutils-4.2.31/Makefile.am 2007-06-12 15:18:53.000000000 +0200
@@ -3,7 +3,7 @@
EXTRA_DIST = COPYING ChangeLog TODO install-sh config.h.in stamp-h.in \
THANKS config.rpath import-gnulib.sh import-gnulib.config
-SUBDIRS = gnulib lib find xargs locate doc po m4
+SUBDIRS = gnulib lib find xargs doc po m4
ACLOCAL_AMFLAGS = -I gnulib/m4 -I m4
--- findutils-4.2.31/Makefile.in_old 2007-06-12 15:18:05.000000000 +0200
+++ findutils-4.2.31/Makefile.in 2007-06-12 15:19:00.000000000 +0200
@@ -423,7 +423,7 @@
EXTRA_DIST = COPYING ChangeLog TODO install-sh config.h.in stamp-h.in \
THANKS config.rpath import-gnulib.sh import-gnulib.config
-SUBDIRS = gnulib lib find xargs locate doc po m4
+SUBDIRS = gnulib lib find xargs doc po m4
ACLOCAL_AMFLAGS = -I gnulib/m4 -I m4
all: config.h
$(MAKE) $(AM_MAKEFLAGS) all-recursive

View File

@ -1,12 +0,0 @@
diff -up findutils-4.2.33/xargs/xargs.c_old findutils-4.2.33/xargs/xargs.c
--- findutils-4.2.33/xargs/xargs.c_old 2008-03-28 14:04:57.000000000 +0100
+++ findutils-4.2.33/xargs/xargs.c 2008-03-28 14:06:54.000000000 +0100
@@ -440,7 +440,7 @@ main (int argc, char **argv)
* specifies that it shall be at least LINE_MAX.
*/
#if defined(ARG_MAX)
- assert(bc_ctl.arg_max <= (ARG_MAX-2048));
+ assert(bc_ctl.arg_max <= bc_ctl.posix_arg_size_max);
#endif
#ifdef LINE_MAX
assert(bc_ctl.arg_max >= LINE_MAX);

View File

@ -0,0 +1,24 @@
diff -up findutils-4.4.0/Makefile.in_old findutils-4.4.0/Makefile.in
--- findutils-4.4.0/Makefile.in_old 2008-04-21 13:32:59.000000000 +0200
+++ findutils-4.4.0/Makefile.in 2008-04-21 13:33:20.000000000 +0200
@@ -572,7 +572,7 @@ EXTRA_DIST = COPYING ChangeLog TODO conf
THANKS import-gnulib.sh import-gnulib.config
# "tests" is the gnulib unit test dir.
-SUBDIRS = gnulib tests build-aux lib find xargs locate doc po m4
+SUBDIRS = gnulib tests build-aux lib find xargs doc po m4
ACLOCAL_AMFLAGS = -I gnulib/m4 -I m4
TESTFILE_SUFFIXES = .exp .xo .xe .xi
all: config.h
diff -up findutils-4.4.0/Makefile.am_old findutils-4.4.0/Makefile.am
--- findutils-4.4.0/Makefile.am_old 2007-11-29 11:50:16.000000000 +0100
+++ findutils-4.4.0/Makefile.am 2008-04-21 13:32:51.000000000 +0200
@@ -4,7 +4,7 @@ AUTOMAKE_OPTIONS=gnits
EXTRA_DIST = COPYING ChangeLog TODO config.h.in stamp-h.in \
THANKS import-gnulib.sh import-gnulib.config
# "tests" is the gnulib unit test dir.
-SUBDIRS = gnulib tests build-aux lib find xargs locate doc po m4
+SUBDIRS = gnulib tests build-aux lib find xargs doc po m4
ACLOCAL_AMFLAGS = -I gnulib/m4 -I m4

View File

@ -0,0 +1,518 @@
diff -up findutils-4.4.0/configure.ac.selinux findutils-4.4.0/configure.ac
--- findutils-4.4.0/configure.ac.selinux 2008-03-15 12:45:00.000000000 +0100
+++ findutils-4.4.0/configure.ac 2008-04-25 16:52:54.000000000 +0200
@@ -114,6 +114,16 @@ AC_CHECK_LIB([m],[fabs],[FINDLIBS="-lm $
AC_DEFINE_UNQUOTED(HAVE_FABS_IN_LIBM,1,[fabs is defined in -lm]))
AC_SUBST([FINDLIBS])
+AC_ARG_WITH([selinux],
+ AS_HELP_STRING([--without-selinux], [disable SELinux support]),
+ [:],
+[AC_CHECK_LIB([selinux], [is_selinux_enabled],
+ [with_selinux=yes], [with_selinux=no])])
+if test x$with_selinux != xno; then
+ AC_DEFINE([WITH_SELINUX], [1], [Define to support SELinux])
+ AC_SUBST([LIBSELINUX], [-lselinux])
+fi
+
dnl Checks for header files.
AC_HEADER_STDC
dnl Assume unistd.h is present - coreutils does too.
diff -up findutils-4.4.0/doc/find.texi.selinux findutils-4.4.0/doc/find.texi
--- findutils-4.4.0/doc/find.texi.selinux 2008-03-10 21:31:16.000000000 +0100
+++ findutils-4.4.0/doc/find.texi 2008-04-29 14:57:42.000000000 +0200
@@ -7,7 +7,6 @@
@c %**end of header
@include version.texi
-@include ../locate/dblocation.texi
@iftex
@finalout
@@ -1242,6 +1241,14 @@ situation.
@end deffn
+@deffn Test -context pattern
+True if file's SELinux context matches the pattern @var{pattern}.
+The pattern uses shell glob matching.
+
+This predicate is supported only on @code{find} versions compiled with
+SELinux support and only when SELinux is enabled.
+@end deffn
+
@node Contents
@section Contents
@@ -1826,6 +1833,9 @@ value used for BLOCKSIZE is system-depen
bytes. If the file size is zero, the value printed is undefined. On
systems which lack support for st_blocks, a file's sparseness is
assumed to be 1.0.
+@item %Z
+File's SELinux context, or empty string if the file has no SELinux context
+or this version of find does not support SELinux.
@end table
@node Location Directives
diff -up findutils-4.4.0/find/find.c.selinux findutils-4.4.0/find/find.c
--- findutils-4.4.0/find/find.c.selinux 2008-03-10 21:26:34.000000000 +0100
+++ findutils-4.4.0/find/find.c 2008-04-28 17:19:26.000000000 +0200
@@ -120,6 +120,36 @@ int get_current_dirfd(void)
return AT_FDCWD;
}
+#ifdef WITH_SELINUX
+static int
+fallback_getfilecon(const char *name, security_context_t *p, int prev_rv)
+{
+ /* Our original getfilecon() call failed. Perhaps we can't follow a
+ * symbolic link. If that might be the problem, lgetfilecon() the link.
+ * Otherwise, admit defeat.
+ */
+ switch (errno)
+ {
+ case ENOENT:
+ case ENOTDIR:
+#ifdef DEBUG_STAT
+ fprintf(stderr, "fallback_getfilecon(): getfilecon(%s) failed; falling back on lgetfilecon()\n", name);
+#endif
+ return lgetfilecon(name, p);
+
+ case EACCES:
+ case EIO:
+ case ELOOP:
+ case ENAMETOOLONG:
+#ifdef EOVERFLOW
+ case EOVERFLOW: /* EOVERFLOW is not #defined on UNICOS. */
+#endif
+ default:
+ return prev_rv;
+ }
+}
+#endif /* WITH_SELINUX */
+
int
main (int argc, char **argv)
@@ -1270,7 +1300,7 @@ process_path (char *pathname, char *name
static void
process_dir (char *pathname, char *name, int pathlen, const struct stat *statp, char *parent)
{
- int subdirs_left; /* Number of unexamined subdirs in PATHNAME. */
+ int subdirs_left = 0; /* Number of unexamined subdirs in PATHNAME. */
boolean subdirs_unreliable; /* if true, cannot use dir link count as subdir limif (if false, it may STILL be unreliable) */
unsigned int idx; /* Which entry are we on? */
struct stat stat_buf;
diff -up findutils-4.4.0/find/find.1.selinux findutils-4.4.0/find/find.1
--- findutils-4.4.0/find/find.1.selinux 2007-12-19 20:53:14.000000000 +0100
+++ findutils-4.4.0/find/find.1 2008-04-25 16:52:54.000000000 +0200
@@ -934,6 +934,8 @@ if \fIc\fR is `l'. In other words, for
checks the type of the file that
.B \-type
does not check.
+.IP "\-context \fIpattern\fR"
+(SELinux only) Security context of the file matches glob \fIpattern\fR.
.SS ACTIONS
.IP "\-delete\fR"
@@ -1340,6 +1342,8 @@ File's type (like in
U=unknown type (shouldn't happen)
.IP %Y
File's type (like %y), plus follow symlinks: L=loop, N=nonexistent
+.IP %Z
+(SELinux only) file's security context.
.PP
A `%' character followed by any other character is discarded, but the
other character is printed (don't rely on this, as further format
diff -up findutils-4.4.0/find/pred.c.selinux findutils-4.4.0/find/pred.c
--- findutils-4.4.0/find/pred.c.selinux 2008-03-10 10:37:22.000000000 +0100
+++ findutils-4.4.0/find/pred.c 2008-04-28 17:09:17.000000000 +0200
@@ -47,6 +47,10 @@
#include "error.h"
#include "verify.h"
+#ifdef WITH_SELINUX
+#include <selinux/selinux.h>
+#endif /*WITH_SELINUX*/
+
#if ENABLE_NLS
# include <libintl.h>
# define _(Text) gettext (Text)
@@ -229,6 +233,9 @@ struct pred_assoc pred_table[] =
{pred_user, "user "},
{pred_writable, "writable "},
{pred_xtype, "xtype "},
+#ifdef WITH_SELINUX
+ {pred_context, "context"},
+#endif /*WITH_SELINUX*/
{0, "none "}
};
#endif
@@ -1053,6 +1060,27 @@ do_fprintf(struct format_val *dest,
mode_to_filetype(stat_buf->st_mode & S_IFMT));
}
break;
+ case 'Z': /* SELinux security context */
+#ifdef WITH_SELINUX
+ {
+ security_context_t scontext;
+ int rv;
+ rv = (*options.x_getfilecon) (state.rel_pathname, &scontext);
+
+ if (rv < 0)
+ {
+ fprintf (stderr, "getfilecon(%s): %s", pathname,
+ strerror(errno));
+ fflush (stderr);
+ }
+ else
+ {
+ checked_fprintf (dest, segment->text, scontext);
+ freecon (scontext);
+ }
+ }
+#endif /* WITH_SELINUX */
+ break;
}
/* end of KIND_FORMAT case */
break;
@@ -1841,6 +1869,33 @@ pred_xtype (const char *pathname, struct
*/
return (pred_type (pathname, &sbuf, pred_ptr));
}
+
+
+#ifdef WITH_SELINUX
+
+boolean
+pred_context (const char *pathname, struct stat *stat_buf,
+ struct predicate *pred_ptr)
+{
+ int rv;
+ security_context_t scontext;
+
+ rv = (*options.x_getfilecon) (state.rel_pathname, &scontext);
+
+ if (rv < 0)
+ {
+ fprintf (stderr, "getfilecon(%s): %s\n", pathname, strerror(errno));
+ fflush (stderr);
+ return false;
+ }
+
+ rv = (fnmatch (pred_ptr->args.scontext, scontext, 0) == 0);
+ freecon (scontext);
+ return rv;
+}
+
+#endif /*WITH_SELINUX*/
+
/* 1) fork to get a child; parent remembers the child pid
2) child execs the command requested
diff -up findutils-4.4.0/find/tree.c.selinux findutils-4.4.0/find/tree.c
--- findutils-4.4.0/find/tree.c.selinux 2007-12-20 22:40:35.000000000 +0100
+++ findutils-4.4.0/find/tree.c 2008-04-30 11:12:46.000000000 +0200
@@ -953,7 +953,8 @@ static struct pred_cost_lookup costlooku
{ pred_used , NeedsStatInfo },
{ pred_user , NeedsStatInfo },
{ pred_writable , NeedsAccessInfo },
- { pred_xtype , NeedsType } /* roughly correct unless most files are symlinks */
+ { pred_xtype , NeedsType }, /* roughly correct unless most files are symlinks */
+ { pred_context , NeedsNothing } /* remove warning only:) */
};
static int pred_table_sorted = 0;
@@ -1434,6 +1435,9 @@ get_new_pred (const struct parser_table
last_pred->need_stat = true;
last_pred->need_type = true;
last_pred->args.str = NULL;
+#ifdef WITH_SELINUX
+ last_pred->args.scontext = NULL;
+#endif
last_pred->pred_next = NULL;
last_pred->pred_left = NULL;
last_pred->pred_right = NULL;
diff -up findutils-4.4.0/find/Makefile.am.selinux findutils-4.4.0/find/Makefile.am
--- findutils-4.4.0/find/Makefile.am.selinux 2007-07-22 14:29:31.000000000 +0200
+++ findutils-4.4.0/find/Makefile.am 2008-04-25 16:52:54.000000000 +0200
@@ -26,7 +26,7 @@ endif
EXTRA_DIST = defs.h $(man_MANS)
INCLUDES = -I../gnulib/lib -I$(top_srcdir)/lib -I$(top_srcdir)/gnulib/lib -I../intl -DLOCALEDIR=\"$(localedir)\"
-LDADD = ./libfindtools.a ../lib/libfind.a ../gnulib/lib/libgnulib.a @INTLLIBS@ @LIB_CLOCK_GETTIME@ @FINDLIBS@
+LDADD = ./libfindtools.a ../lib/libfind.a ../gnulib/lib/libgnulib.a @INTLLIBS@ @LIB_CLOCK_GETTIME@ @FINDLIBS@ @LIBSELINUX@
man_MANS = find.1
SUBDIRS = . testsuite
diff -up findutils-4.4.0/find/parser.c.selinux findutils-4.4.0/find/parser.c
--- findutils-4.4.0/find/parser.c.selinux 2008-03-10 10:37:21.000000000 +0100
+++ findutils-4.4.0/find/parser.c 2008-04-28 15:34:45.000000000 +0200
@@ -53,6 +53,10 @@
#include <unistd.h>
#include <sys/stat.h>
+#ifdef WITH_SELINUX
+#include <selinux/selinux.h>
+#endif
+
#if ENABLE_NLS
# include <libintl.h>
# define _(Text) gettext (Text)
@@ -156,6 +160,9 @@ static boolean parse_noignore_race PARAM
static boolean parse_warn PARAMS((const struct parser_table*, char *argv[], int *arg_ptr));
static boolean parse_xtype PARAMS((const struct parser_table*, char *argv[], int *arg_ptr));
static boolean parse_quit PARAMS((const struct parser_table*, char *argv[], int *arg_ptr));
+#ifdef WITH_SELINUX
+static boolean parse_context PARAMS((const struct parser_table*, char *argv[], int *arg_ptr));
+#endif
boolean parse_print PARAMS((const struct parser_table*, char *argv[], int *arg_ptr));
@@ -252,6 +259,9 @@ static struct parser_table const parse_t
PARSE_TEST ("cmin", cmin), /* GNU */
PARSE_TEST ("cnewer", cnewer), /* GNU */
{ARG_TEST, "ctime", parse_time, pred_ctime}, /* POSIX */
+#ifdef WITH_SELINUX
+ PARSE_TEST ("context", context), /* GNU */
+#endif
PARSE_POSOPT ("daystart", daystart), /* GNU */
PARSE_ACTION ("delete", delete), /* GNU, Mac OS, FreeBSD */
PARSE_OPTION ("d", d), /* Mac OS X, FreeBSD, NetBSD, OpenBSD, but deprecated in favour of -depth */
@@ -348,6 +358,89 @@ static struct parser_table const parse_t
static const char *first_nonoption_arg = NULL;
static const struct parser_table *noop = NULL;
+#ifdef WITH_SELINUX
+static int
+fallback_getfilecon(const char *name, security_context_t *p, int prev_rv)
+{
+ /* Our original getfilecon() call failed. Perhaps we can't follow a
+ * symbolic link. If that might be the problem, lgetfilecon() the link.
+ * Otherwise, admit defeat.
+ */
+ switch (errno)
+ {
+ case ENOENT:
+ case ENOTDIR:
+#ifdef DEBUG_STAT
+ fprintf(stderr, "fallback_getfilecon(): getfilecon(%s) failed; falling back on lgetfilecon()\n", name);
+#endif
+ return lgetfilecon(name, p);
+
+ case EACCES:
+ case EIO:
+ case ELOOP:
+ case ENAMETOOLONG:
+#ifdef EOVERFLOW
+ case EOVERFLOW: /* EOVERFLOW is not #defined on UNICOS. */
+#endif
+ default:
+ return prev_rv;
+ }
+}
+
+/* optionh_getfilecon() implements the getfilecon operation when the
+ * -H option is in effect.
+ *
+ * If the item to be examined is a command-line argument, we follow
+ * symbolic links. If the getfilecon() call fails on the command-line
+ * item, we fall back on the properties of the symbolic link.
+ *
+ * If the item to be examined is not a command-line argument, we
+ * examine the link itself.
+ */
+int
+optionh_getfilecon(const char *name, security_context_t *p)
+{
+ if (0 == state.curdepth)
+ {
+ /* This file is from the command line; deference the link (if it
+ * is a link).
+ */
+ int rv = getfilecon(name, p);
+ if (0 == rv)
+ return 0; /* success */
+ else
+ return fallback_getfilecon(name, p, rv);
+ }
+ else
+ {
+ /* Not a file on the command line; do not derefernce the link.
+ */
+ return lgetfilecon(name, p);
+ }
+}
+/* optionl_getfilecon() implements the getfilecon operation when the
+ * -L option is in effect. That option makes us examine the thing the
+ * symbolic link points to, not the symbolic link itself.
+ */
+int
+optionl_getfilecon(const char *name, security_context_t *p)
+{
+ int rv = getfilecon(name, p);
+ if (0 == rv)
+ return 0; /* normal case. */
+ else
+ return fallback_getfilecon(name, p, rv);
+}
+/* optionp_getfilecon() implements the stat operation when the -P
+ * option is in effect (this is also the default). That option makes
+ * us examine the symbolic link itself, not the thing it points to.
+ */
+int
+optionp_getfilecon(const char *name, security_context_t *p)
+{
+ return lgetfilecon(name, p);
+}
+#endif /* WITH_SELINUX */
void
check_option_combinations(const struct predicate *p)
@@ -451,11 +544,17 @@ set_follow_state(enum SymlinkOption opt)
{
case SYMLINK_ALWAYS_DEREF: /* -L */
options.xstat = optionl_stat;
+#ifdef WITH_SELINUX
+ options.x_getfilecon = optionl_getfilecon;
+#endif
options.no_leaf_check = true;
break;
case SYMLINK_NEVER_DEREF: /* -P (default) */
options.xstat = optionp_stat;
+#ifdef WITH_SELINUX
+ options.x_getfilecon = optionp_getfilecon;
+#endif
/* Can't turn no_leaf_check off because the user might have specified
* -noleaf anyway
*/
@@ -463,6 +562,9 @@ set_follow_state(enum SymlinkOption opt)
case SYMLINK_DEREF_ARGSONLY: /* -H */
options.xstat = optionh_stat;
+#ifdef WITH_SELINUX
+ options.x_getfilecon = optionh_getfilecon;
+#endif
options.no_leaf_check = true;
}
}
@@ -1128,8 +1230,12 @@ tests (N can be +N or -N or N): -amin N
-nouser -nogroup -path PATTERN -perm [+-]MODE -regex PATTERN\n\
-readable -writable -executable\n\
-wholename PATTERN -size N[bcwkMG] -true -type [bcdpflsD] -uid N\n\
- -used N -user NAME -xtype [bcdpfls]\n"));
+ -used N -user NAME -xtype [bcdpfls]"));
+#ifdef WITH_SELINUX
puts (_("\
+ -context CONTEXT\n"));
+#endif
+ puts (_("\n\
actions: -delete -print0 -printf FORMAT -fprintf FILE FORMAT -print \n\
-fprint0 FILE -fprint FILE -ls -fls FILE -prune -quit\n\
-exec COMMAND ; -exec COMMAND {} + -ok COMMAND ;\n\
@@ -2492,6 +2598,10 @@ parse_version (const struct parser_table
printf("LEAF_OPTIMISATION ");
++features;
#endif
+#if defined(WITH_SELINUX)
+ printf("SELINUX ");
+ ++features;
+#endif
flags = 0;
if (is_fts_enabled(&flags))
@@ -2526,6 +2636,32 @@ parse_version (const struct parser_table
exit (0);
}
+#ifdef WITH_SELINUX
+static boolean
+parse_context (const struct parser_table* entry, char **argv, int *arg_ptr)
+{
+ struct predicate *our_pred;
+
+ if ((argv == NULL) || (argv[*arg_ptr] == NULL))
+ return false;
+
+ if (is_selinux_enabled() <= 0)
+ {
+ error (1, 0, _("invalid predicate -context: SELinux is not enabled."));
+ return false;
+ }
+ our_pred = insert_primary (entry);
+ our_pred->need_stat = false;
+#ifdef DEBUG
+ our_pred->p_name = find_pred_name (pred_context);
+#endif /*DEBUG*/
+ our_pred->args.scontext = argv[*arg_ptr];
+
+ (*arg_ptr)++;
+ return true;
+}
+#endif /* WITH_SELINUX */
+
static boolean
parse_xdev (const struct parser_table* entry, char **argv, int *arg_ptr)
{
@@ -2777,7 +2913,7 @@ insert_fprintf (struct format_val *vec,
if (*scan2 == '.')
for (scan2++; ISDIGIT (*scan2); scan2++)
/* Do nothing. */ ;
- if (strchr ("abcdDfFgGhHiklmMnpPsStuUyY", *scan2))
+ if (strchr ("abcdDfFgGhHiklmMnpPsStuUyYZ", *scan2))
{
segmentp = make_segment (segmentp, format, scan2 - format,
KIND_FORMAT, *scan2, 0,
@@ -2904,6 +3040,7 @@ make_segment (struct segment **segment,
case 'h': /* leading directories part of path */
case 'p': /* pathname */
case 'P': /* pathname with ARGV element stripped */
+ case 'Z': /* SELinux security context */
*fmt++ = 's';
break;
diff -up findutils-4.4.0/find/defs.h.selinux findutils-4.4.0/find/defs.h
--- findutils-4.4.0/find/defs.h.selinux 2008-03-10 10:37:21.000000000 +0100
+++ findutils-4.4.0/find/defs.h 2008-04-25 16:52:54.000000000 +0200
@@ -91,6 +91,9 @@ int get_statinfo PARAMS((const char *pat
#define MODE_RWX (S_IXUSR | S_IXGRP | S_IXOTH | MODE_RW)
#define MODE_ALL (S_ISUID | S_ISGID | S_ISVTX | MODE_RWX)
+#ifdef WITH_SELINUX
+#include <selinux/selinux.h>
+#endif
struct predicate;
struct options;
@@ -315,6 +318,9 @@ struct predicate
struct samefile_file_id samefileid; /* samefile */
mode_t type; /* type */
struct format_val printf_vec; /* printf fprintf fprint ls fls print0 fprint0 print */
+#ifdef WITH_SELINUX
+ security_context_t scontext; /* scontext */
+#endif
} args;
/* The next predicate in the user input sequence,
@@ -459,6 +465,9 @@ PREDICATEFUNCTION pred_used;
PREDICATEFUNCTION pred_user;
PREDICATEFUNCTION pred_writable;
PREDICATEFUNCTION pred_xtype;
+#ifdef WITH_SELINUX
+PREDICATEFUNCTION pred_context;
+#endif
@@ -601,6 +610,10 @@ struct options
*/
int regex_options;
+#ifdef WITH_SELINUX
+ int (*x_getfilecon) ();
+#endif
+
/* Optimisation level. One is the default.
*/
unsigned short optimisation_level;

View File

@ -1,468 +0,0 @@
diff -ur --exclude '*.o' --exclude '*~' --exclude '*.selinux' findutils-4.2.27/configure.in findutils/configure.in
--- findutils-4.2.27/configure.in 2005-12-06 07:53:12.000000000 +0100
+++ findutils/configure.in 2006-01-30 21:10:04.000000000 +0100
@@ -95,6 +95,16 @@
AC_CHECK_FUNC(getpwnam, [],
[AC_CHECK_LIB(sun, getpwnam)])
+AC_ARG_WITH([selinux],
+ AS_HELP_STRING([--without-selinux], [disable SELinux support]),
+ [:],
+[AC_CHECK_LIB([selinux], [is_selinux_enabled],
+ [with_selinux=yes], [with_selinux=no])])
+if test x$with_selinux != xno; then
+ AC_DEFINE([WITH_SELINUX], [1], [Define to support SELinux])
+ AC_SUBST([LIBSELINUX], [-lselinux])
+fi
+
dnl Checks for header files.
AC_HEADER_STDC
dnl Assume unistd.h is present - coreutils does too.
diff -ur --exclude '*.o' --exclude '*~' --exclude '*.selinux' findutils-4.2.27/doc/find.texi findutils/doc/find.texi
--- findutils-4.2.27/doc/find.texi 2005-12-05 08:35:33.000000000 +0100
+++ findutils/doc/find.texi 2006-01-30 21:20:10.000000000 +0100
@@ -1091,6 +1091,14 @@
@end deffn
+@deffn Test -context pattern
+True if file's SELinux context matches the pattern @var{pattern}.
+The pattern uses shell glob matching.
+
+This predicate is supported only on @code{find} versions compiled with
+SELinux support and only when SELinux is enabled.
+@end deffn
+
@node Contents
@section Contents
@@ -1610,6 +1618,9 @@
file is a sparse file (that is, it has ``holes'').
@item %s
File's size in bytes.
+@item %Z
+File's SELinux context, or empty string if the file has no SELinux context
+or this version of find does not support SELinux.
@end table
@node Location Directives
diff -ur --exclude '*.o' --exclude '*~' --exclude '*.selinux' findutils-4.2.27/find/defs.h findutils/find/defs.h
--- findutils-4.2.27/find/defs.h 2005-09-04 19:59:34.000000000 +0200
+++ findutils/find/defs.h 2006-01-30 21:15:38.000000000 +0100
@@ -131,6 +131,10 @@
#define MODE_RWX (S_IXUSR | S_IXGRP | S_IXOTH | MODE_RW)
#define MODE_ALL (S_ISUID | S_ISGID | S_ISVTX | MODE_RWX)
+#ifdef WITH_SELINUX
+#include <selinux/selinux.h>
+#endif
+
#if 1
#include <stdbool.h>
typedef bool boolean;
@@ -320,6 +324,9 @@
struct dir_id fileid; /* samefile */
mode_t type; /* type */
FILE *stream; /* ls fls fprint0 */
+#ifdef WITH_SELINUX
+ security_context_t scontext; /* scontext */
+#endif
struct format_val printf_vec; /* printf fprintf fprint */
} args;
@@ -479,6 +486,9 @@
boolean pred_used PARAMS((char *pathname, struct stat *stat_buf, struct predicate *pred_ptr));
boolean pred_user PARAMS((char *pathname, struct stat *stat_buf, struct predicate *pred_ptr));
boolean pred_xtype PARAMS((char *pathname, struct stat *stat_buf, struct predicate *pred_ptr));
+#ifdef WITH_SELINUX
+boolean pred_context PARAMS((char *pathname, struct stat *stat_buf, struct predicate *pred_ptr));
+#endif
@@ -568,6 +578,10 @@
* can be changed with the positional option, -regextype.
*/
int regex_options;
+
+#ifdef WITH_SELINUX
+ int (*x_getfilecon) ();
+#endif
};
extern struct options options;
diff -ur --exclude '*.o' --exclude '*~' --exclude '*.selinux' findutils-4.2.27/find/find.c findutils/find/find.c
--- findutils-4.2.27/find/find.c 2005-11-11 08:41:37.000000000 +0100
+++ findutils/find/find.c 2006-01-30 21:15:21.000000000 +0100
@@ -245,6 +245,93 @@
return lstat(name, p);
}
+#ifdef WITH_SELINUX
+static int
+fallback_getfilecon(const char *name, security_context_t *p, int prev_rv)
+{
+ /* Our original getfilecon() call failed. Perhaps we can't follow a
+ * symbolic link. If that might be the problem, lgetfilecon() the link.
+ * Otherwise, admit defeat.
+ */
+ switch (errno)
+ {
+ case ENOENT:
+ case ENOTDIR:
+#ifdef DEBUG_STAT
+ fprintf(stderr, "fallback_getfilecon(): getfilecon(%s) failed; falling back on lgetfilecon()\n", name);
+#endif
+ return lgetfilecon(name, p);
+
+ case EACCES:
+ case EIO:
+ case ELOOP:
+ case ENAMETOOLONG:
+#ifdef EOVERFLOW
+ case EOVERFLOW: /* EOVERFLOW is not #defined on UNICOS. */
+#endif
+ default:
+ return prev_rv;
+ }
+}
+
+
+/* optionh_getfilecon() implements the getfilecon operation when the
+ * -H option is in effect.
+ *
+ * If the item to be examined is a command-line argument, we follow
+ * symbolic links. If the getfilecon() call fails on the command-line
+ * item, we fall back on the properties of the symbolic link.
+ *
+ * If the item to be examined is not a command-line argument, we
+ * examine the link itself.
+ */
+int
+optionh_getfilecon(const char *name, security_context_t *p)
+{
+ if (0 == state.curdepth)
+ {
+ /* This file is from the command line; deference the link (if it
+ * is a link).
+ */
+ int rv = getfilecon(name, p);
+ if (0 == rv)
+ return 0; /* success */
+ else
+ return fallback_getfilecon(name, p, rv);
+ }
+ else
+ {
+ /* Not a file on the command line; do not derefernce the link.
+ */
+ return lgetfilecon(name, p);
+ }
+}
+
+/* optionl_getfilecon() implements the getfilecon operation when the
+ * -L option is in effect. That option makes us examine the thing the
+ * symbolic link points to, not the symbolic link itself.
+ */
+int
+optionl_getfilecon(const char *name, security_context_t *p)
+{
+ int rv = getfilecon(name, p);
+ if (0 == rv)
+ return 0; /* normal case. */
+ else
+ return fallback_getfilecon(name, p, rv);
+}
+
+/* optionp_getfilecon() implements the stat operation when the -P
+ * option is in effect (this is also the default). That option makes
+ * us examine the symbolic link itself, not the thing it points to.
+ */
+int
+optionp_getfilecon(const char *name, security_context_t *p)
+{
+ return lgetfilecon(name, p);
+}
+#endif /* WITH_SELINUX */
+
#ifdef DEBUG_STAT
static uintmax_t stat_count = 0u;
@@ -272,11 +359,17 @@
{
case SYMLINK_ALWAYS_DEREF: /* -L */
options.xstat = optionl_stat;
+#ifdef WITH_SELINUX
+ options.x_getfilecon = optionl_getfilecon;
+#endif
options.no_leaf_check = true;
break;
case SYMLINK_NEVER_DEREF: /* -P (default) */
options.xstat = optionp_stat;
+#ifdef WITH_SELINUX
+ options.x_getfilecon = optionp_getfilecon;
+#endif
/* Can't turn no_leaf_check off because the user might have specified
* -noleaf anyway
*/
@@ -284,6 +377,9 @@
case SYMLINK_DEREF_ARGSONLY: /* -H */
options.xstat = optionh_stat;
+#ifdef WITH_SELINUX
+ options.x_getfilecon = optionh_getfilecon;
+#endif
options.no_leaf_check = true;
}
@@ -1807,7 +1903,7 @@
static void
process_dir (char *pathname, char *name, int pathlen, struct stat *statp, char *parent)
{
- int subdirs_left; /* Number of unexamined subdirs in PATHNAME. */
+ int subdirs_left=0; /* Number of unexamined subdirs in PATHNAME. */
boolean subdirs_unreliable; /* if true, cannot use dir link count as subdir limif (if false, it may STILL be unreliable) */
int idx; /* Which entry are we on? */
struct stat stat_buf;
diff -ur --exclude '*.o' --exclude '*~' --exclude '*.selinux' findutils-4.2.27/find/find.1 findutils/find/find.1
--- findutils-4.2.27/find/find.1 2005-12-05 18:05:02.000000000 +0100
+++ findutils/find/find.1 2006-01-30 21:46:01.000000000 +0100
@@ -483,6 +483,8 @@
link to a file of type \fIc\fR; if the \-L option has been given, true
if \fIc\fR is `l'. In other words, for symbolic links, \-xtype checks
the type of the file that \-type does not check.
+.IP "\-context \fIpattern\fR"
+(SELinux only) Security context of the file matches glob \fIpattern\fR.
.SS ACTIONS
.IP "\-delete\fR"
@@ -785,6 +787,8 @@
File's type (like in ls \-l), U=unknown type (shouldn't happen)
.IP %Y
File's type (like %y), plus follow symlinks: L=loop, N=nonexistent
+.IP %Z
+(SELinux only) file's security context.
.PP
A `%' character followed by any other character is discarded (but the
other character is printed).
diff -ur --exclude '*.o' --exclude '*~' --exclude '*.selinux' findutils-4.2.27/find/Makefile.am findutils/find/Makefile.am
--- findutils-4.2.27/find/Makefile.am 2005-07-03 18:07:08.000000000 +0200
+++ findutils/find/Makefile.am 2006-01-30 21:46:39.000000000 +0100
@@ -6,7 +6,7 @@
find_SOURCES = find.c fstype.c parser.c pred.c tree.c util.c version.c
EXTRA_DIST = defs.h $(man_MANS)
INCLUDES = -I../gnulib/lib -I$(top_srcdir)/lib -I$(top_srcdir)/gnulib/lib -I../intl -DLOCALEDIR=\"$(localedir)\"
-LDADD = ../lib/libfind.a ../gnulib/lib/libgnulib.a @INTLLIBS@
+LDADD = ../lib/libfind.a ../gnulib/lib/libgnulib.a @INTLLIBS@ @LIBSELINUX@
man_MANS = find.1
SUBDIRS = testsuite
diff -ur --exclude '*.o' --exclude '*~' --exclude '*.selinux' findutils-4.2.27/find/parser.c findutils/find/parser.c
--- findutils-4.2.27/find/parser.c 2005-12-04 03:07:52.000000000 +0100
+++ findutils/find/parser.c 2006-01-30 21:14:46.000000000 +0100
@@ -47,6 +47,10 @@
/* We need <unistd.h> for isatty(). */
#include <unistd.h>
+#ifdef WITH_SELINUX
+#include <selinux/selinux.h>
+#endif
+
#if ENABLE_NLS
# include <libintl.h>
# define _(Text) gettext (Text)
@@ -147,6 +151,9 @@
static boolean parse_warn PARAMS((const struct parser_table*, char *argv[], int *arg_ptr));
static boolean parse_xtype PARAMS((const struct parser_table*, char *argv[], int *arg_ptr));
static boolean parse_quit PARAMS((const struct parser_table*, char *argv[], int *arg_ptr));
+#ifdef WITH_SELINUX
+static boolean parse_context PARAMS((const struct parser_table*, char *argv[], int *arg_ptr));
+#endif
@@ -217,6 +224,9 @@
PARSE_TEST ("cmin", cmin), /* GNU */
PARSE_TEST ("cnewer", cnewer), /* GNU */
PARSE_TEST ("ctime", ctime),
+#ifdef WITH_SELINUX
+ PARSE_TEST ("context", context), /* GNU */
+#endif
PARSE_POSOPT ("daystart", daystart), /* GNU */
PARSE_ACTION ("delete", delete), /* GNU, Mac OS, FreeBSD */
PARSE_OPTION ("d", d), /* Mac OS X, FreeBSD, NetBSD, OpenBSD, but deprecated in favour of -depth */
@@ -802,8 +812,12 @@
puts (_("\
-nouser -nogroup -path PATTERN -perm [+-]MODE -regex PATTERN\n\
-wholename PATTERN -size N[bcwkMG] -true -type [bcdpflsD] -uid N\n\
- -used N -user NAME -xtype [bcdpfls]\n"));
+ -used N -user NAME -xtype [bcdpfls]"));
+#ifdef WITH_SELINUX
puts (_("\
+ -context CONTEXT\n"));
+#endif
+ puts (_("\n\
actions: -delete -print0 -printf FORMAT -fprintf FILE FORMAT -print \n\
-fprint0 FILE -fprint FILE -ls -fls FILE -prune -quit\n\
-exec COMMAND ; -exec COMMAND {} + -ok COMMAND ;\n\
@@ -1716,6 +1730,10 @@
printf("LEAF_OPTIMISATION ");
++features;
#endif
+#if defined(WITH_SELINUX)
+ printf("SELINUX ");
+ ++features;
+#endif
if (0 == features)
{
/* For the moment, leave this as English in case someone wants
@@ -1727,6 +1745,32 @@
exit (0);
}
+#ifdef WITH_SELINUX
+static boolean
+parse_context (const struct parser_table* entry, char **argv, int *arg_ptr)
+{
+ struct predicate *our_pred;
+
+ if ((argv == NULL) || (argv[*arg_ptr] == NULL))
+ return false;
+
+ if (is_selinux_enabled() <= 0)
+ {
+ error (1, 0, _("invalid predicate -context: SELinux is not enabled."));
+ return false;
+ }
+ our_pred = insert_primary (entry);
+ our_pred->need_stat = false;
+#ifdef DEBUG
+ our_pred->p_name = find_pred_name (pred_context);
+#endif /*DEBUG*/
+ our_pred->args.scontext = argv[*arg_ptr];
+
+ (*arg_ptr)++;
+ return true;
+}
+#endif /* WITH_SELINUX */
+
static boolean
parse_xdev (const struct parser_table* entry, char **argv, int *arg_ptr)
{
@@ -1964,7 +2008,7 @@
if (*scan2 == '.')
for (scan2++; ISDIGIT (*scan2); scan2++)
/* Do nothing. */ ;
- if (strchr ("abcdDfFgGhHiklmMnpPstuUyY", *scan2))
+ if (strchr ("abcdDfFgGhHiklmMnpPstuUyYZ", *scan2))
{
segmentp = make_segment (segmentp, format, scan2 - format,
(int) *scan2);
@@ -2046,6 +2090,7 @@
case 'H': /* ARGV element file was found under */
case 'p': /* pathname */
case 'P': /* pathname with ARGV element stripped */
+ case 'Z': /* SELinux security context */
*fmt++ = 's';
break;
diff -ur --exclude '*.o' --exclude '*~' --exclude '*.selinux' findutils-4.2.27/find/pred.c findutils/find/pred.c
--- findutils-4.2.27/find/pred.c 2005-11-30 07:17:15.000000000 +0100
+++ findutils/find/pred.c 2006-01-30 21:13:18.000000000 +0100
@@ -38,6 +38,10 @@
#include "buildcmd.h"
#include "yesno.h"
+#ifdef WITH_SELINUX
+#include <selinux/selinux.h>
+#endif /*WITH_SELINUX*/
+
#if ENABLE_NLS
# include <libintl.h>
# define _(Text) gettext (Text)
@@ -215,6 +219,9 @@
{pred_used, "used "},
{pred_user, "user "},
{pred_xtype, "xtype "},
+#ifdef WITH_SELINUX
+ {pred_context, "context"},
+#endif /*WITH_SELINUX*/
{0, "none "}
};
@@ -903,6 +910,27 @@
mode_to_filetype(stat_buf->st_mode & S_IFMT));
}
break;
+ case 'Z': /* SELinux security context */
+#ifdef WITH_SELINUX
+ {
+ security_context_t scontext;
+ int rv;
+ rv = (*options.x_getfilecon) (state.rel_pathname, &scontext);
+
+ if (rv < 0)
+ {
+ fprintf (stderr, "getfilecon(%s): %s", pathname,
+ strerror(errno));
+ fflush (stderr);
+ }
+ else
+ {
+ fprintf (fp, segment->text, scontext);
+ freecon (scontext);
+ }
+ }
+#endif /* WITH_SELINUX */
+ break;
}
}
return true;
@@ -1493,6 +1521,33 @@
*/
return (pred_type (pathname, &sbuf, pred_ptr));
}
+
+
+#ifdef WITH_SELINUX
+
+boolean
+pred_context (char *pathname, struct stat *stat_buf,
+ struct predicate *pred_ptr)
+{
+ int rv;
+ security_context_t scontext;
+
+ rv = (*options.x_getfilecon) (state.rel_pathname, &scontext);
+
+ if (rv < 0)
+ {
+ fprintf (stderr, "getfilecon(%s): %s\n", pathname, strerror(errno));
+ fflush (stderr);
+ return false;
+ }
+
+ rv = (fnmatch (pred_ptr->args.scontext, scontext, 0) == 0);
+ freecon (scontext);
+ return rv;
+}
+
+#endif /*WITH_SELINUX*/
+
/* 1) fork to get a child; parent remembers the child pid
2) child execs the command requested
diff -ur --exclude '*.o' --exclude '*~' --exclude '*.selinux' findutils-4.2.27/find/util.c findutils/find/util.c
--- findutils-4.2.27/find/util.c 2005-07-01 23:45:18.000000000 +0200
+++ findutils/find/util.c 2006-01-27 14:38:43.000000000 +0100
@@ -78,6 +78,9 @@
last_pred->need_stat = true;
last_pred->need_type = true;
last_pred->args.str = NULL;
+#ifdef WITH_SELINUX
+ last_pred->args.scontext = NULL;
+#endif
last_pred->pred_next = NULL;
last_pred->pred_left = NULL;
last_pred->pred_right = NULL;

View File

@ -1,16 +1,15 @@
Summary: The GNU versions of find utilities (find and xargs)
Name: findutils
Version: 4.2.33
Release: 3%{?dist}
Version: 4.4.0
Release: 1%{?dist}
Epoch: 1
License: GPLv3+
Group: Applications/File
URL: http://www.gnu.org/software/findutils/
Source0: ftp://ftp.gnu.org/gnu/findutils/%{name}-%{version}.tar.gz
#Source1: ftp://ftp.gnu.org/gnu/findutils/%{name}-%{version}.tar.gz.sig
Patch1: findutils-4.2.31-no-locate.patch
Patch2: findutils-selinux.patch
Patch3: findutils-4.2.33-arg-max.patch
Source1: ftp://ftp.gnu.org/gnu/findutils/%{name}-%{version}.tar.gz.sig
Patch1: findutils-4.4.0-no-locate.patch
Patch2: findutils-4.4.0-selinux.patch
Requires(post): /sbin/install-info
Requires(preun): /sbin/install-info
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
@ -33,7 +32,6 @@ useful for finding things on your system.
%setup -q
%patch1 -p1 -b .no-locate
%patch2 -p1 -b .selinux
%patch3 -p1 -b .arg-max
autoreconf
@ -78,13 +76,18 @@ rm -rf $RPM_BUILD_ROOT
%doc AUTHORS COPYING NEWS README THANKS TODO
/bin/find
%{_bindir}/find
%{_bindir}/oldfind
%{_bindir}/xargs
%{_mandir}/man1/find.1*
%{_mandir}/man1/xargs.1*
%{_infodir}/find.info*
%{_infodir}/find-maint.info.gz
%changelog
* Mon Apr 14 2008 Vitezslav Crhonek <vcrhonek@redhat.com> - 1:1.2.33-3
* Wed Apr 30 2008 Vitezslav Crhonek <vcrhonek@redhat.com> - 1:4.4.0-1
- Update to findutils-4.4.0
* Mon Apr 14 2008 Vitezslav Crhonek <vcrhonek@redhat.com> - 1:4.2.33-3
- Move find to /bin
Resolves: #438183

View File

@ -1 +1,2 @@
b7e35aa175778c84942b1fee4144988b findutils-4.2.33.tar.gz
49e769ac4382fae6f104f99d54d0a112 findutils-4.4.0.tar.gz
04a7d2fcf851b770e586d8a01c1f14f1 findutils-4.4.0.tar.gz.sig