synced with devel

This commit is contained in:
Kamil Dudka 2009-11-26 18:20:59 +00:00
parent ca73160123
commit 685e8366e3
6 changed files with 1641 additions and 550 deletions

View File

@ -1,517 +0,0 @@
diff -up findutils-4.4.2/configure.ac_old findutils-4.4.2/configure.ac
--- findutils-4.4.2/configure.ac_old 2009-07-01 10:24:04.000000000 +0200
+++ findutils-4.4.2/configure.ac 2009-07-01 10:24:46.000000000 +0200
@@ -114,6 +114,16 @@ AC_CHECK_LIB([m],[fabs],[FINDLIBS="-lm $
AC_DEFINE_UNQUOTED(HAVE_FABS_IN_LIBM,1,[fabs is defined in -lm]))
AC_SUBST([FINDLIBS])
+AC_ARG_WITH([selinux],
+ AS_HELP_STRING([--without-selinux], [disable SELinux support]),
+ [:],
+[AC_CHECK_LIB([selinux], [is_selinux_enabled],
+ [with_selinux=yes], [with_selinux=no])])
+if test x$with_selinux != xno; then
+ AC_DEFINE([WITH_SELINUX], [1], [Define to support SELinux])
+ AC_SUBST([LIBSELINUX], [-lselinux])
+fi
+
dnl Checks for header files.
AC_HEADER_STDC
dnl Assume unistd.h is present - coreutils does too.
diff -up findutils-4.4.2/doc/find.texi_old findutils-4.4.2/doc/find.texi
--- findutils-4.4.2/doc/find.texi_old 2009-07-01 10:25:09.000000000 +0200
+++ findutils-4.4.2/doc/find.texi 2009-07-01 10:26:37.000000000 +0200
@@ -7,7 +7,6 @@
@c %**end of header
@include version.texi
-@include ../locate/dblocation.texi
@iftex
@finalout
@@ -1242,6 +1241,14 @@ situation.
@end deffn
+@deffn Test -context pattern
+True if file's SELinux context matches the pattern @var{pattern}.
+The pattern uses shell glob matching.
+
+This predicate is supported only on @code{find} versions compiled with
+SELinux support and only when SELinux is enabled.
+@end deffn
+
@node Contents
@section Contents
@@ -1826,6 +1833,9 @@ value used for BLOCKSIZE is system-depen
bytes. If the file size is zero, the value printed is undefined. On
systems which lack support for st_blocks, a file's sparseness is
assumed to be 1.0.
+@item %Z
+File's SELinux context, or empty string if the file has no SELinux context
+or this version of find does not support SELinux.
@end table
@node Location Directives
diff -up findutils-4.4.2/find/defs.h_old findutils-4.4.2/find/defs.h
--- findutils-4.4.2/find/defs.h_old 2009-07-01 12:38:32.000000000 +0200
+++ findutils-4.4.2/find/defs.h 2009-07-01 12:52:47.000000000 +0200
@@ -91,6 +91,9 @@ int get_statinfo PARAMS((const char *pat
#define MODE_RWX (S_IXUSR | S_IXGRP | S_IXOTH | MODE_RW)
#define MODE_ALL (S_ISUID | S_ISGID | S_ISVTX | MODE_RWX)
+#ifdef WITH_SELINUX
+#include <selinux/selinux.h>
+#endif
struct predicate;
struct options;
@@ -315,6 +318,9 @@ struct predicate
struct samefile_file_id samefileid; /* samefile */
mode_t type; /* type */
struct format_val printf_vec; /* printf fprintf fprint ls fls print0 fprint0 print */
+#ifdef WITH_SELINUX
+ security_context_t scontext; /* scontext */
+#endif
} args;
/* The next predicate in the user input sequence,
@@ -459,6 +465,9 @@ PREDICATEFUNCTION pred_used;
PREDICATEFUNCTION pred_user;
PREDICATEFUNCTION pred_writable;
PREDICATEFUNCTION pred_xtype;
+#ifdef WITH_SELINUX
+PREDICATEFUNCTION pred_context;
+#endif
@@ -601,6 +610,10 @@ struct options
*/
int regex_options;
+#ifdef WITH_SELINUX
+ int (*x_getfilecon) ();
+#endif
+
/* Optimisation level. One is the default.
*/
unsigned short optimisation_level;
diff -up findutils-4.4.2/find/find.1_old findutils-4.4.2/find/find.1
--- findutils-4.4.2/find/find.1_old 2009-07-01 10:30:04.000000000 +0200
+++ findutils-4.4.2/find/find.1 2009-07-01 10:30:59.000000000 +0200
@@ -933,6 +933,8 @@ if \fIc\fR is `l'. In other words, for
checks the type of the file that
.B \-type
does not check.
+.IP "\-context \fIpattern\fR"
+(SELinux only) Security context of the file matches glob \fIpattern\fR.
.SS ACTIONS
.IP "\-delete\fR"
@@ -1354,6 +1356,8 @@ File's type (like in
U=unknown type (shouldn't happen)
.IP %Y
File's type (like %y), plus follow symlinks: L=loop, N=nonexistent
+.IP %Z
+(SELinux only) file's security context.
.PP
A `%' character followed by any other character is discarded, but the
other character is printed (don't rely on this, as further format
diff -up findutils-4.4.2/find/find.c_old findutils-4.4.2/find/find.c
--- findutils-4.4.2/find/find.c_old 2009-07-01 10:26:53.000000000 +0200
+++ findutils-4.4.2/find/find.c 2009-07-01 10:29:52.000000000 +0200
@@ -120,6 +120,36 @@ int get_current_dirfd(void)
return AT_FDCWD;
}
+#ifdef WITH_SELINUX
+static int
+fallback_getfilecon(const char *name, security_context_t *p, int prev_rv)
+{
+ /* Our original getfilecon() call failed. Perhaps we can't follow a
+ * symbolic link. If that might be the problem, lgetfilecon() the link.
+ * Otherwise, admit defeat.
+ */
+ switch (errno)
+ {
+ case ENOENT:
+ case ENOTDIR:
+#ifdef DEBUG_STAT
+ fprintf(stderr, "fallback_getfilecon(): getfilecon(%s) failed; falling back on lgetfilecon()\n", name);
+#endif
+ return lgetfilecon(name, p);
+
+ case EACCES:
+ case EIO:
+ case ELOOP:
+ case ENAMETOOLONG:
+#ifdef EOVERFLOW
+ case EOVERFLOW: /* EOVERFLOW is not #defined on UNICOS. */
+#endif
+ default:
+ return prev_rv;
+ }
+}
+#endif /* WITH_SELINUX */
+
int
main (int argc, char **argv)
@@ -1270,7 +1300,7 @@ process_path (char *pathname, char *name
static void
process_dir (char *pathname, char *name, int pathlen, const struct stat *statp, char *parent)
{
- int subdirs_left; /* Number of unexamined subdirs in PATHNAME. */
+ int subdirs_left = 0; /* Number of unexamined subdirs in PATHNAME. */
boolean subdirs_unreliable; /* if true, cannot use dir link count as subdir limif (if false, it may STILL be unreliable) */
unsigned int idx; /* Which entry are we on? */
struct stat stat_buf;
diff -up findutils-4.4.2/find/Makefile.am_old findutils-4.4.2/find/Makefile.am
--- findutils-4.4.2/find/Makefile.am_old 2009-07-01 10:35:04.000000000 +0200
+++ findutils-4.4.2/find/Makefile.am 2009-07-01 10:35:37.000000000 +0200
@@ -26,7 +26,7 @@ endif
EXTRA_DIST = defs.h $(man_MANS)
INCLUDES = -I../gnulib/lib -I$(top_srcdir)/lib -I$(top_srcdir)/gnulib/lib -I../intl -DLOCALEDIR=\"$(localedir)\"
-LDADD = ./libfindtools.a ../lib/libfind.a ../gnulib/lib/libgnulib.a @INTLLIBS@ @LIB_CLOCK_GETTIME@ @FINDLIBS@
+LDADD = ./libfindtools.a ../lib/libfind.a ../gnulib/lib/libgnulib.a @INTLLIBS@ @LIB_CLOCK_GETTIME@ @FINDLIBS@ @LIBSELINUX@
man_MANS = find.1
SUBDIRS = . testsuite
diff -up findutils-4.4.2/find/parser.c_old findutils-4.4.2/find/parser.c
--- findutils-4.4.2/find/parser.c_old 2009-07-01 10:35:43.000000000 +0200
+++ findutils-4.4.2/find/parser.c 2009-07-01 12:38:19.000000000 +0200
@@ -53,6 +53,10 @@
#include <unistd.h>
#include <sys/stat.h>
+#ifdef WITH_SELINUX
+#include <selinux/selinux.h>
+#endif
+
#if ENABLE_NLS
# include <libintl.h>
# define _(Text) gettext (Text)
@@ -155,6 +159,9 @@ static boolean parse_noignore_race PARAM
static boolean parse_warn PARAMS((const struct parser_table*, char *argv[], int *arg_ptr));
static boolean parse_xtype PARAMS((const struct parser_table*, char *argv[], int *arg_ptr));
static boolean parse_quit PARAMS((const struct parser_table*, char *argv[], int *arg_ptr));
+#ifdef WITH_SELINUX
+static boolean parse_context PARAMS((const struct parser_table*, char *argv[], int *arg_ptr));
+#endif
boolean parse_print PARAMS((const struct parser_table*, char *argv[], int *arg_ptr));
@@ -251,6 +258,9 @@ static struct parser_table const parse_t
PARSE_TEST ("cmin", cmin), /* GNU */
PARSE_TEST ("cnewer", cnewer), /* GNU */
{ARG_TEST, "ctime", parse_time, pred_ctime}, /* POSIX */
+#ifdef WITH_SELINUX
+ PARSE_TEST ("context", context), /* GNU */
+#endif
PARSE_POSOPT ("daystart", daystart), /* GNU */
PARSE_ACTION ("delete", delete), /* GNU, Mac OS, FreeBSD */
PARSE_OPTION ("d", d), /* Mac OS X, FreeBSD, NetBSD, OpenBSD, but deprecated in favour of -depth */
@@ -347,6 +357,89 @@ static struct parser_table const parse_t
static const char *first_nonoption_arg = NULL;
static const struct parser_table *noop = NULL;
+#ifdef WITH_SELINUX
+static int
+fallback_getfilecon(const char *name, security_context_t *p, int prev_rv)
+{
+ /* Our original getfilecon() call failed. Perhaps we can't follow a
+ * symbolic link. If that might be the problem, lgetfilecon() the link.
+ * Otherwise, admit defeat.
+ */
+ switch (errno)
+ {
+ case ENOENT:
+ case ENOTDIR:
+#ifdef DEBUG_STAT
+ fprintf(stderr, "fallback_getfilecon(): getfilecon(%s) failed; falling back on lgetfilecon()\n", name);
+#endif
+ return lgetfilecon(name, p);
+
+ case EACCES:
+ case EIO:
+ case ELOOP:
+ case ENAMETOOLONG:
+#ifdef EOVERFLOW
+ case EOVERFLOW: /* EOVERFLOW is not #defined on UNICOS. */
+#endif
+ default:
+ return prev_rv;
+ }
+}
+
+/* optionh_getfilecon() implements the getfilecon operation when the
+ * -H option is in effect.
+ *
+ * If the item to be examined is a command-line argument, we follow
+ * symbolic links. If the getfilecon() call fails on the command-line
+ * item, we fall back on the properties of the symbolic link.
+ *
+ * If the item to be examined is not a command-line argument, we
+ * examine the link itself.
+ */
+int
+optionh_getfilecon(const char *name, security_context_t *p)
+{
+ if (0 == state.curdepth)
+ {
+ /* This file is from the command line; deference the link (if it
+ * is a link).
+ */
+ int rv = getfilecon(name, p);
+ if (0 == rv)
+ return 0; /* success */
+ else
+ return fallback_getfilecon(name, p, rv);
+ }
+ else
+ {
+ /* Not a file on the command line; do not derefernce the link.
+ */
+ return lgetfilecon(name, p);
+ }
+}
+/* optionl_getfilecon() implements the getfilecon operation when the
+ * -L option is in effect. That option makes us examine the thing the
+ * symbolic link points to, not the symbolic link itself.
+ */
+int
+optionl_getfilecon(const char *name, security_context_t *p)
+{
+ int rv = getfilecon(name, p);
+ if (0 == rv)
+ return 0; /* normal case. */
+ else
+ return fallback_getfilecon(name, p, rv);
+}
+/* optionp_getfilecon() implements the stat operation when the -P
+ * option is in effect (this is also the default). That option makes
+ * us examine the symbolic link itself, not the thing it points to.
+ */
+int
+optionp_getfilecon(const char *name, security_context_t *p)
+{
+ return lgetfilecon(name, p);
+}
+#endif /* WITH_SELINUX */
void
check_option_combinations(const struct predicate *p)
@@ -450,11 +543,17 @@ set_follow_state(enum SymlinkOption opt)
{
case SYMLINK_ALWAYS_DEREF: /* -L */
options.xstat = optionl_stat;
+#ifdef WITH_SELINUX
+ options.x_getfilecon = optionl_getfilecon;
+#endif
options.no_leaf_check = true;
break;
case SYMLINK_NEVER_DEREF: /* -P (default) */
options.xstat = optionp_stat;
+#ifdef WITH_SELINUX
+ options.x_getfilecon = optionp_getfilecon;
+#endif
/* Can't turn no_leaf_check off because the user might have specified
* -noleaf anyway
*/
@@ -462,6 +561,9 @@ set_follow_state(enum SymlinkOption opt)
case SYMLINK_DEREF_ARGSONLY: /* -H */
options.xstat = optionh_stat;
+#ifdef WITH_SELINUX
+ options.x_getfilecon = optionh_getfilecon;
+#endif
options.no_leaf_check = true;
}
}
@@ -1127,8 +1229,12 @@ tests (N can be +N or -N or N): -amin N
-nouser -nogroup -path PATTERN -perm [+-]MODE -regex PATTERN\n\
-readable -writable -executable\n\
-wholename PATTERN -size N[bcwkMG] -true -type [bcdpflsD] -uid N\n\
- -used N -user NAME -xtype [bcdpfls]\n"));
+ -used N -user NAME -xtype [bcdpfls]"));
+#ifdef WITH_SELINUX
puts (_("\
+ -context CONTEXT\n"));
+#endif
+ puts (_("\n\
actions: -delete -print0 -printf FORMAT -fprintf FILE FORMAT -print \n\
-fprint0 FILE -fprint FILE -ls -fls FILE -prune -quit\n\
-exec COMMAND ; -exec COMMAND {} + -ok COMMAND ;\n\
@@ -2518,6 +2624,10 @@ parse_version (const struct parser_table
printf("LEAF_OPTIMISATION ");
++features;
#endif
+#if defined(WITH_SELINUX)
+ printf("SELINUX ");
+ ++features;
+#endif
flags = 0;
if (is_fts_enabled(&flags))
@@ -2552,6 +2662,32 @@ parse_version (const struct parser_table
exit (0);
}
+#ifdef WITH_SELINUX
+static boolean
+parse_context (const struct parser_table* entry, char **argv, int *arg_ptr)
+{
+ struct predicate *our_pred;
+
+ if ((argv == NULL) || (argv[*arg_ptr] == NULL))
+ return false;
+
+ if (is_selinux_enabled() <= 0)
+ {
+ error (1, 0, _("invalid predicate -context: SELinux is not enabled."));
+ return false;
+ }
+ our_pred = insert_primary (entry);
+ our_pred->need_stat = false;
+#ifdef DEBUG
+ our_pred->p_name = find_pred_name (pred_context);
+#endif /*DEBUG*/
+ our_pred->args.scontext = argv[*arg_ptr];
+
+ (*arg_ptr)++;
+ return true;
+}
+#endif /* WITH_SELINUX */
+
static boolean
parse_xdev (const struct parser_table* entry, char **argv, int *arg_ptr)
{
@@ -2803,7 +2939,7 @@ insert_fprintf (struct format_val *vec,
if (*scan2 == '.')
for (scan2++; ISDIGIT (*scan2); scan2++)
/* Do nothing. */ ;
- if (strchr ("abcdDfFgGhHiklmMnpPsStuUyY", *scan2))
+ if (strchr ("abcdDfFgGhHiklmMnpPsStuUyYZ", *scan2))
{
segmentp = make_segment (segmentp, format, scan2 - format,
KIND_FORMAT, *scan2, 0,
@@ -2930,6 +3066,7 @@ make_segment (struct segment **segment,
case 'h': /* leading directories part of path */
case 'p': /* pathname */
case 'P': /* pathname with ARGV element stripped */
+ case 'Z': /* SELinux security context */
*fmt++ = 's';
break;
diff -up findutils-4.4.2/find/pred.c_old findutils-4.4.2/find/pred.c
--- findutils-4.4.2/find/pred.c_old 2009-07-01 10:31:11.000000000 +0200
+++ findutils-4.4.2/find/pred.c 2009-07-01 10:33:45.000000000 +0200
@@ -48,6 +48,10 @@
#include "error.h"
#include "verify.h"
+#ifdef WITH_SELINUX
+#include <selinux/selinux.h>
+#endif /*WITH_SELINUX*/
+
#if ENABLE_NLS
# include <libintl.h>
# define _(Text) gettext (Text)
@@ -230,6 +234,9 @@ struct pred_assoc pred_table[] =
{pred_user, "user "},
{pred_writable, "writable "},
{pred_xtype, "xtype "},
+#ifdef WITH_SELINUX
+ {pred_context, "context"},
+#endif /*WITH_SELINUX*/
{0, "none "}
};
#endif
@@ -1054,6 +1061,27 @@ do_fprintf(struct format_val *dest,
mode_to_filetype(stat_buf->st_mode & S_IFMT));
}
break;
+ case 'Z': /* SELinux security context */
+#ifdef WITH_SELINUX
+ {
+ security_context_t scontext;
+ int rv;
+ rv = (*options.x_getfilecon) (state.rel_pathname, &scontext);
+
+ if (rv < 0)
+ {
+ fprintf (stderr, "getfilecon(%s): %s", pathname,
+ strerror(errno));
+ fflush (stderr);
+ }
+ else
+ {
+ checked_fprintf (dest, segment->text, scontext);
+ freecon (scontext);
+ }
+ }
+#endif /* WITH_SELINUX */
+ break;
}
/* end of KIND_FORMAT case */
break;
@@ -1844,6 +1872,32 @@ pred_xtype (const char *pathname, struct
*/
return (pred_type (pathname, &sbuf, pred_ptr));
}
+
+#ifdef WITH_SELINUX
+
+boolean
+pred_context (const char *pathname, struct stat *stat_buf,
+ struct predicate *pred_ptr)
+{
+ int rv;
+ security_context_t scontext;
+
+ rv = (*options.x_getfilecon) (state.rel_pathname, &scontext);
+
+ if (rv < 0)
+ {
+ fprintf (stderr, "getfilecon(%s): %s\n", pathname, strerror(errno));
+ fflush (stderr);
+ return false;
+ }
+
+ rv = (fnmatch (pred_ptr->args.scontext, scontext, 0) == 0);
+ freecon (scontext);
+ return rv;
+}
+
+#endif /*WITH_SELINUX*/
+
/* 1) fork to get a child; parent remembers the child pid
2) child execs the command requested
diff -up findutils-4.4.2/find/tree.c_old findutils-4.4.2/find/tree.c
--- findutils-4.4.2/find/tree.c_old 2009-07-01 10:33:57.000000000 +0200
+++ findutils-4.4.2/find/tree.c 2009-07-01 10:34:54.000000000 +0200
@@ -953,7 +953,8 @@ static struct pred_cost_lookup costlooku
{ pred_used , NeedsStatInfo },
{ pred_user , NeedsStatInfo },
{ pred_writable , NeedsAccessInfo },
- { pred_xtype , NeedsType } /* roughly correct unless most files are symlinks */
+ { pred_xtype , NeedsType }, /* roughly correct unless most files are symlinks */
+ { pred_context , NeedsNothing } /* remove warning only:) */
};
static int pred_table_sorted = 0;
@@ -1434,6 +1435,9 @@ get_new_pred (const struct parser_table
last_pred->need_stat = true;
last_pred->need_type = true;
last_pred->args.str = NULL;
+#ifdef WITH_SELINUX
+ last_pred->args.scontext = NULL;
+#endif
last_pred->pred_next = NULL;
last_pred->pred_left = NULL;
last_pred->pred_right = NULL;

View File

@ -1,3 +1,5 @@
This patch is already applied on gnulib upstream git.
diff --git a/gnulib/lib/fts.c b/gnulib/lib/fts.c
index ceb8935..2f1eda4 100644
--- a/gnulib/lib/fts.c

File diff suppressed because it is too large Load Diff

View File

@ -0,0 +1,453 @@
diff --git a/NEWS b/NEWS
index d00862f..6b8b725 100644
--- a/NEWS
+++ b/NEWS
@@ -1,5 +1,11 @@
GNU findutils NEWS - User visible changes. -*- outline -*- (allout)
+* Major changes in release 4.4.2, 2009-11-26
+
+** Functional Enhancements to find
+
+patch #4848: Patch - Support for SELinux
+
* Major changes in release 4.4.2, 2009-05-16
** Bug Fixes
diff --git a/doc/find.texi b/doc/find.texi
index 8944096..4d71066 100644
--- a/doc/find.texi
+++ b/doc/find.texi
@@ -7,7 +7,6 @@
@c %**end of header
@include version.texi
-@include ../locate/dblocation.texi
@iftex
@finalout
@@ -1242,6 +1241,14 @@ situation.
@end deffn
+@deffn Test -context pattern
+True if file's SELinux context matches the pattern @var{pattern}.
+The pattern uses shell glob matching.
+
+This predicate is supported only on @code{find} versions compiled with
+SELinux support and only when SELinux is enabled.
+@end deffn
+
@node Contents
@section Contents
@@ -1737,6 +1744,7 @@ from the novel you are reading.
* Size Directives::
* Location Directives::
* Time Directives::
+* Other Directives::
* Formatting Flags::
@end menu
@@ -1894,6 +1902,14 @@ File's last modification time in the format specified by @var{k}
(@pxref{Time Formats}).
@end table
+@node Other Directives
+@subsubsection Other Directives
+
+@table @code
+@item %Z
+File's SELinux context, or empty string if the file has no SELinux context.
+@end table
+
@node Time Formats
@subsection Time Formats
diff --git a/find/Makefile.am b/find/Makefile.am
index b001509..6fc7df3 100644
--- a/find/Makefile.am
+++ b/find/Makefile.am
@@ -26,7 +26,7 @@ endif
EXTRA_DIST = defs.h $(man_MANS)
INCLUDES = -I../gnulib/lib -I$(top_srcdir)/lib -I$(top_srcdir)/gnulib/lib -I../intl -DLOCALEDIR=\"$(localedir)\"
-LDADD = ./libfindtools.a ../lib/libfind.a ../gnulib/lib/libgnulib.a @INTLLIBS@ @LIB_CLOCK_GETTIME@ @FINDLIBS@
+LDADD = ./libfindtools.a ../lib/libfind.a ../gnulib/lib/libgnulib.a @INTLLIBS@ @LIB_CLOCK_GETTIME@ @FINDLIBS@ @LIB_SELINUX@
man_MANS = find.1
SUBDIRS = . testsuite
diff --git a/find/defs.h b/find/defs.h
index a0e7059..36d428d 100644
--- a/find/defs.h
+++ b/find/defs.h
@@ -48,6 +48,7 @@ Please stop compiling the program now
#include <stdbool.h> /* for bool/boolean */
#include <stdint.h> /* for uintmax_t */
#include <sys/stat.h> /* S_ISUID etc. */
+#include <selinux/selinux.h>
@@ -315,6 +316,7 @@ struct predicate
struct samefile_file_id samefileid; /* samefile */
mode_t type; /* type */
struct format_val printf_vec; /* printf fprintf fprint ls fls print0 fprint0 print */
+ security_context_t scontext; /* security context */
} args;
/* The next predicate in the user input sequence,
@@ -459,6 +461,7 @@ PREDICATEFUNCTION pred_used;
PREDICATEFUNCTION pred_user;
PREDICATEFUNCTION pred_writable;
PREDICATEFUNCTION pred_xtype;
+PREDICATEFUNCTION pred_context;
@@ -604,6 +607,9 @@ struct options
*/
int regex_options;
+ /* function used to get file context */
+ int (*x_getfilecon) (int, const char *, security_context_t *);
+
/* Optimisation level. One is the default.
*/
unsigned short optimisation_level;
diff --git a/find/find.1 b/find/find.1
index f9c61a3..27ad1da 100644
--- a/find/find.1
+++ b/find/find.1
@@ -936,6 +936,8 @@ if \fIc\fR is `l'. In other words, for symbolic links,
checks the type of the file that
.B \-type
does not check.
+.IP "\-context \fIpattern\fR"
+(SELinux only) Security context of the file matches glob \fIpattern\fR.
.SS ACTIONS
.IP "\-delete\fR"
@@ -1357,6 +1359,8 @@ File's type (like in
U=unknown type (shouldn't happen)
.IP %Y
File's type (like %y), plus follow symlinks: L=loop, N=nonexistent
+.IP %Z
+(SELinux only) file's security context.
.PP
A `%' character followed by any other character is discarded, but the
other character is printed (don't rely on this, as further format
diff --git a/find/parser.c b/find/parser.c
index 036ddb8..6b09eee 100644
--- a/find/parser.c
+++ b/find/parser.c
@@ -53,6 +53,8 @@
#include <unistd.h>
#include <sys/stat.h>
+#include "selinux-at.h"
+
#if ENABLE_NLS
# include <libintl.h>
# define _(Text) gettext (Text)
@@ -156,6 +158,7 @@ static boolean parse_noignore_race PARAMS((const struct parser_table*, char *arg
static boolean parse_warn PARAMS((const struct parser_table*, char *argv[], int *arg_ptr));
static boolean parse_xtype PARAMS((const struct parser_table*, char *argv[], int *arg_ptr));
static boolean parse_quit PARAMS((const struct parser_table*, char *argv[], int *arg_ptr));
+static boolean parse_context PARAMS((const struct parser_table*, char *argv[], int *arg_ptr));
boolean parse_print PARAMS((const struct parser_table*, char *argv[], int *arg_ptr));
@@ -252,6 +255,7 @@ static struct parser_table const parse_table[] =
PARSE_TEST ("cmin", cmin), /* GNU */
PARSE_TEST ("cnewer", cnewer), /* GNU */
{ARG_TEST, "ctime", parse_time, pred_ctime}, /* POSIX */
+ PARSE_TEST ("context", context), /* GNU */
PARSE_POSOPT ("daystart", daystart), /* GNU */
PARSE_ACTION ("delete", delete), /* GNU, Mac OS, FreeBSD */
PARSE_OPTION ("d", d), /* Mac OS X, FreeBSD, NetBSD, OpenBSD, but deprecated in favour of -depth */
@@ -349,6 +353,86 @@ static struct parser_table const parse_table[] =
static const char *first_nonoption_arg = NULL;
static const struct parser_table *noop = NULL;
+static int
+fallback_getfilecon (int fd, const char *name, security_context_t *p,
+ int prev_rv)
+{
+ /* Our original getfilecon () call failed. Perhaps we can't follow a
+ * symbolic link. If that might be the problem, lgetfilecon () the link.
+ * Otherwise, admit defeat. */
+ switch (errno)
+ {
+ case ENOENT:
+ case ENOTDIR:
+#ifdef DEBUG_STAT
+ fprintf (stderr, "fallback_getfilecon(): getfilecon(%s) failed; falling "
+ "back on lgetfilecon()\n", name);
+#endif
+ return lgetfileconat (fd, name, p);
+
+ case EACCES:
+ case EIO:
+ case ELOOP:
+ case ENAMETOOLONG:
+#ifdef EOVERFLOW
+ case EOVERFLOW: /* EOVERFLOW is not #defined on UNICOS. */
+#endif
+ default:
+ return prev_rv;
+ }
+}
+
+/* optionh_getfilecon () implements the getfilecon operation when the
+ * -H option is in effect.
+ *
+ * If the item to be examined is a command-line argument, we follow
+ * symbolic links. If the getfilecon () call fails on the command-line
+ * item, we fall back on the properties of the symbolic link.
+ *
+ * If the item to be examined is not a command-line argument, we
+ * examine the link itself. */
+int
+optionh_getfilecon (int fd, const char *name, security_context_t *p)
+{
+ int rv;
+ if (0 == state.curdepth)
+ {
+ /* This file is from the command line; dereference the link (if it is
+ a link). */
+ rv = getfileconat (fd, name, p);
+ if (0 == rv)
+ return 0; /* success */
+ else
+ return fallback_getfilecon (fd, name, p, rv);
+ }
+ else
+ {
+ /* Not a file on the command line; do not dereference the link. */
+ return lgetfileconat (fd, name, p);
+ }
+}
+
+/* optionl_getfilecon () implements the getfilecon operation when the
+ * -L option is in effect. That option makes us examine the thing the
+ * symbolic link points to, not the symbolic link itself. */
+int
+optionl_getfilecon (int fd, const char *name, security_context_t *p)
+{
+ int rv = getfileconat (fd, name, p);
+ if (0 == rv)
+ return 0; /* normal case. */
+ else
+ return fallback_getfilecon (fd, name, p, rv);
+}
+
+/* optionp_getfilecon () implements the stat operation when the -P
+ * option is in effect (this is also the default). That option makes
+ * us examine the symbolic link itself, not the thing it points to. */
+int
+optionp_getfilecon (int fd, const char *name, security_context_t *p)
+{
+ return lgetfileconat (fd, name, p);
+}
void
check_option_combinations(const struct predicate *p)
@@ -452,11 +536,13 @@ set_follow_state(enum SymlinkOption opt)
{
case SYMLINK_ALWAYS_DEREF: /* -L */
options.xstat = optionl_stat;
+ options.x_getfilecon = optionl_getfilecon;
options.no_leaf_check = true;
break;
case SYMLINK_NEVER_DEREF: /* -P (default) */
options.xstat = optionp_stat;
+ options.x_getfilecon = optionp_getfilecon;
/* Can't turn no_leaf_check off because the user might have specified
* -noleaf anyway
*/
@@ -464,6 +550,7 @@ set_follow_state(enum SymlinkOption opt)
case SYMLINK_DEREF_ARGSONLY: /* -H */
options.xstat = optionh_stat;
+ options.x_getfilecon = optionh_getfilecon;
options.no_leaf_check = true;
}
}
@@ -1129,8 +1216,10 @@ tests (N can be +N or -N or N): -amin N -anewer FILE -atime N -cmin N\n\
-nouser -nogroup -path PATTERN -perm [+-]MODE -regex PATTERN\n\
-readable -writable -executable\n\
-wholename PATTERN -size N[bcwkMG] -true -type [bcdpflsD] -uid N\n\
- -used N -user NAME -xtype [bcdpfls]\n"));
+ -used N -user NAME -xtype [bcdpfls]"));
puts (_("\
+ -context CONTEXT\n"));
+ puts (_("\n\
actions: -delete -print0 -printf FORMAT -fprintf FILE FORMAT -print \n\
-fprint0 FILE -fprint FILE -ls -fls FILE -prune -quit\n\
-exec COMMAND ; -exec COMMAND {} + -ok COMMAND ;\n\
@@ -2520,6 +2609,11 @@ parse_version (const struct parser_table* entry, char **argv, int *arg_ptr)
printf("LEAF_OPTIMISATION ");
++features;
#endif
+ if (0 < is_selinux_enabled ())
+ {
+ printf ("SELINUX ");
+ ++features;
+ }
flags = 0;
if (is_fts_enabled(&flags))
@@ -2555,6 +2649,31 @@ parse_version (const struct parser_table* entry, char **argv, int *arg_ptr)
}
static boolean
+parse_context (const struct parser_table* entry, char **argv, int *arg_ptr)
+{
+ struct predicate *our_pred;
+
+ if ((argv == NULL) || (argv[*arg_ptr] == NULL))
+ return false;
+
+ if (is_selinux_enabled () <= 0)
+ {
+ error (1, 0, _("invalid predicate -context: SELinux is not enabled."));
+ return false;
+ }
+ our_pred = insert_primary (entry);
+ our_pred->est_success_rate = 0.01f;
+ our_pred->need_stat = false;
+#ifdef DEBUG
+ our_pred->p_name = find_pred_name (pred_context);
+#endif /*DEBUG*/
+ our_pred->args.scontext = argv[*arg_ptr];
+
+ (*arg_ptr)++;
+ return true;
+}
+
+static boolean
parse_xdev (const struct parser_table* entry, char **argv, int *arg_ptr)
{
options.stay_on_filesystem = true;
@@ -2815,7 +2934,7 @@ insert_fprintf (struct format_val *vec,
if (*scan2 == '.')
for (scan2++; ISDIGIT (*scan2); scan2++)
/* Do nothing. */ ;
- if (strchr ("abcdDfFgGhHiklmMnpPsStuUyY", *scan2))
+ if (strchr ("abcdDfFgGhHiklmMnpPsStuUyYZ", *scan2))
{
segmentp = make_segment (segmentp, format, scan2 - format,
KIND_FORMAT, *scan2, 0,
@@ -2945,6 +3064,11 @@ make_segment (struct segment **segment,
*fmt++ = 's';
break;
+ case 'Z': /* SELinux security context */
+ mycost = NeedsAccessInfo;
+ *fmt++ = 's';
+ break;
+
case 'H': /* ARGV element file was found under */
*fmt++ = 's';
break;
diff --git a/find/pred.c b/find/pred.c
index b1f48a0..7c34119 100644
--- a/find/pred.c
+++ b/find/pred.c
@@ -48,6 +48,8 @@
#include "error.h"
#include "verify.h"
+#include <selinux/selinux.h>
+
#if ENABLE_NLS
# include <libintl.h>
# define _(Text) gettext (Text)
@@ -230,6 +232,7 @@ struct pred_assoc pred_table[] =
{pred_user, "user "},
{pred_writable, "writable "},
{pred_xtype, "xtype "},
+ {pred_context, "context"},
{0, "none "}
};
#endif
@@ -1054,6 +1057,30 @@ do_fprintf(struct format_val *dest,
mode_to_filetype(stat_buf->st_mode & S_IFMT));
}
break;
+
+ case 'Z': /* SELinux security context */
+ {
+ security_context_t scontext;
+ int rv = (*options.x_getfilecon) (state.cwd_dir_fd, state.rel_pathname,
+ &scontext);
+ if (rv < 0)
+ {
+ /* If getfilecon fails, there will in the general case
+ still be some text to print. We just make %Z expand
+ to an empty string. */
+ checked_fprintf (dest, segment->text, "");
+
+ error (0, errno, "getfilecon: %s",
+ safely_quote_err_filename (0, pathname));
+ state.exit_status = 1;
+ }
+ else
+ {
+ checked_fprintf (dest, segment->text, scontext);
+ freecon (scontext);
+ }
+ }
+ break;
}
/* end of KIND_FORMAT case */
break;
@@ -1844,6 +1871,26 @@ pred_xtype (const char *pathname, struct stat *stat_buf, struct predicate *pred_
*/
return (pred_type (pathname, &sbuf, pred_ptr));
}
+
+
+boolean
+pred_context (const char *pathname, struct stat *stat_buf,
+ struct predicate *pred_ptr)
+{
+ security_context_t scontext;
+ int rv = (*options.x_getfilecon) (state.cwd_dir_fd, state.rel_pathname,
+ &scontext);
+ if (rv < 0)
+ {
+ error (0, errno, "getfilecon: %s", safely_quote_err_filename (0, pathname));
+ return false;
+ }
+
+ rv = (fnmatch (pred_ptr->args.scontext, scontext, 0) == 0);
+ freecon (scontext);
+ return rv;
+}
+
/* 1) fork to get a child; parent remembers the child pid
2) child execs the command requested
diff --git a/find/tree.c b/find/tree.c
index 7420c60..ecdd4c9 100644
--- a/find/tree.c
+++ b/find/tree.c
@@ -904,6 +904,7 @@ static struct pred_cost_lookup costlookup[] =
{ pred_cmin , NeedsStatInfo, },
{ pred_cnewer , NeedsStatInfo, },
{ pred_comma , NeedsNothing, },
+ { pred_context , NeedsAccessInfo },
{ pred_ctime , NeedsStatInfo, },
{ pred_delete , NeedsSyncDiskHit },
{ pred_empty , NeedsStatInfo },
@@ -1434,6 +1435,7 @@ get_new_pred (const struct parser_table *entry)
last_pred->need_stat = true;
last_pred->need_type = true;
last_pred->args.str = NULL;
+ last_pred->args.scontext = NULL;
last_pred->pred_next = NULL;
last_pred->pred_left = NULL;
last_pred->pred_right = NULL;

View File

@ -1,7 +1,8 @@
diff -rup findutils-4.4.2.orig/doc/find.texi findutils-4.4.2/doc/find.texi
--- findutils-4.4.2.orig/doc/find.texi 2009-10-20 14:31:43.902741386 +0200
+++ findutils-4.4.2/doc/find.texi 2009-10-20 14:30:55.680178944 +0200
@@ -1420,6 +1420,10 @@ them.
diff --git a/doc/find.texi b/doc/find.texi
index 2e5958d..8944096 100644
--- a/doc/find.texi
+++ b/doc/find.texi
@@ -1413,6 +1413,10 @@ them.
There are two ways to avoid searching certain filesystems. One way is
to tell @code{find} to only search one filesystem:
@ -12,23 +13,25 @@ diff -rup findutils-4.4.2.orig/doc/find.texi findutils-4.4.2/doc/find.texi
@deffn Option -xdev
@deffnx Option -mount
Don't descend directories on other filesystems. These options are
diff -rup findutils-4.4.2.orig/find/defs.h findutils-4.4.2/find/defs.h
--- findutils-4.4.2.orig/find/defs.h 2009-10-20 14:31:43.902741386 +0200
+++ findutils-4.4.2/find/defs.h 2009-10-20 14:30:55.680906690 +0200
@@ -559,6 +559,9 @@ struct options
diff --git a/find/defs.h b/find/defs.h
index 1708d83..a0e7059 100644
--- a/find/defs.h
+++ b/find/defs.h
@@ -550,6 +550,9 @@ struct options
/* If true, don't cross filesystem boundaries. */
boolean stay_on_filesystem;
+ /* If true, don't descend directories on autofs filesystems. */
+ boolean bypass_autofs;
+
+
/* If true, we ignore the problem where we find that a directory entry
* no longer exists by the time we get around to processing it.
*/
diff -rup findutils-4.4.2.orig/find/find.1 findutils-4.4.2/find/find.1
--- findutils-4.4.2.orig/find/find.1 2009-10-20 14:31:43.903741308 +0200
+++ findutils-4.4.2/find/find.1 2009-10-20 14:30:55.680906690 +0200
@@ -451,6 +451,9 @@ if standard input is a tty, and to
diff --git a/find/find.1 b/find/find.1
index 8b67ae3..f9c61a3 100644
--- a/find/find.1
+++ b/find/find.1
@@ -451,6 +451,9 @@ if standard input is a tty, and to
.B \-nowarn
otherwise.
@ -38,9 +41,10 @@ diff -rup findutils-4.4.2.orig/find/find.1 findutils-4.4.2/find/find.1
.IP \-xdev
Don't descend directories on other filesystems.
diff -rup findutils-4.4.2.orig/find/ftsfind.c findutils-4.4.2/find/ftsfind.c
--- findutils-4.4.2.orig/find/ftsfind.c 2009-05-16 17:17:01.000000000 +0200
+++ findutils-4.4.2/find/ftsfind.c 2009-10-20 14:31:04.745866565 +0200
diff --git a/find/ftsfind.c b/find/ftsfind.c
index b59d896..838b81f 100644
--- a/find/ftsfind.c
+++ b/find/ftsfind.c
@@ -525,6 +525,12 @@ consider_visiting(FTS *p, FTSENT *ent)
}
}
@ -54,10 +58,11 @@ diff -rup findutils-4.4.2.orig/find/ftsfind.c findutils-4.4.2/find/ftsfind.c
if ( (ent->fts_info == FTS_D) && !options.do_dir_first )
{
/* this is the preorder visit, but user said -depth */
diff -rup findutils-4.4.2.orig/find/parser.c findutils-4.4.2/find/parser.c
--- findutils-4.4.2.orig/find/parser.c 2009-10-20 14:31:43.906741469 +0200
+++ findutils-4.4.2/find/parser.c 2009-10-20 14:30:55.683024396 +0200
@@ -154,6 +154,7 @@ static boolean parse_user PARAM
diff --git a/find/parser.c b/find/parser.c
index 534b670..036ddb8 100644
--- a/find/parser.c
+++ b/find/parser.c
@@ -150,6 +150,7 @@ static boolean parse_user PARAMS((const struct parser_table*, char *arg
static boolean parse_version PARAMS((const struct parser_table*, char *argv[], int *arg_ptr));
static boolean parse_wholename PARAMS((const struct parser_table*, char *argv[], int *arg_ptr));
static boolean parse_xdev PARAMS((const struct parser_table*, char *argv[], int *arg_ptr));
@ -65,7 +70,7 @@ diff -rup findutils-4.4.2.orig/find/parser.c findutils-4.4.2/find/parser.c
static boolean parse_ignore_race PARAMS((const struct parser_table*, char *argv[], int *arg_ptr));
static boolean parse_noignore_race PARAMS((const struct parser_table*, char *argv[], int *arg_ptr));
static boolean parse_warn PARAMS((const struct parser_table*, char *argv[], int *arg_ptr));
@@ -330,6 +331,7 @@ static struct parser_table const parse_t
@@ -320,6 +321,7 @@ static struct parser_table const parse_table[] =
PARSE_TEST_NP ("wholename", wholename), /* GNU, replaced -path, but anyway -path will soon be in POSIX */
{ARG_TEST, "writable", parse_accesscheck, pred_writable}, /* GNU, 4.3.0+ */
PARSE_OPTION ("xdev", xdev), /* POSIX */
@ -73,7 +78,7 @@ diff -rup findutils-4.4.2.orig/find/parser.c findutils-4.4.2/find/parser.c
PARSE_TEST ("xtype", xtype), /* GNU */
#ifdef UNIMPLEMENTED_UNIX
/* It's pretty ugly for find to know about archive formats.
@@ -2696,6 +2698,16 @@ parse_xdev (const struct parser_table* e
@@ -2560,6 +2562,16 @@ parse_xdev (const struct parser_table* entry, char **argv, int *arg_ptr)
}
static boolean
@ -90,9 +95,10 @@ diff -rup findutils-4.4.2.orig/find/parser.c findutils-4.4.2/find/parser.c
parse_ignore_race (const struct parser_table* entry, char **argv, int *arg_ptr)
{
options.ignore_readdir_race = true;
diff -rup findutils-4.4.2.orig/find/util.c findutils-4.4.2/find/util.c
--- findutils-4.4.2.orig/find/util.c 2009-05-16 17:17:01.000000000 +0200
+++ findutils-4.4.2/find/util.c 2009-10-20 14:30:55.684180119 +0200
diff --git a/find/util.c b/find/util.c
index a06eada..d3cb467 100644
--- a/find/util.c
+++ b/find/util.c
@@ -933,6 +933,7 @@ set_option_defaults(struct options *p)
p->full_days = false;

View File

@ -1,7 +1,7 @@
Summary: The GNU versions of find utilities (find and xargs)
Name: findutils
Version: 4.4.2
Release: 5%{?dist}
Release: 6%{?dist}
Epoch: 1
License: GPLv3+
Group: Applications/File
@ -9,10 +9,11 @@ URL: http://www.gnu.org/software/findutils/
Source0: ftp://ftp.gnu.org/gnu/findutils/%{name}-%{version}.tar.gz
Source1: ftp://ftp.gnu.org/gnu/findutils/%{name}-%{version}.tar.gz.sig
Patch1: findutils-4.4.0-no-locate.patch
Patch2: findutils-4.4.0-selinux.patch
Patch3: findutils-4.4.2-autofs.patch
Patch4: findutils-4.4.2-xautofs.patch
Patch5: findutils-4.4.2-fts-remount.patch
Patch2: findutils-4.4.2-autofs.patch
Patch3: findutils-4.4.2-xautofs.patch
Patch4: findutils-4.4.2-fts-remount.patch
Patch5: findutils-4.4.2-selinux.patch
Patch6: findutils-4.4.2-selinux-gnulib.patch
Requires(post): /sbin/install-info
Requires(preun): /sbin/install-info
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
@ -24,7 +25,7 @@ BuildRequires: libselinux-devel
The findutils package contains programs which will help you locate
files on your system. The find utility searches through a hierarchy
of directories looking for files which match a certain set of criteria
(such as a filename pattern). The xargs utility builds and executes
(such as a file name pattern). The xargs utility builds and executes
command lines from standard input arguments (usually lists of file
names generated by the find command).
@ -38,7 +39,7 @@ useful for finding things on your system.
%patch3 -p1
%patch4 -p1
%patch5 -p1
%patch6 -p1
autoreconf
%build
@ -83,7 +84,7 @@ fi
rm -rf $RPM_BUILD_ROOT
%files -f %{name}.lang
%defattr(-,root,root)
%defattr(-,root,root,-)
%doc AUTHORS COPYING NEWS README THANKS TODO
/bin/find
%{_bindir}/find
@ -95,6 +96,9 @@ rm -rf $RPM_BUILD_ROOT
%{_infodir}/find-maint.info.gz
%changelog
* Thu Nov 26 2009 Kamil Dudka <kdudka@redhat.com> - 1:4.4.2-6
- update SELinux patch to the latest upstream (gnulib based) version
* Wed Nov 18 2009 Kamil Dudka <kdudka@redhat.com> - 1:4.4.2-5
- do not fail silently on a remount during traverse (#501848)