new upstream release: findutils-4.5.13

This commit is contained in:
Kamil Dudka 2014-07-16 11:55:50 +02:00
parent cbeabfaa1e
commit 412732ac50
8 changed files with 23 additions and 50 deletions

5
.gitignore vendored
View File

@ -1,4 +1 @@
findutils-4.5.9.tar.gz
/findutils-4.5.10.tar.gz
/findutils-4.5.11.tar.gz
/findutils-4.5.12.tar.gz
/findutils-4.*.*.tar.gz

View File

@ -26,7 +26,7 @@ diff --git a/configure.ac b/configure.ac
index f31dd37..431f0ce 100644
--- a/configure.ac
+++ b/configure.ac
@@ -245,8 +245,6 @@ find/testsuite/Makefile
@@ -253,8 +253,6 @@ find/testsuite/Makefile
gl/Makefile
gl/lib/Makefile
lib/Makefile
@ -57,7 +57,7 @@ index 1f278de..c584298 100644
@table @code
@item --database=@var{path}
@@ -2872,13 +2870,9 @@ thrashing the network.
@@ -2874,13 +2872,9 @@ thrashing the network.
directories are indexed by each database file.
The default location for the locate database depends on how findutils
@ -74,7 +74,7 @@ index 1f278de..c584298 100644
@node Database Formats
@section Database Formats
@@ -3421,8 +3415,7 @@ present.
@@ -3423,8 +3417,7 @@ present.
@item --database=@var{path}
@itemx -d @var{path}
@ -84,7 +84,7 @@ index 1f278de..c584298 100644
name databases in @var{path}, which is a colon-separated list of
database file names. You can also use the environment variable
@code{LOCATE_PATH} to set the list of database files to search. The
@@ -3597,8 +3590,7 @@ The environment variable @code{PRUNEFS} also sets this value. Default
@@ -3599,8 +3592,7 @@ The environment variable @code{PRUNEFS} also sets this value. Default
is @file{nfs NFS proc}.
@item --output=@var{dbfile}
@ -94,7 +94,7 @@ index 1f278de..c584298 100644
@item --localuser=@var{user}
The user to search the non-network directories as, using @code{su}.
@@ -5617,7 +5609,7 @@ why @code{xargs} is confused by your operating system).
@@ -5619,7 +5611,7 @@ why @code{xargs} is confused by your operating system).
@section Error Messages From @code{locate}
@table @samp
@ -103,7 +103,7 @@ index 1f278de..c584298 100644
The @code{locate} program relies on a database which is periodically
built by the @code{updatedb} program. That hasn't happened in a long
time. To fix this problem, run @code{updatedb} manually. This can
@@ -5625,7 +5617,7 @@ often happen on systems that are generally not left on, so the
@@ -5627,7 +5619,7 @@ often happen on systems that are generally not left on, so the
periodic ``cron'' task which normally does this doesn't get a chance
to run.

View File

@ -119,7 +119,7 @@ diff --git a/find/util.c b/find/util.c
index 8577396..4d45f84 100644
--- a/find/util.c
+++ b/find/util.c
@@ -1010,6 +1010,7 @@ set_option_defaults (struct options *p)
@@ -1014,6 +1014,7 @@ set_option_defaults (struct options *p)
p->full_days = false;
p->stay_on_filesystem = false;

Binary file not shown.

View File

@ -1,17 +1,17 @@
From 690d4bd9f29a805999a3ce4651dac9585ccc9917 Mon Sep 17 00:00:00 2001
From: Kamil Dudka <kdudka@redhat.com>
Date: Wed, 11 May 2011 16:46:57 +0200
Subject: [PATCH 1/3] findutils-4.5.7-warnings.patch
Subject: [PATCH 1/2] findutils-4.5.7-warnings.patch
---
xargs/xargs.c | 3 ++-
1 files changed, 2 insertions(+), 1 deletions(-)
xargs/xargs.c | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/xargs/xargs.c b/xargs/xargs.c
index 5e373f2..c0a8676 100644
--- a/xargs/xargs.c
+++ b/xargs/xargs.c
@@ -1242,7 +1242,8 @@ xargs_do_exec (struct buildcmd_control *ctl, void *usercontext, int argc, char *
@@ -1253,7 +1253,8 @@ xargs_do_exec (struct buildcmd_control *ctl, void *usercontext, int argc, char *
* utility if we run it, for POSIX compliance on the
* handling of exit values.
*/
@ -28,12 +28,12 @@ index 5e373f2..c0a8676 100644
From c5654b9ca5f50daa1ca406ebd7b4546f24d00db6 Mon Sep 17 00:00:00 2001
From: Kamil Dudka <kdudka@redhat.com>
Date: Mon, 23 Sep 2013 15:04:03 +0200
Subject: [PATCH 2/3] parser: silence a [-Wmaybe-uninitialized] GCC warning
Subject: [PATCH 2/2] parser: silence a [-Wmaybe-uninitialized] GCC warning
... caused by a missing model of error()
---
find/parser.c | 2 +-
1 files changed, 1 insertions(+), 1 deletions(-)
find/parser.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/find/parser.c b/find/parser.c
index 89d8bcf..8c399d7 100644
@ -49,31 +49,5 @@ index 89d8bcf..8c399d7 100644
float rate = 0.5;
const char *typeletter;
--
1.7.1
From 19ee32ab3f001d12859b6e34ddbbaf64c1500c3d Mon Sep 17 00:00:00 2001
From: Kamil Dudka <kdudka@redhat.com>
Date: Mon, 23 Sep 2013 15:05:58 +0200
Subject: [PATCH 3/3] xargs: use a more appropriate printf conversion for size_t
---
xargs/xargs.c | 2 +-
1 files changed, 1 insertions(+), 1 deletions(-)
diff --git a/xargs/xargs.c b/xargs/xargs.c
index c0a8676..b1f5782 100644
--- a/xargs/xargs.c
+++ b/xargs/xargs.c
@@ -1329,7 +1329,7 @@ xargs_do_exec (struct buildcmd_control *ctl, void *usercontext, int argc, char *
default:
{
error (EXIT_FAILURE, errno,
- _("read returned unexpected value %d; "
+ _("read returned unexpected value %lu; "
"this is probably a bug, please report it"), r);
}
} /* switch on bytes read */
--
1.7.1
1.9.3

BIN
findutils-4.5.13.tar.gz.sig Normal file

Binary file not shown.

View File

@ -1,7 +1,7 @@
Summary: The GNU versions of find utilities (find and xargs)
Name: findutils
Version: 4.5.12
Release: 6%{?dist}
Version: 4.5.13
Release: 1%{?dist}
Epoch: 1
License: GPLv3+
Group: Applications/File
@ -16,7 +16,7 @@ Patch1: findutils-4.4.0-no-locate.patch
Patch3: findutils-4.4.2-xautofs.patch
# eliminate compile-time warnings
Patch4: findutils-4.5.12-warnings.patch
Patch4: findutils-4.5.13-warnings.patch
# eliminate failure of gnulib tests on little-endian PowerPC (#1083145)
Patch5: findutils-4.5.12-ppc-gnulib-tests.patch
@ -27,7 +27,6 @@ Conflicts: filesystem < 3
Provides: /bin/find
Provides: bundled(gnulib)
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: automake
BuildRequires: dejagnu
BuildRequires: gettext-devel
@ -100,6 +99,9 @@ fi
%{_infodir}/find-maint.info.gz
%changelog
* Wed Jul 16 2014 Kamil Dudka <kdudka@redhat.com> - 1:4.5.13-1
- new upstream release
* Sat Jul 12 2014 Tom Callaway <spot@fedoraproject.org> - 1:4.5.12-6
- fix license handling

View File

@ -1 +1 @@
e5f8d618aab0641cbbb738c43bcbc104 findutils-4.5.12.tar.gz
4a62988d34d462bd74dfb423a8f21b78 findutils-4.5.13.tar.gz