new upstream release: findutils-4.5.11

This commit is contained in:
Kamil Dudka 2013-02-03 21:03:52 +01:00
parent 7590b65979
commit 2e3e66c981
9 changed files with 170 additions and 61 deletions

1
.gitignore vendored
View File

@ -1,2 +1,3 @@
findutils-4.5.9.tar.gz
/findutils-4.5.10.tar.gz
/findutils-4.5.11.tar.gz

View File

@ -5,8 +5,9 @@ Subject: [PATCH 1/4] findutils-4.4.0-no-locate.patch
---
Makefile.am | 2 +-
configure.ac | 2 --
doc/find.texi | 24 ++++++++----------------
2 files changed, 9 insertions(+), 17 deletions(-)
3 files changed, 9 insertions(+), 19 deletions(-)
diff --git a/Makefile.am b/Makefile.am
index c7f8f39..0dacb93 100644
@ -16,11 +17,24 @@ index c7f8f39..0dacb93 100644
# "tests" is the gnulib unit test dir.
-SUBDIRS = gnulib tests build-aux lib find xargs locate doc po m4
+SUBDIRS = gnulib tests build-aux lib find xargs doc po m4
-SUBDIRS = gl tests build-aux lib find xargs locate doc po m4
+SUBDIRS = gl tests build-aux lib find xargs doc po m4
ACLOCAL_AMFLAGS = -I gnulib/m4 -I m4
ACLOCAL_AMFLAGS = -I gl/m4 -I m4
diff --git a/configure.ac b/configure.ac
index f31dd37..431f0ce 100644
--- a/configure.ac
+++ b/configure.ac
@@ -244,8 +244,6 @@ find/testsuite/Makefile
gl/Makefile
gl/lib/Makefile
lib/Makefile
-locate/Makefile
-locate/testsuite/Makefile
m4/Makefile
po/Makefile.in
po/Makefile
diff --git a/doc/find.texi b/doc/find.texi
index 1f278de..c584298 100644
--- a/doc/find.texi
@ -33,7 +47,7 @@ index 1f278de..c584298 100644
@iftex
@finalout
@@ -570,8 +569,7 @@ the databases are updated, and the directories for which they contain
@@ -571,8 +570,7 @@ the databases are updated, and the directories for which they contain
entries.
Here is how to select which file name databases @code{locate}
@ -43,7 +57,7 @@ index 1f278de..c584298 100644
@table @code
@item --database=@var{path}
@@ -2825,13 +2823,9 @@ thrashing the network.
@@ -2840,13 +2838,9 @@ thrashing the network.
directories are indexed by each database file.
The default location for the locate database depends on how findutils
@ -60,7 +74,7 @@ index 1f278de..c584298 100644
@node Database Formats
@section Database Formats
@@ -3310,8 +3304,7 @@ present.
@@ -3389,8 +3383,7 @@ present.
@item --database=@var{path}
@itemx -d @var{path}
@ -70,7 +84,7 @@ index 1f278de..c584298 100644
name databases in @var{path}, which is a colon-separated list of
database file names. You can also use the environment variable
@code{LOCATE_PATH} to set the list of database files to search. The
@@ -3496,8 +3489,7 @@ The environment variable @code{PRUNEFS} also sets this value. Default
@@ -3575,8 +3568,7 @@ The environment variable @code{PRUNEFS} also sets this value. Default
is @file{nfs NFS proc}.
@item --output=@var{dbfile}
@ -80,7 +94,7 @@ index 1f278de..c584298 100644
@item --localuser=@var{user}
The user to search the non-network directories as, using @code{su}.
@@ -5491,7 +5483,7 @@ why @code{xargs} is confused by your operating system).
@@ -5583,7 +5575,7 @@ why @code{xargs} is confused by your operating system).
@section Error Messages From @code{locate}
@table @samp
@ -89,7 +103,7 @@ index 1f278de..c584298 100644
The @code{locate} program relies on a database which is periodically
built by the @code{updatedb} program. That hasn't happened in a long
time. To fix this problem, run @code{updatedb} manually. This can
@@ -5499,7 +5491,7 @@ often happen on systems that are generally not left on, so the
@@ -5591,7 +5583,7 @@ often happen on systems that are generally not left on, so the
periodic ``cron'' task which normally does this doesn't get a chance
to run.

View File

@ -11,7 +11,7 @@ diff --git a/find/fstype.c b/find/fstype.c
index c6dbe8b..9cbf620 100644
--- a/find/fstype.c
+++ b/find/fstype.c
@@ -205,7 +205,72 @@ must_read_fs_list (bool need_fs_type)
@@ -187,7 +187,72 @@ must_read_fs_list (bool need_fs_type)
return entries;
}
@ -84,7 +84,7 @@ index c6dbe8b..9cbf620 100644
/* Return a newly allocated string naming the type of file system that the
file PATH, described by STATP, is on.
@@ -244,6 +309,10 @@ file_system_type_uncached (const struct stat *statp, const char *path)
@@ -238,6 +303,10 @@ file_system_type_uncached (const struct stat *statp, const char *path)
}
free_file_system_list (entries);

View File

@ -16,7 +16,7 @@ diff --git a/doc/find.texi b/doc/find.texi
index c584298..9731b71 100644
--- a/doc/find.texi
+++ b/doc/find.texi
@@ -1438,6 +1438,10 @@ them.
@@ -1439,6 +1439,10 @@ them.
There are two ways to avoid searching certain filesystems. One way is
to tell @code{find} to only search one filesystem:
@ -31,7 +31,7 @@ diff --git a/find/defs.h b/find/defs.h
index 11d1d00..f95ce72 100644
--- a/find/defs.h
+++ b/find/defs.h
@@ -561,6 +561,9 @@ struct options
@@ -557,6 +557,9 @@ struct options
/* If true, don't cross filesystem boundaries. */
bool stay_on_filesystem;
@ -76,7 +76,7 @@ diff --git a/find/parser.c b/find/parser.c
index 52a1ef6..995aec3 100644
--- a/find/parser.c
+++ b/find/parser.c
@@ -151,6 +151,7 @@ static bool parse_user (const struct parser_table*, char *argv[], int *
@@ -146,6 +146,7 @@ static bool parse_user (const struct parser_table*, char *argv[], int *
static bool parse_version (const struct parser_table*, char *argv[], int *arg_ptr);
static bool parse_wholename (const struct parser_table*, char *argv[], int *arg_ptr);
static bool parse_xdev (const struct parser_table*, char *argv[], int *arg_ptr);
@ -84,7 +84,7 @@ index 52a1ef6..995aec3 100644
static bool parse_ignore_race (const struct parser_table*, char *argv[], int *arg_ptr);
static bool parse_noignore_race (const struct parser_table*, char *argv[], int *arg_ptr);
static bool parse_warn (const struct parser_table*, char *argv[], int *arg_ptr);
@@ -325,6 +326,7 @@ static struct parser_table const parse_table[] =
@@ -306,6 +307,7 @@ static struct parser_table const parse_table[] =
PARSE_TEST_NP ("wholename", wholename), /* GNU, replaced -path, but anyway -path will soon be in POSIX */
{ARG_TEST, "writable", parse_accesscheck, pred_writable}, /* GNU, 4.3.0+ */
PARSE_OPTION ("xdev", xdev), /* POSIX */
@ -92,7 +92,7 @@ index 52a1ef6..995aec3 100644
PARSE_TEST ("xtype", xtype), /* GNU */
#ifdef UNIMPLEMENTED_UNIX
/* It's pretty ugly for find to know about archive formats.
@@ -1235,7 +1237,7 @@ operators (decreasing precedence; -and is implicit where no others are given):\n
@@ -1230,7 +1232,7 @@ operators (decreasing precedence; -and is implicit where no others are given):\n
positional options (always true): -daystart -follow -regextype\n\n\
normal options (always true, specified before other expressions):\n\
-depth --help -maxdepth LEVELS -mindepth LEVELS -mount -noleaf\n\
@ -101,7 +101,7 @@ index 52a1ef6..995aec3 100644
puts (_("\
tests (N can be +N or -N or N): -amin N -anewer FILE -atime N -cmin N\n\
-cnewer FILE -ctime N -empty -false -fstype TYPE -gid N -group NAME\n\
@@ -2800,6 +2802,13 @@ parse_xdev (const struct parser_table* entry, char **argv, int *arg_ptr)
@@ -2799,6 +2801,13 @@ parse_xdev (const struct parser_table* entry, char **argv, int *arg_ptr)
}
static bool
@ -119,7 +119,7 @@ diff --git a/find/util.c b/find/util.c
index 8577396..4d45f84 100644
--- a/find/util.c
+++ b/find/util.c
@@ -1006,6 +1006,7 @@ set_option_defaults (struct options *p)
@@ -1010,6 +1010,7 @@ set_option_defaults (struct options *p)
p->full_days = false;
p->stay_on_filesystem = false;

Binary file not shown.

BIN
findutils-4.5.11.tar.gz.sig Normal file

Binary file not shown.

View File

@ -4,33 +4,47 @@ Date: Wed, 11 May 2011 16:46:57 +0200
Subject: [PATCH 4/4] findutils-4.5.7-warnings.patch
---
find/pred.c | 6 +++---
xargs/xargs.c | 5 +++--
2 files changed, 6 insertions(+), 5 deletions(-)
find/Makefile.am | 2 +-
find/defs.h | 2 +-
find/exec.c | 2 +-
find/find.c | 14 +-------------
find/pred.c | 2 +-
lib/Makefile.am | 2 +-
xargs/Makefile.am | 2 +-
xargs/xargs.c | 5 +++--
8 files changed, 10 insertions(+), 21 deletions(-)
diff --git a/find/pred.c b/find/pred.c
index 3acfe9f..ee3c245 100644
--- a/find/pred.c
+++ b/find/pred.c
@@ -561,7 +561,7 @@ impl_pred_exec (const char *pathname,
struct predicate *pred_ptr)
{
struct exec_val *execp = &pred_ptr->args.exec_vec;
- char *target;
+ const char *target;
bool result;
const bool local = is_exec_in_local_dir (pred_ptr->pred_func);
char *prefix;
@@ -660,7 +660,7 @@ impl_pred_exec (const char *pathname,
if (target != pathname)
{
assert (local);
- free (target);
+ free ((char *) target);
}
return result;
}
@@ -2106,7 +2106,7 @@ launch (struct buildcmd_control *ctl, void *usercontext, int argc, char **argv)
diff --git a/find/Makefile.am b/find/Makefile.am
index 0795b87..f1068bf 100644
--- a/find/Makefile.am
+++ b/find/Makefile.am
@@ -36,7 +36,7 @@ endif
# We don't just include man_MANS in EXTRA_DIST because while the value of
# man_MANS is not always the same, we want to distribute all of those files.
EXTRA_DIST = defs.h sharefile.h print.h find.1 ftsfind.1 oldfind.1
-INCLUDES = -I../gl/lib -I$(top_srcdir)/lib -I$(top_srcdir)/gl/lib -I../intl -DLOCALEDIR=\"$(localedir)\"
+AM_CPPFLAGS = -I../gl/lib -I$(top_srcdir)/lib -I$(top_srcdir)/gl/lib -I../intl -DLOCALEDIR=\"$(localedir)\"
LDADD = ./libfindtools.a ../lib/libfind.a ../gl/lib/libgnulib.a $(LIBINTL) $(LIB_CLOCK_GETTIME) $(LIB_EACCESS) $(LIB_SELINUX) $(LIB_CLOSE) $(MODF_LIBM) $(FINDLIBS) $(GETHOSTNAME_LIB) $(LIB_EACCESS)
# gnulib advises we link against <first> because we use <second>:
# $(GETHOSTNAME_LIB) uname
diff --git a/find/defs.h b/find/defs.h
index 366edab..f25b700 100644
--- a/find/defs.h
+++ b/find/defs.h
@@ -258,7 +258,7 @@ struct predicate
/* Only used for debugging, but defined unconditionally so individual
modules can be compiled with -DDEBUG. */
- char *p_name;
+ const char *p_name;
/* The type of this node. There are two kinds. The first is real
predicates ("primaries") such as -perm, -print, or -exec. The
diff --git a/find/exec.c b/find/exec.c
index aa69fe3..f731d82 100644
--- a/find/exec.c
+++ b/find/exec.c
@@ -324,7 +324,7 @@ launch (struct buildcmd_control *ctl, void *usercontext, int argc, char **argv)
}
}
@ -39,11 +53,96 @@ index 3acfe9f..ee3c245 100644
errno = E2BIG;
else
execvp (argv[0], argv);
diff --git a/find/find.c b/find/find.c
index 5d287b5..00a2a6c 100644
--- a/find/find.c
+++ b/find/find.c
@@ -528,6 +528,7 @@ wd_sanity_check (const char *thing_to_stat,
#ifdef STAT_MOUNTPOINTS
isfatal = dirchange_is_fatal (specific_what,isfatal,silent,newinfo);
#else
+ (void) silent;
isfatal = RETRY_IF_SANITY_CHECK_FAILS;
#endif
}
@@ -1302,7 +1303,6 @@ process_dir (char *pathname, char *name, int pathlen, const struct stat *statp,
{
int subdirs_left; /* Number of unexamined subdirs in PATHNAME. */
bool subdirs_unreliable; /* if true, cannot use dir link count as subdir limif (if false, it may STILL be unreliable) */
- unsigned int idx; /* Which entry are we on? */
struct stat stat_buf;
size_t dircount = 0u;
DIR *dirp;
@@ -1519,7 +1519,6 @@ process_dir (char *pathname, char *name, int pathlen, const struct stat *statp,
if (strcmp (name, "."))
{
enum SafeChdirStatus status;
- struct dir_id did;
/* We could go back and do the next command-line arg
instead, maybe using longjmp. */
@@ -1555,17 +1554,6 @@ process_dir (char *pathname, char *name, int pathlen, const struct stat *statp,
"%s", safely_quote_err_filename (0, pathname));
return;
}
-
- if (dir_curr > 0)
- {
- did.dev = dir_ids[dir_curr-1].dev;
- did.ino = dir_ids[dir_curr-1].ino;
- }
- else
- {
- did.dev = starting_stat_buf.st_dev;
- did.ino = starting_stat_buf.st_ino;
- }
}
free (cur_path);
diff --git a/find/pred.c b/find/pred.c
index 88dacd9..e9c9a49 100644
--- a/find/pred.c
+++ b/find/pred.c
@@ -1216,7 +1216,7 @@ pred_context (const char *pathname, struct stat *stat_buf,
Return BUF. */
static char *
-blank_rtrim (char *str, char *buf)
+blank_rtrim (const char *str, char *buf)
{
int i;
diff --git a/lib/Makefile.am b/lib/Makefile.am
index bbb4dc2..eba43d2 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -28,7 +28,7 @@ DISTCLEANFILES =
MAINTAINERCLEANFILES =
-INCLUDES = -I../gl/lib -I$(top_srcdir)/gl/lib
+AM_CPPFLAGS = -I../gl/lib -I$(top_srcdir)/gl/lib
LDADD = ../gl/lib/libgnulib.a $(LIBINTL)
libfind_a_SOURCES += printquoted.h listfile.h \
diff --git a/xargs/Makefile.am b/xargs/Makefile.am
index d34f87a..1cfe3e4 100644
--- a/xargs/Makefile.am
+++ b/xargs/Makefile.am
@@ -3,7 +3,7 @@ AM_CFLAGS = $(WARN_CFLAGS)
localedir = $(datadir)/locale
bin_PROGRAMS = xargs
man_MANS = xargs.1
-INCLUDES = -I.. -I../gl/lib -I$(top_srcdir)/gl/lib -I$(top_srcdir)/lib -I../intl -DLOCALEDIR=\"$(localedir)\"
+AM_CPPFLAGS = -I.. -I../gl/lib -I$(top_srcdir)/gl/lib -I$(top_srcdir)/lib -I../intl -DLOCALEDIR=\"$(localedir)\"
LDADD = ../lib/libfind.a ../gl/lib/libgnulib.a $(LIB_CLOSE) $(LIBINTL)
EXTRA_DIST = $(man_MANS)
SUBDIRS = . testsuite
diff --git a/xargs/xargs.c b/xargs/xargs.c
index 3cc1832..35f6822 100644
--- a/xargs/xargs.c
+++ b/xargs/xargs.c
@@ -1132,7 +1132,7 @@ xargs_do_exec (struct buildcmd_control *ctl, void *usercontext, int argc, char *
@@ -1208,7 +1208,7 @@ xargs_do_exec (struct buildcmd_control *ctl, void *usercontext, int argc, char *
prep_child_for_exec ();
@ -52,7 +151,7 @@ index 3cc1832..35f6822 100644
errno = E2BIG;
else
execvp (argv[0], argv);
@@ -1150,7 +1150,8 @@ xargs_do_exec (struct buildcmd_control *ctl, void *usercontext, int argc, char *
@@ -1226,7 +1226,8 @@ xargs_do_exec (struct buildcmd_control *ctl, void *usercontext, int argc, char *
* utility if we run it, for POSIX compliance on the
* handling of exit values.
*/

View File

@ -1,7 +1,7 @@
Summary: The GNU versions of find utilities (find and xargs)
Name: findutils
Version: 4.5.10
Release: 7%{?dist}
Version: 4.5.11
Release: 1%{?dist}
Epoch: 1
License: GPLv3+
Group: Applications/File
@ -22,12 +22,6 @@ Patch3: findutils-4.4.2-xautofs.patch
# eliminate compile-time warnings
Patch4: findutils-4.5.7-warnings.patch
# configure.ac: do not use the AM_C_PROTOTYPES macro (removed in Automake 1.12)
Patch5: findutils-4.5.10-automake.patch
# gnulib: do not require gets() to be declared
Patch6: findutils-4.5.10-gets.patch
Requires(post): /sbin/install-info
Requires(preun): /sbin/install-info
Conflicts: filesystem < 3
@ -54,17 +48,14 @@ useful for finding things on your system.
%prep
%setup -q
rm -rf locate
%patch1 -p1
%patch2 -p1
%patch3 -p1
%patch4 -p1
%patch5 -p1
%patch6 -p1
# needed because of findutils-4.4.0-no-locate.patch
aclocal -I gnulib/m4 -I m4
automake
touch -c configure config.h
autoreconf -iv
%build
%configure
@ -102,11 +93,15 @@ fi
%{_bindir}/oldfind
%{_bindir}/xargs
%{_mandir}/man1/find.1*
%{_mandir}/man1/oldfind.1*
%{_mandir}/man1/xargs.1*
%{_infodir}/find.info*
%{_infodir}/find-maint.info.gz
%changelog
* Sun Feb 03 2013 Kamil Dudka <kdudka@redhat.com> - 1:4.5.11-1
- new upstream release
* Tue Aug 28 2012 Kamil Dudka <kdudka@redhat.com> - 1:4.5.10-7
- fix specfile issues reported by the fedora-review script
- do not use the AM_C_PROTOTYPES macro (removed in Automake 1.12)

View File

@ -1 +1 @@
06bd1e0c0026e134c591c07de83dd94b findutils-4.5.10.tar.gz
05307c7b283873d6da03fd6ada36895a findutils-4.5.11.tar.gz