- 4.2.23.

This commit is contained in:
Tim Waugh 2005-06-20 08:47:17 +00:00
parent 24ec15e80c
commit 248647ce69
5 changed files with 60 additions and 60 deletions

View File

@ -2,3 +2,4 @@ findutils-4.1.20.tar.gz
findutils-4.2.15.tar.gz
findutils-4.2.18.tar.gz
findutils-4.2.20.tar.gz
findutils-4.2.23.tar.gz

View File

@ -1,5 +1,5 @@
--- findutils-4.2.20/Makefile.am.no-locate 2005-03-02 22:36:19.000000000 +0000
+++ findutils-4.2.20/Makefile.am 2005-03-17 13:13:22.000000000 +0000
--- findutils-4.2.23/Makefile.am.no-locate 2005-06-07 23:18:41.000000000 +0100
+++ findutils-4.2.23/Makefile.am 2005-06-20 09:30:26.000000000 +0100
@@ -2,7 +2,7 @@
EXTRA_DIST = COPYING ChangeLog TODO install-sh config.h.in stamp-h.in \
@ -9,14 +9,14 @@
ACLOCAL_AMFLAGS = -I gnulib/m4 -I m4
--- findutils-4.2.20/Makefile.in.no-locate 2005-03-17 12:11:29.000000000 +0000
+++ findutils-4.2.20/Makefile.in 2005-03-17 13:13:52.000000000 +0000
@@ -142,7 +142,7 @@
--- findutils-4.2.23/Makefile.in.no-locate 2005-06-19 12:28:34.000000000 +0100
+++ findutils-4.2.23/Makefile.in 2005-06-20 09:30:57.000000000 +0100
@@ -263,7 +263,7 @@
EXTRA_DIST = COPYING ChangeLog TODO install-sh config.h.in stamp-h.in \
THANKS config.rpath
-SUBDIRS = gnulib lib find xargs locate doc po m4
+SUBDIRS = gnulib lib find xargs doc po m4
ACLOCAL_AMFLAGS = -I gnulib/m4 -I m4
subdir = .
all: config.h
$(MAKE) $(AM_MAKEFLAGS) all-recursive

View File

@ -1,5 +1,5 @@
--- findutils-4.2.20/find/util.c.selinux 2005-01-24 16:12:31.000000000 +0000
+++ findutils-4.2.20/find/util.c 2005-03-17 13:14:11.000000000 +0000
--- findutils-4.2.23/find/util.c.selinux 2005-06-07 23:18:41.000000000 +0100
+++ findutils-4.2.23/find/util.c 2005-06-20 09:43:21.000000000 +0100
@@ -70,6 +70,9 @@
last_pred->need_stat = true;
last_pred->need_type = true;
@ -10,8 +10,8 @@
last_pred->pred_next = NULL;
last_pred->pred_left = NULL;
last_pred->pred_right = NULL;
--- findutils-4.2.20/find/find.c.selinux 2005-03-03 22:30:10.000000000 +0000
+++ findutils-4.2.20/find/find.c 2005-03-17 13:14:11.000000000 +0000
--- findutils-4.2.23/find/find.c.selinux 2005-06-19 09:48:00.000000000 +0100
+++ findutils-4.2.23/find/find.c 2005-06-20 09:43:21.000000000 +0100
@@ -239,6 +239,93 @@
{
return lstat(name, p);
@ -142,7 +142,7 @@
+ int is_selinux_enabled_flag = is_selinux_enabled()>0;
+#endif /* WITH_SELINUX */
int i;
PFB parse_function; /* Pointer to the function which parses. */
PARSE_FUNC parse_function; /* Pointer to the function which parses. */
struct predicate *cur_pred;
@@ -512,6 +611,14 @@
if (strchr ("-!(),", argv[i][0]) == NULL)
@ -159,9 +159,9 @@
parse_function = find_parser (predicate_name);
if (parse_function == NULL)
/* Command line option not recognized */
--- findutils-4.2.20/find/find.1.selinux 2005-03-02 22:36:20.000000000 +0000
+++ findutils-4.2.20/find/find.1 2005-03-17 13:14:11.000000000 +0000
@@ -441,6 +441,9 @@
--- findutils-4.2.23/find/find.1.selinux 2005-06-19 09:48:00.000000000 +0100
+++ findutils-4.2.23/find/find.1 2005-06-20 09:43:21.000000000 +0100
@@ -443,6 +443,9 @@
link to a file of type \fIc\fR; if the \-L option has been given, true
if \fIc\fR is `l'. In other words, for symbolic links, \-xtype checks
the type of the file that \-type does not check.
@ -171,7 +171,7 @@
.SS ACTIONS
.IP "\-delete\fR"
@@ -713,6 +716,8 @@
@@ -735,6 +738,8 @@
File's type (like in ls \-l), U=unknown type (shouldn't happen)
.IP %Y
File's type (like %y), plus follow symlinks: L=loop, N=nonexistent
@ -180,9 +180,9 @@
.PP
A `%' character followed by any other character is discarded (but the
other character is printed).
--- findutils-4.2.20/find/Makefile.in.selinux 2005-03-17 12:11:50.000000000 +0000
+++ findutils-4.2.20/find/Makefile.in 2005-03-17 13:14:11.000000000 +0000
@@ -52,7 +52,7 @@
--- findutils-4.2.23/find/Makefile.in.selinux 2005-06-19 12:28:32.000000000 +0100
+++ findutils-4.2.23/find/Makefile.in 2005-06-20 09:43:21.000000000 +0100
@@ -175,7 +175,7 @@
CPP = @CPP@
CPPFLAGS = @CPPFLAGS@
CYGPATH_W = @CYGPATH_W@
@ -191,17 +191,17 @@
DEPDIR = @DEPDIR@
ECHO_C = @ECHO_C@
ECHO_N = @ECHO_N@
@@ -142,7 +142,7 @@
bin_PROGRAMS = find
@@ -268,7 +268,7 @@
localedir = $(datadir)/locale
find_SOURCES = find.c fstype.c parser.c pred.c tree.c util.c version.c
EXTRA_DIST = defs.h $(man_MANS)
-LDADD = ../lib/libfind.a ../gnulib/lib/libgnulib.a @INTLLIBS@
+LDADD = ../lib/libfind.a ../gnulib/lib/libgnulib.a @INTLLIBS@ -lselinux
man_MANS = find.1
SUBDIRS = testsuite
subdir = find
--- findutils-4.2.20/find/defs.h.selinux 2005-03-04 09:58:29.000000000 +0000
+++ findutils-4.2.20/find/defs.h 2005-03-17 13:14:11.000000000 +0000
all: all-recursive
--- findutils-4.2.23/find/defs.h.selinux 2005-06-19 09:48:00.000000000 +0100
+++ findutils-4.2.23/find/defs.h 2005-06-20 09:44:07.000000000 +0100
@@ -130,6 +130,10 @@
#define MODE_RWX (S_IXUSR | S_IXGRP | S_IXOTH | MODE_RW)
#define MODE_ALL (S_ISUID | S_ISGID | S_ISVTX | MODE_RWX)
@ -213,17 +213,17 @@
#if 1
#include <stdbool.h>
typedef bool boolean;
@@ -314,6 +318,9 @@
@@ -318,6 +322,9 @@
struct dir_id fileid; /* samefile */
mode_t type; /* type */
FILE *stream; /* fprint fprint0 */
FILE *stream; /* ls fls fprint0 */
+#ifdef WITH_SELINUX
+ security_context_t scontext; /* scontext */
+#endif /*WITH_SELINUX*/
struct format_val printf_vec; /* printf fprintf */
struct format_val printf_vec; /* printf fprintf fprint */
} args;
@@ -444,6 +451,9 @@
@@ -451,6 +458,9 @@
boolean pred_used PARAMS((char *pathname, struct stat *stat_buf, struct predicate *pred_ptr));
boolean pred_user PARAMS((char *pathname, struct stat *stat_buf, struct predicate *pred_ptr));
boolean pred_xtype PARAMS((char *pathname, struct stat *stat_buf, struct predicate *pred_ptr));
@ -233,7 +233,7 @@
int launch PARAMS((const struct buildcmd_control *ctl,
struct buildcmd_state *buildstate));
@@ -524,6 +534,9 @@
@@ -531,6 +541,9 @@
* flag to open(2).
*/
boolean open_nofollow_available;
@ -243,8 +243,8 @@
};
extern struct options options;
--- findutils-4.2.20/find/Makefile.am.selinux 2004-11-23 00:10:40.000000000 +0000
+++ findutils-4.2.20/find/Makefile.am 2005-03-17 13:14:11.000000000 +0000
--- findutils-4.2.23/find/Makefile.am.selinux 2005-06-07 23:18:41.000000000 +0100
+++ findutils-4.2.23/find/Makefile.am 2005-06-20 09:43:21.000000000 +0100
@@ -3,8 +3,9 @@
bin_PROGRAMS = find
find_SOURCES = find.c fstype.c parser.c pred.c tree.c util.c version.c
@ -256,12 +256,12 @@
man_MANS = find.1
SUBDIRS = testsuite
--- findutils-4.2.20/find/parser.c.selinux 2005-03-17 13:14:11.000000000 +0000
+++ findutils-4.2.20/find/parser.c 2005-03-17 13:14:11.000000000 +0000
@@ -36,6 +36,10 @@
#include <sys/file.h>
--- findutils-4.2.23/find/parser.c.selinux 2005-06-19 09:48:00.000000000 +0100
+++ findutils-4.2.23/find/parser.c 2005-06-20 09:43:21.000000000 +0100
@@ -45,6 +45,10 @@
#endif
+#ifdef WITH_SELINUX
+#include <selinux/selinux.h>
+#endif /*WITH_SELINUX*/
@ -269,7 +269,7 @@
#if ENABLE_NLS
# include <libintl.h>
# define _(Text) gettext (Text)
@@ -139,6 +143,9 @@
@@ -148,6 +152,9 @@
static boolean parse_warn PARAMS((char *argv[], int *arg_ptr));
static boolean parse_xtype PARAMS((char *argv[], int *arg_ptr));
static boolean parse_quit PARAMS((char *argv[], int *arg_ptr));
@ -278,8 +278,8 @@
+#endif /*WITH_SELINUX*/
static boolean insert_regex PARAMS((char *argv[], int *arg_ptr, boolean ignore_case));
static boolean insert_type PARAMS((char *argv[], int *arg_ptr, boolean (*which_pred )()));
@@ -266,6 +273,8 @@
static boolean insert_type PARAMS((char *argv[], int *arg_ptr, PRED_FUNC which_pred));
@@ -276,6 +283,8 @@
{ARG_TEST, "wholename", parse_wholename}, /* GNU, replaces -path */
{ARG_OPTION, "xdev", parse_xdev},
{ARG_TEST, "xtype", parse_xtype}, /* GNU */
@ -288,7 +288,7 @@
{0, 0, 0}
};
@@ -744,6 +753,10 @@
@@ -755,6 +764,10 @@
-nouser -nogroup -path PATTERN -perm [+-]MODE -regex PATTERN\n\
-wholename PATTERN -size N[bcwkMG] -true -type [bcdpflsD] -uid N\n\
-used N -user NAME -xtype [bcdpfls]\n"));
@ -297,9 +297,9 @@
+ -context CONTEXT\n"));
+#endif /*WITH_SELINUX*/
puts (_("\
actions: -exec COMMAND ; -fprint FILE -fprint0 FILE -fprintf FILE FORMAT\n\
-fls FILE -ok COMMAND ; -print -print0 -printf FORMAT -prune -ls -delete\n\
@@ -1602,6 +1615,32 @@
actions: -delete -print0 -printf FORMAT -fprintf FILE FORMAT -print \n\
-fprint0 FILE -fprint FILE -ls -fls FILE -prune -quit\n\
@@ -1670,6 +1683,32 @@
return true;
}
@ -332,7 +332,7 @@
static boolean
parse_xtype (char **argv, int *arg_ptr)
{
@@ -1777,7 +1816,11 @@
@@ -1867,7 +1906,11 @@
if (*scan2 == '.')
for (scan2++; ISDIGIT (*scan2); scan2++)
/* Do nothing. */ ;
@ -344,11 +344,11 @@
{
segmentp = make_segment (segmentp, format, scan2 - format,
(int) *scan2);
--- findutils-4.2.20/find/pred.c.selinux 2005-03-04 10:33:39.000000000 +0000
+++ findutils-4.2.20/find/pred.c 2005-03-17 13:14:11.000000000 +0000
@@ -35,6 +35,14 @@
#include "wait.h"
--- findutils-4.2.23/find/pred.c.selinux 2005-06-07 23:18:41.000000000 +0100
+++ findutils-4.2.23/find/pred.c 2005-06-20 09:43:21.000000000 +0100
@@ -38,6 +38,14 @@
#include "buildcmd.h"
#include "yesno.h"
+#ifdef WITH_SELINUX
+#include <selinux/selinux.h>
@ -361,15 +361,15 @@
#if ENABLE_NLS
# include <libintl.h>
# define _(Text) gettext (Text)
@@ -78,7 +86,6 @@
@@ -83,7 +91,6 @@
extern int yesno ();
-
/* Get or fake the disk device blocksize.
Usually defined by sys/param.h (if at all). */
#ifndef DEV_BSIZE
@@ -209,6 +216,9 @@
@@ -215,6 +222,9 @@
{pred_used, "used "},
{pred_user, "user "},
{pred_xtype, "xtype "},
@ -379,7 +379,7 @@
{0, "none "}
};
@@ -839,6 +849,26 @@
@@ -893,6 +903,26 @@
}
break;
@ -406,7 +406,7 @@
}
}
return (true);
@@ -1411,6 +1441,34 @@
@@ -1470,6 +1500,34 @@
*/
return (pred_type (pathname, &sbuf, pred_ptr));
}

View File

@ -3,16 +3,14 @@
%endif
Summary: The GNU versions of find utilities (find and xargs).
Name: findutils
Version: 4.2.20
Version: 4.2.23
Release: 1
Epoch: 1
License: GPL
Group: Applications/File
Source0: ftp://ftp.gnu.org/gnu/findutils/%{name}-%{version}.tar.gz
Patch1: findutils-no-locate.patch
Patch2: findutils-regex.patch
Patch3: findutils-gcc4.patch
Patch4: findutils-selinux.patch
Patch2: findutils-selinux.patch
Prereq: /sbin/install-info
Buildroot: %{_tmppath}/%{name}-%{version}-root
@ -36,11 +34,9 @@ useful for finding things on your system.
%prep
%setup -q
%patch1 -p1 -b .no-locate
%patch2 -p1 -b .regex
%patch3 -p1 -b .gcc4
%if %{WITH_SELINUX}
#SELinux
%patch4 -p1 -b .selinux
%patch2 -p1 -b .selinux
%endif
autoreconf
@ -95,6 +91,9 @@ rm -rf %{buildroot}
%{_infodir}/find.info*
%changelog
* Mon Jun 20 2005 Tim Waugh <twaugh@redhat.com> 1:4.2.23-1
- 4.2.23.
* Thu Mar 17 2005 Tim Waugh <twaugh@redhat.com> 1:4.2.20-1
- 4.2.20.

View File

@ -1 +1 @@
7c8e12165b221dd67a19c00d780437a4 findutils-4.2.20.tar.gz
ecaff8b060e8d69c10eb2391a8032e26 findutils-4.2.23.tar.gz